14:00:19 <alexchadin> #startmeeting watcher
14:00:20 <openstack> Meeting started Wed Mar 22 14:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:23 <openstack> The meeting name has been set to 'watcher'
14:00:38 <alexchadin> Hi Watcher folks!
14:00:40 <chrisspencer_> o/
14:00:44 <sballe_> o/
14:00:48 <dtardivel> hi
14:00:50 <vincentfrancoise> o/
14:01:17 <alexchadin> #info Today we have the following agenda https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#02.2F15.2F2016
14:01:34 <alexchadin> #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F22.2F2017
14:01:49 <alexchadin> #topic Announcements
14:01:55 <alexchadin> Due to time changes the next meeting will be one hour later than usually.
14:02:10 <pshedimb> Yayy :)
14:02:14 <alexchadin> so be prepared next time ;)
14:02:26 <sballe_> ok
14:02:27 <vincentfrancoise> alexchadin: depends on the country though :p
14:02:47 <sballe_> alexchadin: not for people in the US though
14:02:54 <alexchadin> vincentfrancoise: yeah, it is applicable only for time-change countries :)
14:03:15 <sballe_> :) just wanted to pshedimb to not be late
14:03:17 <vincentfrancoise> alexchadin: even worse not all country change time on the same day...
14:03:34 <pshedimb> sballe_, haha :)
14:03:48 <alexchadin> we have a lot of discussions today so I'd like to start with them
14:03:57 <alexchadin> #topic Open discussions
14:04:04 <alexchadin> Python 3.5 Support – it is one of the main goals for Pike cycle and we need to meet completion criteria.
14:04:09 <alexchadin> #link https://governance.openstack.org/tc/goals/pike/python35.html
14:04:50 <alexchadin> we have unit test gates for both 2.7 and 3.5 - it is great!
14:04:57 <vincentfrancoise> alexchadin: so after a quick read it means we need to have both unit tests **and** tempest test to pass with py35
14:05:15 <alexchadin> but our functional tests works only with 2.7
14:05:28 <alexchadin> so yes, vincentfrancoise +1, we need functional gate for 3.5
14:05:56 <vincentfrancoise> alexchadin: I reckon they work with py34 (I checked once like 3-4 months ago)
14:06:30 <alexchadin> vincentfrancoise: if so, I believe they will work great with 3.5
14:06:40 <vincentfrancoise> alexchadin: regarding tempest tests, they are really flaky these days so before getting them onto py35, we also need to spend time stabilizing them
14:07:31 <alexchadin> vincentfrancoise: we need to define what we want from functional tests and set boundaries
14:07:52 <alexchadin> vincentfrancoise: the situation with "one more blueprint" ;)
14:08:10 <acabot> hi sorry to be late
14:08:14 <alexchadin> hi acabot
14:08:15 <vincentfrancoise> alexchadin: all api tests + the dummy strategy end2end execution
14:08:29 <alexchadin> vincentfrancoise: +1
14:08:37 <alexchadin> who would like to take it?
14:08:53 <alexchadin> I suppose we need some sort of spec here
14:10:01 <alexchadin> which would define what tests we actually need
14:11:30 <alexchadin> well, I will add it to my TODO's and assign it later
14:11:37 <alexchadin> move on
14:11:45 <alexchadin> WSGI Support. Does our API work with WSGI? #link https://governance.openstack.org/tc/goals/pike/deploy-api-in-wsgi.html#watcher
14:12:42 <vincentfrancoise> alexchadin: our API stack is the same as magnum and ironic so if it works for them then we should be OK
14:13:21 <sballe_> alexchadin: I will go through as many of the spec as i can review. based ont hese minutes
14:13:43 <alexchadin> vincentfrancoise: there are status of projects: https://governance.openstack.org/tc/goals/pike/deploy-api-in-wsgi.html#current-state-anticipated-impact
14:13:52 <alexchadin> sballe_: thank you!
14:14:25 <vincentfrancoise> alexchadin: yes but the remaining steps can be copied from ironic then
14:14:57 <vincentfrancoise> alexchadin: https://github.com/openstack/ironic/blob/master/ironic/api/app.wsgi seems like one of the main difference we don't have
14:15:11 <alexchadin> as it is one of the main goals for Pike cycle, it would be great to take it now
14:16:06 <adisky_> alexchadin: I can take it
14:16:59 <alexchadin> adisky_: thanks!
14:17:14 <adisky_> :)
14:17:18 <alexchadin> #action adisky_ update WSGI status of Watcher
14:17:36 <alexchadin> Watcher is not presented in Debian-based systems due to issue. It would be great to build package by ourselves. #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/112220.html
14:18:32 <alexchadin> the main problem here is that zigo lost his contract with Mirantis, so there is no one who can hold it
14:19:26 <alexchadin> adisky_ said that we are not presented in Debian repos for Ocata release
14:19:59 <zigo> There's no Ocata release in Debian *at all*.
14:20:15 <zigo> Hopefully, this may change though ...
14:20:16 <alexchadin> Here is page https://openstack.alioth.debian.org that explains packaging process
14:20:29 <alexchadin> hi, zigo!
14:20:41 <zigo> No, this is old, and doesn't take into account the fact we're now packaging on OpenStack infra.
14:21:37 <alexchadin> zigo: could you please give us some information about building and releasing Watcher for Debian?
14:22:19 <zigo> alexchadin: We need to first get a Stretch image into OpenStack infra, which I have been working on, then all of the rest of OpenStack needs to get packaged (oslo, etc.).
14:22:49 <zigo> All is done through Gerrit these days.
14:22:57 <alexchadin> zigo: is there some docs with first steps?
14:22:58 <zigo> So just openstack/deb-watcher...
14:23:34 <zigo> alexchadin: Basically, it's fix the issues with openstack-infra/project-config stuff. ie: ./tools/build-image.sh
14:23:41 <zigo> Currently, it fails.
14:23:47 <zigo> I'm not sure why yet...
14:23:51 <zigo> Help would be appreciated.
14:24:01 <zigo> It's been 1 week I'm on that already, and can't find what's going on.
14:24:11 <zigo> Probably something with Puppet 4 instead of 3.
14:24:44 <zigo> Running ./tools/build-image.sh with these variables:
14:24:54 <zigo> export DIB_RELEASE="stretch"
14:24:54 <zigo> export DIB_DEBOOTSTRAP_EXTRA_ARGS=--include=systemd-sysv
14:24:54 <zigo> export DISTRO=debian-minimal
14:24:54 <zigo> export DISTRO_NAME=debian
14:24:54 <zigo> export CONFIG_REF=refs/changes/13/445813/4
14:25:02 <zigo> then fix the problems.
14:25:19 <alexchadin> zigo: thank you. can we discuss it in our main channel, openstack-watcher?
14:25:43 <zigo> Sure ! Feel free to discuss that Stretch issue on #openstack-infra or even #openstack-pkg if you like too.
14:25:50 <alexchadin> zigo: great!
14:26:08 <zigo> Once that's done, I believe I can release Ocata quite fast.
14:26:20 <alexchadin> #action continue discussion with zigo about building Watcher for Ocata
14:26:27 <alexchadin> move on
14:26:30 <alexchadin> adisky reported that python-watcherclient is not included in rdo repo of python-openstackclient.
14:27:12 <adisky_> alexchadin:  correction there is no rpm package of python-watcherclient
14:27:50 <adisky_> we have rpm packages available for watcher, but not for watcher-client
14:28:46 <zigo> number80 is the nick behind all RDO stuff.
14:28:47 <adisky_> so i am unable to complete installation  guide for rdo
14:28:49 <zigo> Chat with him ...
14:29:06 <alexchadin> adisky_: can you resolve this issue?
14:29:08 <adisky_> zigo: thanks :)
14:29:48 <adisky_> alexchadin: yes i will
14:30:42 <alexchadin> #action adisky_ contact number80 to resolve rpm-issue
14:31:16 <alexchadin> #topic Review Action Items
14:31:20 <alexchadin> Watcher
14:31:29 <alexchadin> Versioned Notifications for service object needs reviews #link https://review.openstack.org/#/c/437333/
14:32:36 <alexchadin> who would like to review it?
14:32:38 <chrisspencer_> +1
14:32:55 <vincentfrancoise> +1
14:32:56 <alexchadin> it isn't big patch
14:33:08 <alexchadin> thanks chrisspencer_ vincentfrancoise
14:33:21 <alexchadin> #action chrisspencer_ vincentfrancoise review https://review.openstack.org/#/c/437333/
14:33:31 <alexchadin> Add Gnocchi datasource needs final core reviews #link https://review.openstack.org/#/c/438530/
14:34:00 <sanfern> hello
14:34:09 <alexchadin> hi sanfern
14:34:20 <sballe_> hi
14:34:52 <alexchadin> I can't just +2 on my patch :)
14:35:06 <alexchadin> vincentfrancoise: will you take a look?
14:35:08 <pshedimb> +1
14:35:38 <alexchadin> pshedimb: thanks
14:35:40 <vincentfrancoise> alexchadin: on this one there were comments you didn't answer
14:35:59 <alexchadin> vincentfrancoise: ah sure
14:36:00 <vincentfrancoise> alexchadin: so I remember I was waiting for you to answer before putting a +2
14:36:39 <vincentfrancoise> alexchadin: once you do, I'll review it once more
14:36:41 <alexchadin> #action vincentfrancoise pshedimb review https://review.openstack.org/#/c/438530/ when alexchadin update it
14:36:57 <alexchadin> Added suspended audit state needs reviews #link https://review.openstack.org/#/c/438800/
14:37:29 <pshedimb> alexchadin, also gnocchi is moving out of openstack. will it affect the patch?
14:38:21 <alexchadin> pshedimb: I've seen this thread and they promise that there won't be any changes for projects which use it
14:38:33 <pshedimb> alexchadin, okay :)
14:38:56 <vincentfrancoise> pshedimb: alexchadin what about gnocchi moving out? can I have a link about this?
14:39:21 <alexchadin> pshedimb: they will have changes with CI, but should remain OpenStack support
14:39:25 <alexchadin> vincentfrancoise: let me find
14:39:34 <sanfern> vincentfrancoise, https://review.openstack.org/#/c/447438/
14:39:46 <pshedimb> vincentfrancoise, Gnocchi guys submitted request to OpenStack congress to move out of openstack
14:39:47 <alexchadin> vincentfrancoise: http://lists.openstack.org/pipermail/openstack-dev/2017-March/114300.html
14:40:51 <sballe_> Maybe we should do the same down the line if we want to support other eco-system than openstack... Not now but just food for thoughts
14:40:52 <alexchadin> pshedimb: although there were some opinions that they are more OpenStack-related than they thought
14:40:53 <acabot> they just want to leave the big tent
14:41:22 <acabot> it doesn't mean it will not work with openstack anymore
14:41:32 <vincentfrancoise> alexchadin: pshedimb: so that means there is won't be any openstack-tagged telemetry project anymore
14:41:33 <sballe_> acabot: I agree
14:41:42 <alexchadin> vincentfrancoise: yeap
14:41:58 <sballe_> how about Monasca they claim to do it all
14:42:05 <pshedimb> vincentfrancoise, alexchadin Ceilometer is still there
14:42:15 <pshedimb> The main component of telemetry
14:42:20 <alexchadin> pshedimb: ceilometer doesn't have API
14:42:21 <sballe_> pshedimb: but witth no supported APIS
14:42:27 <sballe_> alexchadin: lol
14:42:39 <alexchadin> pshedimb: high five!:D
14:42:44 <pshedimb> alexchadin sballe_ , yeah we gotta use backend like mongodb
14:42:55 <pshedimb> haha :D
14:43:17 <sballe_> indfluxDb is better for the stuff we are lookign at doing anywau
14:43:22 <pshedimb> Gnocchi is just a backend. So any other backend like Mongo or HBase will work just fine.
14:43:22 <sballe_> s/anyway
14:43:24 <vincentfrancoise> which is why Watcher should definitely be datasource agnostic as much as possible
14:43:25 <alexchadin> pshedimb: gnocchi works perfectly as API for Ceilometer
14:43:43 <pshedimb> alexchadin, Yeah I agree.
14:44:47 <alexchadin> let's leave this discussion for main channel
14:44:53 <sballe_> +1
14:44:55 <vincentfrancoise> +1
14:44:56 <alexchadin> we have only 15 minutes left
14:44:57 <pshedimb> +1
14:44:59 <alexchadin> move on
14:45:00 <alexchadin> Prevent the migration of VM with 'optimize' False in VM metadata needs new PS
14:45:08 <alexchadin> #link https://review.openstack.org/#/c/443070/
14:45:29 <alexchadin> pksingh is not here
14:45:39 <vincentfrancoise> alexchadin: I discussed this with him
14:45:43 <alexchadin> vincentfrancoise: +1
14:45:47 <alexchadin> vincentfrancoise: I've seen it
14:46:13 <alexchadin> vincentfrancoise: Have you got some conclusion?
14:46:17 <vincentfrancoise> alexchadin: basically, the code made me realise there was another issue with the nova metadata representation
14:46:45 <vincentfrancoise> alexchadin: we have an XML reprenstation to declare scenarios
14:47:15 <vincentfrancoise> alexchadin: this is a declarative/human readable system to make it easy in tests
14:47:52 <alexchadin> vincentfrancoise: is it applicable only for basic_consolidation strategy?
14:47:57 <vincentfrancoise> alexchadin: but the metadata breaks it (or at least the test do not pass because dicts are unordered so we cannot dafely bootstrap)
14:48:10 <vincentfrancoise> safely*
14:48:52 <pksingh> Hello
14:48:53 <vincentfrancoise> alexchadin: so we need to ensure that we can test the model which contains json
14:49:01 <vincentfrancoise> pksingh: hi
14:49:18 <pksingh> vincentfrancoise: Hi
14:49:28 <vincentfrancoise> alexchadin: before we can carry on with what pksingh was actually trying to do in the first place
14:49:48 <alexchadin> #action vincentfrancoise and pksingh work together on https://review.openstack.org/#/c/443070/
14:49:52 <vincentfrancoise> alexchadin: does that make sense?
14:50:03 <alexchadin> vincentfrancoise: yeah
14:50:13 <vincentfrancoise> alexchadin: good :)
14:50:19 <alexchadin> Adding tempest test that executes outlet_temp_control strategy. needs reviews #link https://review.openstack.org/#/c/439184/
14:50:50 <pshedimb> +1
14:51:11 <alexchadin> #action pshedimb review https://review.openstack.org/#/c/439184/
14:51:37 <alexchadin> Reduced the code complexity needs new PS #link https://review.openstack.org/#/c/441873/
14:52:31 <alexchadin> stale the action plan needs final core reviews #link https://review.openstack.org/#/c/440927/
14:52:58 <alexchadin> I will review it, who else?
14:53:39 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/440927/
14:53:51 <alexchadin> Add gnocchi support in basic_consolidation strategy needs reviews #link https://review.openstack.org/#/c/440293/
14:54:25 <chrisspencer_> +1
14:54:30 <alexchadin> sanfern provided new PS yesterday, let's review it
14:54:58 <alexchadin> #action chrisspencer_ alexchadin review https://review.openstack.org/#/c/440293/
14:55:18 <alexchadin> exception when running 'watcher service list' needs reviews #link https://review.openstack.org/#/c/447354/
14:55:40 <chrisspencer_> +1
14:55:46 <alexchadin> I have a question here: is it good pattern to have one named hosts?
14:56:27 <alexchadin> same named*
14:57:23 <vincentfrancoise> alexchadin: I guess no, but sometimes legcy bites...
14:58:04 <alexchadin> vincentfrancoise: well, let's ask licanwei about it
14:58:24 <alexchadin> #action alexchadin put some comments on https://review.openstack.org/#/c/447354/
14:58:33 <alexchadin> we have only 2 minutes left
14:59:00 <acabot> no time left for specs :-D
14:59:01 <alexchadin> Don't forget there are 5 specs which are waiting for your reviews
14:59:25 <alexchadin> acabot: unfortunately...
14:59:41 <alexchadin> well, thank you for your attention
14:59:53 <vincentfrancoise> bye everyone
15:00:05 <alexchadin> bye
15:00:09 <sanfern> bye
15:00:14 <adisky_> bye
15:00:19 <pshedimb> bye
15:00:19 <ostroverkhov> bye
15:00:21 <acabot> bye
15:00:24 <chrisspencer_> bye
15:00:28 <alexchadin> #endmeeting