13:01:03 <alexchadin> #startmeeting watcher
13:01:04 <openstack> Meeting started Wed Mar 15 13:01:03 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:08 <openstack> The meeting name has been set to 'watcher'
13:01:16 <alexchadin> Hi
13:01:19 <hidekazu> hi
13:01:22 <adisky_> hi
13:01:34 <alexchadin> #info Today we have the following agenda https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F15.2F2017
13:01:50 <alexchadin> #topic Announcements
13:02:06 <alexchadin> Two Watcher-related presentations has been accepted for Summit. #link https://www.openstack.org/summit/boston-2017/summit-schedule/global-search?t=Watcher
13:02:13 <dtardivel> Hi
13:02:25 <alexchadin> congratulations to presentation holders!
13:02:34 <hidekazu> congrats!
13:02:49 <hidekazu> my session was not chosen :(
13:02:53 <ostroverkhov> congrats!
13:03:06 <sballe_> o/
13:03:22 <sballe_> thx
13:03:41 <alexchadin> Any other announcements?
13:04:12 <alexchadin> well, move on
13:04:18 <licanwei> :)
13:04:22 <alexchadin> #topic Review Action Items
13:04:32 <alexchadin> Watcher specs
13:04:52 <alexchadin> audit-tag-vm-metadata should be updated #link https://review.openstack.org/#/c/391374/
13:05:29 <alexchadin> seems that hvprash isn't here
13:05:44 <vincentfrancoise> hi
13:05:55 <sballe_> vincentfrancoise: hi
13:06:28 <alexchadin> vincentfrancoise: have hvprash contacted you to discuss your last comments on audit-tag-vm-metadata?
13:06:50 <acabot> hi sorry to be late
13:07:09 <alexchadin> hi acabot
13:07:18 <vincentfrancoise> alexchadin: no
13:07:41 <alexchadin> then I just mark it as action for him
13:08:07 <alexchadin> #action hvprash provide new PS and answers on https://review.openstack.org/#/c/391374/
13:08:25 <alexchadin> workload-characterization-grammar still needs reviews #link https://review.openstack.org/#/c/377100/
13:09:18 <alexchadin> who wants to review new PS here?
13:09:44 <acabot> +1
13:09:44 <alexchadin> there are a lot of changes made by Chris Spencer
13:09:59 <sballe_> I can do that but chisspencer has been on vacation
13:10:11 <sballe_> he should be back today and work on it again
13:10:31 <sballe_> chris spencer is the new owner
13:10:49 <alexchadin> sballe_: very well
13:10:51 <licanwei> +1
13:11:19 <alexchadin> #action acabot licanwei sballe_ review new version of https://review.openstack.org/#/c/377100/
13:11:33 <alexchadin> noisy-neighbor-dashboard needs answers to licanwei #link https://review.openstack.org/#/c/427308/
13:11:42 <vincentfrancoise> I'll try to have have a look at it
13:11:53 <sballe_> again chris has been on vacation. he is back today
13:11:54 <vincentfrancoise> I mean for workload-characterization-grammar
13:11:59 <alexchadin> Chris Spencer should answer here
13:12:18 <alexchadin> #action vincentfrancoise review https://review.openstack.org/#/c/377100/
13:12:28 <sballe_> just assign him actions and he can follow up
13:12:32 <vincentfrancoise> sballe_: yes but I'll do it probably next week
13:13:07 <sballe_> my comment was meant for alexchadin
13:13:13 <sballe_> but cool
13:13:20 <alexchadin> #action chrisspencer_ give some answers on https://review.openstack.org/#/c/427308/
13:13:22 <vincentfrancoise> sballe_ my bad
13:13:41 <alexchadin> cron-based-continuous-audits needs new PS with mentioning Vincent's propositions #link https://review.openstack.org/#/c/442388/
13:13:43 <sballe_> Ilol
13:14:31 <alexchadin> this BP will have dependencies with making apscheduler's jobs persistance
13:15:30 <alexchadin> #action alexchadin update https://review.openstack.org/#/c/442388/
13:15:40 <alexchadin> add-power-on-off needs answers to David's questions #link https://review.openstack.org/#/c/435436/
13:16:14 <alexchadin> it would be great if someone else review it too
13:16:22 <dtardivel> alexchadin: I read again the last updates from Yumeng.
13:17:37 <dtardivel> We need to improve again this spec. If we decide to interact with Ironic to power on/off, this spec should be define how to work with the Ironic service.
13:18:02 <dtardivel> so in the title, as example, set ironic term and so on ....
13:18:33 <alexchadin> dtardivel: I agree
13:19:15 <alexchadin> dtardivel: meanwhile, if we plan to work with Ironic, we need some development vector here
13:19:24 <dtardivel> licanwei: do you plan to add metadata in node-create API call to build the mapping between the hypersisor ID and the Baremetal node ID (and its management IP) ?
13:19:34 <dtardivel> alexchadin: yes
13:20:06 <vincentfrancoise> alexchadin: +1
13:20:21 <licanwei> dtardivel: just use ironicclient to control node power on/off
13:20:22 <dtardivel> alexchadin: I proposed to split this spec in 3 specs: 1: Baremetal DAta Model, 2: action power on/off, 3 the strategy
13:20:36 <licanwei> dtardivel: yes
13:21:09 <dtardivel> licanwei: where the API call parameters will come from ? the baremetal data model ?
13:21:20 <alexchadin> +1 it is good to split it
13:21:30 <vincentfrancoise> +1 for splitting
13:21:44 <alexchadin> Baremetal Data Model may correlate with CDM
13:22:20 <licanwei> dtardivel: add the mapping in the node table extra field
13:22:28 <dtardivel> alexchadin: licanwei: I think we can continue this discussion on #openstack-watcher :)
13:22:34 <alexchadin> We need to define placement for baremetal data in our data structure
13:22:39 <alexchadin> dtardivel: +1
13:22:43 <licanwei> ok
13:23:16 <alexchadin> #action vincentfrancoise dtardivel alexchadin licanwei discuss add-power-on-off
13:23:17 <dtardivel> licanwei: yes, I agree with you, so please describe this point in the spec ;=
13:23:22 <alexchadin> cancel-action-plan needs reviews
13:23:30 <alexchadin> #link https://review.openstack.org/#/c/432264/
13:23:32 <dtardivel> +1
13:24:16 <alexchadin> #action dtardivel alexchadin review https://review.openstack.org/#/c/432264/
13:24:26 <alexchadin> move on to Watcher
13:24:29 <alexchadin> Watcher
13:24:37 <alexchadin> gnocchi-watcher needs core reviews #link https://review.openstack.org/#/c/438530/
13:25:36 <alexchadin> who would like to take it?
13:26:18 <vincentfrancoise> I can
13:26:36 <alexchadin> hidekazu: could you please review it?
13:26:43 <alexchadin> vincentfrancoise: cool!
13:26:51 <hidekazu> ok, but i will do next week.
13:26:57 <alexchadin> no worries
13:27:24 <alexchadin> #action vincentfrancoise hidekazu give final reviews https://review.openstack.org/#/c/438530/
13:27:38 <alexchadin> Actuator strategy needs to be taken by someone else since Vincent cannot work on it anymore #link https://review.openstack.org/#/c/425110/
13:27:57 <alexchadin> vincentfrancoise has made a lot of work here and it is almost done
13:28:45 <vincentfrancoise> alexchadin: just need to fix the remaining few issues, but that shouldn't be too difficult
13:29:44 <alexchadin> who would like to take *heavy* burden and finish this commit? ;)
13:31:17 <alexchadin> well, I send proposition to the ML
13:31:56 <alexchadin> #action find a committer for https://review.openstack.org/#/c/425110/
13:32:06 <alexchadin> gnocchi support in basic_consolidation strategy needs new PS #link https://review.openstack.org/#/c/440293/
13:33:12 <alexchadin> #action sanfern provide new PS https://review.openstack.org/#/c/440293/
13:33:28 <alexchadin> Add period input parameter to vm workload consolidation and outlet temp control strategy. needs new PS #link https://review.openstack.org/#/c/444429/
13:33:44 <alexchadin> same thing here
13:34:12 <alexchadin> #action sanfern provide new PS https://review.openstack.org/#/c/444429/
13:34:28 <alexchadin> Added suspended audit state needs reviews #link https://review.openstack.org/#/c/438800/
13:35:24 <alexchadin> dtardivel: could you please review it?
13:35:41 <dtardivel> +1
13:35:43 <Yumeng__> I can also do the review
13:36:19 <alexchadin> #action dtardivel Yumeng__ review https://review.openstack.org/#/c/438800/
13:36:42 <alexchadin> stale-action-plan needs new PS #link https://review.openstack.org/#/c/440927/
13:37:55 <alexchadin> #action hidekazu vincentfrancoise alexchadin review https://review.openstack.org/#/c/440927/
13:38:13 <alexchadin> audit-tag-vm-metadata needs reviews #link https://review.openstack.org/#/c/443070/
13:39:27 <alexchadin> #action dtardivel vincentfrancoise hidekazu review https://review.openstack.org/#/c/443070/
13:39:46 <alexchadin> Local copy of scenario test base class needs new PS #link https://review.openstack.org/#/c/442756/
13:40:14 <alexchadin> who wants to review it?
13:41:38 <vincentfrancoise> alexchadin: +1
13:41:55 <alexchadin> #action vincentfrancoise review https://review.openstack.org/#/c/442756/
13:42:10 <alexchadin> #topic Blueprint/Bug Review and Discussion
13:42:12 <vincentfrancoise> alexchadin: but since it's a copy of another file, there's not much to do here
13:42:27 <alexchadin> vincentfrancoise: +1
13:42:38 <alexchadin> Reduced the code complexity needs new PS #link https://review.openstack.org/#/c/441873/
13:43:30 <alexchadin> we need to wait for answers from Béla Vancsics
13:43:45 <alexchadin> so move on to discussions
13:43:52 <alexchadin> #topic Open discussions
13:44:07 <alexchadin> Propositions for Forum Brainstorming are gathering now. What do we want to discuss? #link http://lists.openstack.org/pipermail/openstack-dev/2017-March/113115.html
13:44:45 <alexchadin> it is a good place to get feedback from users
13:45:03 <sballe_> is something like the requirements we had on nova for workload placement a topic?
13:45:20 <acabot> +1
13:45:26 <acabot> cross project topic
13:46:16 <sballe_> could we branstorm about how to best integrate with Cinder given taht that is our next target?
13:46:23 <alexchadin> so we can create etherpad for this and place our proposals there
13:46:32 <alexchadin> sballe_: great idea
13:46:45 <alexchadin> Ironic too
13:46:50 <sballe_> +1
13:47:43 <alexchadin> I will place a link here: https://wiki.openstack.org/wiki/Forum/Boston2017
13:47:53 <alexchadin> feel free to share your thoughts
13:48:31 <alexchadin> Adding Watcher install guide to openstack-manuals: who would like to take care of it?
13:48:59 <alexchadin> this idea don't leave me :)
13:49:33 <alexchadin> I already said that docs.openstack.org is a starting point for most newcomers
13:50:12 <alexchadin> seeing Watcher Installation Guide among other guides will help make Watcher more popular
13:50:19 <sballe_> +1
13:50:40 <sballe_> I agree but don't sign me up
13:50:47 <vincentfrancoise> alexchadin: What's the process to push a doc in the manuals?
13:50:50 <alexchadin> So I'd like to know if there is someone who can take care of it
13:51:39 <vincentfrancoise> alexchadin: this is almost like a BP on its own
13:51:42 <alexchadin> vincentfrancoise: it has commit form
13:51:45 <alexchadin> vincentfrancoise: like this https://review.openstack.org/#/c/438328/
13:51:49 <adisky_> alexchadin: I will take care of it
13:52:19 <alexchadin> adisky_: cool!
13:52:39 <alexchadin> adisky_: could you please give us status of it weekly?
13:52:51 <adisky_> alexchadin: ok
13:53:07 <alexchadin> adisky_: of course, once some related commit is ready, add us please as reviewers ;)
13:53:33 <adisky_> alexchadin: ok
13:53:49 <alexchadin> Watcher presentations for LinuxCon + ContainerCon + CloudOpen China #link http://events.linuxfoundation.org/events/linuxcon-containercon-cloudopen-china/program/cfp
13:53:56 <alexchadin> who would like to talk about it?
13:54:12 <Yumeng__> https://www.irccloud.com/pastebin/aMMwYfA0
13:54:23 <Yumeng__> Ops.. too many words
13:54:37 <Yumeng__> Can you see it?
13:54:41 <alexchadin> I see
13:55:04 <alexchadin> it is good idea
13:55:14 <alexchadin> Yumeng__: do you plan to hold it by yourself?
13:56:30 <Yumeng__> Yes, licanwei and I will be more than happy to help
13:56:34 <sballe_> Yumeng__: let us know if you need any help
13:56:56 <sballe_> with materials etc
13:57:11 <alexchadin> Yumeng__: great, we are ready to help
13:57:28 <Yumeng__> thx sballe Alex
13:57:57 <Yumeng__> I need your materials in last summit  for reference
13:58:20 <alexchadin> Yumeng__: contact me and I will give you all you need
13:58:40 <Yumeng__> Great! I will email you
13:59:38 <alexchadin> well, I think we are ready to end meeting
13:59:54 <alexchadin> thank you for your participation
14:00:06 <acabot> thx bye
14:00:07 <sballe_> bye
14:00:10 <hidekazu> bye
14:00:10 <alexchadin> bye
14:00:12 <Yumeng__> Thx bye
14:00:19 <alexchadin> #endmeeting