14:00:32 <alexchadin> #startmeeting watcher
14:00:34 <openstack> Meeting started Wed Mar  8 14:00:32 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:37 <openstack> The meeting name has been set to 'watcher'
14:00:41 <alexchadin> o/
14:00:46 <hvprash> hi
14:00:46 <chrisspencer_> o/
14:01:14 <sballe_> o/
14:01:16 <alexchadin> #info Today we have the following agenda https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F08.2F2017
14:01:24 <alexchadin> #topic Announcements
14:01:35 <alexchadin> #info Project onboarding rooms on Summit. 90 minutes to talk with people interesting in getting started with Watcher. When do we want to reserve one?
14:01:56 <sballe_> I like this idea
14:02:04 <alexchadin> me too
14:02:08 <sballe_> earlier in the summit is better
14:02:19 <sballe_> since people might start leaving
14:02:31 <alexchadin> We need to make a decision by monday
14:02:48 <alexchadin> I propose 9 may
14:03:05 <alexchadin> Since someone might not be on start
14:03:56 <alexchadin> I will write to ML to ask your opinion
14:04:24 <alexchadin> Our team needs to make decision by this Friday
14:04:47 <sballe_> may 9 is on sunday
14:05:27 <alexchadin> ahm
14:05:39 <alexchadin> isn't it tuesday?
14:06:41 <alexchadin> Do someone have other announcement?
14:07:14 <sballe_> alexchadin: yes my fault. I was looking at the wrong month
14:07:41 <sballe_> I have a question. do we want to try to do a Watcher dinner at the summit
14:07:42 <alexchadin> sballe_: it happens:) well, move on
14:07:51 <pksingh> hello, i am late
14:07:57 <pksingh> sorry
14:07:59 <alexchadin> hi pksingh
14:08:03 <alexchadin> sballe_: It would be great
14:08:33 <sballe_> I can try to find a cool place not too expensive since I am local
14:09:02 <sballe_> I'll give oyu guys a couple of choice and we can vote
14:09:14 <alexchadin> #action alexchadin and sballe discussion about dinner and planning
14:09:24 <alexchadin> sballe_: great!
14:09:52 <alexchadin> #topic Review Action Items
14:09:58 <alexchadin> Watcher specs
14:10:26 <alexchadin> noisy-neighbor-dashboard needs new PS
14:10:32 <alexchadin> #link https://review.openstack.org/#/c/427308/
14:11:00 <sballe_> we are still debugging the metrics and don;t want to put in the algorithms before we have it working
14:11:02 <alexchadin> chrisspencer_: have you seen comments?
14:11:05 <chrisspencer_> +1 also needs to be updated post PTG on decision to use grafana templates
14:11:17 <sballe_> sorry wrong spec
14:11:37 <hvprash> yeah, we discussed on this
14:12:04 <alexchadin> well, great, could you publish new PS by EOW?
14:12:18 <chrisspencer_> alexchadin: yup
14:13:03 <alexchadin> #action chrisspencer_ publish new PS to https://review.openstack.org/#/c/427308/
14:13:12 <alexchadin> noisy-neighbor-strategy needs new PS
14:13:21 <alexchadin> #link https://review.openstack.org/#/c/398162/
14:13:27 <pshedimb> hi, sorry I'm late
14:13:34 <alexchadin> well, it is still in progress
14:13:34 <sballe_> just in time
14:13:54 <pshedimb> This spec is still in work
14:14:03 <pshedimb> We're working and testing the algo.
14:14:08 <alexchadin> sballe_: maybe we could tag it like WiP?
14:14:22 <pshedimb> Had some issue with ceilometer. Raised bug for it.
14:14:25 <alexchadin> just to make sure that we don't need to review it yet
14:14:27 <sballe_> yes that would be fine. We are really close
14:14:56 <sballe_> the issue is we don;t want to put the alog in until we have it working because it would be a waste of reviews
14:15:05 <alexchadin> #action sballe_ pshedimb tag https://review.openstack.org/#/c/398162/ as WiP
14:15:07 <sballe_> s/algo
14:15:08 <alexchadin> sballe_: I agree
14:15:09 <pshedimb> alexchadin, I commented WIP. It is not owned by me, so can't give -1 WF
14:15:58 <alexchadin> pshedimb: You just need to add [WiP] before name of commit, it would be enough
14:16:00 <sballe_> pshedimb: done
14:16:11 <pshedimb> alexchadin, Ah okay.
14:16:25 <alexchadin> thank you, we move on
14:16:39 <alexchadin> gnocchi-watcher needs reviews #link https://review.openstack.org/#/c/437261/
14:17:36 <hvprash> will take a look
14:17:39 <pshedimb> Me
14:17:51 <sanfern> hello
14:17:53 <pshedimb> Already on review list for this.
14:17:58 <alexchadin> sanfern has made good work here, since it is high priority bp, we would like to review and merge it ASAP
14:18:03 <pksingh> will review it
14:18:06 <hvprash> sanfern, just in time :)
14:18:13 <sanfern> :)
14:18:43 <alexchadin> #act pshedimb hvprash pksingh review https://review.openstack.org/#/c/437261/
14:19:00 <alexchadin> #action pshedimb hvprash pksingh review https://review.openstack.org/#/c/437261/
14:19:18 <alexchadin> cancel-action-plan needs new PS, to answer questions #link https://review.openstack.org/#/c/432264/
14:20:07 <alexchadin> seems that aditi sharma is not here
14:20:41 <pksingh> it seems adisky_ is there but i am not sure whether she is looking or not
14:20:55 <alexchadin> adisky_: ping
14:21:26 <alexchadin> #action adisky_ answer new questions and publish new PS https://review.openstack.org/#/c/432264/
14:21:44 <alexchadin> cron-based-continuous-audits needs new PS #link https://review.openstack.org/#/c/442388/
14:21:59 <alexchadin> well, ok :)
14:22:27 <alexchadin> #action alexchadin publish new PS https://review.openstack.org/#/c/442388/
14:22:31 <alexchadin> who want to review it?
14:22:50 <licanwei> me
14:23:06 <pshedimb> me
14:23:12 <pksingh> me too
14:23:16 <chrisspencer_> +1
14:23:35 <alexchadin> #action licanwei pshedimb pksingh chrisspencer_ review https://review.openstack.org/#/c/442388/
14:23:38 <alexchadin> thank you!
14:23:52 <alexchadin> dynamic-action-description needs core reviews #link https://review.openstack.org/#/c/401111/
14:24:49 <alexchadin> licanwei: are you managing it now?
14:24:55 <pshedimb> Looks like I reviewed it before I was core. I'll reread it and give +2
14:25:02 <licanwei> yes
14:25:40 <alexchadin> licanwei: don't you want to add Co-Authored-By tag to commit message?
14:26:26 <alexchadin> licanwei: you may mention yourself there
14:26:43 <licanwei> ok
14:26:44 <alexchadin> licanwei: since you are commit holder now
14:27:12 <alexchadin> #action pshedimb review https://review.openstack.org/#/c/401111/
14:27:21 <alexchadin> move on to Watcher
14:27:24 <alexchadin> Watcher
14:27:36 <alexchadin> tempest-for-workload_stabilization needs to be tested by someone #link https://review.openstack.org/#/c/393355/
14:28:00 <alexchadin> I will try to test it, but I need to reconfigure my devstack env
14:28:19 <alexchadin> Who have active Ocata deployment now?
14:29:21 <alexchadin> ok, I will test it by myself :)
14:29:33 <alexchadin> #action alexchadin test https://review.openstack.org/#/c/393355/
14:29:50 <alexchadin> service-versioned-notifications-api when WiP tag should be removed? #link https://review.openstack.org/#/c/437333/
14:30:05 <alexchadin> Vladimir is not here
14:30:24 <alexchadin> I will ask him personally
14:30:49 <alexchadin> #action alexchadin ask service-versioned-notifications-api status
14:31:00 <alexchadin> reduced-the-code-complexity needs reviews #link https://review.openstack.org/#/c/441873/
14:31:38 <alexchadin> who wants to review it?
14:31:52 <alexchadin> it is just refactoring commit
14:32:14 <pksingh> me
14:32:28 <licanwei> +1
14:33:04 <alexchadin> #action pksingh licanwei alexchadin review https://review.openstack.org/#/c/441873/
14:33:20 <alexchadin> Add gnocchi support in basic_consolidation strategy needs new PS #link https://review.openstack.org/#/c/440293/
14:33:39 <pshedimb> me
14:34:23 <alexchadin> sanfern: IMHO, 300 is good default value for granularity since it is low archive policy (which is default for now)
14:34:47 <pksingh> alexchadin: +1
14:34:54 <pshedimb> Also is 0 even possible for granularity in gnocchi?
14:34:59 <alexchadin> nope
14:35:00 <sanfern> yeah I saw that was typo
14:35:05 <alexchadin> I don't think so:)
14:35:10 <sanfern> will fix it
14:35:57 <alexchadin> FYI, there are great people in gnocchi IRC channel, they may answer to every you questions regarding gnocchi
14:36:12 <sanfern> sure
14:37:12 <alexchadin> #action sanfern publish new PS https://review.openstack.org/#/c/440293/
14:37:29 <alexchadin> #action pksingh pshedimb alexchadin review https://review.openstack.org/#/c/440293/ once new PS is provided
14:37:39 <alexchadin> suspended-audit-state needs core reviews #link https://review.openstack.org/#/c/438800/
14:37:47 <pksingh> alexchadin: have you collected compute node metrics in gnocchi?
14:38:08 <pksingh> alexchadin: i was not able to, so asking
14:38:20 <alexchadin> pksingh: I didn't take into account it
14:38:35 <alexchadin> pksingh: will take a look next time I run gnocchi
14:38:41 <pksingh> alexchadin: ok, sure
14:39:02 <alexchadin> pksingh: I've seen your message about it, I will let you know
14:39:14 <pksingh> alexchadin: thanks :)
14:39:40 <alexchadin> BTW, is there someone who wants to review suspended audit state?
14:40:01 <alexchadin> hidekazu provided new PS this morning
14:41:48 <chrisspencer_> +1
14:41:57 <alexchadin> well, I will add all the core reviewers here :)
14:42:06 <alexchadin> and chrisspencer_ too ;)
14:42:52 <alexchadin> #action chrisspencer_ and Watcher Core team review https://review.openstack.org/#/c/438800/
14:43:11 <alexchadin> stale-action-plan needs reviews #link https://review.openstack.org/#/c/440927/
14:43:37 <alexchadin> licanwei: is it ready to review?
14:43:52 <licanwei> yes :)
14:44:36 <alexchadin> licanwei: don't you want to mention your changes in documentation? Have you planned it?
14:45:23 <licanwei> I have updated the bp
14:45:47 <pshedimb> licanwei, In PTG we have decided to add release notes with every commit that adds features.
14:46:04 <licanwei> o~ sorry
14:46:25 <licanwei> i'll add
14:46:45 <pshedimb> Sure. :)
14:46:52 <alexchadin> licanwei: thank you
14:47:06 <alexchadin> #action add some docs to https://review.openstack.org/#/c/440927/
14:47:12 <alexchadin> #undo
14:47:13 <openstack> Removing item from minutes: #action add some docs to https://review.openstack.org/#/c/440927/
14:47:21 <alexchadin> #action licanwei add some docs to https://review.openstack.org/#/c/440927/
14:47:55 <alexchadin> Watcher CLI & Dashboard
14:48:06 <alexchadin> Update test requirement needs final core review #link https://review.openstack.org/#/c/440484/
14:48:17 <alexchadin> oh sorry
14:48:31 <alexchadin> It is already merged by hidekazu
14:48:45 <alexchadin> #topic Open discussions
14:49:03 <alexchadin> Create a slack channel and connect it to watcher IRC channel
14:49:15 <alexchadin> We had this proposal on PTG
14:50:13 <hvprash> yes, i am testing this
14:50:16 <alexchadin> the main idea is to sync slack and IRC channel and work in Slack since it is more comfortable
14:50:29 <hvprash> point is irc is blocked in many companies
14:50:39 <hvprash> so this integration will help
14:50:54 <alexchadin> and many public Wi-Fi networks too
14:51:01 <hvprash> yeah
14:51:13 <pshedimb> And slack has option to send forced notification even if someone is in Do not disturb mode :P
14:51:25 <alexchadin> pshedimb: +1
14:51:31 <pksingh> pshedimb: +1 :)
14:51:45 <hvprash> found one https://github.com/ekmartin/slack-irc
14:51:51 <hvprash> need to test it
14:52:03 <hvprash> hope everyone ok with this ?
14:52:34 <pshedimb> Yes :)
14:52:36 <alexchadin> hvprash: can you share your achievements by next meeting?
14:52:47 <chrisspencer_> alexchadin: we also missed talking about grammar bp: https://review.openstack.org/#/c/377100/ there is a new PS and needs reviews
14:52:47 <hvprash> sure
14:53:17 <hvprash> chrisspencer_ i will look into it
14:53:24 <alexchadin> chrisspencer_: thx, didn't see it
14:53:29 <chrisspencer_> thanks hvprash I updated with some tosca info
14:53:39 <pksingh> guys i submitted my first PS to watcher https://review.openstack.org/#/c/443070/, please review and give your valuable comments
14:53:59 <hvprash> thanks chrisspencer_, i will go over it
14:54:24 <hvprash> awesome pksingh !
14:54:32 <alexchadin> to everyone: please, take a look at agenda before meeting starts. If there are something I've missed, feel free to edit wiki page.
14:55:00 <alexchadin> pksingh: nice work!
14:55:21 <pksingh> alexchadin: thanks :)
14:55:37 <alexchadin> #action hvprash pksingh review https://review.openstack.org/#/c/377100/
14:56:00 <alexchadin> #action chrisspencer_ hvprash review https://review.openstack.org/#/c/443070/
14:56:39 <pshedimb> hvprash, Also I added metadata into CDM
14:56:50 <alexchadin> there are no b-com folks today, they are busy today :)
14:57:02 <hvprash> pshedimb, is that merged ?
14:57:09 <pshedimb> hvprash, Yes.
14:57:21 <alexchadin> I won't discuss removing of Zone Migration wiki page since hidekazu is not here
14:57:25 <pshedimb> So you can see VM metadata in compute CDM
14:57:37 <pksingh> hvprash: pshedimb i used metadata in my patch, thanks
14:57:50 <hvprash> nice !
14:58:01 <hvprash> thanks pshedimb !
14:58:17 <pshedimb> hvprash, Sure. :)
14:58:47 <alexchadin> There are 2 minutes left, so if you don't have any announcements, I propose to end it
14:58:55 <hvprash> btw, pksingh, sanfern and myself are in the same team in walmart
14:59:27 <alexchadin> thank you all!
14:59:33 <pshedimb> alexchadin, thank you :)
14:59:38 <hvprash> thanks
14:59:39 <pksingh> bye
14:59:40 <alexchadin> see you in openstack-watcher channel!
14:59:43 <sanfern> thanks
14:59:47 <licanwei> bye
14:59:50 <alexchadin> bye
14:59:53 <pshedimb> bye
15:00:05 <alexchadin> #endmeeting