13:01:16 <acabot> #startmeeting watcher
13:01:17 <openstack> Meeting started Wed Feb 15 13:01:16 2017 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:21 <acabot> o/
13:01:21 <openstack> The meeting name has been set to 'watcher'
13:01:29 <chrisspencer> o/
13:01:31 <tmetsch> hi
13:01:32 <sballe_> o/
13:01:34 <hidekazu_> hello
13:01:35 <pshedimb> hi
13:01:59 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#02.2F15.2F2016
13:02:42 <acabot> #topic Announcements
13:02:53 <acabot> #info PTG is in 1 week, etherpad is open and a 1st draft of agenda is available / no projector in the room
13:03:04 <acabot> #link https://etherpad.openstack.org/p/pike-watcher-ptg
13:03:26 <acabot> I have a couple of new topics to add since last meeting
13:03:35 <vincentfrancoise> hi
13:03:47 <licanwei> hi
13:04:05 <acabot> I plan to finalize the agenda on Friday so please add any topic that needs to be discussed
13:04:51 <acabot> as our new PTL will be in remote, I'd like to have a clear agenda before we start
13:05:19 <hidekazu_> acabot: i will add more detail.
13:05:31 <acabot> #info Prudhvi Rao Shedimbi (pshedimb) has been nominated to Watcher Core
13:05:40 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/112114.html
13:05:46 <acabot> please vote on the ML
13:06:08 <sballe_> +1
13:06:31 <acabot> I'd like to have our new cores on board before the PTG
13:06:39 <sballe_> +1
13:06:43 <acabot> #info licanwei has been nominated to Watcher Core
13:06:51 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/112116.html
13:06:58 <acabot> please vote also for licanwei
13:07:01 <sballe_> +1
13:07:28 <licanwei> thank you acabot, vincent,sballe
13:07:37 <acabot> alexchadin : I think if we have enough +1 by next Monday, we can add them in core group
13:07:48 <vincentfrancoise> acabot: +1
13:07:52 <alexchadin> acabot: +1
13:08:03 <sballe_> acabot: +1
13:08:04 <pshedimb> thanka acabot vincentfrancoise alexchadin
13:08:07 <hidekazu_> acabot: vote is only by core, right?
13:08:23 <acabot> hidekazu_ : no no anyone can vote on the ML
13:08:38 <alexchadin> hidekazu_: feel free to give your vote :)
13:08:38 <hidekazu_> acabot: i see.
13:08:40 <acabot> hidekazu_ : most +1 we have, better it is
13:08:54 <hidekazu_> acabot: +1
13:08:54 <sballe_> acabot: totally agree!
13:09:20 <acabot> #info no meeting next week as we will be in Atlanta for the most part
13:09:58 <alexchadin> acabot: seems that it is your last meeting as PTL
13:10:10 <vincentfrancoise> I was also thinking about nominating hidekazu_ as core BTW
13:10:11 <acabot> alexchadin : :-) yes,
13:10:15 <sballe_> acabot: thanks for a great job as PTL!
13:10:24 <acabot> sballe_ : thx
13:10:27 <sballe_> You have done a fantastic job
13:10:31 <alexchadin> acabot: Thank you for your great work!
13:10:33 <pshedimb> great work acabot :)
13:10:56 <acabot> thank you alexchadin pshedimb
13:10:59 <vincentfrancoise> acabot: good job boss :)
13:11:11 <sballe_> lol
13:11:15 <acabot> vincentfrancoise : thx (not your boss anymore ;-))
13:11:17 <licanwei> great work for watcher
13:11:27 <alexchadin> vincentfrancoise: ah, you again used this word! :D
13:11:43 <vincentfrancoise> alexchadin: hahaha did it on purpose :D
13:11:56 <acabot> hidekazu_ : what do you think about becoming watcher core ?
13:12:08 <acabot> #link http://stackalytics.com/report/contribution/watcher/90
13:12:26 <hidekazu_> acabot: yes, i will do my best.
13:12:57 <sballe_> acabot: +1
13:13:07 <hidekazu_> acabot: i will be more involved in watcher in pike cycle.
13:13:08 <vincentfrancoise> I'll send an email on the ML for you hidekazu_ then ;)
13:13:11 <alexchadin> hidekazu_: you've made good progress and your reviews is helpfull
13:13:22 <alexchadin> +1 for nominating hidekazu_
13:13:29 <pshedimb> +1
13:13:32 <hidekazu_> vincentfrancoise: alexchadin: thanks.
13:13:56 <acabot> #action vincentfrancoise nominate hidekazu_ as core on the ML
13:14:10 <acabot> please all vote on the ML for hidekazu_
13:14:13 <licanwei> +1
13:14:27 <sballe_> +1
13:14:44 <acabot> #info next meeting will be chaired by alexchadin ;-)
13:14:56 <alexchadin> acabot: I'll do my best
13:15:01 <acabot> a quick work about the track chair process
13:15:21 <acabot> our talks are moving from categories
13:15:39 <acabot> no pb for now as they all stay in different categories
13:15:55 <acabot> sballe_ : your talk is still a lightning talk (I don't know why)
13:16:15 <sballe_> I don;t understand it either. it is setup as a presentation
13:16:22 <sballe_> can you change it?
13:16:27 <acabot> and the foundation should annonce a dedicated slot for each project to give a status update at the summit
13:16:51 <acabot> even if the Watcher presentation is not selected, we should have a slot
13:17:03 <acabot> sballe_ : no I can't
13:17:09 <sballe_> anythign I can do?
13:17:19 <sballe_> other than what I alreayd did
13:17:20 <acabot> sballe_ : I don't think so
13:17:54 <acabot> any other announcement ?
13:18:16 * acabot thinking its the last time he is asking this stupid question :-)
13:18:29 <acabot> #topic Review Action Items
13:18:40 <acabot> Watcher specs
13:18:53 <acabot> we still have specs targeted for ocata that needs to be moved
13:18:59 <acabot> before being reviewed
13:19:14 <acabot> #link https://review.openstack.org/#/c/398162/
13:19:36 <pshedimb> acabot, I will move noisy neigbor to Pike. Totally missed it.
13:19:55 <acabot> #action pshedimb move https://review.openstack.org/#/c/398162/ to pike
13:20:12 <acabot> #action hvprash move https://review.openstack.org/#/c/391374/ to Pike
13:20:35 <acabot> #action vincentfrancoise move https://review.openstack.org/#/c/420612/ to Pike
13:20:46 <vincentfrancoise> acabot: ok
13:20:51 <acabot> Suspended audit state needs a gate fix
13:20:57 <acabot> #link https://review.openstack.org/#/c/434144/
13:21:08 <hidekazu_> acabot: yes, i will fix.
13:21:21 <acabot> #action hidekazu_ fix gate for https://review.openstack.org/#/c/434144/
13:21:28 <acabot> specs for blueprint cancel action plan needs a new PS
13:21:35 <acabot> #link https://review.openstack.org/#/c/432264/
13:23:01 <acabot> hidekazu_ : do you know the nickname of Aditi ?
13:23:12 <hidekazu_> adisky_
13:23:19 <acabot> thx
13:23:43 <acabot> #action adisky_ add a new PS answering comments on https://review.openstack.org/#/c/432264/
13:23:52 <acabot> Define when an action plan is stale/invalid needs reviews
13:23:58 <acabot> #link https://review.openstack.org/#/c/432193/
13:24:17 <acabot> who wants to review ?
13:24:52 <hidekazu_> acabot: i will
13:25:02 <acabot> #action acabot hidekazu_ review https://review.openstack.org/#/c/432193/
13:25:10 <acabot> Support Description For Dynamic Action needs final reviews from core
13:25:18 <acabot> #link https://review.openstack.org/#/c/401111/
13:26:01 <acabot> #action sballe_ acabot hvprash alexchadin review https://review.openstack.org/#/c/401111/
13:26:18 <acabot> Moving to Watcher
13:26:28 <acabot> workload-balance-tempest needs core final reviews
13:26:35 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:detached/workload-balance-tempest
13:27:05 <acabot> alexchadin : could you have a look at it ?
13:27:42 <alexchadin> acabot: I will take workload_stabilization, I'm not familiar with workload-balance strategy
13:28:20 <acabot> #action alexchadin review https://review.openstack.org/#/c/393355/
13:28:34 <acabot> I think we will have to wait for our new cores :-)
13:28:40 <vincentfrancoise> acabot: the other one cannot be finished because it doesn't support the absence of metrics
13:28:58 <acabot> vincentfrancoise : ok could you W-1 ?
13:29:05 <vincentfrancoise> acabot: ok
13:29:15 <acabot> Add Action Notification needs core final reviews
13:29:22 <acabot> #link https://review.openstack.org/#/c/427646/
13:29:34 <acabot> #action dtardivel review https://review.openstack.org/#/c/427646/
13:29:54 <acabot> Reactivate watcher dashboard plugin in devstack/local.conf.controller needs core final reviews
13:30:02 <acabot> #link https://review.openstack.org/#/c/429256/
13:30:21 <alexchadin> W+1
13:30:43 <acabot> alexchadin : what do you mean ?
13:30:55 <alexchadin> acabot: I'm ready to W+1 it
13:31:09 <acabot> ok vincentfrancoise can you +2 ?
13:31:27 <acabot> vincentfrancoise : or you need to do more testes
13:31:35 <acabot> s/testes/tests
13:31:55 <vincentfrancoise> acabot: I want to have it enabled in the tempest tests as well so we know if it breaks again
13:32:40 <acabot> vincentfrancoise : ok so should we add a wishlist bug in this case ?
13:32:42 <vincentfrancoise> but I don't want to block it just for that as well, that's why I didn't +1 or -1'd it
13:33:24 <vincentfrancoise> acabot: we can do that yes
13:33:38 <acabot> #action vincentfrancoise submit a bug to have tempest tests for watcher dashboard
13:34:09 <acabot> #action vincentfrancoise alexchadin review & merge https://review.openstack.org/#/c/429256/
13:34:17 <acabot> dynamic-action-description needs a new PS
13:34:24 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/dynamic-action-description
13:34:44 <acabot> is yumeng here ?
13:35:15 <acabot> #action hanrong add a PS for https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/dynamic-action-description
13:35:24 <acabot> #topic Blueprint/Bug Review and Discussion
13:35:44 <acabot> #info Bug fixing in progress for Ocata-rcfinal targeted for February 16th
13:35:51 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-rc-final
13:37:12 <acabot> we need reviews on bug fixing before tomorrow so that we can release Watcher in v1.0.1
13:37:23 <acabot> #link https://review.openstack.org/#/c/429995/
13:37:30 <acabot> #link https://review.openstack.org/#/c/422295/
13:37:37 <acabot> #link https://review.openstack.org/#/c/430521/
13:38:13 <alexchadin> Will review them
13:38:49 <acabot> #action alexchadin vincentfrancoise review and merge (if possible) https://review.openstack.org/#/c/429995/ https://review.openstack.org/#/c/422295/ & https://review.openstack.org/#/c/430521/
13:39:24 <vincentfrancoise> acabot: will do
13:39:32 <acabot> thx
13:39:49 <acabot> #info We will release a v1.0.1 on February 16th due to #1662810
13:39:57 <acabot> #link  https://bugs.launchpad.net/watcher/+bug/1662810
13:39:57 <openstack> Launchpad bug 1662810 in watcher "model_root.get_node_instances(node) returns none instances" [Medium,Fix released] - Assigned to licanwei (li-canwei2)
13:40:00 <licanwei> acabot https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/dynamic-action-description W-1 by vincent
13:40:26 <acabot> licanwei : yes because spec has been updated
13:40:41 <acabot> since hanrong implementation
13:40:59 <acabot> licanwei : was it your question ?
13:41:11 <licanwei> acabot no question:)
13:41:26 <acabot> licanwei : ok
13:41:51 <acabot> so we are waiting for a new PS from hanrong based on updated spec
13:42:07 <licanwei> ok
13:42:17 <acabot> #info dont forget that all fixed bugs should be backported to stable/ocata branch
13:43:07 <acabot> #topic Open discussions
13:43:14 <acabot> 15 minutes left !
13:43:23 <acabot> #info Ceilometer API is now deprecated and not supported anymore in devstack
13:43:50 <sballe_> yeah I wanted to talk about this as well
13:43:52 <acabot> so our existing strategies don't work any more in devstack
13:44:05 <acabot> we have to rely on Gnocchi now
13:44:18 <pshedimb> yes
13:44:20 <sballe_> can we go directly to Monasca?
13:44:42 <sballe_> Gnocchi doesn't sounds like the rigth choice. Not sure anybody is using it
13:44:56 <acabot> sballe_ : no because Monasca is too heavy to be integrated with devstack
13:45:23 <acabot> sballe_ : we don't really care about who is using it, we need to stick to devstack
13:45:23 <alexchadin> it is proposed as official API replacement
13:45:26 <sballe_> so we end up doing extra busy work that doesn't really benefit anybody
13:45:26 <alexchadin> sballe_: ^
13:45:43 <sballe_> ok
13:45:47 <sballe_> alexchadin: ok
13:45:48 <alexchadin> I've started to work on using gnocchi api for Watcher, but sanfern (right?) take this BP
13:45:52 <acabot> sballe_ : no no we talk about devstack only (not a real env)
13:46:05 <alexchadin> I've installed gnocchi, it works not bad at all
13:46:11 <hidekazu_> redhat support gnocchi.
13:46:15 <acabot> alexchadin : good to hear
13:46:51 <acabot> maybe we could have a quick sync with jdanjou next week in Atlanta
13:47:19 <acabot> he is Telemetry PTL
13:47:24 <alexchadin> Monasca is even too hard to install it, there are big technology stack
13:47:33 <alexchadin> gnocchi is more lightweight
13:47:49 <alexchadin> and it has good sync with ceilometer publishers
13:48:20 <acabot> santhosh.fernandes took this BP a week ago but anyone discussed with him since ?
13:48:39 <alexchadin> I wanted to speak with him, but he wasn't online
13:48:50 <alexchadin> Actually, I'd like to complete my work here
13:48:53 <acabot> I'm not sure he's really working on it
13:49:06 <alexchadin> I've missed talks about taking this BP
13:49:24 <vincentfrancoise> acabot: he's pksingh's colleague so you can talk to him to know about it
13:50:05 <acabot> vincentfrancoise : ok
13:50:40 <pshedimb> acabot, alexchadin I have one thing to add
13:50:50 <pshedimb> I think there needs to be change in new devstack local.conf, with placement-api mandatory now
13:51:00 <pshedimb> To the one given in watcher docs
13:51:00 <acabot> #action alexchadin sync with pksingh & santhosh64 to know the status of https://blueprints.launchpad.net/watcher/+spec/gnocchi-watcher
13:51:37 <alexchadin> pshedimb: what commit are you talking about?
13:52:27 <pshedimb> alexchadin, the new devstack needs placement-api in nova.conf of compute node.
13:52:34 <pshedimb> Which was not required previously.
13:53:15 <alexchadin> pshedimb: let's discuss it in openstack-watcher channel
13:53:25 <pshedimb> alexchadin, okay.
13:54:00 <acabot> I forgot to mention that we have our official Watcher logo !!
13:54:03 <acabot> #link https://drive.google.com/open?id=0B_h5gjY7WQPMOWJUMlVhOG9rWGM
13:54:24 <acabot> #info Watcher logo is now official #link at we have our offi
13:54:35 <acabot> #undo
13:54:36 <openstack> Removing item from minutes: #info Watcher logo is now official #link at we have our offi
13:54:41 <acabot> #info Watcher logo is now official #link https://drive.google.com/open?id=0B_h5gjY7WQPMOWJUMlVhOG9rWGM
13:55:11 <sballe_> cool!
13:55:28 <alexchadin> looks good :)
13:55:46 <acabot> #info At the PTG, we�ll have stickers for your team of the mascot, plus signage on your room.
13:56:18 <acabot> we will all be jellyfished !!! thx to jwcroppe :-D
13:56:19 <alexchadin> seems that next summit will be filled with new logo merchandise :)
13:56:21 <sballe_> cool! Can somebody take a couple of stickers for me
13:56:35 <acabot> sballe_ : sure I will
13:56:37 <alexchadin> sballe_: +1
13:56:38 <pshedimb> sballe_, I surely can
13:56:52 <sballe_> thx
13:57:39 <acabot> its time for me to end my last meeting !
13:58:05 <acabot> thank you all for having Watcher been a great openstack project !
13:58:11 <sballe_> bye thx!
13:58:12 <licanwei> thank you acabot
13:58:25 <vincentfrancoise> bye all!
13:58:27 <alexchadin> thank you, acabot
13:58:28 <hidekazu_> acabot: thank you
13:58:31 <acabot> and I'm sure that it will be even greater with alex ;-)
13:58:43 <chrisspencer> thanks acabot
13:58:53 <acabot> see you in Atlanta !
13:59:03 <alexchadin> acabot: hope to see you in Summit :)
13:59:17 <acabot> alexchadin : yes I hope so
13:59:24 <acabot> bye
13:59:28 <alexchadin> bye
13:59:31 <licanwei> bye
13:59:38 <acabot> #endmeeting