14:01:15 <acabot> #startmeeting watcher
14:01:15 <openstack> Meeting started Wed Jan 25 14:01:15 2017 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:20 <openstack> The meeting name has been set to 'watcher'
14:01:25 <sballe_> hi
14:01:30 <chrisspencer> o/
14:01:31 <acabot> o/
14:01:33 <alexchadin> o/
14:01:33 <vincentfrancoise> o/
14:01:38 <hvprash> hi
14:01:55 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#01.2F25.2F2016
14:02:07 <dtardivel> hi
14:02:24 <acabot> #topic Announcements
14:02:42 <acabot> #info Pike PTLs self nomination has started and Watcher has no candidate yet
14:02:49 <acabot> #link https://governance.openstack.org/election/
14:03:01 <acabot> PTL nomination ends in 4d9h42m1s
14:03:03 <alexchadin> acabot: I've placed my self-nomination couple of hours ago
14:03:10 <sballe_> alexchadin: +1
14:03:21 <acabot> alexchadin : yop sorry I missed it
14:03:23 <vincentfrancoise> alexchadin: Nice!
14:03:29 <acabot> alexchadin : review # ?
14:03:40 <alexchadin> acabot: seconds
14:03:50 <alexchadin> https://review.openstack.org/#/c/425163/
14:04:25 <acabot> alexchadin : thx Alex, looks great
14:04:40 <sballe_> alexchadin: I like your plans!
14:04:58 <alexchadin> acabot, sballe_, vincentfrancoise thank you!
14:05:18 <hvprash> great alexchadin !
14:05:48 <alexchadin> hvprash: thank you!
14:05:55 <acabot> #info alexchadin has submited his candidacy as Watcher PTL https://review.openstack.org/#/c/425163/
14:06:12 <acabot> #info Meeting time for odd weeks will be moved from 9:00 UTC to 13:00 UTC on #openstack-meeting-alt
14:06:23 <acabot> as requested by US contributors
14:06:34 <sballe_> all thx a million for agreeing to move the time :-)
14:06:39 <hvprash> +1
14:06:43 <acabot> I hope it will be easier for you guys and still compatible with asian agenda
14:06:57 <acabot> #link https://review.openstack.org/#/c/425107/
14:07:20 <sballe_> acabot: It will be for me since I have been travling a lot to CA and it was at 1am i nthat timezone
14:07:32 <acabot> as soon as the review will be merged we will met at 13 UTC on #openstack-meeting-alt
14:07:42 <Yumeng> hi guys
14:07:46 <sballe_> hi
14:07:46 <alexchadin> hi Yumeng
14:07:52 <vincentfrancoise> hi Yumeng
14:07:55 <acabot> hi Yumeng
14:08:11 <Yumeng> thank you  such warm welcome!
14:08:26 <acabot> Yumeng : our weekly meeting on odd weeks will be moved to 13 UTC
14:08:39 <acabot> Yumeng : I hope its still good for you
14:08:55 <acabot> #info PTG is in one month, a dedicated etherpad is now open, please submit topics that you want to discuss
14:09:02 <acabot> #link https://etherpad.openstack.org/p/pike-watcher-ptg
14:09:18 <acabot> please add at least your name in the attendees list
14:09:41 <acabot> I hope to have around 10 people here but I still dont know who bought a ticket
14:10:05 <acabot> thx chrisspencer
14:10:11 <chrisspencer> :)
14:10:16 <sballe_> acabot: we got travel approval for pshedimb and chrisspencer
14:10:42 <sballe_> chrisspencer: +2
14:10:50 <acabot> ok Yumeng any update on your visa approval ?
14:11:04 <Yumeng> not yet
14:11:09 <acabot> ok
14:11:31 <acabot> feel free to add topics in the list even if you dont plan to be in Atlanta
14:11:45 <acabot> #info Call for presentations for Boston summit is now open (deadline is February 6th), a dedicated etherpad is ready to be completed
14:11:53 <acabot> #link https://etherpad.openstack.org/p/Watcher_abstracts_boston2017
14:12:12 <acabot> Yumeng : thx for your contribution
14:12:33 <acabot> if we could submit at least 3 talks next week it would be great
14:12:35 <Yumeng> acabot: :)
14:12:46 <sballe_> I will submit one today
14:12:53 <acabot> sballe_ : thx
14:13:11 <acabot> #info Watcher CLI has been released as 1.0.0
14:13:18 <acabot> #link https://releases.openstack.org/ocata/#ocata-python-watcherclient
14:13:33 <acabot> thx dtardivel & vincentfrancoise
14:13:34 <sballe_> alexchadin: since you are our new PTL you should be on the Watcher, the Infrastructure Optimization service for OpenStack: Plans for the P&Q-releases
14:14:09 <acabot> sballe_ : I think we can wait for the end of the week to see if we have any other candidate ;-)
14:14:11 <sballe_> For some reasons I am thinking that only two speakers can be on talks. If that is true I would suggest you and acabot on the talk
14:14:27 <sballe_> acabot: make sense
14:14:42 <acabot> #topic Review Action Items
14:14:48 <acabot> Specs
14:14:55 <acabot> Add improvements to the planner and workflow mechanisms needs a final core review before release
14:14:56 <alexchadin> sballe_: 95% I'll be in Boston
14:15:04 <acabot> #link https://review.openstack.org/#/c/385871/
14:15:24 <acabot> sballe_ : could you do a W+1 on this ?
14:15:30 <sballe_> yes
14:15:33 <acabot> sballe_ : all code has been merged already
14:15:34 <alexchadin> sballe_: code already has been merged
14:15:46 <acabot> #sballe_ : W+1 on https://review.openstack.org/#/c/385871/
14:15:52 <acabot> #action sballe_ : W+1 on https://review.openstack.org/#/c/385871/
14:16:04 <acabot> Define grammar for workload characterization needs a new PS answering previous comments
14:16:09 <acabot> #link https://review.openstack.org/#/c/377100/19
14:16:23 <acabot> hvprash : what's the status for this spec ?
14:16:42 <hvprash> acabot, there are still certain things unclear for the workload characterization. would have to discuss during the design summit
14:16:58 <hvprash> i am working on the PS though
14:17:27 <hvprash> may have to move this to Pike
14:17:27 <acabot> hvprash : ok please add it in the topics list then, I think its a major topic we have to discuss
14:17:29 <dtardivel> sballe_: give me more time to review it please #link https://review.openstack.org/#/c/385871/
14:17:39 <sballe_> ok
14:17:44 <hvprash> yes, will do
14:18:29 <acabot> #action hvprash add a new PS for https://review.openstack.org/#/c/377100/ and add it to the topics list in https://etherpad.openstack.org/p/pike-watcher-ptg
14:18:38 <acabot> Support Description For Dynamic Action needs a new PS
14:18:44 <acabot> #link https://review.openstack.org/#/c/401111/
14:18:55 <acabot> is hanrong here ?
14:19:29 <acabot> Yumeng : any update on this spec ?
14:19:51 <acabot> Noisy Neighbor Strategy has still work in progress
14:19:57 <acabot> #link https://review.openstack.org/#/c/398162/
14:20:09 <acabot> sballe_ : could you please complete it ?
14:20:38 <Yumeng> acabot: I will pass the message :)
14:20:56 <acabot> Yumeng : ok thx
14:21:11 <sballe_> acabot: yes. we got our systems working this week so we are now good to go. I will finish the spec
14:21:18 <acabot> thx
14:21:38 <acabot> #action sballe_ complete https://review.openstack.org/#/c/398162/
14:21:58 <acabot> sballe_ : this strategy could be a good candidate for Watcher talk in Boston
14:22:15 <sballe_> yes thta is the talk I am submitting
14:22:22 <acabot> sballe_ : ok
14:22:26 <acabot> Audit tag in VM Metadata needs reviews
14:22:32 <acabot> #link https://review.openstack.org/#/c/391374/
14:22:41 <acabot> thx hvprash for adding a PS
14:22:46 <hvprash> sballe_ vincentfrancois - need your help on this. pls review. pksingh and sanfern have started looking into the code.
14:22:47 <acabot> who wants to review it ?
14:23:06 <alexchadin> acabot: tag me
14:23:14 <acabot> #action sballe_ vincentfrancoise acabot alexchadin review https://review.openstack.org/#/c/391374/
14:23:15 <hvprash> i would need vincent to take a look and have some clarifications on the cluster data model
14:23:37 <hvprash> thabnks alexchadin
14:23:48 <acabot> moving to Watcher
14:23:56 <vincentfrancoise> hvprash: well, this week I'm still busy to finalize the release but we can discuss about it next week
14:24:10 <hvprash> just need 10 mins of your time. after this meeting ?
14:24:29 <acabot> we should release Watcher O3 tomorrow so a lot of code has been merged recently
14:24:30 <vincentfrancoise> hvprash: oh ok then
14:24:40 <hvprash> thx a lot
14:25:02 <acabot> #info New default planner has been merged #link https://review.openstack.org/#/c/406991/
14:25:17 <acabot> thx alexchadin vincentfrancoise for this great addition
14:25:20 <alexchadin> 2(!) new default planners:D
14:25:29 <alexchadin> thanks vincentfrancoise
14:25:33 <vincentfrancoise> alexchadin: sure :p
14:25:43 <acabot> alexchadin : yes now we have 2 planners :-)
14:26:03 <acabot> good to see that the plugin system works well
14:26:08 <vincentfrancoise> acabot: just need to be able to be able to select one in PIke :)
14:26:27 <acabot> vincentfrancoise : yes indeed
14:26:39 <acabot> #info Graph cluster model instead of mapping one & Remove obsolete Resource element have been merged
14:26:51 <acabot> thx tmetsh & vincentfrancoise for this
14:27:23 <acabot> all this work really improve watcher
14:27:42 <acabot> Fix multinode tempest test failure multinode gate is still being fixed
14:27:47 <vincentfrancoise> thx to intel folks for also giving us  a good starting point to integrate cinder and neutron data in the future
14:27:48 <acabot> #link https://review.openstack.org/#/c/419544/
14:28:28 <sballe_> vincentfrancoise: +1
14:28:51 <acabot> sballe_  : as the graph model is now used by watcher, you should probably check that all Intel's strategies are still working
14:29:09 <vincentfrancoise> acabot: +1
14:29:14 <sballe_> acabot: make sense. chrisspencer can you do that?
14:29:26 <acabot> because we check only workload consolidation & dummy strategies with the gate
14:29:34 <vincentfrancoise> all strategies aren't covered by integration tests so can you all test the strategies
14:29:44 <sballe_> acabot: can you add an action for chrisspencer
14:29:49 <acabot> sure
14:30:22 <acabot> #action chrisspencer check that existing Intel strategies are still working with graph model implementation
14:30:54 <acabot> so our multinode tempest gate still has problems
14:31:01 <acabot> vincentfrancoise is investigating it
14:31:24 <vincentfrancoise> acabot: we are getting there though
14:31:40 <acabot> we hope to have it fixed before the release to test Watcher in multinode
14:31:50 <vincentfrancoise> acabot: but right now people are merging code big time so things are moving slow
14:32:14 <acabot> #action vincentfrancoise Fix multinode tempest test failure https://review.openstack.org/#/c/419544/
14:32:22 <acabot> check the state of action plan needs final core reviews
14:32:28 <acabot> #link https://review.openstack.org/#/c/391383/
14:32:41 <acabot> who wants to review this last BP for O3 ?
14:33:12 <acabot> does anyone wants to fix the merge conflict ?
14:33:32 <dtardivel> =&
14:33:33 <dtardivel> +1
14:33:41 <acabot> ok thx
14:33:52 <acabot> #action dtardivel fix merge conflict for https://review.openstack.org/#/c/391383/
14:34:06 <acabot> who wants to review it before merge tomorrow ?
14:34:22 <vincentfrancoise> acabot: I'll work with dtardivel on it I guess
14:34:41 <acabot> #action vincentfrancoise review https://review.openstack.org/#/c/391383/
14:34:52 <acabot> Documentation update needs reviews
14:35:02 <acabot> #link https://review.openstack.org/#/c/424187/
14:35:17 <acabot> dtardivel reviewed our current doc before the release
14:35:30 <acabot> and provides a new architecture diagram
14:35:42 <acabot> I think its good for all to take a look at it
14:36:00 <acabot> http://docs-draft.openstack.org/87/424187/8/check/gate-watcher-docs-ubuntu-xenial/1dfdacb//doc/build/html/architecture.html
14:36:01 <alexchadin> +1
14:36:48 <acabot> #action alexchadin sballe_ hvprash acabot review https://review.openstack.org/#/c/424187/
14:37:09 <acabot> add Ocata release notes needs reviews
14:37:09 <hvprash> will do
14:37:16 <acabot> #link https://review.openstack.org/#/c/421281/
14:37:36 <acabot> I have created Reno release notes for Ocata
14:38:01 <acabot> I would really like to have a quick feedback about it before merging it
14:38:06 <sballe_> dtardivel: I guess joe W+1 https://review.openstack.org/#/c/385871/ right now and didn't wait for you to review :-(
14:39:04 <acabot> who wants to review release notes ? (its really quick)
14:39:18 <sballe_> +1
14:39:23 <chrisspencer> acabot: will do
14:39:31 <hvprash> +1
14:39:43 <acabot> #action sballe_ chrisspencer hvprash review https://review.openstack.org/#/c/421281/
14:39:48 <acabot> thx
14:39:56 <acabot> Add period input parameter to basic strategy is in merge conflict
14:40:03 <acabot> #link https://review.openstack.org/#/c/416432/
14:40:12 <acabot> I dont think hidekazu is here
14:40:24 <acabot> vincentfrancoise : should we merge it for o3 ?
14:40:31 <acabot> or it can wait
14:40:32 <dtardivel> I can resolv this issue as well
14:40:43 <alexchadin> +1
14:40:47 <alexchadin> can resolve
14:40:50 <vincentfrancoise> acabot: we could
14:41:00 <vincentfrancoise> acabot: it's a nice to have only though
14:41:08 <acabot> #action alexchadin fix merge conflict on https://review.openstack.org/#/c/416432/
14:41:39 <acabot> #action dtardivel merge https://review.openstack.org/#/c/416432/ in o3
14:41:49 <acabot> #topic Blueprint/Bug Review and Discussion
14:42:00 <acabot> #info Ocata 3 Milestone, with Feature and Requirements Freezes: 26 Jan
14:42:08 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-3
14:42:32 <acabot> we still have bugs and 1 BP in progress
14:42:57 <acabot> I plan to submit the release in 24h
14:43:47 <acabot> atuly_ : are you still working on https://bugs.launchpad.net/watcher/+bug/1640099 ?
14:43:47 <openstack> Launchpad bug 1640099 in watcher "Add tempest test for workload_stabilization" [Low,Triaged] - Assigned to Atul Pandey (atul-4you)
14:44:15 <acabot> #info Ocata RC1 target: 2 Feb
14:44:22 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-rc1
14:44:59 <acabot> hvprash : I will move your 2 BPs to Pike
14:45:12 <hvprash> thanks acabot
14:45:28 <acabot> #action acabot move hvprash BPs to Pike cycle
14:46:09 <acabot> #info Ocata Final Release candidate deadline: 16 Feb
14:46:19 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-rc-final
14:46:56 <acabot> so we will have at least 3 weeks to run tests between tomorrow and the final release
14:47:45 <acabot> I hope everyone will run tests on master branch during this period
14:47:56 <acabot> as we are targeting 1.0.0 version
14:48:20 <acabot> #topic Open discussions
14:48:43 <hvprash> i have an open discussion topic
14:48:56 <acabot> hvprash : please go ahead
14:49:13 <hvprash> with the monasca helper, does that mean the existing strategies needed to be modified too ?
14:49:20 <alexchadin> I've done all BPs related to Applier except limiting
14:49:24 <hvprash> existing action plans
14:49:32 <alexchadin> I think it is time for that old BP
14:49:58 <vincentfrancoise> hvprash: yes we still need to make each one Monasca-compatible
14:50:31 <alexchadin> vincentfrancoise: have you installed it yet?
14:51:10 <vincentfrancoise> alexchadin: you mean Monasca? Yes dtardivel did in our lab
14:51:45 <acabot> hvprash : yes you have to modify the strategy like this https://review.openstack.org/#/c/414617/
14:51:51 <hvprash> vincentfrancois - so we will be maintaining multiple versions or something configurable ?
14:52:21 <hvprash> thanks vincent. that helps.. will go thru it
14:52:26 <alexchadin> vincentfrancoise: yeah, Monasca. Do you have proper installation guide? There are a lot of technologies to be configured well
14:52:59 <vincentfrancoise> hvprash: well each strategy has to provide a datasource switch like I did for basic_consolidation
14:53:14 <dtardivel> alexchadin: please have a look on https://github.com/b-com/ansible-monasca
14:53:17 <hvprash> got it !
14:53:41 <vincentfrancoise> hvprash: but some like IPMI based do not have the corresponding metrics in Monasca I believe so this can be a bit complicated
14:53:56 <hvprash> ok
14:54:09 <alexchadin> dtardivel: thanks!
14:54:38 <acabot> alexchadin : alex, could you please send an email on the ML with your PTL candidacy ?
14:54:48 <vincentfrancoise> alexchadin: I also have a quick memo to configure the libvirt metrics somewhere if you want
14:55:06 <alexchadin> vincentfrancoise: If I need them I will let you know:)
14:55:32 <alexchadin> acabot: yeah, just the message with the same content?
14:55:41 <acabot> alexchadin : yes please
14:55:49 <alexchadin> acabot: will do
14:56:05 <acabot> #action alexchadin share PTL candidacy on the ML
14:57:03 <acabot> thank you all
14:57:10 <acabot> have a good day/night
14:57:14 <alexchadin> bye
14:57:15 <hvprash> thanks !
14:57:19 <hvprash> bye
14:57:19 <acabot> bye
14:57:24 <acabot> #endmeeting