09:01:13 <acabot> #startmeeting watcher
09:01:14 <openstack> Meeting started Wed Jan 18 09:01:13 2017 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:18 <openstack> The meeting name has been set to 'watcher'
09:01:24 <acabot> o/
09:01:32 <dtardivel> hi
09:01:34 <vincentfrancoise> o/
09:01:37 <pksingh> Pradeep from WalmartLabs
09:01:47 <pksingh> hello
09:02:01 <acabot> hello pksingh
09:02:08 <pksingh> acabot: hi
09:02:19 <acabot> pksingh : in which timezone are you ?
09:02:26 <alexchadin> hi
09:02:39 <pksingh> acabot: IST(Indian Standerd Timezone)
09:02:47 <tmetsch> hi
09:03:08 <acabot> pksingh : ok this meeting time is better for you then
09:03:20 <pksingh> acabot: yes, its 2:30 PM here
09:04:01 <acabot> pksingh : if we move it 2h later, would it be good for you as well ?
09:04:33 <acabot> I'm asking because sballe & jwcroppe asked to change meeting time last week
09:04:37 <pksingh> acabot: 4:30 PM? I think at that time i will be travelling from office to home
09:05:15 <acabot> pksingh : ok, 3h later would be better ?
09:05:54 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#01.2F18.2F2016
09:06:01 <pksingh> acabot: for safe time i would like to request to 6:30 PM IST if its possible and necessary
09:06:30 <acabot> pksingh : ok I will check that thx
09:06:43 <acabot> #topic Announcements
09:06:47 <pksingh> acabot: thanks a lot
09:07:00 <acabot> #info PTG is in one month, a dedicated etherpad is now open, please submit topics that you want to discuss
09:07:09 <acabot> #link https://etherpad.openstack.org/p/pike-watcher-ptg
09:07:25 <acabot> ttx just told me that there are only 100 seats left
09:07:58 <acabot> so if you plan to join us in Atlanta, please register at https://www.eventbrite.com/e/project-teams-gathering-tickets-27549298694 asap
09:08:18 <acabot> PTG could be full by end of week
09:08:40 <acabot> and add you name as attendees in the etherpad
09:09:01 <acabot> #action acabot send an email to all watcher contributors about PTG tickets rush$
09:09:31 <acabot> please also complete the topics section on the etherpad
09:09:31 <pksingh> acabot: is there any travel support program from openstack community for PTG?
09:10:25 <acabot> pksingh : https://www.openstack.org/ptg#tab_travel
09:10:35 <acabot> deadline to submit was January 13th
09:11:21 <pksingh> ahh
09:11:25 <acabot> even if you dont join us, please complete the topic list so that we can discuss all subjects coming from the community
09:11:33 <pksingh> sure
09:11:48 <acabot> #info Call for presentations for Boston summit is now open (deadline is February 6th), a dedicated etherpad is ready to be completed
09:11:59 <acabot> #link https://etherpad.openstack.org/p/Watcher_abstracts_boston2017
09:12:25 <acabot> as a reminder, if your talk is selected, you will get a free pass for Boston summit
09:12:41 <acabot> so please complete the etherpad
09:12:52 <acabot> #info Pike PTLs self nomination will start next week and Watcher needs to find a new PTL
09:12:59 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/109019.html
09:13:10 <acabot> any other announcement form you guys ?
09:13:59 <acabot> #topic Review Action Items
09:14:19 <acabot> Still a lot of specs open waiting for reviews
09:14:28 <acabot> Add improvements to the planner and workflow mechanisms needs to be rewrited after implementation as it differs from original spec
09:14:35 <acabot> #link https://review.openstack.org/#/c/385871/
09:14:46 <acabot> alexchadin : do you see what needs to be updated ?
09:14:53 <alexchadin> I'm working on it today
09:15:10 <ttx> pksingh: you can still submit for teh travel support program in the coming hour, haven't closed the poll yet
09:15:19 <alexchadin> acabot: to complete info about weight planner
09:15:26 <ttx> It's still Tuesday in Hawai after all
09:15:31 <pksingh> if i submit by next two hour will it be OK?/
09:15:41 <alexchadin> acabot: and update info about workload_stabilization planner also
09:15:41 <ttx> yes sure
09:15:51 <pksingh> ttx, thanks
09:16:08 <ttx> pksingh: doesn't mean you will get selected, since we have many demands, but worth a try!
09:16:23 <pksingh> ttx: yes, i understand. thankx
09:16:49 <acabot> alexchadin : ok looks good, dont forget to do it promptly as we plan to have your code merged by ocata-3
09:17:11 <acabot> alexchadin : I'd like to have the spec in sync ;-)
09:17:20 <alexchadin> acabot: me too:)
09:17:23 <acabot> Add improvements to Applier to make it parallel needs a final core review
09:17:29 <acabot> #link https://review.openstack.org/#/c/413079/
09:17:30 <pksingh> acabot: what is the last date for code freeze in this cycle?
09:17:35 <dtardivel> +1
09:17:59 <acabot> pksingh : CLI & dashboard 01/19, Watcher 01/23
09:18:30 <acabot> jwcroppe already merged it
09:18:30 <pksingh> acabot: i wanted to implement https://review.openstack.org/#/c/391374/
09:19:05 <acabot> #info Audit tag in VM Metadata still has TODOs
09:19:11 <acabot> #link https://review.openstack.org/#/c/391374/
09:19:35 <vincentfrancoise> pksingh: unless you are already about to push the code for review and we don't have much to say on it, I don't think it'll make it
09:19:37 <acabot> pksingh : could you complete this spec ?
09:20:05 <pksingh> acabot: i will work with Prashanth
09:20:45 <acabot> pksingh : you really need to complete this spec as I'd like to discuss implementation details at the PTG
09:21:09 <acabot> #action pksingh hvprash complete spec https://review.openstack.org/#/c/391374/
09:21:13 <pksingh> acabot: OK
09:21:24 <acabot> Define grammar for workload characterization needs a new PS answering previous comments
09:21:30 <acabot> #link https://review.openstack.org/#/c/377100/19
09:21:37 <acabot> this one also come from hvprash
09:21:52 <acabot> pksingh : are you working on this one too ?
09:22:07 <pksingh> acabot: not looked yet
09:22:23 <acabot> #action hvprash answer comments on https://review.openstack.org/#/c/377100/19
09:22:32 <acabot> Support Description For Dynamic Action needs a new PS
09:22:38 <acabot> #link https://review.openstack.org/#/c/401111/
09:22:44 <acabot> is hanrong here ?
09:23:41 <acabot> #action hanrong add a new PS for https://review.openstack.org/#/c/401111/
09:23:48 <acabot> Noisy Neighbor Strategy has still work in progress
09:23:54 <acabot> #link https://review.openstack.org/#/c/398162/
09:24:02 <acabot> #action sballe complete https://review.openstack.org/#/c/398162/
09:24:10 <acabot> cluster energy saving needs to be resubmitted as launchpad does not allow to change the superseded state
09:24:45 <acabot> ttx as you are here, do you know if we can remove a superseded state for a blueprint in laucnhpad ?
09:25:31 <acabot> #action hanrong jinquan yumengbao resubmit the BP https://blueprints.launchpad.net/watcher/+spec/cluster-energy-saving
09:25:39 <acabot> moving to Watcher
09:25:52 <acabot> #info Automatic triggering audit has been merged
09:25:58 <acabot> #link https://review.openstack.org/#/q/topic:bp/automatic-triggering-audit
09:26:02 <acabot> thx alexchadin
09:26:11 <vincentfrancoise> +1
09:26:14 <acabot> #info Added Monasca Helper & Multi datasource support for Basic Consolidation have been merged
09:26:20 <ttx> hmm let me see
09:26:31 <acabot> #link https://review.openstack.org/#/c/348891/ & #link https://review.openstack.org/#/c/414617/
09:26:37 <acabot> thx vincentfrancoise
09:26:42 <alexchadin> great news!
09:27:19 <acabot> Fix multinode tempest test failure multinode gate is still being fixed
09:27:27 <acabot> #link https://review.openstack.org/#/c/419544/
09:28:20 <acabot> dtardivel & vincentfrancoise are still investigating
09:28:38 <acabot> #action dtardivel vincentfrancoise fix multinode gate
09:28:41 <ttx> (re: inability to un-supersede blueprints: looks like another LP limitation)
09:28:58 <acabot> ttx ok good to know :-D
09:29:18 <acabot> ttx thx
09:29:28 <acabot> New default planner needs final core reviews
09:29:34 <acabot> #link https://review.openstack.org/#/c/406991/
09:30:13 <alexchadin> +1
09:30:14 <dtardivel> I'm running additional integration tests on our lab OS cluster
09:30:20 <vincentfrancoise> as I told alexchadin, I need to test it today to see if I don't find any more bugs
09:30:46 <alexchadin> vincentfrancoise: Will you test it along with new applier?
09:30:56 <acabot> #action dtardivel vincentfrancoise do additional testing on https://review.openstack.org/#/c/406991/
09:31:30 <vincentfrancoise> alexchadin: dtardivel will test the whole chain I think, I will only look at the planner itself
09:31:53 <acabot> Graph cluster model instead of mapping one needs final reviews and all strategy authors should try their strategy
09:32:00 <acabot> #link https://review.openstack.org/#/c/418434/
09:32:15 <acabot> tmetsch : did you already looked at it with Kevin ?
09:32:30 <tmetsch> acabot: jup - comments should be in now.
09:32:44 <vincentfrancoise> tmetsch: I saw them, thx
09:33:02 <tmetsch> generally looks good to us, just some minors to ensure future usage - good work!
09:33:12 <acabot> tmetsch : thx
09:33:58 <acabot> check the state of action plan needs final reviews
09:34:05 <acabot> #link https://review.openstack.org/#/c/391383/
09:34:24 <acabot> who wants to review it ?
09:34:40 <dtardivel> +1
09:34:57 <acabot> #action dtardivel review https://review.openstack.org/#/c/391383/
09:35:24 <acabot> dynamic action description needs a status
09:35:31 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/dynamic-action-description
09:35:46 <acabot> #action hanrong give a status for https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/dynamic-action-description
09:36:00 <acabot> Watcher CLI & dashboard
09:36:28 <acabot> #info CLI & dashboard must be released by January 19th for Ocata
09:36:52 <acabot> alexchadin : we need to merge your code that depends from Watcher PS
09:36:57 <acabot> in CLI
09:37:34 <acabot> #topic Blueprint/Bug Review and Discussion
09:37:34 <vincentfrancoise> acabot: that's why I'm on it today
09:37:35 <alexchadin> acabot: what PS your are speaking about?
09:37:56 <acabot> alexchadin : https://review.openstack.org/#/q/status:open+project:openstack/python-watcherclient+branch:master+topic:bp/tempest-cli-test
09:37:58 <alexchadin> acabot: support parents?
09:38:12 <alexchadin> acabot: ah, understood
09:39:04 <acabot> #info ocata-3 is due January 23rd (feature freeze)
09:39:11 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-3
09:39:17 <dtardivel> alexchadin: yes, new 'parents' feature in db
09:39:37 <acabot> we still have 3 BPs in review
09:39:54 <acabot> and 9 bugs open
09:40:24 <acabot> please try to fix bugs by January 23rd
09:41:03 <acabot> #topic Open discussions
09:41:21 <acabot> we discussed last week about changing the time of this meeting
09:42:01 <acabot> according to pksingh having it 4 hours later would be fine
09:42:10 <acabot> it will also be good for US
09:42:20 <acabot> but not so good for China I suppose
09:42:50 <acabot> it would be 13 UTC
09:43:24 <acabot> so 9pm in China
09:43:43 <acabot> and 8am in the US
09:44:40 <acabot> let me try to find a slot on openstack meeting schedule
09:45:10 <acabot> #action acabot find a new slot available for meeting on odd weeks at 13UTC
09:45:29 <acabot> any other topic to discuss ?
09:45:33 <pksingh> acabot: for even weeks it will be same?
09:45:44 <acabot> yes we keep 14UTC on even weeks
09:46:15 <pksingh> thats also good foe me
09:46:56 <acabot> ok thank you guys
09:47:05 <acabot> have a nice day/night
09:47:19 <pksingh> acabot: i have one question, can i ask?
09:47:37 <acabot> sure
09:47:56 <pksingh> acabot: why did we choose voluptous over jsonschema?
09:48:18 <vincentfrancoise> pksingh: we actually want to get away from voluptuous now :p
09:48:39 <vincentfrancoise> pksingh: see https://blueprints.launchpad.net/watcher/+spec/jsonschema-validation
09:48:45 <pksingh> vincentfrancoise: yes, i find it too hard, you have to write code for it
09:49:01 <pksingh> vincentfrancoise: is anybody working on that
09:49:09 <pksingh> i can take that
09:49:26 <vincentfrancoise> pksingh: hum yumengbao is workon on it
09:49:45 <vincentfrancoise> pksingh: I don't know if he actually started it though
09:49:52 <pksingh> vincentfrancoise: ok great, if he needs any help i can help him
09:49:59 <vincentfrancoise> pksingh: we talked about it last week
09:50:40 <pksingh> in which timezone he is, any idea?
09:51:14 <acabot> pksingh : china
09:51:35 <pksingh> acabot: OK, will discuss with him tomorrow
09:51:54 <acabot> ok
09:52:21 <pksingh> thanks guys, i would like to be part of this wonderful team bye :)
09:52:38 <acabot> thank you pksingh
09:52:43 <acabot> see you
09:52:48 <acabot> #endmeeting