09:00:05 <acabot> #startmeeting watcher
09:00:06 <openstack> Meeting started Wed Jan  4 09:00:05 2017 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:09 <openstack> The meeting name has been set to 'watcher'
09:00:15 <vincentfrancoise> o/
09:00:26 <sballe_> Hi
09:00:28 <acabot> o/
09:00:30 <hidekazu> hi
09:00:34 <acabot> happy new year everyone !
09:00:39 <licanwei> hi
09:00:43 <sballe_> Thx
09:00:52 <dtardivel> hi
09:01:00 <acabot> #info our agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#01.2F04.2F2016
09:01:01 <vincentfrancoise> Happy New Year !
09:01:23 <acabot> #topic Announcements
09:01:27 <dtardivel> Bonne Année 2017 - Happy New Year to you all
09:02:00 <acabot> #info Watcher ocata-2 has been released on December 15th
09:02:25 <acabot> we missed 2 BPs for this release because of late reviews
09:02:25 <sballe_> +1
09:02:44 <acabot> sorry alexchadin for postponing your 2 BPs to ocata-3
09:02:56 <acabot> so now we have 12 BPs for ocata-3 !
09:03:22 <Yumeng> hi
09:03:34 <acabot> #info Pike PTLs self nomination will start January 23rd and Watcher needs to find a new PTL
09:03:59 <acabot> as said in the ML #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/109019.html I wont be candidate for a 4th cycle
09:04:49 <acabot> so please think about becoming Watcher PTL before January 23rd
09:04:53 <acabot> ;-)
09:05:34 <acabot> you should also know that nobody from bcom will be candidate (vincentfrancoise, dtardivel, jed56)
09:06:04 <acabot> and I'd like to avoid having no candidate for the election :-)
09:06:15 <acabot> lets move on
09:06:22 <acabot> #topic Review Action Items
09:06:40 <acabot> we really need to finalize a couple of specs here
09:06:53 <acabot> Audit tag in VM Metadata There are +1s but TODOs are still left in spec
09:07:02 <acabot> #link https://review.openstack.org/#/c/391374/
09:07:22 <acabot> hvprash told me that he will work on this one this week
09:07:52 <acabot> #actio hvprash complete and finalize spec https://review.openstack.org/#/c/391374/
09:08:22 <acabot> #action hvprash complete and finalize spec https://review.openstack.org/#/c/391374/
09:08:29 <acabot> Define grammar for workload characterization needs a new PS an answering previous comments
09:08:36 <acabot> #link https://review.openstack.org/#/c/377100/
09:08:51 <acabot> sballe : could you please try to add a new PS ?
09:09:08 <acabot> sballe_ : could you please try to add a new PS ?
09:09:23 <sballe_> Yes hvprash and I will do that this week
09:09:47 <acabot> #action hvprash sballe_ : answer comments on https://review.openstack.org/#/c/377100/
09:09:55 <acabot> Support Description For Dynamic Action needs a new PS
09:10:02 <acabot> #link https://review.openstack.org/#/c/401111/
09:10:28 <acabot> is hanrong here ?
09:11:06 <acabot> #action hanrong add a new PS on https://review.openstack.org/#/c/401111/
09:11:11 <Yumeng> nope. she will join very soon
09:11:25 <acabot> Yumeng : thx
09:11:27 <acabot> Spec for Noisy Neighbor Startegy needs reviews
09:11:33 <acabot> #link https://review.openstack.org/#/c/398162/
09:11:42 <acabot> who wants to review this strategy ?
09:12:31 <acabot> Add improvements to the planner and workflow mechanisms needs final reviews
09:12:39 <acabot> #link https://review.openstack.org/#/c/385871/
09:12:50 <sballe_> I can review
09:13:21 <acabot> #action sballe_ acabot : final review on https://review.openstack.org/#/c/385871/
09:13:37 <acabot> Add improvements to Applier to make it parallel needs reviews
09:13:43 <acabot> #link https://review.openstack.org/#/c/413079/
09:14:19 <acabot> #action sballe_ acabot hvprash review https://review.openstack.org/#/c/413079/
09:14:31 <acabot> cluster energy saving needs to be resubmitted as launchpad does not allow to change the superseded state
09:14:31 <hidekazu> i want to review
09:14:45 <acabot> #action hidekazu review https://review.openstack.org/#/c/413079/
09:14:57 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/cluster-energy-saving
09:15:34 <acabot> Yumeng hanrong : I cant remove the superseded state in launchpad so could you resubmit your BP with the same description ?
09:15:54 <acabot> I'd like to keep the ZTE origin of drafted bps
09:16:44 <acabot> Yumeng : could you do it ?
09:17:03 <Yumeng> yes, will do.
09:17:32 <acabot> #action Yumeng resubmit BP https://blueprints.launchpad.net/watcher/+spec/cluster-energy-saving as a new PB
09:17:36 <Yumeng> actually i think hanrong has updated that .. i didn't find the link
09:17:48 <acabot> she updated the description
09:18:00 <acabot> but I cant remove the superseded state
09:18:15 <acabot> moving to Watcher
09:18:21 <acabot> Add auto_trigger support to watcher needs final reviews & merge
09:18:28 <acabot> #link https://review.openstack.org/#/c/403718/
09:19:10 <acabot> do we need to create a new BP for BDB migration before moving on ?
09:19:11 <vincentfrancoise> acabot: I can review this one
09:19:23 <sballe_> Me too
09:19:41 <acabot> #action vincentfrancoise sballe_ review https://review.openstack.org/#/c/403718/
09:19:54 <sballe_> What's BDB?
09:19:58 <acabot> sorry DB
09:20:14 <sballe_> 😀
09:20:19 <acabot> Graph model needs reviews
09:20:25 <acabot> #link https://review.openstack.org/#/c/362730/
09:20:32 <vincentfrancoise> acabot: if we want to have a Watcher 1.0, yes
09:20:36 <acabot> I'd like to have it merge by octata-3
09:21:02 <acabot> #action acabot submit a BP to handle DB migration
09:21:26 <acabot> who wants to review the graph model ?
09:21:49 <vincentfrancoise> acabot: I started already so count me on
09:21:56 <acabot> ok thx
09:22:13 <acabot> #action vincentfrancoise review https://review.openstack.org/#/c/362730/
09:22:22 <acabot> Added Monasca Helper needs reviews
09:22:29 <acabot> #link https://review.openstack.org/#/c/348891/
09:23:21 <sballe_> I can review
09:23:22 <acabot> who wants to review ?
09:23:38 <hidekazu> I will
09:23:48 <acabot> thx
09:24:11 <dtardivel> +1
09:24:16 <acabot> #action sballe_ hidekazu dtardivel review https://review.openstack.org/#/c/348891/
09:24:26 <acabot> Multi datasource support for Basic Consolidation needs discussions
09:24:32 <acabot> #link https://review.openstack.org/#/c/414617/
09:25:10 <acabot> the point from licanwei is should we add an abstraction layer
09:25:28 <acabot> to deal with multiple datasource (Monasca, Gnocchi)
09:25:37 <acabot> it has been a very long discussion on our side
09:26:12 <acabot> vincentfrancoise proposed a BP for that #link https://blueprints.launchpad.net/watcher/+spec/watcher-multi-datasource
09:27:03 <acabot> for now we decided to implement a basic version with backend choice in the strategy
09:27:24 <acabot> it means that every strategy will be specific to a metrics backend
09:28:17 <acabot> who wants to review https://review.openstack.org/#/c/414617/ ?
09:28:24 <dtardivel> +1
09:28:34 <acabot> #action dtardivel review https://review.openstack.org/#/c/414617/
09:28:57 <acabot> New default planner & check the state of action plan needs final reviews
09:29:03 <acabot> #link https://review.openstack.org/#/c/406991/
09:29:10 <acabot> #link https://review.openstack.org/#/c/391383/
09:30:05 <acabot> New default planner needs to be discussed with alexchadin
09:30:23 <vincentfrancoise> +1
09:30:44 <vincentfrancoise> I proposed an alternative that I would like to discuss with him
09:30:51 <acabot> #action vincentfrancoise dtardivel : sync with alexchadin about https://review.openstack.org/#/c/406991/
09:30:54 <vincentfrancoise> #link https://review.openstack.org/#/c/415505/
09:32:05 <acabot> #action vincentfrancoise dtardivel final reviews on https://review.openstack.org/#/c/391383/
09:32:19 <acabot> Watcher CLI
09:32:26 <acabot> Add auto_trigger support needs final reviews & merge
09:32:33 <acabot> #link https://review.openstack.org/#/c/403716/
09:33:10 <dtardivel> acabot: there is a Depends-On rule
09:34:12 <acabot> #action dtardivel review & merge https://review.openstack.org/#/c/403716/
09:34:26 <acabot> #topic Blueprint/Bug Review and Discussion
09:34:34 <acabot> Watcher ocata-3 has started and finishes on January 23rd with 12 BPs to finish
09:34:38 <acabot> #info Watcher ocata-3 has started and finishes on January 23rd with 12 BPs to finish
09:34:49 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-3
09:35:14 <acabot> we wont be able to deliver 12 BPs in 2 weeks !
09:35:40 <acabot> we should focus on "needs code review" BP !
09:35:55 <dtardivel> +1
09:36:01 <acabot> I will move the others to the next release
09:36:48 <acabot> does any one can update the status of his/her BPs ? set as started if it is
09:37:23 <acabot> I will move all not started or unknown state BPs to ocata-rc today
09:37:54 <Yumeng> i have just started https://blueprints.launchpad.net/watcher/+spec/watcher-api-validation
09:38:19 <Yumeng> but also pls  move it to ocata-rc
09:38:32 <acabot> Yumeng : do you plan to write a spec for it ?
09:39:32 <acabot> Yumeng : you can use the one from keystone https://review.openstack.org/#/c/95957/14/specs/juno/keystone-api-validation.rst
09:39:44 <Yumeng> i am doing with the code about initial implementation of the validator framework
09:40:12 <Yumeng> can i just submit a rough implementaion first ?
09:40:19 <acabot> Yumeng : sure you can
09:40:26 <Yumeng> and see what's your suggestions
09:40:33 <Yumeng> ok, thx
09:40:48 <vincentfrancoise> Yumeng: Can you explain to me/us how you want to do it?
09:41:16 <Yumeng> i was following this https://review.openstack.org/#/c/86483/
09:41:32 <Yumeng> but keep update with the new code in keystone
09:42:39 <vincentfrancoise> Yumeng: the idea was to use jsonschema if I remember correctly
09:42:59 <Yumeng> yes, i will use jsonschema
09:43:38 <vincentfrancoise> Yumeng: ok
09:43:55 <vincentfrancoise> Yumeng: if you need help or you are not sure, please do ping me ;)
09:44:11 <acabot> #action acabot move all unstarted BPs to ocata-rc1
09:44:17 <Yumeng> vincentfrancoise: thx
09:44:27 <acabot> #topic Open discussions
09:44:37 <acabot> 15 mins left for open discussions
09:45:05 <hidekazu> acabot: https://bugs.launchpad.net/watcher/+bug/1640105 was fixed actually.
09:45:07 <openstack> Launchpad bug 1640105 in watcher "Change hardware.cpu_util to compute.node.cpu.percent in workload_stabilization" [Medium,In progress] - Assigned to Hidekazu Nakamura (nakamura-h)
09:45:09 <acabot> Yumeng : do you know the priority on your side for cluster-energy-saving ?
09:45:42 <Yumeng> i don't know
09:46:04 <acabot> hidekazu : ok this is because you didn't mention Closes-Bug in your commit msg
09:46:12 <acabot> I will update
09:46:17 <vincentfrancoise> acabot: I did it ;)
09:46:21 <hidekazu> acabot: yes, sorry.
09:47:29 <acabot> anyone has submitted a new BP during holidays ?
09:47:36 <acabot> I could have missed it
09:48:14 <acabot> I will create Pike cycle in launchpad soon and start adding next BPs
09:48:19 <Yumeng> acabot: can we have the priority of  cluster-energy-saving as "high" ?
09:49:16 <acabot> Yumeng : I can set it as high but it will be in the Pike cycle
09:49:47 <Yumeng> aha~ that's ok
09:49:56 <acabot> #link https://blueprints.launchpad.net/watcher/ocata
09:50:00 <Yumeng> thx
09:50:21 <acabot> we still have 3 BPs with high priority that needs to be implemented
09:51:07 <acabot> any other topic to discuss ?
09:52:22 <acabot> so thank you all
09:52:26 <acabot> see you next week
09:52:36 <acabot> #endmeeting