09:00:32 <acabot> #startmeeting watcher
09:00:33 <openstack> Meeting started Wed Nov 23 09:00:32 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:37 <openstack> The meeting name has been set to 'watcher'
09:00:37 <acabot> o/
09:00:40 <dtardivel> hi
09:00:44 <brunograz> o/
09:00:47 <seanmurphy> hi guys
09:00:58 <Yumeng> hi
09:01:01 <acabot> europe is awake ;-)
09:01:32 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F23.2F2016
09:01:36 <seanmurphy> i guess the us is preparing for thanksgiving ;-)
09:01:47 <acabot> seanmurphy : for sure
09:02:24 <acabot> so lets start
09:02:31 <acabot> #topic Announcements
09:02:47 <acabot> #info python-watcher v0.32 & python-watcherclient v0.26 & watcher-dashboard v0.6 have been released for ocata-1 on November 18th
09:03:09 <acabot> thx everyone for meeting the deadline
09:03:22 <acabot> #info recap for Barcelona has been sent
09:03:30 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107623.html
09:03:46 <acabot> do not hesitate to answer the thread if something is missing
09:03:57 <acabot> #info a discussion has been started regarding the way we should validate Watcher strategies
09:04:07 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107402.html
09:04:32 <acabot> this is an important issue so feel free to send your thoughts about it
09:04:39 <acabot> on the ML
09:04:55 <acabot> #info acabot didn't has the time to prepare the trello board for the meeting
09:05:03 <acabot> sorry for that, I will do it next week
09:05:06 <alexchadin> hello everyone
09:05:11 <acabot> hello alex
09:05:21 <acabot> #info acabot presented Watcher & our big tent journey on November 22nd @openstackdayfrance2016
09:05:49 <acabot> I had 40 attendees
09:06:15 <alexchadin> great!
09:06:23 <acabot> #info your OSIC cluster request for testing Watcher has been rejected
09:06:45 <dtardivel> acabot: why ?
09:06:48 <acabot> they ask us to request a bare metal env instead of an openstack already deployed
09:06:56 <seanmurphy> well done on the openstack france presentation
09:07:19 <acabot> and I dont really want to have to configure OpenStack for our tests
09:07:50 <seanmurphy> can we get some usage info from osic so we could estimate what gains could be made?
09:08:12 <acabot> seanmurphy : I need to check that with sballe
09:08:28 <acabot> seanmurphy : as I dont really know what metrics we can get
09:08:58 <acabot> my main concern is to take 2 weeks to have an openstack ready with monasca deployed...
09:09:08 <seanmurphy> one idea that i thought might make sense - (I mentioned it in barca) - was if watcher could publish some usage data from some real systems as a driver for showing what gains are possible
09:09:11 <acabot> and we can have a cluster for a month max
09:09:48 <acabot> seanmurphy : yes this is something we planned to do before Barcelona, with the Intel cluster
09:10:12 <acabot> seanmurphy : unfortunately it took 7 weeks to have openstack & watcher ready !
09:10:31 <seanmurphy> haha - things always take longer than planned ;-)
09:10:47 <acabot> seanmurphy : so we stopped the experimentation falling back on OSIC node with an openstack already deployed
09:11:20 <acabot> seanmurphy : but as I said, they want us to deploy openstack as well...
09:11:35 <alexchadin> acabot: how much servers?
09:12:03 <acabot> alexchadin : we can have 132 nodes or 66 nodes cluster
09:12:47 <acabot> I would suggest to work on improving watcher code until christmas and then ask for a testing env in january
09:13:23 <acabot> I will check with Intel if they can handle the openstack deployment on the OSIC cluster
09:13:24 <dtardivel> acabot: from  my point of view, we have no choice, we have to run watcher within a medium cluster size, to be able to demonstrate the real gains with watcher
09:14:26 <acabot> dtardivel : I agree but on bcom side, we wont be able to work on an openstack deployment on OSIC before Xmas
09:14:55 <dtardivel> acabot: could we find some guys in our teams ready to help us to deploy a OS for our aims ?
09:15:00 <acabot> #action acabot check with Intel if they could set up a new test environment for Watcher
09:15:27 <acabot> dtardivel : I will try to find some
09:15:29 <alexchadin> dtardivel: I have 2 years experience with deploying openstack
09:15:36 <alexchadin> but only on very small cluster
09:15:42 <alexchadin> 4-5 machines
09:15:58 <dtardivel> alexchadin: 8 machines for me :)
09:16:02 <alexchadin> without automation tools like ansible, vagrant so on
09:16:12 <acabot> I think configuring Newton on a 66 nodes env is not that easy ;-)
09:16:27 <alexchadin> we need some tools to automate it
09:16:30 <alexchadin> like fuel
09:16:34 <acabot> s/Newton/Neutron
09:16:45 <alexchadin> but it is in nearly dead state
09:17:13 <acabot> let me ask for help next week
09:17:23 <acabot> #topic Review Action Items
09:17:32 <acabot> Watcher specs
09:17:39 <acabot> automatic triggering of action plans for AUDIT should now be reviewed and merged
09:17:45 <acabot> #link https://review.openstack.org/#/c/342473/
09:18:12 <acabot> alexchadin diga : can we merge it ?
09:18:18 <alexchadin> I think yes
09:18:34 <alexchadin> +2 from me
09:18:34 <acabot> diga ?
09:18:50 <diga> hi
09:19:06 <acabot> diga : can we merge your spec ?
09:19:14 <acabot> nothing to add ?
09:19:14 <diga> acabot: yesm we can merge the spec
09:19:18 <acabot> ok thx
09:19:36 <acabot> #action acabot sballe review and merge https://review.openstack.org/#/c/342473/
09:19:44 <acabot> Define grammar for workload characterization needs a new PS
09:19:51 <acabot> #link https://review.openstack.org/#/c/377100/
09:20:04 <acabot> thx seanmurphy for your comments
09:20:14 <acabot> #action hvprash answer comments on https://review.openstack.org/#/c/377100/
09:20:24 <acabot> Define when an action plan is stale/invalid needs final reviews from cores
09:20:30 <acabot> #link https://review.openstack.org/#/c/386293/
09:20:54 <acabot> I think this spec looks good
09:21:03 <acabot> anyone wants to review it before merging ?
09:21:25 <acabot> #action acabot sballe review and merge https://review.openstack.org/#/c/386293/
09:21:32 <hanrong> +1
09:21:47 <acabot> #action hanrong review and merge https://review.openstack.org/#/c/386293/
09:21:51 <acabot> hi hanrong ;-)
09:21:59 <hanrong> hi, :-D
09:22:02 <acabot> Audit tag in VM Metadata needs reviews
09:22:12 <acabot> #link https://review.openstack.org/#/c/391374/
09:22:37 <acabot> vincentfrancoise did a great addition to this spec
09:22:45 <acabot> anyone wants to review it ?
09:23:07 <acabot> I think its now complete
09:23:10 <dtardivel> acabot: i think vincentfrancoise forgot to update this spec with our latest comments. I will do it.
09:23:23 <acabot> dtardivel : PS 5 ?
09:23:29 <alexchadin> I'd like to review it
09:23:46 <dtardivel> yes i think so. I will check.
09:23:58 <acabot> #action alexchadin acabot review https://review.openstack.org/#/c/391374/
09:24:06 <acabot> Add improvements to the planner and workflow mechanisms needs reviews
09:24:13 <acabot> #link https://review.openstack.org/#/c/385871/
09:24:40 <acabot> we talked about splitting this spec in 2
09:24:55 <acabot> dtardivel : did you talked with alexchadin about it ?
09:25:16 <alexchadin> acabot: I talked with vincent about it
09:25:18 <seanmurphy> i can review 385871
09:25:37 <alexchadin> seanmurphy: I appreciate it!
09:25:37 <dtardivel> acabot: no, this is the position of vincentfrancoise.
09:26:01 <alexchadin> acabot: In this spec I've described only the first part of BP
09:26:32 <acabot> alexchadin : ok so should we update the BP description  and add a new one ?
09:26:33 <dtardivel> alexchadin: so only the data model impact ?
09:26:44 <alexchadin> acabot: the second one, about modifying Applier, would be in the next spec.
09:26:56 <acabot> seanmurphy : let me check is the scope is ok before reviewing
09:27:03 <alexchadin> dtardivel: yes, but we cannot merge it without the second part:)
09:27:51 <acabot> alexchadin : lets discuss this on our channel
09:27:53 <alexchadin> so, these two specs cannot exists without each other
09:28:34 <acabot> #action dtardivel alexchadin acabot sync on openstack-watcher about https://review.openstack.org/#/c/385871/
09:28:43 <acabot> Moving to Watcher code
09:28:53 <dtardivel> alexchadin: from vincentfrancoise point of view, we should be able to update the data model and the way the planner will handle new model to make the action plan, without impacting the applier
09:29:09 <acabot> watcher-notifications-ovo & audit-versioned-notifications-api merged
09:29:23 <acabot> Documentation for Outlet Temperature Based Strategy looks good and will be merged soon
09:29:31 <acabot> #link https://review.openstack.org/#/c/397411/
09:29:42 <acabot> is it the last doc strategy ?
09:30:33 <acabot> dtardivel : do we still have strategies without doc ?
09:30:42 <dtardivel> acabot: not sure
09:30:51 <dtardivel> acabot: let me check
09:31:04 <acabot> #action dtardivel check if we have all our strategies documented
09:31:11 <acabot> centralise config options need reviews
09:31:22 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/centralise-config-opts
09:31:30 <acabot> who wants to review this ?
09:31:40 <dtardivel> +1
09:31:48 <hanrong> +1
09:31:59 <acabot> #action dtardivel hanrong review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/centralise-config-opts
09:32:39 <acabot> check the state of action plan needs a new PS
09:32:45 <acabot> #link https://review.openstack.org/#/c/391383/
09:32:56 <acabot> #action licanwei answer comments on https://review.openstack.org/#/c/391383/
09:33:05 <acabot> Watcher CLI
09:33:10 <acabot> Add functional tests to watcherclient needs reviews
09:33:17 <acabot> #link https://review.openstack.org/#/c/389181/
09:33:20 <dtardivel> +1
09:33:28 <acabot> #action dtardivel review https://review.openstack.org/#/c/389181/
09:33:45 <acabot> #topic Blueprint/Bug Review and Discussion
09:33:57 <acabot> #info Ocata-2 is our current target due December 12th
09:34:04 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-2
09:34:36 <dtardivel> acabot: uniform airflow strategy is not documented
09:35:07 <acabot> nishi's strategy
09:35:13 <acabot> I will ask sballe
09:35:31 <acabot> #action acabot ask sballe for documenting airflow strategy
09:36:04 <acabot> for ocata-2, we have 9 BPs targeted
09:36:25 <acabot> please update the delivery field if you already started implementing
09:36:48 <acabot> hanrong : did you start https://blueprints.launchpad.net/watcher/+spec/dynamic-action-description ?
09:36:55 <hanrong> yes
09:37:12 <hanrong> https://review.openstack.org/#/c/401111/
09:37:39 <acabot> hanrong : ops sorry I missed it
09:37:51 <hanrong> I submitted today
09:37:55 <acabot> ok ;-)
09:38:14 <dtardivel> 36 min ago ;)
09:38:54 <hanrong> need more discussion
09:39:08 <acabot> ok
09:39:18 <acabot> #topic Open discussions
09:39:27 <dtardivel> hanrong: I will read your proposition
09:39:38 <acabot> #undo
09:39:39 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7fbb93d2fc10>
09:39:57 <acabot> #action dtardivel review https://review.openstack.org/#/c/401111/
09:40:08 <acabot> #topic Open discussions
09:40:24 <acabot> I dont have any topic to discuss today
09:40:31 <acabot> anyone wants to open one ?
09:40:31 <Yumeng> I can also do review for https://review.openstack.org/#/c/401111/
09:40:45 <acabot> #action Yumeng review https://review.openstack.org/#/c/401111/
09:41:50 <seanmurphy> we have been setting up monasca to understand resource consumption
09:41:57 <seanmurphy> as sballe suggested at barca meeting
09:42:02 <seanmurphy> it’s a pita!
09:42:08 <acabot> seanmurphy : :-)
09:42:13 <seanmurphy> brunograz put up a blog post on it
09:42:19 <acabot> please share it
09:42:24 <seanmurphy> we’re now thinking that prometheus is a better option
09:42:38 <brunograz> #link https://blog.zhaw.ch/icclab/installing-monasca-a-happy-ending-after-much-sadness-and-woe/
09:42:47 <alexchadin> seanmurphy: hi:)
09:42:53 <acabot> I heard also yesterday that prometheus is probably the best option today for monitoring
09:43:08 <alexchadin> I read your post yesterday and leaved some comments
09:43:20 <seanmurphy> interestingly, it seems to have little support so far for openstack
09:43:26 <seanmurphy> canonical are working on it afaik
09:43:43 <seanmurphy> anyway - it’s just a ‘by the way’ - not core to watcher, i guess but relevant
09:44:07 <seanmurphy> we did bounce around the idea of embedded a grafana dashboard into watcher on horizon
09:44:15 <seanmurphy> but we will see how doable it might be
09:44:27 <acabot> ok
09:45:14 <acabot> so thx everyone
09:45:24 <acabot> have a good day/evening
09:45:25 <dtardivel> promotheus is available on dockey hub: #link https://hub.docker.com/r/prom/prometheus
09:45:51 <dtardivel> s/dockey/docker
09:45:54 <seanmurphy> dockey hub - i like it ;-)
09:46:24 <seanmurphy> yeah - it took 10 mins to set up prometheus to play with
09:46:28 <seanmurphy> vs days for monasca
09:46:37 <acabot> #
09:46:49 * acabot not surprised ;-)
09:47:19 <acabot> thx
09:47:22 <acabot> #endmeeting