14:00:29 <acabot_> #startmeeting watcher
14:00:30 <openstack> Meeting started Wed Nov 16 14:00:29 2016 UTC and is due to finish in 60 minutes.  The chair is acabot_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:33 <openstack> The meeting name has been set to 'watcher'
14:00:36 <acabot_> o/
14:00:49 <sballe_> ji
14:00:51 <vincentfrancoise> o/
14:00:53 <sballe_> hi
14:00:58 <dtardivel> hello
14:00:59 <brunograz> o/
14:01:02 <hvprash_> hi
14:01:05 <licanwei> hi
14:01:06 <exploreshaifali> \o
14:01:14 <pshedimb> hi
14:01:33 <acabot_> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F16.2F2016
14:02:12 <acabot_> #topic Announcements
14:02:23 <acabot_> #info We should send a recap of discussions in Barcelona on the ML
14:02:40 <acabot_> sballe_ : I dont know if you have seen this action from last meeting
14:03:16 <acabot_> I suggested to send a recap of Watcher sessions in Barcelona but as I was not there I'm probably not the best person to do it ;-)
14:03:22 <sballe_> no I forgot. But I do want you guys to welcome the two new intel developers to watcher
14:03:36 <sballe_> pshedimb: welcome
14:03:47 <sballe_> I am not sure what chris' irc nickname is
14:04:05 <acabot_> sballe_ : welcome !!!
14:04:23 <vincentfrancoise> pshedimb: Welcome on board!
14:04:36 <sballe_> edwin will be fading out of watcher and moving to a different project.
14:04:47 <sballe_> pshedimb: and chris are located int he US
14:04:52 <vincentfrancoise> sballe_: there is a chrisspencer on #openstack-watcher: is it him?
14:04:58 <sballe_> yes
14:05:04 <pshedimb> thanks you :)
14:05:22 <hvprash_> welcome pshedimb !
14:05:27 <vincentfrancoise> sballe_: nice!
14:05:32 <acabot_> pshedimb & chrisspencer : welcome on board !
14:05:42 <hvprash_> welcome chrisspencer !
14:06:05 <exploreshaifali> welcome psachin, cholcombe :)
14:06:45 <acabot_> sballe_ : sorry but we have many subjects to discuss today so I'm moving on, could you send the recap on the ML ?
14:06:58 <sballe_> yes will do
14:07:24 <acabot_> #action sballe_ send a recap of watcher sessions on the ML
14:07:37 <acabot_> #info We will start a thread on the ML to discuss the way we can test available strategies
14:07:55 <acabot_> dtardivel : can you handle it ?
14:07:56 <sballe_> love it. that is definetly neede
14:08:55 <dtardivel> acabot_: I sent an email this morning
14:09:05 <acabot_> ok sorry I missed it ;-)
14:09:14 <acabot_> #topic Review Action Items
14:09:18 <acabot_> Watcher specs
14:09:26 <acabot_> #info team priorities for Ocata have been merged
14:09:35 <acabot_> #link http://specs.openstack.org/openstack/watcher-specs/priorities/ocata-priorities.html
14:09:48 <acabot_> scale out or delete instance based on workload should be abandonned
14:09:57 <acabot_> #link https://review.openstack.org/#/c/359690/
14:10:21 <acabot_> licanwei : can you do it on behalf on jinquan ?
14:10:39 <licanwei> yunmeng do it
14:10:50 <acabot_> licanwei : by the way is jinquan back on the project ?
14:11:07 <licanwei> maybe not
14:11:17 <acabot_> #action yunmeng abandon the spec https://review.openstack.org/#/c/359690/
14:11:24 <acabot_> licanwei : ok
14:11:33 <acabot_> automatic triggering of action plans for AUDIT should now be reviewed and merged
14:11:48 <acabot_> #link https://review.openstack.org/#/c/342473/
14:12:26 <acabot_> alexchadin took this bp as diga was not there
14:12:49 <acabot_> sballe_ : can you do a final review on https://review.openstack.org/#/c/342473/ ?
14:12:54 <vincentfrancoise> acabot_: diga started to implement something about it
14:12:59 <sballe_> sure
14:13:02 <acabot_> or hvprash_
14:13:28 <hvprash_> yes acabot_. have some clarifications on that BP which may have some dependency with audit tag
14:13:29 <acabot_> vincentfrancoise : I saw it right before the meeting, not sure it fit the spec
14:14:01 <acabot_> #action acabot_ sballe_ hvprash_ review and merge https://review.openstack.org/#/c/342473/
14:14:10 <acabot_> Specs for watcher-versioned-objects must be merged as code has already been merged
14:14:17 <vincentfrancoise> acabot_: yes, it's clearly not enough to fully implement what was said in the specs
14:14:20 <acabot_> #link https://review.openstack.org/#/c/383718/
14:14:44 <acabot_> again hvprash_ & sballe_ could you please +2 +1 this spec ?
14:14:51 <sballe_> definetly
14:14:53 <hvprash_> yes
14:15:02 <vincentfrancoise> acabot_: it's just that I don't know if it's alexchadin or diga that is supposed to work on it at the moment
14:15:12 <acabot_> this code will be released tomorrow so please do it today
14:15:19 <sballe_> ok
14:15:40 <acabot_> #action sballe_ hvprash_ review and merge https://review.openstack.org/#/c/383718/ today
14:15:47 <acabot_> Specs for audit-versioned-notifications-api needs final reviews from core
14:15:53 <vincentfrancoise> sballe_: the code is already merged anyway
14:15:57 <acabot_> #link https://review.openstack.org/#/c/385077/
14:16:13 <acabot_> code will be merged today so we need to merge it as well
14:16:29 <sballe_> ok
14:16:30 <acabot_> #action acabot_ sballe_ hvprash_ review & merge https://review.openstack.org/#/c/385077/ today
14:16:36 <acabot_> Define grammar for workload characterization needs reviews
14:16:45 <acabot_> #link https://review.openstack.org/#/c/377100/
14:17:00 <acabot_> hvprash_ : can we continue reviewing it ?
14:17:01 <hvprash_> thanks sballe_ for reviewing. will add the job priority to the characterization. others review too
14:17:22 <acabot_> I will
14:17:22 <hvprash_> yes acabot_ pls continue reviewing
14:17:33 <acabot_> #action acabot review https://review.openstack.org/#/c/377100/
14:17:56 <acabot_> Define when an action plan is stale/invalid needs discussions
14:18:04 <acabot_> #link https://review.openstack.org/#/c/386293/
14:18:26 <sballe_> are we not discussing the QoS BP?
14:18:31 <acabot_> licanwei : you sent me an email about brunograz comments, I'm sorry I didn't had time to go trough them
14:18:54 <acabot_> sballe_ : link ?
14:19:02 <sballe_> Workload Characterization and QoS needs to be assigned to me. I already changed the BP.We submitted a new Blueprint  which is a sub-task of: https://blueprints.launchpad.net/watcher/+spec/workload-characterization-qoshttps://blueprints.launchpad.net/watcher/+spec/cache-occupancy-strategySpec is here: https://review.openstack.org/#/c/398162/1
14:19:02 <sballe_> https://usercontent.irccloud-cdn.com/file/M2FRZ3ae/
14:19:10 <licanwei> acabot: i need your suggest
14:19:13 <sballe_> these where my updates
14:19:25 <sballe_> sorry for the weird format
14:19:48 <sballe_> Should I just change the ownership to me in the priorities?
14:19:57 <acabot_> no its in the agenda
14:20:03 <acabot_> just wait
14:20:24 <sballe_> ok we can talk afterwards on how to get all this done
14:20:30 <acabot_> licanwei : I will review it tomorrow
14:20:39 <licanwei> acabot: ok,thanks
14:20:48 <acabot_> #action acabot review https://review.openstack.org/#/c/386293/
14:20:58 <acabot_> Audit tag in VM Metadata needs a jenkins fix & reviews
14:21:07 <acabot_> #link https://review.openstack.org/#/c/391374/
14:21:13 <acabot_> hvprash_ : could you fix it ?
14:21:36 <sballe_> i will review
14:21:54 <hvprash_> i need to do a PS. also, have some clarifications on implementing this feature. Either acabot_ vincent or jed could help me on this
14:21:57 <acabot_> #action sballe_ review https://review.openstack.org/#/c/391374/
14:21:58 <vincentfrancoise> acabot_: I will review it too
14:22:20 <acabot_> #action acabot_ vincentfrancoise review https://review.openstack.org/#/c/391374/
14:22:34 <acabot_> Add improvements to the planner and workflow mechanisms needs reviews
14:22:43 <acabot_> #link https://review.openstack.org/#/c/385871/
14:23:19 <acabot_> we are thinking of splitting this BP in 2 but it needs to be discussed with alexchadin
14:23:51 <acabot_> #action acabot_ alexchadin discuss BP split for https://review.openstack.org/#/c/385871/
14:23:58 <acabot_> Add specs for cache occupancy strategy needs discussions
14:24:06 <acabot_> #link https://review.openstack.org/#/c/398162/
14:24:09 <sballe_> ok now is the time
14:24:13 <acabot_> sballe_ : yes ;-)
14:24:45 <sballe_> theworkload charcatrization needs to be assignd to me insead of hvprash_
14:24:50 <acabot_> its great to have a new strategy but if edwin leaves the project, who will work on it ?
14:24:58 <sballe_> We submitted a new Blueprint  which is a sub-task of: https://blueprints.launchpad.net/watcher/+spec/workload-characterization-qoshttps://blueprints.launchpad.net/watcher/+spec/cache-occupancy-strategySpec is here: https://review.openstack.org/#/c/398162/1 https://usercontent.irccloud-cdn.com/file/R7bYxzNX/
14:25:18 <sballe_> pru and chris and I will work on this.
14:25:20 <hvprash_> sballe_, you mean workload characterization qos
14:25:31 <acabot_> sballe_ : https://blueprints.launchpad.net/watcher/+spec/workload-characterization-qos assigned to you already
14:25:57 <sballe_> yes We have done some design and the way to get to the qos functionality we need is by dividing up that bp into smaller ones
14:26:02 <hvprash_> yeah, i think I already assigned to you :)
14:26:23 <acabot_> I would suggest that pru & chris work on the framework instead of a strategy if they want to start with watcher
14:26:32 <sballe_> yes the BP and I will change it in hte ocata priotities
14:27:03 <sballe_> acabot_: not an option at this point.
14:27:14 <sballe_> the RDT integration is Intel's highest priotity
14:27:14 <acabot_> sballe_ : we really need more code reviewers on the framework
14:27:34 <sballe_> acabot_: they can review code.
14:28:07 <acabot_> sballe_ : I dont think they will review code from the framework if they dont work on it...
14:28:16 <acabot_> sballe_ : just guessing
14:28:55 <acabot_> sballe_ : but ok if its Intel priority, when do you plan to have this strategy implemented ? ocata-2 , 3 ?
14:29:02 <sballe_> let's talk but for now pru or chris will work on moving forward the Intel RDT integration. We could look at some low hanging task for them to work on too
14:29:17 <sballe_> ocata-3
14:29:24 <acabot_> ok thx
14:29:41 <exploreshaifali> low_hanging tasks for me too
14:29:42 <acabot_> can we start reviewing the spec from edwin ?
14:29:43 <vincentfrancoise> there's the config BP that can be done as a starter
14:30:08 <acabot_> https://blueprints.launchpad.net/watcher/+spec/centralise-config-opts
14:30:11 <sballe_> no it is not ready yet. give it a week and you can review
14:30:17 <hvprash_> sorry, forgot about exploreshaifali. she will be working on some of my BPs
14:30:20 <exploreshaifali> I am trying to understand the code of watcher, to contribute ahead
14:30:34 <hvprash_> yeah, some low hanging will help exploreshaifali to catch up too
14:30:46 <vincentfrancoise> I already did the base so it will be easier to finish the job without having to start fresh on it
14:31:14 <sballe_> same with pshedimb and Chrisspencer
14:31:14 <acabot_> ok lets move to Wathcher code base
14:31:23 <acabot_> Documentation for workload stabilization [1] & workload consolidation [2] have been merged
14:31:39 <acabot_> thx alexchadin & brunograz for handling it
14:31:49 <acabot_> Documentation for Outlet Temperature Based Strategy need a new PS and reviews
14:31:51 <sballe_> I am working on the 3 intel ones. Waiting for some info around version of node manager
14:31:57 <acabot_> #link https://review.openstack.org/#/c/397411/
14:32:25 <acabot_> sballe_ : ok cool as you have set W-1 I suppose you dont need review yet
14:33:02 <dtardivel> acabot_: FYI, a new section named 'algorithm' has been added by alexchain in the template doc. Please take time to add it into your strategy documentation
14:33:06 <sballe_> because I still need the version of Node manager I put -1 because even if everything is perfect I don;t want it merged
14:33:26 <sballe_> dtardivel: thx for the pointer to the bug id
14:33:31 <acabot_> sballe_ : ok so you need reviews ?
14:33:56 <acabot_> as the ocata-1 release is tomorrow, we will merge a lot of code right after this meeting
14:33:59 <sballe_> you guys can review it but I need to add the NM version
14:34:07 <acabot_> ok
14:34:07 <sballe_> before I want it merged
14:34:37 <acabot_> its still time to put your +1 for stats on all these patches :
14:34:49 <acabot_> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/watcher-notifications-ovo
14:34:57 <acabot_> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/audit-versioned-notifications-api
14:35:06 <acabot_> #link https://review.openstack.org/#/c/378466/
14:35:28 <brunograz> acabot: blind +1? I like it ;)
14:35:31 <acabot_> so please do it asap because we will have to deal with merge conflicts
14:35:57 <acabot_> brunograz : I would say "stackalytics reviews..."
14:36:08 <brunograz> :D
14:36:13 <dtardivel> acabot_: too late for #link https://review.openstack.org/#/c/378466/. I've jut mergd it :)
14:36:14 <sballe_> lol
14:36:32 <acabot_> as you know its good for the project to have reviewers from diverse companies so please add your +1 ;-)
14:36:51 <acabot_> dtardivel : too bad I missed it ;-)
14:37:27 <sballe_> lol
14:37:42 <acabot_> 2 other patches should be merged for the release
14:37:51 <acabot_> #link https://review.openstack.org/#/c/398299/
14:38:00 <acabot_> #link https://review.openstack.org/#/c/396281/
14:38:33 <acabot_> so if some of you can review them we can merge them today as well and be part of ocata-1
14:38:48 <sballe_> ok I can review
14:39:07 <acabot_> #action sballe_ review https://review.openstack.org/#/c/398299/ https://review.openstack.org/#/c/396281/
14:39:10 <vincentfrancoise> ^ anyone interested in working on https://blueprints.launchpad.net/watcher/+spec/centralise-config-opts should probably review https://review.openstack.org/#/c/396281/
14:39:31 <hvprash_> +1
14:39:33 <acabot_> vincentfrancoise : thats right
14:39:45 <atuly> i can if noone is working.
14:39:49 <hvprash_> i mean I can review
14:39:51 <hvprash_> :)
14:40:07 <acabot_> #action exploreshaifali atuly hvprash_ review https://review.openstack.org/#/c/396281/
14:40:15 <brunograz> +1 -  can review as well
14:40:17 <exploreshaifali> :)
14:40:20 <vincentfrancoise> atuly: no need to ask, when it comes to reviewing, just go for it ;)
14:40:30 <acabot_> #action brunograz review https://review.openstack.org/#/c/396281/
14:40:33 <acabot_> Watcher CLI
14:40:39 <acabot_> Add functional tests to watcherclient needs reviews
14:40:39 <dtardivel> acabot_: about 398299, we should wait for alexchain review as well ....
14:40:42 <atuly> :)
14:40:50 <dtardivel> acabot_: +1
14:41:44 <acabot_> #link https://review.openstack.org/#/c/389181/
14:41:52 <acabot_> #action dtardivel review https://review.openstack.org/#/c/389181/
14:42:05 <acabot_> dtardivel : thats right I will try to ping alex
14:42:22 <acabot_> #topic Blueprint/Bug Review and Discussion
14:42:30 <acabot_> #info Ocata-1 will be released tomorrow
14:42:38 <acabot_> #link https://launchpad.net/watcher/+milestone/ocata-1
14:43:09 <diga> hi, sorry got late
14:43:19 <acabot_> there is still 4 bugs in progress
14:43:44 <acabot_> sorry 3 in fact
14:44:30 <acabot_> #info A couple of unfinished blueprints have been moved to Ocata-2
14:44:39 <acabot_> #link https://launchpad.net/watcher/+milestone/ocata-2
14:44:56 <acabot_> so Ocata-2 is our new target expected 12/12
14:45:16 <diga> acabot_: I have started pushing PS on automatic triggerring BP
14:45:19 <acabot_> sballe_ : any update from kevin about the graph model ?
14:45:33 <acabot_> diga : sorry we already discussed it
14:45:35 <sballe_> no is thijs here?
14:45:45 <sballe_> I'll follow up again :-(
14:46:16 <diga> acabot_: I can finish the code by EOW, can I continue work on it
14:46:44 <acabot_> diga : we will discuss it on watcher channel after the meeting
14:46:50 <diga> ok
14:47:03 <acabot_> #action sballe_ follow up on https://blueprints.launchpad.net/watcher/+spec/graph-based-cluster-model
14:47:28 <acabot_> #topic Open discussions
14:47:38 <acabot_> Should we use Trello to keep progress on Watcher ?
14:47:50 <sballe_> yes but only if it makes sense
14:48:01 <acabot_> it was a topic to discuss in Barcelona but meetings were too short
14:48:04 <sballe_> if peopel are not going ot pay attention to it then no
14:48:21 <acabot_> the idea is to keep actions in Trello
14:48:35 <acabot_> instead of relying only on the IRC bot from one meeting to another
14:48:45 <sballe_> I like the idea so I can tell my management about the Watcher roadmap
14:49:10 <sballe_> it looks a lot like JiRA so we can keep track of use stories, etc
14:49:16 <acabot_> and also keep ideas for Watcher long term evolutions somewhere
14:49:22 <seanmurphy> +1 for trello from our side!
14:49:29 <sballe_> +1 same here
14:49:33 <hvprash_> i like trello too. +1
14:49:43 <vincentfrancoise> +1
14:49:47 <brunograz> +1
14:50:01 <acabot_> #link https://trello.com/invite/b/qPDRBsG7/d735794f93465d1d45ad18729c8395b9/openstack-watcher
14:50:18 <acabot_> I have created a board to give you an overview
14:51:04 <acabot_> as everyone seems happy with trello :-) I will prepare our next meeting with it
14:51:33 <acabot_> if you want to add a column, feel free to do it
14:51:33 <sballe_> cool!
14:52:21 <acabot_> #action acabot_ use Trello for preparing our next IRC meeting
14:52:31 <acabot_> licanwei : can you access the Trello board ?
14:52:47 <acabot_> licanwei : just to check that you can use it from China
14:53:09 <licanwei> ok
14:53:18 <licanwei> i'll try it
14:53:29 <sballe_> acabot_: looks great!
14:53:49 <acabot_> licanwei : can you just click on the link https://trello.com/invite/b/qPDRBsG7/d735794f93465d1d45ad18729c8395b9/openstack-watcher ?
14:54:05 <acabot_> and tell me if it works ?
14:54:25 <licanwei> acabot: need sign up first
14:54:33 <acabot_> ok
14:54:49 <acabot_> if you can access the sigh-up page thats fine :-D
14:54:59 <licanwei> yes
14:55:01 <acabot_> any other topic to discuss today ?
14:55:03 <sballe_> nice
14:55:39 <acabot_> for our new contributors, feel free to ask questions on #openstack-watcher
14:55:50 <acabot_> there is always someone to help you
14:55:58 <atuly> acabot : regarding some pointer on Workload balance strategy
14:56:03 <vincentfrancoise> FYI I'll be on vacation starting next week ;)
14:56:13 <sballe_> vincentfrancoise: enjoy
14:56:27 <acabot_> vincentfrancoise : oh yes I forgot to mention that Vincent will be off for 4 weeks
14:56:37 <exploreshaifali> vincentfrancoise, enjoy :)
14:56:43 <hvprash_> vincentfrancoise, i need to catch you then this week :)
14:56:45 <sballe_> vincentfrancoise: that sounds like a great time off
14:56:49 <vincentfrancoise> thx all :p
14:56:57 <acabot_> he really deserves it ;-)
14:57:01 <hvprash_> yes +@
14:57:03 <hvprash_> +2
14:57:03 <atuly> vincentfrancoise : enjoy:)
14:57:16 <sballe_> acabot: do you have 10 mins for a quick chat around Intel contributions?
14:57:50 <acabot_> so during next month, the challenge would be to have more commits than vincentfrancoise on the ocata release ;-)
14:57:56 <sballe_> lol
14:58:09 <exploreshaifali> lol
14:58:12 <vincentfrancoise> should be easy ;)
14:58:38 <acabot_> sballe_ : 10 min max right after the meeting
14:58:48 <sballe_> cool!
14:59:02 <acabot_> so thank you all
14:59:10 <acabot_> time to close the meeting
14:59:13 <vincentfrancoise> bye all
14:59:14 <brunograz> bye
14:59:15 <acabot_> have a good day/night
14:59:20 <licanwei> bye
14:59:21 <atuly> bye
14:59:23 <exploreshaifali> bye
14:59:24 <dtardivel> bye
14:59:28 <acabot_> #endmeeting