09:00:35 <acabot> #startmeeting watcher
09:00:35 <openstack> Meeting started Wed Nov  9 09:00:35 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:38 <openstack> The meeting name has been set to 'watcher'
09:00:39 <acabot> o/
09:00:58 <brunograz> o/
09:01:34 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F09.2F2016
09:01:37 <alexchadin> o/
09:01:50 <acabot> brunograz alexchadin : how was the summit ?
09:02:11 <alexchadin> acabot: it was beautiful!
09:02:13 <brunograz> acabot: v interesting - first time attending it
09:02:41 <acabot> I know this place in Barcelona from previous events and its very nice
09:02:51 <acabot> jed56 told me that weather was great too
09:02:56 <Yumeng> hi
09:02:58 <exploreshaifali> hello! I want to contribute to watcher, currently trying to understand watcher current codebase! so I am here :)
09:03:15 <acabot> exploreshaifali : welcome !
09:03:23 <exploreshaifali> Thanks! acabot
09:03:26 <alexchadin> exploreshaifali: you're welcome!
09:03:35 <brunograz> welcome :)
09:03:37 <acabot> exploreshaifali : for which company are you working ?
09:03:48 <exploreshaifali> Thanks all!
09:04:06 <exploreshaifali> acabot, I am an individual contributor.... I started with openstack as Outreachy intern
09:04:18 <exploreshaifali> now I want to continue contributing to OpenStack more
09:04:29 <acabot> exploreshaifali : ok looks great
09:04:58 <hidekazu> hello.
09:05:02 <acabot> waiting 2 min for others to join
09:05:16 <exploreshaifali> so I will keep pinging you guys for further help to understand watcher codebase
09:05:30 <acabot> hidekazu : hi, how was your summit ?
09:05:44 <hidekazu> acabot: good.
09:05:55 <atuly> Hello
09:06:06 <acabot> hi atuly
09:06:13 <hidekazu> acabot: i am sure watcher is good community.
09:06:33 <acabot> hidekazu : thx and sorry for not being at the summit personnaly
09:06:33 <hidekazu> hi atuly.
09:06:44 <acabot> #topic Announcements
09:06:53 <acabot> #info The OpenStack Summit in Barcelona is over, minutes are available on etherpad
09:07:00 <acabot> #link https://etherpad.openstack.org/p/watcher-ocata-design-session
09:07:44 <acabot> We should send a recap of all discussions on the ML, as I was not there, I would suggest that someone else does it
09:08:06 <acabot> does anyone wants to do it ?
09:08:55 <acabot> #action acabot ask sballe to send a recap of the summit on the ML
09:09:02 <atuly> acabot: how do i get included in ML?
09:09:18 <acabot> atuly : you should register to openstack-dev
09:09:26 <acabot> and filter with [watcher] tag
09:09:31 <atuly> ok
09:09:37 <acabot> #info Team priorities for Ocata have to be merged
09:09:44 <acabot> #link https://review.openstack.org/#/c/372528/
09:10:09 <acabot> I would like to have a maximum of +1 on this review before merging it
09:10:31 <acabot> so please go through it (its very small) and +1
09:10:51 <acabot> #info Feedback for the mascot is requested by Friday 11th
09:10:58 <acabot> #link https://drive.google.com/file/d/0B_h5gjY7WQPMX2FYSVBOWk8zYWs/view?usp=sharing
09:11:10 <acabot> does anyone has feedback to share ?
09:11:32 <acabot> personnaly I'm fine with the design
09:11:53 <alexchadin> looks good, material design?
09:11:55 <brunograz> acabot: looks nice and neat
09:12:33 <exploreshaifali> yeah, It looks good
09:12:38 <acabot> ok so lets keep this design
09:12:50 <acabot> #topic Review Action Items
09:12:59 <acabot> we have a lot of reviews open
09:13:05 <acabot> Watcher specs
09:13:12 <acabot> automatic triggering of action plans for AUDIT needs a new PS and final reviews from core
09:13:18 <acabot> #link https://review.openstack.org/#/c/342473/
09:13:22 <acabot> is diga here ?
09:13:36 <acabot> alexchadin : did you ping diga to help him ,
09:13:37 <acabot> ?
09:13:45 <alexchadin> acabot: not yet
09:13:56 <alexchadin> acabot: I haven't seen him online
09:14:21 <acabot> alexchadin : would you mind to reassign the BP to yourself ?
09:14:41 <acabot> alexchadin : diga is not able to give us feedback
09:14:55 <acabot> alexchadin : and its an essential BP for Ocata
09:15:03 <alexchadin> acabot: If he wouldn't mind, I will take care of it
09:15:24 <acabot> #action acabot ask diga for a reassignment of his bp
09:15:34 <acabot> scale out or delete instance based on workload needs a new PS
09:15:41 <acabot> #link https://review.openstack.org/#/c/359690/
09:15:57 <acabot> yumeng : any update ?
09:16:04 <Yumeng> acabot:hi
09:16:16 <Yumeng> since there is an existed strategy handling the same problem using Heat auto-sacling, we are considering abandon and not to duplicate that work.
09:16:45 <acabot> Yumeng : ok, sorry for that
09:17:06 <acabot> we definitely need to document existing strategies to avoid this case
09:17:31 <acabot> Specs for watcher-versioned-objects needs a new PS and final reviews from core
09:17:38 <acabot> #link https://review.openstack.org/#/c/383718/
09:17:55 <acabot> vincentfrancoise : any update ?
09:18:26 <acabot> vincentfrancoise : I think you have all comments from core reviewers
09:19:34 <acabot> sorry he wasn't there
09:19:38 <vincentfrancoise> hi all
09:19:43 <acabot> #link https://review.openstack.org/#/c/383718/
09:19:52 <acabot> vincentfrancoise : any update ?
09:20:28 <vincentfrancoise> acabot: well, I still have some work to do to remove the previous notification code that is still there
09:20:39 <acabot> but the spec ?
09:20:44 <acabot> ok
09:20:48 <acabot> code in the spec
09:21:13 <acabot> Specs for audit-versioned-notifications-api needs a new PS
09:21:20 <acabot> #link https://review.openstack.org/#/c/385077/
09:21:27 <vincentfrancoise> acabot: spec wise, I need to add some extra precisions regarding things I didn't mention
09:21:41 <acabot> ok and for https://review.openstack.org/#/c/385077/ ?
09:21:42 <vincentfrancoise> acabot: but also take into account the comments that were made
09:22:06 <acabot> ok
09:22:11 <vincentfrancoise> acabot: I need to add 2 more payloads for audit.strategy.error and ausit.planner.error
09:22:32 <acabot> #action vincentfrancoise add new PS for https://review.openstack.org/#/c/383718/ https://review.openstack.org/#/c/385077/
09:22:33 <vincentfrancoise> acabot: these will be sent over when things go wrong
09:23:04 <acabot> Define grammar for workload characterization needs a new PS
09:23:10 <acabot> #link https://review.openstack.org/#/c/377100/
09:23:24 <acabot> #action hvprash add a new PS for https://review.openstack.org/#/c/377100/
09:23:37 <acabot> Define when an action plan is stale/invalid is in merge conflict and needs final reviews from core
09:23:44 <acabot> #link https://review.openstack.org/#/c/386293/
09:23:57 <acabot> is licanwei here ?
09:24:03 <licanwei> yes
09:24:22 <acabot> could you rebase this patch ?
09:24:30 <licanwei> ok
09:24:52 <dtardivel> acabot: licanwei: I've just reviewed this spec this morning. Please take into account my comments
09:24:59 <acabot> #action licanwei add a new PS for https://review.openstack.org/#/c/386293/ answering comments
09:25:16 <acabot> Audit tag in VM Metadata needs a new PS
09:25:20 <licanwei> dtardivel: Thanks
09:25:22 <acabot> #link https://review.openstack.org/#/c/391374/
09:25:44 <acabot> #action hvprash add a new PS for https://review.openstack.org/#/c/391374/ answering comments
09:25:52 <acabot> Add improvements to the planner and workflow mechanisms needs reviews
09:25:58 <acabot> #link https://review.openstack.org/#/c/385871/
09:26:22 <acabot> alexchadin : can we start reviewing your spec ?
09:26:41 <alexchadin> acabot: yes, David already started
09:26:47 <acabot> I see that
09:26:58 <acabot> so I suppose its fine to start reviewing
09:27:13 <acabot> who wants to review ?
09:27:14 <alexchadin> +1
09:27:24 <vincentfrancoise> acabot: me
09:27:39 <licanwei> +1
09:27:40 <acabot> #action vincentfrancoise acabot review https://review.openstack.org/#/c/385871/
09:27:45 <vincentfrancoise> acabot: although I'll probably do it next week
09:27:48 <acabot> #action licanwei review https://review.openstack.org/#/c/385871/
09:28:13 <acabot> exploreshaifali : reviewing spec could be a good way to start contributing
09:28:21 <acabot> exploreshaifali : we need more +1 to improve specs
09:28:33 <acabot> moving to Watcher
09:28:36 <exploreshaifali> acabot, sure! I will follow them
09:29:09 <acabot> #action exploreshaifali review https://review.openstack.org/#/c/385871/
09:29:15 <acabot> watcher versionned objects needs reviews
09:29:23 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/watcher-versioned-objects
09:29:46 <acabot> we just need W+1 on those patches
09:29:58 <acabot> vincentfrancoise : can we merge them by EOW ?
09:30:25 <alexchadin> acabot: I'm ready to set W+1 on https://review.openstack.org/#/c/359065/
09:30:40 <vincentfrancoise> alexchadin: I'll add a trust-me-it-works tag on them if you want :D
09:30:56 <alexchadin> vincentfrancoise: :D
09:31:01 <exploreshaifali> haha
09:31:04 <acabot> alexchadin: I think the best would be to have you #W+1 all of them
09:31:55 <acabot> alexchadin : as it has been reviewed by dtardivel and we don't have an Intel core anymore
09:33:07 <acabot> vincentfrancoise : do we need to have all patches merged at the same time for consistency ?
09:33:15 <acabot> https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/watcher-versioned-objects
09:33:45 <acabot> audit versioned notifications api needs reviews
09:33:52 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/audit-versioned-notifications-api
09:34:09 <acabot> vincentfrancoise : I suppose this is still in WIP ?
09:35:10 <vincentfrancoise> acabot: yes
09:35:17 <acabot> ok
09:35:19 <acabot> check the state of action plan needs reviews
09:35:26 <acabot> #link https://review.openstack.org/#/c/391383/
09:35:59 <acabot> licanwei : I suppose you need review on this ? who wants to review it ?
09:36:23 <licanwei> acabot: yes
09:36:44 <brunograz> +1
09:36:46 <Yumeng> +1
09:37:01 <acabot> #action brunograz yumeng dtardivel review https://review.openstack.org/#/c/391383/
09:37:36 <acabot> Add doc for workload-stabilization spec needs discussion ?
09:37:43 <acabot> #link https://review.openstack.org/#/c/389101/
09:37:46 <licanwei> brunograz, Ymeng: Thanks
09:38:13 <hidekazu> acabot: i am reviewing.
09:38:31 <Yumeng> licanwei: :)
09:38:33 <acabot> hidekazu : did you try again this strategy ?
09:38:54 <hidekazu> acabot: yes.
09:39:01 <acabot> #action acabot review https://review.openstack.org/#/c/389101/
09:39:37 <acabot> Added Tempest API tests for /scoring_engines needs reviews
09:39:48 <acabot> #link https://review.openstack.org/#/c/371558/
09:40:07 <acabot> it needs a new PS after hidekazu comments
09:40:19 <acabot> alexchadin : can you submit a new patch ?
09:40:39 <acabot> sorry this patch is from vincentfrancoise
09:40:52 <acabot> vincentfrancoise : can you resubmit a patch ?
09:41:15 <acabot> vincentfrancoise : at least answer hidekazu comments
09:41:21 <vincentfrancoise> acabot: will do but it will be come after my work on OVO/notification blueprints
09:41:28 <acabot> ok
09:41:43 <acabot> #action vincentfrancoise add a new PS for https://review.openstack.org/#/c/371558/
09:41:56 <acabot> Watcher CLI
09:42:06 <vincentfrancoise> acabot: if someone wants to finish it, I'll be more than happy to leave it to someone else ;)
09:42:30 <acabot> #undo
09:42:31 <atuly> i can pick it up.
09:42:32 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7fac5536a450>
09:42:48 <acabot> #action atuly add a new PS for https://review.openstack.org/#/c/371558/
09:42:52 <acabot> thx atuly
09:43:02 <acabot> Add functional tests to watcherclient is still WIP ? needs reviews ?
09:43:04 <vincentfrancoise> atuly: cool!
09:43:08 <acabot> #link https://review.openstack.org/#/c/389181/
09:43:24 <acabot> alexchadin : is this still WIP ?
09:43:25 <alexchadin> You can start to review it, I will just add new objects
09:43:47 <acabot> ok so should we wait for a new PS before reviewing ?
09:44:19 <alexchadin> It would be great to get review on already implemented things:)
09:44:42 <dtardivel> acabot: I will recview it
09:44:55 <alexchadin> I need to add test_audit and test_scoring_engine files
09:45:07 <acabot> exploreshaifali : do you want to review functional tests as well ?
09:45:16 <exploreshaifali> acabot, yes :)
09:45:33 <acabot> #action dtardivel exploreshaifali review https://review.openstack.org/#/c/389181/
09:45:43 <alexchadin> vincentfrancoise: can you remind me how to add gate test for functional module?
09:45:59 <acabot> exploreshaifali : whats your gerrit nick ?
09:45:59 <alexchadin> in our primary channel, of course
09:46:41 <acabot> #info I forgot to mention that Watcher CLI v0.25.1 has been released after Summit freeze
09:46:42 <vincentfrancoise> alexchadin: it's within the openstack/project-config project
09:47:07 <vincentfrancoise> alexchadin: we can discuss this after the meeting if you want
09:47:14 <alexchadin> +1
09:47:19 <acabot> #topic Blueprint/Bug Review and Discussion
09:47:30 <acabot> #info Our current milestone target is Ocata-1 due November 14th
09:47:38 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-1
09:48:01 <acabot> we still have 10 BPs targeted for next week :-)
09:48:24 <alexchadin> oh
09:49:08 <acabot> I will move "not started" BP to Ocata-2
09:49:47 <acabot> https://blueprints.launchpad.net/watcher/+spec/automatic-triggering-audit is marked as essential
09:49:56 <acabot> and we dont have a spec ready
09:50:43 <acabot> #action refresh BPs list to reflect ocata-1 achievements
09:50:50 <acabot> #action acabot refresh BPs list to reflect ocata-1 achievements
09:50:57 <exploreshaifali> acabot, my gerrit nick - shaifali
09:51:21 <acabot> thx
09:51:28 <acabot> #topic Open discussions
09:51:35 <acabot> Shouldn't all strategies have an associated tempest test to make sure they work?
09:51:57 <vincentfrancoise> IMHO, they should
09:52:07 <acabot> it would be nice but can we always do it ?
09:52:21 <dtardivel> vincentfrancoise: how to handle metrics ?
09:52:22 <acabot> I mean if the strategy rely on non available metrics on the gate ?
09:52:37 <vincentfrancoise> one problem I had when trying to help hidekazu out was that the strategy wasn't working straight away
09:53:04 <alexchadin> They should. How will tempest create loads on some compute nodes? For example, in case of workload stabilization strategy we need at least two compute nodes with different loads inside.
09:53:42 <vincentfrancoise> this is something that can discourage some people from using Watcher
09:54:05 <vincentfrancoise> as for the handling of metrics
09:54:38 <vincentfrancoise> IMHO, all strategies should work even if the no metrics are available
09:54:52 <vincentfrancoise> but in such a case the resulting action plan should be empty
09:54:58 <vincentfrancoise> and warnings should be raised
09:55:20 <acabot> the problem I see is that strategy developer should be aware of tempest behavior
09:55:30 <alexchadin> vincentfrancoise: What do we need to test then?:)
09:55:44 <acabot> brunograz : what do you think ? could you provide tempest tests to test your strategy ?
09:55:44 <alexchadin> If we do not provide any metrics
09:56:23 <brunograz> acabot: we could have a look on this - I'm not familiar with tempest tests
09:56:28 <vincentfrancoise> acabot: what do you mean by tempest behaviour?
09:56:46 <acabot> I mean understanding how tempest tests should be written
09:56:56 <dtardivel> I don't think that ALL strategies should be checked in tempest test ? What do we want to check with tempest tests ? the framework, the strategies ?
09:57:03 <vincentfrancoise> acabot: ah yes
09:57:56 <vincentfrancoise> acabot: the thing is that we can also ask the question the other way around: how can a reviewer make sure it really works if he cannot run it on his environment?
09:58:40 <vincentfrancoise> acabot: regarding existing strategies, it's another problem although we should eventually have them covered
09:58:41 <acabot> ok so it will be a kind of "dummy test"
09:59:14 <acabot> just to check that the strategy run without any metric
09:59:29 <vincentfrancoise> acabot: yes
09:59:43 <acabot> I will move this discussion to next week agenda
09:59:44 <vincentfrancoise> acabot: but if someone has these metrics setup on their own infrastructure
09:59:48 <brunograz> that sounds reasonable
09:59:54 <acabot> yes it is
09:59:56 <vincentfrancoise> acabot: that dummy test on the gate becomes a real test
10:00:15 <acabot> we have to leave
10:00:16 <acabot> thx
10:00:19 <brunograz> bye
10:00:20 <vincentfrancoise> thx
10:00:22 <alexchadin> thank you all
10:00:22 <vincentfrancoise> bye all
10:00:24 <acabot> #endmeeting