14:01:21 <acabot> #startmeeting watcher
14:01:22 <openstack> Meeting started Wed Oct  5 14:01:21 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:25 <openstack> The meeting name has been set to 'watcher'
14:01:28 <sballe_> morning
14:01:30 <acabot> o/
14:01:32 <dtardivel> hi
14:01:41 <vincentfrancoise> o/
14:01:42 <licanwei> hi
14:01:43 <alexchadin> O/
14:01:43 <hvprash> hi
14:01:46 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#10.2F04.2F2016
14:02:10 <acabot> many people there today !
14:02:22 <acabot> #topic Announcements
14:02:38 <acabot> #info please complete topics list in barcelona summit etherpad
14:02:39 <Yumeng> Hi
14:02:45 <acabot> #link https://etherpad.openstack.org/p/watcher-ocata-design-session
14:02:48 <sballe_> this is a good time ;-) next week I won't make it because I will be in california and it will be 2am
14:03:01 <acabot> ok
14:03:18 <acabot> we started filling topics with sballe this week
14:03:40 <acabot> please do it asap as the summit is in 2 weeks now
14:03:56 <sballe_> yes I had Intel people add topics or at least asked them to
14:04:04 <acabot> hvprash : your new topic is tricky ;-)
14:04:08 <sballe_> I would liek for us to review a draft timeline next week
14:04:19 <hvprash> yeah, have a use case. happy to share :)
14:04:24 <sballe_> pefect
14:05:04 <acabot> I plan to submit work sessions topics to the foundation by end of next week
14:05:27 <acabot> so we need to have a final agenda that we will agree for next meeting
14:05:37 <sballe_> acabot: let's sync-up on the work sessions and their agenda on Mon morning?
14:05:55 <sballe_> acabot: +2
14:05:56 <acabot> sballe_ : you mean monday morning at the summit ?
14:06:10 <sballe_> no next week
14:06:32 <acabot> ok I plan to submit it next week so no rush
14:06:44 <acabot> but I want to be sure that all topics will be discussed
14:06:55 <sballe_> agreed
14:07:14 <acabot> as we have all our BPs for Ocata already defined, we need to work on new strategies and new BPs for the P release
14:07:39 <acabot> or if we need working sessions for current specs, I also need to know it
14:07:55 <acabot> we will start the week with the fish bowl session
14:07:57 <sballe_> acabot: I have reviewed Ananth's spec and I would have assumed that he would have submitted it by now
14:08:14 <acabot> if we want to gather people, we need to find an appealing description
14:08:21 <sballe_> +2
14:08:47 <acabot> any idea about the topic we should address during this session ?
14:09:29 <acabot> I dont want to do the Newton retrospective during the fishbowl
14:09:59 <sballe_> what is the goal of a fishbowl session? it is different from normal sessions?
14:09:59 <acabot> I would prefer an open discussion about possible new strategies enabled by Watcher
14:10:57 <acabot> "Our traditional largish rooms organized in fishbowl style, with
14:10:57 <acabot> advertised session content on the summit schedule for increased external
14:10:57 <acabot> participation. Ideal for when wider feedback is essential."
14:11:05 <sballe_> I think taht is a good idea.. also it would be nice to see if we can consolidate stratgeis so we do not have several that pretty much do the same but a little different
14:11:35 <sballe_> I don;t mena consolidate at this point but more moving forwad decide how we do for example app characterization
14:11:45 <acabot> ok I will put this in the etherpad but please think about it
14:11:47 <hvprash> +1
14:11:48 <sballe_> and agree on maybe one way
14:12:10 <acabot> #info Watcher Newton final release has been released
14:12:22 <acabot> #link https://releases.openstack.org/teams/watcher.html
14:12:32 <acabot> congrats to all the team
14:12:39 <sballe_> +2
14:12:50 <sballe_> acabot: could we do this during fishbowl: How do we streamline the BPs so we have a more coherent set of strategies moving forward around finerprinting/workload characterization. as well as wokload placement  on resources (sballe)
14:12:57 <acabot> watcher CLI is still waiting for a fix but it will be released soon
14:13:31 <alexchadin> Congratulations!
14:13:35 <sballe_> +2
14:13:37 <hvprash> +2
14:13:39 <vincentfrancoise> +1
14:13:47 <acabot> sballe_ : could be interesting but maybe a too much specific if we want to gather people
14:13:51 <dtardivel> acabot: We have also a regression about 'parameter' attribute for audit creation, on CLI :/
14:14:24 <dtardivel> I'm investigating if we had again a merge conflict not well resolved ....
14:14:32 <acabot> dtardivel : ok, should we update the hash as it still possible ?
14:15:01 <acabot> #link https://review.openstack.org/#/c/378771/
14:15:08 <acabot> any other announcement ?
14:15:38 <acabot> #topic Review Action Items
14:15:46 <dtardivel> acabot: not sure if parameter is used a lot for now in audit creation .... It is not critical for me.
14:15:57 <acabot> dtardivel : ok
14:16:10 <acabot> a couple of specs needs to be reviewed by cores
14:16:19 <acabot> #link https://review.openstack.org/#/c/359690/
14:16:32 <acabot> #link https://review.openstack.org/#/c/342473/
14:16:39 <acabot> #link https://review.openstack.org/#/c/372528/
14:16:58 <sballe_> I can do that since I am back from cluster hell
14:17:07 <acabot> #action hvprash sballe_ jwcroppe review https://review.openstack.org/#/c/372528/ https://review.openstack.org/#/c/342473/ https://review.openstack.org/#/c/359690/
14:17:18 <hvprash> will do
14:17:31 <acabot> Limit concurrent actions invoked by Watcher needs a new PS
14:17:39 <alexchadin> Yeah yeah
14:17:39 <acabot> #link https://review.openstack.org/#/c/348049/
14:17:49 <alexchadin> Will upload new tomorrow
14:18:15 <sballe_> alexchadin: please add me as a reviewer if I anot already on it
14:18:29 <alexchadin> Of course
14:18:31 <acabot> alexchadin : actually we realized that TaskFlow is already dealing with this in Watcher
14:18:56 <acabot> jed56 who has implemented TaskFlow can give you more details
14:19:13 <jed56> hi
14:19:16 <alexchadin> Ok
14:19:17 <alexchadin> Hi
14:19:43 <jed56> For more information about taskflow => https://wiki.openstack.org/wiki/TaskFlow
14:20:00 <jed56> The watcher applier is relying on this library
14:20:14 <acabot> does TaskFlow handle the limitation of concurent actions ?
14:20:26 <alexchadin> How can we limit it then?
14:20:48 <jed56> IMHO, this is not the responsability of TaskFlow. This is more the scope of the Planner
14:21:03 <jed56> Task is in charge of executing a flow of actions
14:21:03 <sballe_> I agree
14:21:17 <jed56> This flow action is build by the watcher planner
14:21:46 <acabot> ok so in this case we need a spec to define the number of concurrent actions right ?
14:22:08 <jed56> IMHO, we need a spec to amend the implementation of the default planner
14:22:31 <jed56> https://github.com/openstack/watcher/blob/master/watcher/decision_engine/planner/default.py
14:22:46 <acabot> ok so you said that we should look at TaskFlow implementation in more details to write the spec ?
14:23:13 <jed56> TaskFlow can be just see as a executor
14:23:26 <jed56> the "brain" is in the planner
14:23:45 <jed56> So we need to change the implementation of the default planner to add a limit
14:24:10 <jed56> However, this is not possible for now because we need https://blueprints.launchpad.net/watcher/+spec/planner-storage-action-plan
14:25:14 <acabot> alexchadin : I would suggest that we put this spec in "stand-by"
14:25:40 <acabot> as we need a planner improvement before and it will impact your spec
14:25:43 <alexchadin> acabot: Agree
14:26:04 <acabot> ok put it as W-1 in this case
14:26:22 <acabot> #action alexchadin W-1 https://review.openstack.org/#/c/348049/
14:26:29 <acabot> #action alexchadin W-1 https://review.openstack.org/#/c/348049/
14:26:32 <acabot> Define grammar for workload characterization needs a new PS
14:26:38 <alexchadin> I can try to start work on planner spec
14:26:40 <acabot> #link https://review.openstack.org/#/c/377100/
14:26:51 <acabot> alexchadin : sure you can
14:27:09 <sballe_> I will work with hvprash on Define grammar for workload characterization needs a new PS
14:27:12 <hvprash> acabot, still working on it
14:27:23 <acabot> alexchadin : https://blueprints.launchpad.net/watcher/+spec/planner-storage-action-plan
14:27:37 <hvprash> sballe_, will do
14:27:39 <acabot> hvprash : ok do you need feedback ?
14:27:50 <alexchadin> Target me then as Assignee
14:28:04 <hvprash> acabot, after the PS :)
14:28:42 <acabot> #action hvprash sballe_ complete https://review.openstack.org/#/c/377100/
14:28:51 <acabot> moving to Watcher
14:29:01 <acabot> Add Audit Scope Handler needs reviews from core
14:29:08 <acabot> #link https://review.openstack.org/#/q/status:open++topic:bp/define-the-audit-scope
14:29:59 <acabot> we need a final review for this
14:29:59 <dtardivel> acabot: done
14:30:03 <acabot> ok
14:30:11 <acabot> #action dtardivel review https://review.openstack.org/#/q/status:open++topic:bp/define-the-audit-scope
14:30:21 <acabot> Graph cluster model implementation needs a new PS
14:30:28 <acabot> #link https://review.openstack.org/#/c/362730/
14:30:43 <acabot> sballe_ : can you ask Kevin to update his code ?
14:31:20 <acabot> any other reviewer is welcome on this
14:31:53 <acabot> Add service supervisor needs reviews
14:31:59 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/watcher-service-list
14:32:42 <acabot> licanwei : as you have reviewed doc, could you review the code ?
14:33:07 <licanwei> acabot: ok
14:33:18 <acabot> #action licanwei review https://review.openstack.org/#/c/371632/
14:33:19 <acabot> thx
14:33:34 <acabot> #action sballe_ add a new PS for https://review.openstack.org/#/c/362730/
14:33:47 <acabot> Added Tempest API tests for /scoring_engines needs reviews
14:33:54 <acabot> #link https://review.openstack.org/#/c/371558/
14:34:12 <acabot> sorry it needs a new PS
14:34:25 <acabot> #action vincentfrancoise add a new PS for https://review.openstack.org/#/c/371558/
14:34:38 <acabot> Watcher versioned objects needs reviews
14:34:42 <vincentfrancoise> acabot: ok will do by EOD
14:34:46 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/watcher-versioned-objects
14:34:52 <dtardivel> acabot: +1
14:34:53 <sballe_> acabot: yes
14:35:11 <acabot> #action dtardivel review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/watcher-versioned-objects
14:35:27 <acabot> I'd like to have more reviewers on this as its a large set of code
14:35:48 <licanwei> +1
14:35:55 <acabot> reviewers and testers neeeded ;-)
14:36:03 <acabot> #action licanwei review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/watcher-versioned-objects
14:36:23 <alexchadin> Will review some of them
14:36:37 <acabot> #action alexchadin review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/watcher-versioned-objects
14:36:43 <vincentfrancoise> alexchadin licanwei: thx
14:37:16 <acabot> Watcher CLI
14:37:22 <acabot> Add service support needs reviews
14:37:28 <acabot> #link https://review.openstack.org/#/c/373533/
14:38:19 <dtardivel> +1, but waiting for new PS on the watcher side
14:38:30 <acabot> ok
14:38:42 <acabot> #action dtardivel review https://review.openstack.org/#/c/373533/
14:38:57 <acabot> #topic Blueprint/Bug Review and Discussion
14:39:07 <acabot> Improve the storage of the ActionPlan has many dependencies and should be started asap
14:39:16 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/planner-storage-action-plan
14:39:37 <acabot> alexchadin : I have assigned it to you, could you start the spec ?
14:39:51 <alexchadin> Yes
14:39:56 <acabot> ok thx
14:40:10 <acabot> #info we still have many unassigned blueprints for Ocata
14:40:18 <acabot> #link https://blueprints.launchpad.net/watcher/ocata
14:40:43 <acabot> licanwei : did you take one or not ?
14:41:01 <licanwei> acabot: yes
14:41:33 <acabot> licanwei : which one ?
14:41:56 <licanwei> any one :)
14:42:03 <acabot> sballe_ : could you ask Ananth to take https://blueprints.launchpad.net/watcher/+spec/context-aware-workload-mgmt-using-fingerprints ?
14:42:24 <acabot> licanwei : it depends your interests :-)
14:43:01 <hvprash> sorry, i would have taken but already 2 in my plate
14:43:12 <acabot> licanwei : https://blueprints.launchpad.net/watcher/+spec/stale-action-plan ?
14:43:17 <sballe_> take it where?
14:43:48 <acabot> sballe_ : in launchpad so that we have an assignee for it
14:43:52 <sballe_> you mean to assign it to himself
14:43:58 <acabot> yes
14:44:03 <sballe_> yes I will do that
14:44:08 <acabot> thx
14:44:39 <licanwei> acabot: ok
14:45:08 <acabot> licanwei : ok could you start with a spec ?
14:46:15 <acabot> we also have open bugs #link https://bugs.launchpad.net/watcher
14:46:33 <licanwei> acabot: yes ,i can
14:46:44 <acabot> licanwei : thx
14:46:49 <acabot> #topic Open discussions
14:47:19 <acabot> as already said last week, we need more reviewers
14:47:30 <sballe_> droveI plan to review again
14:47:41 <acabot> droveI ?
14:48:07 <acabot> gzhai doesn't do any core review
14:48:11 <sballe_> s/I
14:48:24 <sballe_> irc did some sort of text completion.
14:48:29 <acabot> :-)
14:48:40 <acabot> I think we need new cores from IBM & Intel
14:48:49 <acabot> if we want to keep the project on track
14:49:09 <acabot> hvprash : do you plan to have a core reviewer on Watcher code ?
14:49:19 <acabot> hvprash : I mean on Walmart side
14:49:35 <hvprash> acabot, i will have an answer next week and some updates
14:49:47 <acabot> hvprash : ok
14:50:20 <acabot> sballe_ : on your side, any option to have a new core ?
14:51:20 <sballe_> I need to look at it. let me see what i can figure out
14:52:12 <acabot> ok
14:52:20 <acabot> any other topic to discuss ?
14:52:47 <acabot> did you plan your parties in Barca ? :-)
14:52:58 <dtardivel> acabot: fyi, I will push a new PS about strategy template doc, in 10mn :)
14:53:09 <acabot> dtardivel : ok cool
14:53:10 <hvprash> acabot, is it the same etherpad https://etherpad.openstack.org/p/watcher-ocata-design-session to discuss general watcher topics in barcelona ?
14:53:24 <dtardivel> so all, please review it ;)
14:53:49 <acabot> hvprash : yes I try to avoid having multiple etherpads
14:53:59 <acabot> hvprash : do you need a specific one ?
14:54:04 <hvprash> ok thx, will keep updating then :)
14:54:36 <acabot> hvprash : thx
14:54:47 <hvprash> have some topics. created one under general topics in the etherpad
14:55:05 <acabot> hvprash : I can see that, thx
14:55:19 <acabot> I can close the meeting
14:55:23 <acabot> thank you guys
14:55:29 <hvprash> thanks everyone !
14:55:31 <vincentfrancoise> bye
14:55:35 <dtardivel> bye
14:55:37 <licanwei> bye
14:55:40 <alexchad_> bye
14:55:41 <acabot> #endmeeting