14:00:09 <acabot> #startmeeting watcher
14:00:11 <openstack> Meeting started Wed Sep 21 14:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'watcher'
14:00:16 <acabot> o/
14:00:24 <sballe_> o/
14:00:26 <hvprash> hi everyone
14:00:26 <Yumeng> Hi
14:00:26 <diga_> o/
14:00:30 <edleafe> \o
14:00:39 <sballe_> I am woking with dtardivel  on something
14:00:59 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#09.2F21.2F2016
14:01:21 <acabot> #topic Announcements
14:01:35 <acabot> #info Watcher Newton RC1 (v0.30.0) has been released, please follow instructions sent on the ML
14:01:43 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-September/103989.html
14:02:01 <acabot> #info Newton stable branches have been created by the TC for watcher & python-watcherclient
14:02:15 <jwcroppe> o/
14:02:15 <dtardivel> hi
14:02:17 <jwcroppe> hi
14:02:42 <acabot> so if you file a bug that needs to be released in newton, please tag it as *newton-rc-potential*
14:03:10 <acabot> now we will have to deal with a newton stable branch
14:04:06 <acabot> watcher-dashboard is still waiting for a rc-final release next week
14:04:20 <acabot> #info we need your help to test the release and submit bugs before the final release next week
14:04:55 <acabot> #info acabot will be Watcher PTL for Ocata cycle
14:05:04 <acabot> as I'm the only candidate
14:05:07 <jwcroppe> acabot: congrats :)
14:05:14 <acabot> so thanks for electing me :-D
14:05:14 <hvprash> congrats !
14:05:18 <sballe_> +2
14:05:20 <vincentfrancoise> o/
14:05:25 <diga_> acabot: congrats!
14:05:46 <acabot> #info design summit sessions timeslots are available on the dedicated etherpad
14:05:53 <acabot> #link https://etherpad.openstack.org/p/watcher-ocata-design-session
14:06:06 <jwcroppe> sballe_: btw, the presentation looks good... few nits I'll send today/tomorrow
14:06:17 <sballe_> jwcroppe: thx
14:06:48 <acabot> as you may probably know, I wont be with you in Barcelona so I hope sballe_ can deal with PTL assignements during the summit
14:06:54 <sballe_> acabot: I can drive the filling out of design sessions
14:07:14 <acabot> sballe_ : definitely
14:07:15 <acabot> thx
14:07:26 <sballe_> I am the virtual acabot ... Pretty big shoes to fill ;-)
14:07:43 <acabot> #action sballe_ start filling working sessions agenda in https://etherpad.openstack.org/p/watcher-ocata-design-session
14:08:04 <acabot> sballe_ : I'm sure you will fit the role ;-)
14:08:14 <sballe_> thx
14:08:28 <acabot> any other announcement ?
14:08:55 <acabot> lets move on
14:08:59 <acabot> #topic Review Action Items
14:09:05 <acabot> Watcher specs
14:09:13 <acabot> Resize instance base on workload needs a new PS and should be retargeted to Ocata
14:09:20 <acabot> #link https://review.openstack.org/#/c/359690/
14:09:35 <acabot> Yumeng : are you working on it ?
14:09:38 <Yumeng_> yep
14:09:45 <Yumeng_> hanrong has uploaded a new patch about this spec. and some problems are reported in jekins. we will do more revision asap.
14:10:15 <acabot> Yumeng_ : please retarget it to Ocata in your next PS
14:10:39 <Yumeng_> ok.
14:10:43 <Yumeng_> i will do that
14:10:47 <acabot> #action Yumeng_ hanrong retarget and update https://review.openstack.org/#/c/359690/
14:10:55 <acabot> automatic triggering of action plans for AUDIT needs reviews
14:11:01 <acabot> #link https://review.openstack.org/#/c/342473/
14:11:19 <acabot> diga_ : I saw that you added a new PS, is that ready to be reviewed ?
14:11:34 <diga_> acabot: yes
14:11:39 <vincentfrancoise> I made some comments on it already
14:11:57 <acabot> ok
14:12:08 <vincentfrancoise> there is 1 main question that still misses an answer
14:12:20 <acabot> sballe_ jwcroppe hvprash : anyone who wants to review it ?
14:12:32 <sballe_> I can d that
14:12:36 <hvprash> +1
14:13:02 <gzhai> +1
14:13:14 <jwcroppe> +1
14:13:23 <acabot> #action hvprash sballe_ acabot gzhai jwcroppe review https://review.openstack.org/#/c/342473/
14:13:45 <diga_> vincentfrancoise: Your comment "How do plan on making sure there only one action plan that is executed at a time? "
14:13:51 <acabot> Limit concurrent actions invoked by Watcher needs reviews
14:14:02 <acabot> #link https://review.openstack.org/#/c/348049/
14:14:23 <acabot> sorry I didn't have time to review it yet, anyone here who wants to review ?
14:14:50 <hvprash> i can
14:14:54 <sballe_> ditto
14:15:07 <acabot> #action hvprash sballe_ review https://review.openstack.org/#/c/348049/
14:15:26 <diga_> vincentfrancoise: we are introducing the AUTO_TRIGGER_ACTION_PLAN attribute in the AUDIT, only those Audits action plan executed
14:15:28 <acabot> hvprash : dont take too many reviews because you have a spec to write ;-)
14:15:28 <vincentfrancoise> diga_: yes that's the one question that needs to be addressed
14:15:52 <hvprash> thats fine acabot :)
14:16:11 <vincentfrancoise> diga_: yes but if 2 action plans have that AUTO_TRIGGER_ACTION_PLAN flag, they will be concurrently executed and we don't want that
14:16:26 <hvprash> been away for few weeks and was missing some action ;)
14:16:39 <acabot> hvprash ;-)
14:16:50 <acabot> Add team priorities for Ocata needs reviews and will be merged during the summit
14:16:56 <acabot> #link https://review.openstack.org/#/c/372528/
14:17:10 <acabot> I had a discussion with alexchadin about the watcher roadmap
14:17:25 <diga_> vincentfrancoise: how many action plan we can execute for one audit, can we execute many action plan for audit ??
14:17:32 <acabot> and realized that we didn't set priorities after the mid-cycle
14:17:38 <vincentfrancoise> diga: we need to add some logic on the watcher-applier side to make sure that only 1 action plan can be executed at a time
14:17:50 <diga_> vincentfrancoise: okay
14:17:51 <vincentfrancoise> diga: 2 action plans from 2 different audits
14:18:00 <acabot> diga_ vincentfrancoise : could you please iterate through gerrit ?
14:18:14 <diga_> acabot: okay
14:18:15 <vincentfrancoise> acabot: ok
14:18:43 <acabot> so I did a first draft of Ocata priorities, I could have missed some important BPs so please review it before the summit
14:19:00 <acabot> We need a spec for Define grammar for workload characterization
14:19:08 <hvprash> yes
14:19:08 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/workload-characterization-grammar
14:19:10 <hvprash> working on it
14:19:34 <sballe_> +1
14:19:36 <acabot> #action sballe_ jwcroppe hvprash review https://review.openstack.org/#/c/372528/
14:19:49 <sballe_> hvprash: pull me in
14:19:53 <acabot> #action hvprash submit a spec for https://blueprints.launchpad.net/watcher/+spec/workload-characterization-grammar
14:19:56 <hvprash> of course sballe_
14:20:07 <acabot> moving to Watcher
14:20:19 <acabot> many bug fixes merged last week
14:20:40 <acabot> now that we have a stable branch, we can start merging code for Ocata
14:20:52 <acabot> Add Audit Scope Handler needs reviews
14:21:10 <acabot> #link https://review.openstack.org/#/q/status:open++topic:bp/define-the-audit-scope
14:21:27 <acabot> who wants to review the audit scope handler ?
14:21:35 <dtardivel> +1
14:21:44 <sballe_> +1
14:21:57 <acabot> #action dtardivel sballe_ review https://review.openstack.org/#/q/status:open++topic:bp/define-the-audit-scope
14:22:09 <acabot> Graph cluster model implementation needs reviews
14:22:16 <acabot> #link https://review.openstack.org/#/c/362730/
14:22:32 <acabot> who wants to review the graph model ?
14:22:50 <vincentfrancoise> me
14:22:59 <dtardivel> me
14:23:09 <acabot> #action vincentfrancoise dtardivel review  https://review.openstack.org/#/c/362730/
14:23:19 <acabot> Watcher dashboard
14:23:27 <acabot> Dashboard devstack plugin has been disabled until a bug is fixed in devstack
14:23:36 <acabot> #link https://bugs.launchpad.net/devstack/+bug/1540328
14:23:38 <openstack> Launchpad bug 1540328 in devstack "Devstack cannot install Horizon plugins using pip 8.x" [Undecided,Confirmed] - Assigned to YAMAMOTO Takashi (yamamoto)
14:23:45 <acabot> it impacts many different projects
14:24:06 <acabot> and our devstack setup does not work anymore
14:24:40 <acabot> #topic Blueprint/Bug Review and Discussion
14:24:53 <dtardivel> acabot: I would like to check watcher:stable/newton branch on devstack, but stable/newton branch on devstack is not yet available...
14:25:36 <acabot> as discussed last week, after the RC-1 release, all BPs targeted for Ocata were medium or low priority
14:25:47 <acabot> #link https://blueprints.launchpad.net/watcher/ocata
14:26:03 <acabot> so I tried to set a priority and a milestone for each BP
14:26:41 <acabot> I'd like everyone to review it and check if the priority and milestone is ok
14:27:12 <acabot> we have 17 BPs for Ocata (15 have been completed in Newton)
14:27:48 <acabot> of course if I missed important BP in the list https://blueprints.launchpad.net/watcher please let me know asap
14:28:11 <sballe_> this is a good cadense. pretty impressive
14:28:41 <acabot> the Ocata schedule is shorter than previous cycle
14:28:55 <acabot> as there will be the PTG event in february
14:29:23 <sballe_> where is the PTG event? I forgot
14:29:28 <acabot> Atlanta
14:29:52 <acabot> scalability tests - platform status
14:30:09 <acabot> dtardivel sballe_ gzhai : any updates on the platform ?
14:30:13 <sballe_> yes
14:30:33 <dtardivel> we are going to check all the platform conf with Susanne
14:30:40 <sballe_> We have systems up and runnign with Monasca but dtardivel and I are debugging it
14:30:53 <sballe_> Monacsa needs to be configured
14:31:04 <sballe_> I have access to the systems now s we shoul dbe moving forward
14:31:23 <sballe_> a million thx to dtardivel for his help here
14:31:26 <acabot> how many nodes do we have now ?
14:31:34 <sballe_> 12=15
14:31:40 <sballe_> 12+15
14:31:54 <sballe_> and 3 as control plane
14:31:58 <acabot> ok
14:32:19 <acabot> any idea of when we will be able to run PKB ?
14:32:37 <sballe_> as soon as we have it debugged and ceilosca installd
14:32:44 <sballe_> hopefuly next week
14:32:48 <acabot> ok
14:33:11 <acabot> Monday 26th
14:33:21 <sballe_> dtardivel: and I still have some debugging to do
14:33:40 <dtardivel> yep
14:33:46 <sballe_> lol
14:33:52 <acabot> sballe_ : we planned to have the platform until Monday 26th :-)
14:34:09 <sballe_> I have been told we can have it unitl the end of october
14:34:18 <acabot> sballe_ : good news
14:34:34 <acabot> I hope we will be able to get metrics before the summit
14:34:34 <sballe_> :-)
14:34:55 <acabot> #topic Open discussions
14:35:03 <acabot> Notifications in Watcher is too big and need to be segmented
14:35:09 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/watcher-notifications-ovo
14:35:24 <acabot> vincentfrancoise : your subject ;-)
14:35:53 <vincentfrancoise> well this BP is quite big and tackles many aspects of Watcher at the same time
14:36:06 <jed56> +2 ;)
14:36:07 <vincentfrancoise> first of there is the setup of the notification system
14:36:37 <vincentfrancoise> and then we have to lay down all the notifications (and their respective payload) we want for each one of the Watcher objects
14:37:22 <vincentfrancoise> so I would suggest we use this BP to only create the common plumbing
14:37:44 <vincentfrancoise> and then create a separate BP for the Audit notifications, Action Plan notifications, and so on...
14:38:22 <jed56> this is a good idea
14:38:40 <acabot> vincentfrancoise : so you plan to have only the Audit updated in this BP ?
14:38:47 <acabot> + the plumbing
14:39:34 <vincentfrancoise> well I plan to do the common plumbing and the new audit-related notifications BP
14:39:40 <vincentfrancoise> so yes
14:39:49 <dtardivel> vincentfrancoise: +1
14:40:15 <acabot> my main concern would be, if we merge the Audit and then dont have time to update other Watcher objects, will Watcher still be usable ?
14:40:19 <vincentfrancoise> IMHO, the most important objects we need to focus on in ocata should be audit and action plan
14:40:54 <acabot> as we will use 2 different mechanisms to deal with objects
14:41:20 <vincentfrancoise> because Watcher actions involve Nova (e.g. for migrations or service state update)
14:41:34 <vincentfrancoise> and these already emit notifications of their own
14:42:07 <vincentfrancoise> and the audit template is pretty much copied as an audit before any action gets done so audit notifications should suffice
14:42:29 <acabot> ok
14:42:57 <acabot> could you please update the BP description and submit a draft of spec for it ?
14:43:17 <acabot> vincentfrancoise : could you please update the BP description and submit a draft of spec for it ?
14:43:37 <vincentfrancoise> acabot: yes I will, I am still in an 'exploration' stage
14:44:04 <acabot> #action vincentfrancoise update BP description and submit a draft spec for https://blueprints.launchpad.net/watcher/+spec/watcher-notifications-ovo
14:44:13 <acabot> vincentfrancoise : ok thx
14:44:22 <acabot> we should provide a user documentation for each strategy
14:44:41 <vincentfrancoise> +1
14:45:09 <acabot> as dtardivel was testing strategies last week, we realized that there is no dedicated doc for each strategy available in watcher
14:45:35 <dtardivel> acabot: yep. the main idea is to propose a template doc to explain a strategy
14:45:57 <acabot> what do you think ?
14:46:14 <dtardivel> acabot: and how to use it, what are required metrics, how to collect them ? ....
14:46:43 <vincentfrancoise> the most important bit was the metrics requirements
14:46:48 <acabot> should we let devs build there own doc when they submit a new strategy or should we guide them with a template ?
14:47:17 <vincentfrancoise> and then the parameter tunings
14:47:26 <dtardivel> acabot: I prefer a template doc ... and an exemple
14:47:31 <hvprash> +1
14:47:47 <sballe_> +1
14:48:09 <acabot> ok do we need a BP for that ? (I dont think so)
14:48:29 <dtardivel> I created a wishlist bug
14:48:34 <vincentfrancoise> acabot: a BP might be needed to go through all existing strategies
14:48:43 <acabot> its a doc improvement, I think a bug is sufficient
14:49:17 <dtardivel> +1
14:49:21 <acabot> vincentfrancoise : if we have a template, I think we can ask every strategy provider to add a doc
14:49:34 <dtardivel> +1
14:49:36 <vincentfrancoise> +1
14:49:38 <acabot> who wants to start working on a template ?
14:50:02 <dtardivel> I can try on basic consolisation strategy
14:50:13 <acabot> ok
14:50:47 <acabot> #action build a template for strategy doc using basic consolidation as an example
14:50:58 <acabot> #action dtradivel build a template for strategy doc using basic consolidation as an example
14:51:07 <acabot> #action dtardivel build a template for strategy doc using basic consolidation as an example
14:51:17 * acabot a bit tired...
14:51:33 <acabot> fix requirements
14:51:39 <acabot> https://review.openstack.org/#/q/status:open+topic:tox/requirements
14:51:49 <acabot> #link https://review.openstack.org/#/q/status:open+topic:tox/requirements
14:52:14 <acabot> dtardivel : do you want to explain this change sets ?
14:52:34 <dtardivel> vincentfrancoise: please can you explain it ? :)))
14:52:42 <vincentfrancoise> dtardivel: ok :p
14:53:42 <vincentfrancoise> so basically, these are needed to set precise requirement versions
14:54:57 <vincentfrancoise> e.g. for the stable/newton branch, this will guarantee that all test are passing with with the newton-capped package versions instead of beeing changed all the time
14:55:07 <acabot> so now stable newton branch has fixed requirements right ?
14:55:13 <dtardivel> strict requirements are set in openstack/requirements github project, in the file upper-contraints.txt
14:55:36 <acabot> so do we have to test it again with these requirements or it was already done ?
14:55:56 <vincentfrancoise> requirements.txt only defines the lower boundary for package requirements
14:56:05 <dtardivel> So we add into tox.ini a way to read this strict requirements and to update our dependencies versions while running unitary tests
14:56:13 <vincentfrancoise> with this, we now have the upper boundary
14:56:44 <acabot> ok
14:56:57 <acabot> 4 min left, any other discussion to open ?
14:57:51 <dtardivel> acabot: I proposed a commit for stable/newton and master branches on watcher and python-watcherclient project
14:58:03 <dtardivel> s/commit/patchset
14:58:29 <acabot> dtardivel : https://review.openstack.org/#/q/status:open++topic:tox/requirements
14:58:54 <acabot> ok thank you all
14:59:00 <acabot> have a nice day/night
14:59:02 <vincentfrancoise> bye
14:59:05 <hvprash> bye
14:59:11 <acabot> #endmeeting