08:59:59 <acabot> #startmeeting watcher
09:00:00 <openstack> Meeting started Wed Aug 31 08:59:59 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:03 <openstack> The meeting name has been set to 'watcher'
09:00:21 <sballe_> hi
09:00:22 <acabot> hello
09:00:33 <dtardivel> bonjour
09:00:46 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#08.2F31.2F2016
09:01:07 <acabot> vincentfrancoise & jed56 are on vacation
09:01:26 <acabot> are gzhai & jinquan here ?
09:01:47 <jinquan> acabot: i'm on
09:01:53 <acabot> hi jinquan
09:01:56 <jinquan> hi
09:02:05 <tkaczynski> hi
09:02:07 <acabot> #topic Announcements
09:02:11 <diga> o/
09:02:25 <acabot> #info Only one talk accepted for Barcelona summit
09:02:33 <acabot> #link https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/16023/watcher-the-infrastructure-optimization-service-for-openstack-plans-for-the-o-release-and-beyond
09:03:28 <acabot> Taylor does not contribute any more to the project, I suppose that jwcroppe will speak
09:03:53 <acabot> jinquan : does Charlotte wants to talk in Barcelona ?
09:04:04 <sballe_> I would like to add somebody from b-com to the talk
09:04:06 <hanrong> hi
09:04:19 <acabot> sorry hanrong
09:04:37 <jinquan> acabot: i guess so
09:04:43 <acabot> hanrong : do you want to be part of this talk ?
09:04:57 <hanrong> yes
09:05:17 <sballe_> acabot: I talked to her early august and she wanted to talk.
09:05:44 <acabot> ok in this case we will wait for jwcroppe to confirm before letting someone from bcom join the talk
09:06:10 <acabot> #action jwcroppe confirm that he will be speaking at https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/16023/watcher-the-infrastructure-optimization-service-for-openstack-plans-for-the-o-release-and-beyond
09:06:36 <jinquan> one topic only have 3 talkers?
09:06:46 <sballe_> yes
09:06:52 <acabot> jinquan : yes the foundation ask for max 3 speakers
09:07:26 <jinquan> ok, we can wait the info from jwcroppe first
09:07:29 <jinquan> i think
09:07:43 <acabot> we will also have design sessions so b<>com folks will also be able to present watcher (but it wont be on youtube ;-))
09:07:48 <hanrong> I have discussed with Susanne before.
09:07:59 <alexchadin> hi
09:08:10 <acabot> ok great lets wait for jwcroppe next week
09:08:24 <acabot> #info Newton-3 release has been submitted to the release team
09:08:24 <sballe_> ok.
09:08:31 <hanrong> ok
09:08:34 <acabot> #link https://review.openstack.org/#/c/362930/
09:08:47 <acabot> as you may know, we are in a release week
09:09:07 <acabot> for the first time we will release watcher-dashboard to be part of Newton officialy
09:09:14 <sballe_> +1
09:09:31 <acabot> so I'm still fixing a couple of gate issues for it but it should be announced tomorrow
09:09:53 <acabot> #info hvprash is now core contributor on Watcher specs
09:10:04 <sballe_> Great news
09:10:05 <acabot> thx for your votes on the ML
09:10:16 <dtardivel> Thx everybody for this release n3 :)
09:10:35 <acabot> #info we now have 4 core on watcher-specs : sballe_ jwcroppe hvprash & acabot
09:11:22 <acabot> Yes thanks a lot for all the work done during this cycle, I was really impressed while writing release notes of the amount of work we have done !
09:11:33 <alexchadin> Great work!
09:11:39 <jinquan> cool
09:12:07 <acabot> 14 new features !
09:12:30 <sballe_> cool!
09:12:37 <acabot> #info Watcher has got Rally support
09:12:46 <alexchadin> :)
09:12:50 <alexchadin> It was long story
09:12:51 <acabot> #link https://review.openstack.org/#/q/owner:%22Alexander+Chadin+%253Ca.chadin%2540servionica.ru%253E%22+project:openstack/rally+status:merged
09:13:22 <acabot> alexchadin : yes and thx for your support, I think its a great addition !
09:13:24 <alexchadin> Now we can test our strategies
09:13:35 <sballe_> this is great news!
09:13:46 <alexchadin> Thank you!
09:13:48 <acabot> alexchadin : yes I'd like to test it on intel infra
09:13:50 <sballe_> This should imporve our overall testing
09:14:15 <acabot> any other announcement ?
09:14:22 <dtardivel> alexchadin: do we have a dedicated section in Watcher documentation about Rally ?
09:14:26 <acabot> sballe_ : no news about the mascot ;-)
09:14:35 <sballe_> lol
09:14:47 <alexchadin> dtardivel: take a look https://review.openstack.org/#/c/333371/3/rally-jobs/README.rst
09:15:24 <acabot> alexchadin : we probably need to add a link from Watcher doc right ?
09:15:47 <dtardivel> alexchadin: yes I think so.
09:15:52 <alexchadin> acabot: where to?
09:17:02 <acabot> alexchadin : we can find it in the git repo but we need to add a section somewhere in the generated doc
09:17:20 <alexchadin> Ah, yes
09:17:24 <acabot> http://docs.openstack.org/developer/watcher/
09:17:46 <acabot> I suppose it would be in the developer guide
09:18:02 <acabot> alexchadin : can you create an entry for it ,
09:18:04 <acabot> ?
09:18:31 <alexchadin> hm, I think so
09:18:40 <alexchadin> I will need your help regarding docs
09:18:46 <acabot> #action alexchadin add a doc section for Rally in Watcher documentation
09:18:48 <alexchadin> in that case*
09:18:56 <dtardivel> alexchadin: I will help you
09:19:06 <acabot> #topic Review Action Items
09:19:12 <alexchadin> dtardivel: cool!
09:19:36 <acabot> Watcher specs
09:19:38 <acabot> Newton approved specs have been moved to implemented folder
09:19:46 <acabot> #link https://review.openstack.org/#/c/362108/
09:20:10 <acabot> #info all specs must now be submitted in Ocata folder
09:20:26 <acabot> Graph model describing virtual and physical elements in a data center has been merged
09:20:35 <acabot> #link https://review.openstack.org/#/c/298891/
09:20:43 <alexchadin> acabot: When can we start to merge our features again?
09:20:52 <alexchadin> After newton release?
09:21:04 <acabot> alexchadin : you mean the code ?
09:21:07 <alexchadin> yeap
09:21:16 <alexchadin> I saw it should be 1-3 october
09:21:34 <acabot> alexchadin : as soon as the release team will have created the newton branch (should occur next week)
09:21:55 <alexchadin> ok, good news:)
09:22:15 <acabot> Resize instance base on workload should be retargeted to Ocata
09:22:24 <acabot> #link https://review.openstack.org/#/c/359690/
09:22:25 <diga> yes, this is good
09:22:31 <jinquan> yeah, i have a mistake when push the patchset
09:22:40 <jinquan> and maybe resize have too much risk indeed , so i need modify specs about the comment from sballe_, and Sameer Adhikari,
09:22:48 <jinquan> sballe_: Sameer Adhikari:thank you for your review!
09:22:57 <acabot> jinquan : yes please add a PS
09:23:13 <jinquan> acabot: ok
09:23:21 <acabot> #action jinquan add a PS to https://review.openstack.org/#/c/359690/
09:23:29 <acabot> Limit concurrent actions invoked by Watcher needs reviews
09:23:36 <acabot> #link https://review.openstack.org/#/c/348049/
09:24:05 <acabot> #action jwcroppe add a new PS for https://review.openstack.org/#/c/348049/
09:24:20 <acabot> #action acabot hvprash review https://review.openstack.org/#/c/348049/
09:24:30 <acabot> automatic triggering audit needs reviews
09:24:36 <acabot> #link https://review.openstack.org/#/c/342473/
09:24:58 <acabot> diga : sorry I didnt have time to review your spec
09:25:11 <diga> acabot: Np
09:25:31 <acabot> diga : can you answer sballe_ comments ?
09:25:33 <diga> acabot: I am submitting again with changes suggeste
09:25:37 <diga> yes
09:25:51 <acabot> #action diga add a PS for https://review.openstack.org/#/c/342473/
09:26:01 <acabot> Watcher
09:26:02 <diga> I will submit it by tomorrow
09:26:22 <acabot> Scoring module has been merged and doc is in review
09:26:29 <acabot> #link https://review.openstack.org/#/c/362827/
09:26:39 <acabot> who wants to review scoring module doc ?
09:26:53 <sballe_> I am in the middle of reviewing it
09:26:53 <jinquan> i can review the doc
09:27:00 <acabot> #action acabot sballe_ jinquan review https://review.openstack.org/#/c/362827/
09:27:06 <tkaczynski> thanks guys
09:27:27 <alexchadin> acabot: I will
09:27:30 <acabot> and thx tkaczynski for the code !
09:27:43 <tkaczynski> thanks for reviews :)
09:27:50 <acabot> #action alexchadin review https://review.openstack.org/#/c/362827/
09:28:05 <acabot> Cluster model objects wrapper has been merged
09:28:12 <acabot> #link https://review.openstack.org/#/q/status:merged+project:openstack/watcher+branch:master+topic:bp/cluster-model-objects-wrapper
09:28:25 <acabot> thx vincentfrancoise for this huge contribution
09:28:44 <sballe_> +1
09:28:44 <acabot> dtardivel is still testing it
09:28:49 <tkaczynski> +1
09:28:51 <diga> acabot: I have another one BP I have submitted  I guess, but I guess this BP is right fit for watcher with some addition - https://blueprints.launchpad.net/nova/+spec/license-cost-aware-vm-placement
09:29:19 <diga> this tells about cloud placement on licence cost aware VM placement
09:29:30 <acabot> diga : I didnt' see it, I will take a look
09:29:33 <diga> ok
09:29:45 <acabot> #action acabot look at https://blueprints.launchpad.net/nova/+spec/license-cost-aware-vm-placement
09:29:50 <acabot> thx
09:29:58 <acabot> Newton release notes have been merged
09:30:01 <sballe_> me 2
09:30:03 <diga> wc!
09:30:04 <acabot> #link https://review.openstack.org/#/c/362013/
09:30:13 <acabot> thx for your fast reviews ;-)
09:30:24 <acabot> Graph cluster model implementation needs reviews
09:30:33 <acabot> #link https://review.openstack.org/#/c/362730/
09:30:49 <acabot> there is still a pep8 issue
09:31:03 <acabot> sballe_ : can you check with Greg if he needs help ?
09:31:16 <sballe_> will do
09:31:37 <acabot> #action sballe_ check if Greg needs help to solve pep8 issue on https://review.openstack.org/#/c/362730/
09:31:53 <acabot> who wants to review the graph model ?
09:32:01 <hanrong> +1
09:32:19 <acabot> #action hanrong review https://review.openstack.org/#/c/362730/
09:32:20 <sballe_> please add me to that
09:32:28 <acabot> #action sballe_ review https://review.openstack.org/#/c/362730/
09:32:40 <acabot> Add rally-jobs folder to get rally support needs tests ?
09:32:47 <acabot> #link https://review.openstack.org/#/c/333371/
09:33:09 <acabot> alexchadin : what can we do with this PS ?
09:33:17 <alexchadin> I think there shouldn't be any tests
09:33:38 <alexchadin> Other projects don't have them for rally-jobs folder
09:34:02 <acabot> by test I meant test Rally (not unit tests) ;-)
09:34:19 <acabot> so we can just merge it and run Rally
09:34:34 <alexchadin> We have one experimental gate test
09:35:07 <alexchadin> wait a sec
09:35:13 <acabot> did you update the gate config ?
09:35:50 <alexchadin> https://review.openstack.org/#/c/333860/
09:36:46 <acabot> ok so we can already test it in the gate !
09:36:49 <acabot> thats great
09:37:02 <alexchadin> yeap, we can
09:37:26 <acabot> #info gate-rally-dsvm-watcher-watcher is available as experimental
09:37:39 <acabot> #topic Blueprint/Bug Review and Discussion
09:37:56 <acabot> #info Current milestone is Newton-rc1 due September 12th
09:38:03 <acabot> #link https://launchpad.net/watcher/+milestone/newton-rc1
09:38:16 <acabot> only one BP (scalability tests) & bug fixes
09:38:36 <acabot> so during this month, please do not hesitate to submit bugs
09:38:56 <acabot> I will try to update the bug list priorities everyday
09:39:08 <sballe_> thanks
09:39:17 <jinquan> +1
09:39:23 <acabot> the idea is to have an rc-final version fully tested
09:39:36 <acabot> we can also improve unit test coverage
09:39:44 <acabot> and translations
09:40:24 <acabot> #topic Open discussions
09:40:52 <dtardivel> acabot: can we talk about Intel platform ?
09:40:52 <acabot> I'd like to discuss scalability tests on intel infra, sballe_ can you give us a quick status ?
09:41:16 <sballe_> I talked to the Intel team yesterday
09:41:16 <acabot> is gzhai here ?
09:41:47 <sballe_> gzhai and I met with the Intel team yesterday and we retold them our requirements
09:42:10 <sballe_> They will install all the services we asked for including Monasca and ceiloasca
09:42:22 <sballe_> and Watcher per our description
09:42:39 <sballe_> We expect to get the system by the end of this week or beginnign of next
09:42:51 <sballe_> gzhai is workign on the PBK scripts
09:43:24 <acabot> ok regarding PKB, we will have to define scenarios using YAML files
09:43:30 <sballe_> also week 1 we get 15 systems because the ceilomter team is using the rest
09:43:43 <acabot> in these files, we need to specify server names and image names
09:43:53 <sballe_> Week 2 and beyond we get all 30 systems. of course we use 3 for control planes
09:44:07 <sballe_> acabot: ok
09:44:18 <dtardivel> sballe_: from our side, we are working on a new benchmark for PKB, to meet our requirements
09:44:21 <acabot> #link https://etherpad.openstack.org/p/watcher-test-environment-specifications
09:44:48 <acabot> so week 1, we will have : 10 x 1U x 2 racks Intel Xeon Haswell-EP E5-2699 2.3hz 18 cores ?
09:45:26 <dtardivel> We need to sync with gzhai about our PKB benchmark tests
09:45:48 <sballe_> acabot: yes 12 systems to start with given 3 are being used for control plane
09:46:01 <sballe_> dtardivel: yes please do that
09:46:59 <sballe_> gzhai is at the F2F some of this week but I was expecting him at the iRC today
09:47:04 <sballe_> not sure what happened
09:47:41 <acabot> dtardivel will share an example of the yaml file we use in PKB to define the targeted infra
09:47:41 <dtardivel> sballe_: our new benchmark will be able de deploy specific instances on dedicated nodes.
09:47:55 <dtardivel> sballe_: Configuration will be something like this
09:48:05 <sballe_> what do you mean by dedicated nodes
09:48:13 <dtardivel> https://www.irccloud.com/pastebin/ScnaS6oy/
09:48:46 <acabot> sballe_ : if we want to test Watcher, we need to define a state of the infra before running watcher
09:49:31 <acabot> so we will share this kind of yaml file with gzhai to be able to deploy VMs and workloads on specific hosts
09:49:33 <sballe_> I agree. What are you guys thinking in term of defining the state of the infra?
09:49:49 <sballe_> make sense
09:49:56 <acabot> I mean defining which VM is running on which host
09:50:11 <acabot> to be able to "unbalance" the cluster
09:50:12 <sballe_> ok
09:50:15 <acabot> and then run Watcher
09:50:25 <dtardivel> sballe_: On each instance, we will be able to control, independently, CPU workload (by using stress linux command)
09:50:27 <acabot> the yaml file is pretty straightforward
09:50:41 <sballe_> agreed. it is early so I have still not had my coffee
09:51:01 <acabot> we just need to know the compute node name (replacing nodeX in yaml) and the name of the image to deploy
09:51:14 <sballe_> ok
09:51:35 <acabot> then gzhai will be able to run the bench in PKB
09:51:38 <sballe_> I will follow up with gzhai, please ping him too
09:51:48 <dtardivel> sballe_: +1
09:51:57 <acabot> what we need to define also is how we will get the results !
09:52:13 <sballe_> agreed
09:52:50 <acabot> Watcher logs, Monasca DB export, cluster state after running the strategy...i dont know what he will be able to provide
09:53:19 <acabot> maybe we could schedule a conf call (or IRC meeting) tomorrow ?
09:53:24 <sballe_> let add this to the etherpad
09:53:25 <dtardivel> sballe_: can we ask to gzhai to propose to us a solution to collect this information for each PKB test ?
09:54:15 <sballe_> dtardivel: yes
09:54:17 <dtardivel> sballe_: and from our side, we focus on new PKB benchmark and new image ?
09:54:30 <sballe_> ok
09:54:52 <acabot> ok thx
09:54:58 <acabot> any other topic to discuss ?
09:55:01 <sballe_> dtardivel: add all the peices you need to the tehrpad and we'll figure out how to get it
09:55:32 <dtardivel> sballe_: +1
09:55:51 <sballe_> https://etherpad.openstack.org/p/watcher-test-environment-specifications
09:56:54 <acabot> thanks everyone
09:56:58 <acabot> have a good day
09:56:59 <sballe_> thanks
09:57:03 <sballe_> bye
09:57:05 <acabot> bye
09:57:09 <sballe_> you too
09:57:11 <acabot> #endmeeting