09:00:27 <acabot> #startmeeting watcher
09:00:27 <openstack> Meeting started Wed Aug 17 09:00:27 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:30 <openstack> The meeting name has been set to 'watcher'
09:00:31 <acabot> hello guys
09:00:33 <alexchadin> hi
09:00:37 <jinquan> hi
09:00:45 <vincentfrancoise> o/
09:01:19 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#08.2F17.2F2016
09:01:35 <acabot> #topic Announcements
09:01:47 <acabot> #info alexchadin is now core on Watcher
09:01:51 <acabot> congrats !
09:01:53 <alexchadin> wow
09:01:58 <alexchadin> thanks!
09:02:11 <jinquan> alexchadin: congrats!!!
09:02:15 <acabot> you should have a +/- 2 option in gerrit ;-)
09:02:22 <dtardivel> hi
09:02:39 <alexchadin> thank you, guys!
09:03:03 <vincentfrancoise> alexchadin: welcome to the club :D
09:03:04 <acabot> #info please vote for promoting hvprash as core on watcher-specs
09:03:11 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-August/101750.html
09:03:30 <alexchadin> vincentfrancoise: no one speak about club :D
09:03:35 <alexchadin> vincentfrancoise: rule 1
09:03:42 <vincentfrancoise> alexchadin: hahahaha
09:04:18 <acabot> #info we now have 5 core contributors for Watcher jed56, dtardivel, vincentfrancoise, alexchadin & gzhai
09:04:47 <acabot> any other announcement ?
09:04:49 <jed56> alexchadin: :)
09:05:09 <acabot> #rtopic Review Action Items
09:05:15 <acabot> #topic Review Action Items
09:05:22 <acabot> Watcher specs
09:05:36 <acabot> Graph model describing virtual and physical elements in a data center needs a new PS and final reviews
09:05:45 <acabot> #link https://review.openstack.org/#/c/298891/
09:06:05 <acabot> #action acabot send an email to greg to get an update on https://review.openstack.org/#/c/298891/
09:06:29 <acabot> Update define-the-audit-scope spec needs reviews from core
09:06:41 <acabot> #link https://review.openstack.org/#/c/339456/
09:06:53 <acabot> #action sballe jwcroppe acabot review https://review.openstack.org/#/c/339456/
09:07:31 <acabot> Added spec for automatic triggering audit needs a new PS
09:07:40 <acabot> #link https://review.openstack.org/#/c/342473/
09:08:13 <acabot> diga told me that he will update the spec today
09:08:29 <acabot> #action diga__ add a new PS to https://review.openstack.org/#/c/342473/
09:08:43 <acabot> Limit concurrent actions invoked by Watcher needs reviews
09:08:50 <acabot> #link https://review.openstack.org/#/c/348049/
09:08:57 <hanrong> +1
09:08:59 <acabot> anyone wants to review it ?
09:09:13 <acabot> #action hanrong review https://review.openstack.org/#/c/348049/
09:09:25 <gzhai-mobl> i
09:09:39 <acabot> #action gzhai-mobl review https://review.openstack.org/#/c/348049/
09:09:42 <acabot> thx
09:09:48 <acabot> Move Mitaka specs to Newton cycle & Add ocata folders and template for specs need +2
09:09:55 <acabot> #link https://review.openstack.org/#/c/353454/
09:10:01 <acabot> #link https://review.openstack.org/#/c/353320/
09:10:27 <acabot> #action sballe jwcroppe +2 https://review.openstack.org/#/c/353454/ & https://review.openstack.org/#/c/353320/
09:10:35 <acabot> Watcher
09:10:54 <acabot> Add Scoring Module implementation needs more reviews
09:11:02 <acabot> #link https://review.openstack.org/#/c/351577/
09:11:08 <acabot> who wants to review it ?
09:11:11 <hanrong> +1
09:11:22 <acabot> #action hanrong review https://review.openstack.org/#/c/351577/
09:11:25 <vincentfrancoise> I will too
09:11:34 <acabot> #action vincentfrancoise review https://review.openstack.org/#/c/351577/
09:11:50 <acabot> Added Monasca Helper has to be merged
09:11:57 <acabot> #link https://review.openstack.org/#/c/348891/
09:12:13 <acabot> because we need it for benchmarks in september
09:12:14 <dtardivel> acabot: I will review it
09:12:24 <acabot> #action dtardivel review https://review.openstack.org/#/c/348891/
09:12:39 <acabot> anyone else wants to review ? gzhai-mobl ?
09:12:52 <gzhai-mobl> gave comments
09:12:58 <alexchadin> I'll take a look
09:13:02 <acabot> ok thx
09:13:11 <acabot> #action alexchadin review https://review.openstack.org/#/c/348891/
09:13:28 <acabot> Added strategy ID + Action Plan syncing needs reviews
09:13:35 <acabot> #link https://review.openstack.org/#/c/325213/
09:13:49 <jinquan> i will review this one
09:13:55 <dtardivel> acabot: I will review it too
09:14:09 <acabot> #action jinquan dtardivel review https://review.openstack.org/#/c/325213/
09:14:12 <acabot> thx
09:14:28 <acabot> #topic Blueprint/Bug Review and Discussion
09:14:51 <acabot> #info current milestone is n-3 due August 29th
09:14:58 <acabot> #link https://launchpad.net/watcher/+milestone/newton-3
09:15:22 <acabot> I would suggest to freeze the code on Friday 26th
09:15:33 <acabot> in 10 days
09:16:19 <acabot> alexchadin : are you confident to deliver the audit scope by Friday 26th ?
09:16:19 <jed56> +1
09:16:39 <alexchadin> I'll try to do it
09:16:54 <alexchadin> It depends on spec review
09:17:43 <acabot> I think we can merge the spec today if I got feedback from jwcroppe
09:18:05 <acabot> did you already start implementing ?
09:18:38 <alexchadin> A little bit
09:18:55 <acabot> ok lets keep it on n-3 then
09:19:04 <alexchadin> cool!
09:19:10 <acabot> gzhai-mobl : what about https://blueprints.launchpad.net/watcher/+spec/statemachine-transition-permission ?
09:19:23 <gzhai-mobl> not yet
09:19:36 <acabot> gzhai-mobl : did you start working on a spec ?
09:19:58 <gzhai-mobl> sorry, have some other task
09:20:06 <gzhai-mobl> not yet
09:20:07 <acabot> ok
09:20:22 <gzhai-mobl> will start this week
09:20:40 <acabot> #info I suggest to move all unimplemented BP to Ocata to keep our next Newton milestones empty and focus on bug fixes
09:20:53 <vincentfrancoise> +1
09:20:57 <acabot> is that ok for you guys ?
09:21:05 <dtardivel> +1
09:21:35 <acabot> as we will have 17 BPs implemented in the Newton cycle, we need more tests before releasing the Newton version
09:21:38 <vincentfrancoise> we are closing in to our first big tent release so IMHO we should make things right :)
09:21:50 <acabot> +1
09:21:53 <alexchadin> +2
09:22:13 <jinquan> +1
09:22:41 <acabot> gzhai-mobl : is that OK for you ? just keep the scalability tests and bug fixes in september ?
09:22:47 <alexchadin> many of our open bugs have long store
09:22:50 <gzhai-mobl> ok
09:22:55 <alexchadin> story*
09:23:19 <acabot> #action acabot move Automatic triggering Action Plans & Use a state machine to model Watcher objects lifecycle BPs to Ocata
09:23:24 <alexchadin> don't we need to review them?
09:23:31 <acabot> sure we can
09:23:52 <acabot> there are 5 bugs open
09:24:09 <alexchadin> I see 10 bugs
09:24:32 <alexchadin> 3 of them are in wishlist/undecided
09:24:43 <acabot> alexchadin : right I was on the newton-3 panel
09:24:53 <acabot> #link https://bugs.launchpad.net/watcher
09:25:23 <acabot> jinquan : are you working on https://bugs.launchpad.net/watcher/+bug/1599879 ?
09:25:23 <openstack> Launchpad bug 1599879 in watcher "we should return FAILED status when we create an audit with unspecified parameters" [Medium,Triaged] - Assigned to Jinquan Ni (ni-jinquan)
09:25:51 <jinquan> yes, will done
09:25:58 <jinquan> this week
09:27:49 <dtardivel> acabot: Fix on bug https://bugs.launchpad.net/watcher/+bug/1600707 has been merged. We need to update its status
09:27:49 <openstack> Launchpad bug 1600707 in watcher "use parameters to set the threshold for strategies of Airflow,workload and outlet temerature" [Undecided,Fix committed] - Assigned to junjie.huang (junjie-huang)
09:28:24 <acabot> :-) done
09:28:39 <acabot> sometimes gerrit trigger doesnt work...
09:28:48 <vincentfrancoise> BTW, the same kind of bug should be filed for the other strategies
09:29:01 <acabot> alexchadin : any bug you want to discuss in particular ?
09:29:39 <alexchadin> acabot: I wouldn't for now
09:29:47 <alexchadin> vincentfrancoise: +1
09:30:12 <acabot> #action acabot do a bit of clean-up in bugs list !
09:30:39 <acabot> resize-overload-instance needs a new description and specs
09:30:45 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/resize-overload-instance
09:31:00 <acabot> jinquan : you probably had questions about it
09:31:25 <jinquan> acabot:yes i just discuss with vicent
09:31:28 <jinquan> vincent
09:32:09 <jinquan> by the way , i should put the spec into newton folders or ocata folders(not merged)?
09:32:44 <acabot> jinquan : ok the main idea from the mid-cycle was that the description is unclear
09:32:56 <acabot> put the spec in ocata
09:33:18 <acabot> now every new spec must be in Ocata (I will try to have the folders merged today)
09:33:19 <jinquan> when the folder will merged?
09:33:34 <jinquan> acabot: ok get it!
09:33:44 <vincentfrancoise> FYI, I just created https://bugs.launchpad.net/watcher/+bug/1614021
09:33:44 <openstack> Launchpad bug 1614021 in watcher "Remove hardcoded strategy attributes and promote them strategy parameters" [Medium,New]
09:33:48 <acabot> #action jinquan write a spec for https://blueprints.launchpad.net/watcher/+spec/resize-overload-instance
09:34:32 <acabot> thx vincentfrancoise
09:34:55 <acabot> #topic Open discussions
09:35:08 <acabot> #info email sent to Monasca PTL to get a status on Ceilosca code
09:35:11 <alexchadin> vincentfrancoise: I will ask my colleagues, maybe some of them will take this bug
09:35:34 <vincentfrancoise> alexchadin: that would be great!
09:36:11 <acabot> I 've got a first answer saying that HPE team working on Ceilosca has already fix some bugs and performance isssues and they plan to push them upstream
09:36:31 <acabot> he will come back to me next week with a timeframe
09:37:25 <acabot> regarding scalability tests
09:37:40 <acabot> dtardivel is working on scripts for gzhai-mobl
09:37:48 <gzhai-mobl> ok
09:38:04 <acabot> gzhai-mobl : can we package PKB in a docker container ?
09:38:22 <gzhai-mobl> pkb?
09:38:30 <acabot> perfkit benchamrker
09:38:42 <acabot> to run scenarios
09:38:56 <gzhai-mobl> not sure
09:39:02 <acabot> the tool will run on top of openstack and call Nova API
09:39:26 <acabot> would you prefer a VM ?
09:39:45 <gzhai-mobl> container seems better
09:40:11 <gzhai-mobl> but, big difference?
09:40:18 <acabot> it will be lighter but you need to have a docker engine deployed somewhere
09:40:48 <dtardivel> gzhai-mobl: OK, could you check this point from your side quickly please. I will push a container image today on our public repository.
09:41:35 <gzhai-mobl> dtardivel: decision?
09:41:46 <gzhai-mobl> vm or container?
09:42:06 <dtardivel> gzhai-mobl: yes please :)
09:42:51 <acabot> #action gzhai-mobl check that we can use a docker container to run PKB on intel infrastructure
09:42:59 <gzhai-mobl> either is ok. i prefer vm as i didn't use container before
09:43:27 <gzhai-mobl> ok. i'll check
09:43:30 <acabot> thx
09:43:47 <acabot> any other open discussion to open ?
09:43:57 <dtardivel> gzhai-mobl: I will provide a README doc to explain how to use Docker and PKB. I will be simple
09:44:26 <gzhai-mobl> dtardivel: thanks
09:45:39 <acabot> ok so thank you guys
09:45:44 <acabot> have a good day
09:45:52 <dtardivel> bye
09:45:56 <gzhai-mobl> bye
09:46:02 <acabot> bye
09:46:05 <acabot> #endmeeting