14:01:05 <acabot> #startmeeting watcher
14:01:06 <openstack> Meeting started Wed Aug 10 14:01:05 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:10 <openstack> The meeting name has been set to 'watcher'
14:01:11 <acabot> hello !
14:01:22 <gzhai-mobl> hi
14:01:24 <vincentfrancoise> o/
14:01:28 <hvprash> hi
14:01:28 <jinquan1> hi
14:01:34 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#08.2F10.2F2016
14:01:39 <jed56> hi
14:01:48 <jwcroppe> o/
14:02:00 <acabot> #topic Announcements
14:02:08 <acabot> a couple of announcements today ;)
14:02:25 <acabot> #info Watcher release mode has been updated to cycle-with-milestones but TC prefer that we wait for the Ocata cycle
14:02:31 <edleafe> \o
14:02:35 <acabot> #link https://review.openstack.org/#/c/353333/
14:02:41 <jwcroppe> \o
14:02:42 <jwcroppe> hi
14:03:00 <acabot> it doesn't change anything, we just have to do it again at the end of the newton cycle
14:03:23 <acabot> #info ongoing discussions on the ML regarding Watcher use cases for Nova placement API
14:03:31 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-August/100600.html
14:03:38 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-July/100327.html
14:03:54 <acabot> thx edleafe for describing our needs on the ML
14:04:19 <acabot> jwcroppe : did you get feedback from jaypipes ?
14:04:34 <jwcroppe> acabot: yep, I updated the etherpad as well
14:04:49 <acabot> #link https://etherpad.openstack.org/p/newton-watcher-midcycle
14:05:03 <jwcroppe> acabot: there is a lot of placement discussion going on - really two different ideas
14:05:37 <acabot> jwcroppe : ok so anything we can do on our side for now ?
14:06:05 <acabot> just follow the ML :-)
14:06:26 <jwcroppe> follow ML for now
14:06:30 <acabot> ok
14:06:51 <acabot> edleafe : any update on your side or the ML is up to date ?
14:06:53 <edleafe> yeah - nothing Watcher-related will be possible until the placement API is solid
14:07:13 <acabot> edleafe : ok
14:07:37 <acabot> edleafe : and when do you see that happened ? ocata ? p ?
14:07:40 <edleafe> there is no interest in adding a new API to live migrate if the placement API is coming soon
14:07:52 <jed56> hmm
14:08:04 <edleafe> ocata is possible, but P is more likely
14:08:04 <acabot> edleafe : yes it depends is the placement API is targeted for ocata
14:08:13 <acabot> ok
14:08:14 <alexchadin> hi
14:08:24 <edleafe> acabot: we're trying to get the basics in Newton
14:08:36 <acabot> edleafe : ok
14:08:40 <edleafe> acabot: so that the data will be migrated by ocata
14:08:52 <acabot> #info tpeoples stepped down from Watcher core
14:09:07 <acabot> #info alexchadin is promoted as Watcher core, please vote on the ML
14:09:15 <acabot> http://lists.openstack.org/pipermail/openstack-dev/2016-August/100828.html
14:09:18 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-August/100828.html
14:10:06 <acabot> #info (special for edleafe ;-)) jellyfish is now the official Watcher mascot
14:10:26 <jed56> ;-)
14:10:35 <edleafe> acabot: :)
14:10:38 <acabot> #info votes for Barcelona talks are closed, we will get the results on August 25th
14:11:04 <jwcroppe> Jellyfish!  nice
14:11:13 <hvprash> :)
14:11:15 <acabot> #info last mid-cycle etherpad with actions #link https://etherpad.openstack.org/p/newton-watcher-midcycle
14:11:53 <acabot> so please review your actions and strikeout them when completed
14:12:13 <acabot> any other announcement ?
14:12:45 <acabot> #topic Review Action Items
14:12:56 <acabot> watcher-specs
14:13:20 <acabot> alexchadin : you should update https://review.openstack.org/#/c/339456/
14:13:51 <alexchadin> acabot: I'm working on it and will discuss some things with jed56
14:13:55 <acabot> alexchadin : I saw your quick chat with vincentfrancoise, is the scope clear enough ?
14:14:11 <acabot> ok thx
14:14:26 <jed56> just after the meeting ;-)
14:14:30 <acabot> #action alexchadin update spec https://review.openstack.org/#/c/339456/ to reflect mid-cycle decisions
14:14:32 <alexchadin> thanks!
14:14:51 <acabot> https://review.openstack.org/#/c/298891/ needs reviews from core
14:15:05 <acabot> because Greg's team is ready to release the code
14:15:20 <acabot> #action jwcroppe sballe acabot review and merge https://review.openstack.org/#/c/298891/
14:15:45 <acabot> Added spec for automatic triggering audit needs a new PS
14:15:51 <acabot> #link https://review.openstack.org/#/c/342473/
14:16:17 <acabot> I dont think digambar is here
14:16:43 <acabot> #action digambar add a new PS for https://review.openstack.org/#/c/342473/
14:16:54 <acabot> Limit concurrent actions invoked by Watcher needs reviews
14:17:01 <acabot> #link https://review.openstack.org/#/c/348049/
14:17:09 <acabot> jwcroppe : is this spec ready for reviews ?
14:17:50 <acabot> watcher
14:17:58 <acabot> Add goal_id, strategy_id and host_aggregate CLI options to audit has been merged
14:18:05 <acabot> #link https://review.openstack.org/#/c/332982/
14:18:10 <jwcroppe> acabot: yes
14:18:18 <acabot> thx hvprash
14:18:25 <jwcroppe> acabot: it's ready for review
14:18:38 <acabot> jwcroppe : ok thx
14:18:41 <hvprash> thx
14:19:09 <acabot> Add Scoring Module implementation needs reviews
14:19:15 <acabot> #link https://review.openstack.org/#/c/351577/
14:19:33 <acabot> I dont think tomasz is here
14:19:50 <acabot> but he is probably waiting for reviews :-D
14:20:10 <acabot> who wants to review the scoring module ?
14:20:14 <vincentfrancoise> I will
14:20:37 <vincentfrancoise> already started bu now tomasz added tests so I will go through them
14:20:39 <jinquan-tmp> i can do it also
14:20:51 <acabot> #action vincentfrancoise jinquan-tmp review https://review.openstack.org/#/c/351577/
14:20:54 <acabot> thx
14:21:04 <acabot> Added Monasca Helper needs reviews
14:21:10 <tkaczynski> hi, sorry for being late - have problems with network
14:21:11 <acabot> #link https://review.openstack.org/#/c/348891/
14:21:26 <gzhai-mobl> i can have a look
14:21:29 <acabot> tkaczynski : no pb, is the scoring module ready for reviews ?
14:21:40 <vincentfrancoise> gzhai-mobl: thanks
14:21:41 <tkaczynski> yes, it's ready
14:21:50 <acabot> gzhai-mobl : yes I'd like to have you on Monasca
14:22:20 <acabot> #action gzhai-mobl review https://review.openstack.org/#/c/348891/
14:22:43 <acabot> tkaczynski : vincentfrancoise & jinquan will review your code, thx
14:22:59 <acabot> Added strategy ID + Action Plan syncing needs reviews to close the efficacy-indicator BP
14:23:05 <acabot> #link https://review.openstack.org/#/c/325213/
14:23:20 <acabot> hvprash : could you please take a look at this PS ?
14:23:36 <hvprash> sure
14:23:38 <tkaczynski> acabot: thanks.  I'm not working this week ad the next one, but I will be addressing all potential issues to not block the review
14:24:07 <acabot> tkaczynski : great thx, I'd like to have the scoring engine merged by August 28th
14:24:26 <acabot> #action hvprash review https://review.openstack.org/#/c/325213/
14:24:40 <tkaczynski> acabot: me too, I'll do my best to make you guys happy :)
14:24:52 <acabot> :-)
14:24:54 <vincentfrancoise> :)
14:24:59 <acabot> Add rally-jobs folder to get rally support any update since Rally additions ?
14:25:05 <jed56> :p
14:25:11 <acabot> #link https://review.openstack.org/#/c/333371/
14:25:22 <acabot> alexchadin : any update on rally support .
14:25:23 <acabot> ?
14:25:47 <alexchadin> acabot: 1 commit left to get full rally support for watcher
14:25:57 <alexchadin> 4 are already merged
14:26:36 <acabot> #info 1 commit left to get full rally support for watcher
14:26:50 <acabot> #topic Blueprint/Bug Review and Discussion
14:26:55 <alexchadin> after that I will update this PS
14:27:03 <acabot> our current milestone in Newton-3 due August 29th
14:27:10 <acabot> #link https://launchpad.net/watcher/+milestone/newton-3
14:27:33 <acabot> our 3 essentials BPs are almost done
14:28:29 <acabot> gzhai-mobl : did you start working on a spec for "Use a state machine to model Watcher objects lifecycle" ? #link https://blueprints.launchpad.net/watcher/+spec/statemachine-transition-permission
14:29:32 <acabot> Handle race condition of sync from multiple decision engines should be abandoned (mid-cycle discussion)
14:29:35 <gzhai-mobl> not yet. i am on some ceilometer task this week
14:29:37 <gzhai-mobl> i will start it soon
14:29:46 <acabot> gzhai-mobl : ok
14:30:10 <acabot> could you also abandon this change ? https://review.openstack.org/#/c/339285/
14:30:20 <acabot> gzhai-mobl : could you also abandon this change ? https://review.openstack.org/#/c/339285/
14:30:23 <gzhai-mobl> acabot: got it
14:30:39 <vincentfrancoise> acabot did you see the discussion about this on the laucnhapad bug comments section?
14:30:58 <gzhai-mobl> ok
14:31:06 <vincentfrancoise> https://bugs.launchpad.net/watcher/+bug/1598946
14:31:06 <openstack> Launchpad bug 1598946 in watcher "Initial execution of parallel engines can be racey " [Undecided,In progress] - Assigned to Zhai, Edwin (edwin-zhai)
14:31:28 <acabot> vincentfrancoise : yes we looked at it during the midcycle
14:31:45 <vincentfrancoise> ok good :)
14:31:50 <acabot> and stated that its not really a bug and we dont have to support it
14:32:12 <acabot> #action abandon the change https://review.openstack.org/#/c/339285/
14:32:25 <acabot> #action gzhai-mobl abandon the change https://review.openstack.org/#/c/339285/
14:32:56 <acabot> gzhai-mobl : any update regarding perform scalability test for watcher ?
14:33:20 <acabot> gzhai-mobl : I mean is the requirements list OK for the deployment team ?
14:33:43 <acabot> #link https://etherpad.openstack.org/p/watcher-test-environment-specifications
14:34:07 <gzhai-mobl> they confirm the configuration
14:34:39 <acabot> gzhai-mobl : ok they dont need any more details ?
14:34:50 <gzhai-mobl> they ask for the scripts
14:35:08 <acabot> for Monasca deployment ?
14:35:52 <acabot> dtardivel will be back next week and share scripts
14:36:27 <acabot> jinquan1 : resize-overload-instance needs an updated description and specs
14:36:39 <gzhai-mobl> yes. they didnt deploy monasca before
14:37:03 <gzhai-mobl> but they said it should be ok with some help from us
14:37:08 <acabot> #action dtardivel send Monasca deployment scripts with gzhai-mobl
14:37:08 <jinquan-tmp> acabot:yes, will  do
14:37:15 <jinquan-tmp> In recent weeks, mainly in the company's internal projects, so less time to invest watcher.
14:37:27 <jinquan-tmp> i will back to watcher after tommorow
14:37:30 <acabot> jinquan-tmp : midcycle outputs are clear enough ?
14:38:01 <jinquan-tmp> umm, i maybe need discuss with jed
14:38:03 <acabot> jinquan-tmp : ok no pb, do not hesitate to ask if you need more explanations
14:38:28 <jed56> jinquan-tmp: yes we can discuss today
14:38:31 <jed56> if you want
14:38:48 <gzhai-mobl> we didn't require cinder, right?
14:39:04 <jinquan-tmp> jed56, to late for me today :)
14:39:09 <jinquan-tmp> too
14:39:15 <jed56> jinquan-tmp: ah yes sorry
14:39:33 <acabot> gzhai-mobl : right, we dont need it
14:39:34 <jinquan-tmp> jed56: i will contact you next day
14:39:40 <jinquan-tmp> ok?
14:39:47 <jed56> jinquan-tmp: yes :)
14:40:01 <acabot> #topic Open discussions
14:40:02 <gzhai-mobl> acabot: ok
14:40:04 <jinquan-tmp> jed56: thank you very much !
14:40:17 <jed56> jinquan-tmp: welcome
14:40:19 <acabot> Thanks to POC [9] & bench [10] done by vincentfrancoise, we need to decide which metrics back-end we need to support in Watcher
14:40:26 <acabot> #link https://review.openstack.org/#/c/348892/
14:40:32 <acabot> #link https://pad.b-com.com/p/monasca-ceilometer-ceilosca
14:41:00 <acabot> I really want to avoid having one strategy implemented for each metrics back-end
14:41:42 <acabot> with the bench, we see that Monasca is really better than telemetry
14:41:59 <acabot> but Monasca is a nightmare to deploy in a devstack env
14:42:34 <acabot> so if we want to keep it consistent (telemetry for devstack and monasca for real deployment)
14:42:36 <hvprash> suggest ceilosca considering the performance improvements
14:42:46 <acabot> we should rely on ceilosca
14:42:55 <acabot> hvprash : exactly
14:43:08 <acabot> we have 2 problems with Ceilosca
14:43:27 <acabot> performances are poor compare to standalone Monasca
14:43:38 <acabot> and we cannot use groupby is requests
14:43:43 <acabot> s/is/in
14:44:13 <acabot> so I would suggest to share our bench results with Monasca team and see if they can improve ceilosca
14:44:23 <hvprash> +1
14:44:34 <acabot> instead of choosing between Monasca or Telemetry support
14:44:59 <hvprash> internally we were planning to go the ceilosca route
14:45:22 <vincentfrancoise> hvprash: whilst trying out ceilosca
14:45:52 <acabot> jwcroppe edleafe : any thoughts on this ?
14:46:00 <vincentfrancoise> I had some tiny behaviour differences between plain old ceilometer and ceilosca
14:46:29 <edleafe> I haven't looked into the differences. Are they significant?
14:46:40 <vincentfrancoise> one being when you don't specify a start time
14:46:45 <gzhai-mobl> which one for scalability test? monasca
14:46:46 <gzhai-mobl> ?
14:46:58 <acabot> gzhai-mobl : yes monasca
14:47:13 <acabot> edleafe : differences between telemetry and monasca ?
14:47:21 <vincentfrancoise> ceilosca will give you data starting from epoch whereas ceilometer seems to limit it to 1 mont-worth of data
14:47:43 <jwcroppe> acabot: hmm ...
14:47:52 <edleafe> acabot: yes, as well as ceilometer/ceilosca differences
14:48:00 <hvprash> vincentfrancoise, what behavior differences ? we could discuss after the meeting too. interested in knowing more.
14:48:21 <edleafe> vincentfrancoise: so if you specify a start, they are the same?
14:48:40 <vincentfrancoise> edleafe: yes
14:48:54 <vincentfrancoise> that's why I said tiny differences
14:48:59 <hvprash> ah ok
14:49:16 <vincentfrancoise> watcher strategies we not giving any start time until now
14:49:33 <vincentfrancoise> and it was working although slowly using Ceilometer
14:49:40 <edleafe> I would strive to keep the interface consistent, and work to make ceilosca as close to ceilometer as necessary
14:49:55 <edleafe> This keeps the Watcher side simple, and improves ceilosca
14:50:04 <acabot> +1
14:50:10 <vincentfrancoise> but when I switched to Ceilosca, it pretty much broke Watcher because it was returning to much data with zeros everywhere
14:50:13 <hvprash> +1
14:50:27 <jed56> edleafe: this is the idea of ceilosca but ceilosca have some drawbacks
14:51:19 <acabot> #action acabot vincentfrancoise share bench results with Monasca team and ask for possible improvements of ceilosca
14:51:21 <edleafe> vincentfrancoise: so it sounds like ceilosca still needs a lot of work
14:51:32 <vincentfrancoise> edleafe: yes that's my point
14:51:36 <edleafe> vincentfrancoise: I wouldn't mangle Watcher logic to compensate
14:51:38 <jed56> edleafe: +2
14:52:30 <acabot> I think using ceilosca give prefs as good as using ceilometer ;-)
14:52:39 <acabot> s/prefs/perfs
14:53:02 <vincentfrancoise> acabot: it was still 8 times slower
14:53:07 <edleafe> So unless you want to add a driver (translation) layer to the interface to telemetry, I'd standardize on ceilometer and help the ceilosca folks improve their product
14:53:40 <acabot> edleafe : I want to avoir the driver layer !
14:53:46 <acabot> s/avoir/avoid
14:53:56 <edleafe> acabot: yeah, so would I!
14:54:21 <acabot> ok lets try to sync with ceilosca team and see what happened
14:54:48 <acabot> any other topic to discuss in the last 5 minutes ?
14:55:30 <jwcroppe> edleafe: I agree
14:55:33 <acabot> hvprash : I will send the email for promoting you as core on watcher-specs next week
14:55:51 <hvprash> thx acabot
14:56:27 <acabot> hvprash : do you know if michaelgugino will be available next week to work on ansible scripts with dtradivel ?
14:56:54 <hvprash> i will check and confirm. i think he should be available
14:57:04 <acabot> great thx
14:57:19 <hvprash> sure
14:57:45 <acabot> ok so thank you and have a good day/night
14:58:16 <vincentfrancoise> bye
14:58:18 <hvprash> bye
14:58:19 <jed56> bye
14:58:21 <jinquan-tmp> Bye
14:58:21 <alexchadin> bye
14:58:24 <acabot> #endmeeting