09:01:52 <jed56> #startmeeting watcher
09:01:53 <openstack> Meeting started Wed Aug  3 09:01:52 2016 UTC and is due to finish in 60 minutes.  The chair is jed56. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:56 <openstack> The meeting name has been set to 'watcher'
09:02:09 <jed56> Hello
09:02:13 <alexchadin> hi
09:02:32 <diga> o/
09:02:58 <vincentfrancoise> o/
09:03:31 <jed56> Agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#08.2F03.2F2016
09:03:42 <tkaczynski> hi
09:04:12 <jed56> #topic Announcements
09:04:45 <jed56> #info I will send a mail to promote alexchadin as a watcher core contributor today
09:05:12 <hanrong> hi
09:05:19 <jed56> any other announcement ?
09:05:50 <alexchadin> some parts of watcher support in rally has been merged
09:06:19 <alexchadin> 2 patches is waiting for new PS
09:06:23 <jed56> can you share with us the links ?
09:06:29 <alexchadin> yeap, wait a sec
09:07:47 <alexchadin> https://review.openstack.org/#/q/openstack/rally+owner:%22Alexander+Chadin+%253Ca.chadin%2540servionica.ru%253E%22
09:08:09 <jed56> #info some parts of watcher support in rally has been merged
09:08:18 <jed56> #link https://review.openstack.org/#/q/openstack/rally+owner:%22Alexander+Chadin+%253Ca.chadin%2540servionica.ru%253E%22
09:08:29 <jed56> thanks
09:08:33 <jed56> #topic Review Action Items
09:08:38 <jed56> #topic watcher specs
09:09:05 <jed56> The Graph model describing virtual and physical elements in a data center blueprint has to be reviewed by the cores because the development will start soon.
09:09:21 <jed56> #info https://review.openstack.org/#/c/298891/ need to be merged
09:09:37 <jed56> #topic watcher
09:10:01 <jed56> The blueprint 'cluster-model-objects-wrapper' has been merged so we can start to develop 'Graph model' blueprint.
09:10:08 <jed56> The first part of the scoring-module has been merged and also the blueprint 'bp/persistent-audit-parameters'.
09:10:15 <jed56> Congratulations to all those who worked on these blueprints  !
09:11:15 <tkaczynski> +1 :)
09:11:23 <jed56> #info 'cluster-model-objects-wrapper' first part 'scoring-module' persistent-audit-parameters are available in the watcher trunk
09:11:42 <jed56> As we have merged many things, I would like that everybody take some time to test Watcher on his environment.
09:11:57 <diga> +1
09:12:23 <alexchadin> will do
09:12:35 <jed56> Who could take some time to test watcher ?
09:12:43 <gzhai> I'll do
09:12:58 <diga> I am trying out everything now
09:13:00 <hanrong> +1
09:13:22 <jed56> #action diga alexchadin hanrong gzhai test watcher on his own infrastructure
09:13:31 <diga> +1
09:13:40 <tkaczynski> I will also do some testing as part of testing scoring module
09:13:56 <jed56> This is better that each developer of the available watcher strategies take some time
09:14:16 <jed56> this is  the more "complex" part to evaluate right now
09:14:31 <vincentfrancoise> +1
09:14:49 <jed56> for example if alexchadin you can test https://github.com/openstack/watcher/blob/master/watcher/decision_engine/strategy/strategies/workload_stabilization.py
09:14:53 <vincentfrancoise> unit tests on strategy do not cover all possible scenarios
09:15:02 <jed56> vincentfrancoise: +2 :)
09:15:55 <alexchadin> jed56: ok, once I discuss with you audit scope a little bit later:)
09:16:06 <jed56> alexchadin: yes
09:16:19 <jed56> vincentfrancoise: has started to evaluate monasca
09:16:28 <jed56> https://review.openstack.org/#/c/348891/
09:16:37 <jed56> #info vincentfrancoise: has started to evaluate monasca
09:16:51 <jed56> vincentfrancoise: Can you share with us some results ?
09:17:11 <alexchadin> jed56: I will be full-time available since 8 august, is it okay for you?
09:17:40 <vincentfrancoise> so here is a pad that show some of the results I had while playing around with monasca: https://pad.b-com.com/p/monasca-ceilometer-ceilosca
09:17:44 <jed56> no full-time for me enough time to help you ;)
09:18:11 <gzhai> vincentfrancoise: how about current status of monasca?
09:18:21 <gzhai> Is it ok for scalability test?
09:18:26 <jed56> #link monasca evaluation results https://pad.b-com.com/p/monasca-ceilometer-ceilosca
09:18:35 <vincentfrancoise> so basically I pushed a monasca helper that will be available for strategy developers
09:18:51 <vincentfrancoise> using influxDB as storage with monasca
09:19:13 <vincentfrancoise> we can see that the metrics queries are much faster
09:19:22 <gzhai> so need change strategy's code?
09:19:26 <gzhai> It's great!
09:19:43 <vincentfrancoise> so there are 3 approaches
09:20:26 <vincentfrancoise> with the ceilometer one, it took 18s to execute the basic_consolidation strategy
09:20:59 <vincentfrancoise> but with a tweak in the query formatting I could actually reduce it down to 4 seconds
09:21:28 <vincentfrancoise> see https://review.openstack.org/#/c/348891/2/watcher/common/ceilometer_helper.py
09:21:58 <vincentfrancoise> which means that we can still use ceilometer with "acceptable" performances
09:22:19 <gzhai> i see. limit the query.
09:22:29 <vincentfrancoise> but compared to monasca, we can get down to .5 seconds with the same configuration
09:22:50 <gzhai> Fantastic!
09:23:10 <gzhai> total strategy execution time?
09:23:29 <vincentfrancoise> yes that includes the time spent building the cluster data model (nova queries)
09:23:44 <jed56> #info  performances => ceilometer 4 seconds versus monasca 0.5 seconds
09:24:35 <jed56> so, we have to decide if we keep the both ( ceilometer or monasca)
09:24:40 <jed56> because the queries are not the same
09:24:56 <vincentfrancoise> gzhai: if you look at line 11 and 12 in the pad I explain the difference
09:25:13 <vincentfrancoise> jed56: +1
09:25:28 <jed56> #info we have to decide if we maintain ceilometer and monasca in watcher
09:25:54 <gzhai> vincentfrancoise: the strategy code can handle both, right?
09:26:11 <vincentfrancoise> https://review.openstack.org/#/c/348892/ shows how much I had to change basic_consolidation to make it work using monasca
09:27:29 <jed56> I forgot to say that there is new spec https://review.openstack.org/#/c/348049/ from joe
09:27:32 <alexchadin> what is dimensions?
09:27:47 <vincentfrancoise> gzhai: yes but there is not abstraction with the 2 so the strategy will have to be explicit on whether it uses ceilometer or monasca
09:28:01 <jed56> vincentfrancoise: +2
09:28:01 <vincentfrancoise> alexchadin: dimensions are pretty much filters
09:28:28 <gzhai> we need rewrite all existed strategies for monasca?
09:28:39 <gzhai> Keep both ceilometer and Monasca copy?
09:28:45 <vincentfrancoise> if we decide to move away from ceilometer: yes
09:29:16 <vincentfrancoise> gzhai: that's a question that will have to be answered at some point
09:29:54 <vincentfrancoise> that's why I pushed the basic_consolidation updates as a [PoC]
09:30:03 <gzhai> got it. thanks.
09:30:23 <diga> jed56: can we implement the celometer & monasca both
09:30:43 <diga> I think this way, we are giving more options to the user
09:31:16 <jed56> as vincentfrancoise says this is possible but this is not easily
09:31:34 <jed56> s/easliy/easy
09:31:36 <jed56> todo
09:31:44 <diga> yes, okay
09:31:50 <vincentfrancoise> the best thing that can be done would be to add a strategy parameter asking which metrics backend to use
09:31:52 <jed56> diga: I agree the best solution is to have the boths
09:32:03 <jed56> vincentfrancoise: I agreee
09:32:09 <diga> jed56: yep
09:32:24 <jed56> #topic Blueprint/Bug
09:32:31 <jed56> https://review.openstack.org/#/c/343135/  has been merged
09:32:45 <jed56> oops, need a new patchset :)
09:33:27 <jed56> but https://review.openstack.org/#/c/342594/ has been merged
09:34:08 <jed56> any others bugs ?
09:34:17 <jed56> #topic open discussion
09:34:56 <jed56> I have not open discussion.
09:34:59 <jed56> :)
09:35:01 <diga> we have shifted meeting from 1600 UTC to now ??
09:35:14 <diga> is this the fix timing of meeting ?
09:35:27 <jed56> this is changing every week
09:35:42 <diga> alternative weeks
09:35:43 <diga> ok
09:35:47 <jed56> we meet weekly on Wednesdays at 14:00 UTC on even weeks, 9:00 UTC on odd weeks
09:36:00 <diga> okay
09:36:03 <diga> got it
09:36:21 <tkaczynski> htop
09:36:27 <jed56> 100%
09:36:29 <jed56> 100%
09:36:34 <vincentfrancoise> :D
09:36:43 <tkaczynski> sorry guys, wrong window :)
09:36:52 <jed56> bye
09:36:55 <diga> hahah
09:36:58 <diga> bye
09:37:01 <jed56> logout
09:37:05 <tkaczynski> bye
09:37:09 <jed56> #endmeeting