14:00:54 <jed56> #startmeeting watcher
14:00:55 <openstack> Meeting started Wed Jul 27 14:00:54 2016 UTC and is due to finish in 60 minutes.  The chair is jed56. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:58 <openstack> The meeting name has been set to 'watcher'
14:01:07 <jed56> hi everybody
14:01:14 <vincentfrancoise> o/
14:01:57 <jed56> woah
14:03:08 <jed56> many peoples!
14:03:27 <jed56> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#04.2F06.2F2016
14:03:34 <jed56> #topic Announcements
14:03:40 <vincentfrancoise> seems like everyone is on holiday :)
14:03:54 <jed56> #info our talks are open to votes
14:04:03 <jed56> We submitted 6 talks, this is great !
14:04:06 <hvprash> Hi
14:04:08 <jwcroppe> Hi
14:04:14 <gzhai-mobl> hi
14:04:22 <jed56> This is the list of presentations
14:04:31 <jed56> Watcher, the Infrastructure Optimization service for OpenStack: Plans for the O-release and beyond with Susanne Balle, Charlotte, Taylor Peoples
14:04:33 <sballe_> Hi
14:04:41 <jed56> Optimizing Cloud Resources leveraging OpenStack Watcher with Prashanth Hari
14:04:41 <jed56> Susanne Balle, Sameer Adhikari
14:04:49 <jwcroppe> o/
14:04:49 <jed56> Automatic network efficiency adjustment to optimize power saving
14:04:49 <jed56> David Slama,Tal Anker, Joe Cropper
14:04:54 <jed56> Installing Watcher and demo of a Watcher optimization with Vincent francoise, David TARDIVEL Gang Zhai
14:05:01 <jed56> Towards to an Intelligent Cloud Gang Zhai, Susanne Balle
14:05:08 <jed56> Balance workloads for optimal performance with Watcher Vincent Mahe, Ananth Narayan Sankaranarayanan
14:05:23 <jed56> so please vote for us ;)
14:05:25 <jed56> #link https://www.openstack.org/summit/barcelona-2016/vote-for-speakers/presentation/15931/?q=Watcher
14:05:42 <sballe_> +1
14:06:34 <jed56> #info The mascot for watcher is a jellyfish (mid-cycle)
14:06:54 <jed56> The watcher mid-cycle was a great meeting, thanks everybody !
14:07:03 <sballe_> Is that settled ? The jellyfish
14:07:18 <sballe_> We gave them 3 proposals
14:07:41 <jed56> I'm not sure
14:07:47 <jed56> this is the winner of our pool
14:07:49 <jed56> poll
14:08:12 <jed56> we will need to wait acabot to have this information
14:08:13 <sballe_> Yeah I hope for the jelly fish
14:08:33 <michaelgugino> hello all
14:08:33 <jed56> The etherpad of the meeting is available here : https://etherpad.openstack.org/p/newton-watcher-midcycle
14:09:03 <jwcroppe> jellyfish ... +100000  :)
14:09:09 <sballe_> Lol
14:09:20 <jed56> jwcroppe: ;-)
14:09:24 <hvprash> :)
14:09:58 <jed56> jwcroppe: :)
14:10:12 <jed56> jwcroppe: can you share with us your meeting with nova
14:10:34 <jwcroppe> yes, there was a lot of discussion on the watcher use cases
14:11:44 <jwcroppe> jaypipes was in favor of opening up a placement API that would, given an instance ID, would return the resource providers (from which you could determine the hosts) that satisfied the request spec
14:12:06 <jed56> jwcroppe: every possible hosts ?
14:12:32 <jwcroppe> yes (possibly there could be some item to pass in that would limit the # of return results)
14:12:43 <jed56> ok
14:12:53 <jwcroppe> but there were also some others that had other ideas of having nova support a general weighing function...
14:13:14 <jwcroppe> and then the nova placement API would just return the top-ranked one that satisfied the request spec
14:13:39 <jed56> do you know how nova will decided to rank the list ?
14:13:49 <jwcroppe> but... there was concern that having external parties (e.g., Watcher) having to constantly update the weights for the resources would overwhelm the placement API
14:14:40 <jwcroppe> So those were essentially the two ideas - I think more discussion is needed to reach consensus
14:15:27 <jed56> what are the next actions ? do we need to write a backlog spec ?
14:17:23 <jwcroppe> not yet, I want to talk with Jay a bit more...
14:17:54 <jed56> #action jwcroppe talk to Jay Pipes
14:17:55 <jed56> :)
14:17:56 <jwcroppe> the problem is understood and there are two very different ideas about how to solve the prob
14:18:51 <vincentfrancoise> at least that's a start :)
14:18:52 <jwcroppe> and the new placement APIs they're discussing are still to-be-created as well (maybe edleafe can tell us more about those)
14:19:29 <jed56> edleafe: are you here ? :)
14:19:57 <jed56> ok let's continue
14:20:23 <jed56> #action jwcroppe jed56 talk to edleafe Placement APIs nova
14:21:01 <jed56> vincentfrancoise: yes this is the first step
14:21:04 <jed56> quick update regarding newton-3
14:21:17 <jed56> #info : 8 BPs en 12 bugs are targeted for newton-3
14:21:26 <jed56> this is great
14:21:54 <jed56> https://launchpad.net/watcher/+milestone/newton-3
14:22:17 <jed56> any other announcement ?
14:23:21 <jed56> #topic Review Action Items
14:24:12 <jed56> The spec “Graph model describing virtual and physical elements in a data center” need to be merged as soon as possible because the development will start soon.
14:24:26 <jed56> #link https://review.openstack.org/#/c/298891/
14:24:27 <sballe_> Ok I will review
14:24:48 <jed56> #action sballe_ jed56 review https://review.openstack.org/#/c/298891/
14:24:49 <hvprash> +1
14:26:38 <jed56> The update define-the-audit-scope (https://review.openstack.org/#/c/339456/) spec need to be overhaul
14:27:07 <jed56> We will only need to filter by AvaibilityZone and aggregatehost
14:27:09 <jwcroppe> I'm also working on the limit-concurrent-actions spec and will have it ready by Fri
14:27:52 <jed56> #action alexchadin "define-the-audit-scope" aggregatehost and avaibilityzone
14:28:22 <jed56> jwcroppe: cool
14:28:36 <jed56> jwcroppe: do you  know that this is not possible for now in watcher to have concurrent actions ?
14:28:56 <jed56> we need to implement https://blueprints.launchpad.net/watcher/+spec/planner-storage-action-plan
14:28:58 <jed56> first
14:29:19 <jwcroppe> ok, we can keep as a backlog spec if we need as well
14:29:45 <jed56> yes ! jinquan want to work this blueprint
14:29:58 <jed56> on
14:30:04 <sballe_> Cool
14:30:04 <jwcroppe> I'll still write up the spec for limit-concurrent-actions
14:30:19 <jed56> jwcroppe: yes this is important feature for watcher
14:30:30 <jed56> jwcroppe: can you create a blueprint ?
14:30:42 <jwcroppe> I did
14:30:55 <jwcroppe> https://blueprints.launchpad.net/watcher/+spec/limit-concurrent-actions
14:30:56 <jed56> #action jwcroppe create a blueprint regarding limit-concurrent-actions
14:31:05 <jed56> sorrry :)
14:31:10 <jwcroppe> no prob :)
14:31:41 <jed56> the spec "automatic triggering audit" => https://review.openstack.org/#/c/342473/ need a new patchset
14:32:06 <jed56> #action diga update the spec https://review.openstack.org/#/c/342473/
14:32:48 <jed56> so now, watcher
14:33:10 <jed56> I would like that the 'cluster-model-objects-wrapper ' and 'scoring-module'  blueprints to be merged before the 3 of august.
14:33:18 <jed56> The cluster-model-objects-wrapper blueprint is on the critical path for 'graph-based-cluster-model' blueprint.
14:33:26 <jed56> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/cluster-model-objects-wrapper
14:33:33 <jed56> #link https://review.openstack.org/#/q/status:open+topic:bp/scoring-module
14:33:39 <jed56> Who could take some time to look at that in priority, please ?
14:34:19 <hvprash> jed56, i can take a look
14:34:46 <sballe_> I can look to
14:34:54 <hanrong1> +1
14:34:55 <jed56> #action sballe_ hvprash review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/cluster-model-objects-wrapper and https://review.openstack.org/#/q/status:open+topic:bp/scoring-module
14:34:58 <danpawlik> +1
14:35:18 <sballe_> I have some time now because I go on vacation Fri
14:35:39 <jed56> #action danpawlik hanrong1 review https://review.openstack.org/#/q/status:open+topic:bp/scoring-module https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/cluster-model-objects-wrapper
14:35:43 <jed56> thanks a lot
14:35:49 <hanrong1> ok
14:36:42 <vincentfrancoise> I need to rebase cluster-model-objects-wrapper <https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/cluster-model-objects-wrapper> due to the recent merges but please do review it :)
14:37:26 <jed56> Add goal_id, strategy_id and host_aggregate CLI options to audit https://review.openstack.org/#/c/332982/ need a new patchset
14:37:38 <hvprash> jed56, working on it today
14:37:55 <jed56> hvprash: super!
14:37:57 <hvprash> there is one unit test i missed and will add to the PS
14:38:09 <vincentfrancoise> good :)
14:38:10 <hvprash> there is also the changes which michaelgugino is working https://review.openstack.org/#/c/330165/
14:38:13 <jed56> #action hvprash push a new patchset 332982
14:38:14 <sballe_> I can review
14:38:15 <hvprash> which is critical
14:38:42 <hvprash> thx
14:38:52 <jed56> okay
14:39:07 <gzhai-mobl> i can revie
14:39:30 <sballe_> gzhai-mobl: cool
14:39:36 <jed56> #action gzhai-mobl review https://review.openstack.org/#/q/status:open+topic:bp/scoring-module https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/cluster-model-objects-wrapper
14:39:36 <gzhai-mobl> w
14:40:16 <jed56> https://review.openstack.org/#/c/330165/ Implement goal_id, strategy_id and host_aggregate into Audit api need a new patchset
14:40:40 <jed56> this is almost finish
14:41:05 <jed56> michaelgugino: do you think that you will have time to work on it ?
14:41:06 <hvprash> yes
14:41:32 <jed56> okay great
14:41:34 <jed56> #action michaelgugino push a new patchset https://review.openstack.org/#/c/330165/
14:41:41 <michaelgugino> yes, I'm working on it.  I will continue to make changes based on people's reviews
14:41:53 <jed56> michaelgugino: thanks a lot
14:41:55 <hvprash> thx michaelgugino
14:41:57 <michaelgugino> yw
14:42:26 <vincentfrancoise> michaelgugino: do you have a devstack to make sure the integration tests are passing ?
14:43:12 <michaelgugino> not at the moment, I will build one today.
14:43:19 <hvprash> i tested the cli options against the api changes michaelgugino is working and works as expected
14:43:37 <vincentfrancoise> michaelgugino: ok cool :)
14:44:00 <jed56> Add rally-jobs folder to get rally support(https://review.openstack.org/#/c/333371/) patchset need a status
14:44:41 <jed56> #action alexchadin can you give a us a feedback regarding https://review.openstack.org/#/c/333371/ ?
14:45:02 <jed56> https://review.openstack.org/#/c/345214/ need a new patchset
14:46:01 <jed56> #action vincentfrancoise rebase 345214
14:46:51 <jed56> sballe_: do you know if junjie.huang plan to work on https://review.openstack.org/#/c/342594/ ?
14:47:20 <sballe_> Not sure I thought we decided not to move forward with it for now
14:47:31 <sballe_> Is this the airflow one?
14:47:45 <gzhai-mobl> i  will ping him
14:47:52 <sballe_> Ok
14:47:55 <sballe_> Thx
14:48:25 <jed56> #action gzhai-mobl contact junjie.huang in order to have status on https://review.openstack.org/#/c/342594/
14:48:28 <gzhai-mobl> he is waiting for the ci error got fixed
14:48:54 <sballe_> Ok so junjie will finish it?
14:49:05 <sballe_> gzhai-mobl: ^^^
14:49:09 <jed56> what is the problem with the CI ?
14:49:12 <gzhai-mobl> should do
14:49:18 <sballe_> ok thx
14:49:35 <jed56> IMHO, this is not a CI problem
14:49:55 <gzhai-mobl> some generic error tha
14:50:02 <gzhai-mobl> t time
14:50:18 <jed56> gzhai-mobl: can you rebase the code of junjie ?
14:51:17 <jed56> #action gzhai-mobl rebase https://review.openstack.org/#/c/342594
14:51:28 <gzhai-mobl> i will ask him
14:51:42 <sballe_> jed56: I ll follow up with junjie as well
14:52:19 <jed56> okay
14:52:46 <jed56> #action sballe_ follow https://review.openstack.org/#/c/342594
14:52:58 <jed56> #topic Blueprint/Bug
14:53:09 <jed56> Many bugs have been merged in newton-2 thanks to everybody!
14:53:40 <sballe_> Cool
14:53:46 <jed56> #topic open discussion
14:53:59 <jed56> some body want to discuss something ? :)
14:54:15 <hvprash> would like to start planning for the workload qos. sballe_ do you have sometime before vacation ?
14:54:35 <sballe_> Yes let's talk today or tomorrow
14:54:55 <hvprash> cool, thx
14:54:56 <sballe_> Plus I can IRC while on vacation since you are on the east coast
14:55:11 <sballe_> Only 6 hrs difference
14:55:15 <hvprash> that works too ! but don't want to bother while you are in vacation :)
14:55:17 <jed56> #action sballe_ hvprash  start planning for the workload qos
14:55:53 <sballe_> hvprash: no worries
14:56:50 <jed56> Can I close the meeting ?
14:57:10 <vincentfrancoise> I guess so :)
14:57:18 <hvprash> sure :)
14:57:25 <gzhai-mobl> bye
14:57:32 <hvprash> thx jed56
14:57:33 <jed56> thanks everybody have a nice week !
14:57:34 <vincentfrancoise> bye
14:57:38 <jed56> #endmeeting