08:59:50 <acabot> #startmeeting watcher
08:59:51 <openstack> Meeting started Wed Jul  6 08:59:50 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:59:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:59:54 <openstack> The meeting name has been set to 'watcher'
08:59:57 <acabot> hi
09:00:27 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#07.2F05.2F2016
09:01:19 <vincentfrancoise> o/
09:01:40 <dtardivel> hi
09:01:45 <jinquan> o/
09:01:47 <gzhai2> hi
09:01:58 <acabot> hi
09:02:04 <ostroverkhov> o/
09:02:22 <gzhai2> jinquan: Not come for China bugsmash?
09:02:42 <jinquan> gzhai2: no, :(
09:02:47 <acabot> #topic Announcements
09:03:01 <acabot> #info last week to complete talk descriptions for the summit, we need 2 more speakers and description updates
09:03:13 <acabot> #link https://etherpad.openstack.org/p/Watcher_abstracts_barcelona2016
09:03:23 <acabot> who plans to be in Barcelona ?
09:04:45 <jwcroppe> bonjour
09:04:58 <acabot> our next meeting will be the last time to join us as a speaker
09:04:58 <dtardivel> jwcroppe: bonjour :)
09:05:38 <acabot> jinquan : do you plan to come to spain ?
09:06:05 <jinquan> acabot:currently , no idea
09:06:22 <acabot> ok, did you receive an ATC pass ?
09:06:38 <jwcroppe> acabot: 2.30 pm in India, so easy time to make today :)
09:06:39 <jinquan> hanrong may be  go
09:06:44 <acabot> ok
09:07:08 <acabot> hanrong : do not hesitate to add yourself as a speaker, you will get a free pass
09:07:54 <jinquan> acabot: we will discuss about this after irc meeting
09:08:10 <jinquan> then we will give your the result, ok?
09:08:14 <acabot> ok
09:08:29 <acabot> #info mid-cycle agenda is open for additions / sync with Nova team in progress
09:08:41 <acabot> #link https://etherpad.openstack.org/p/newton-watcher-midcycle
09:09:08 <acabot> jwcroppe : please add any items you would like to discuss on IBM side
09:09:14 <jwcroppe> #info Gave a session on Watcher in Bangalore earlier this week - told folks development/tests/etc. all welcomed
09:09:32 <acabot> jwcroppe : great thx
09:09:53 <acabot> jwcroppe : IBM internal session ?
09:10:21 <jwcroppe> acabot : yes, probably 100 people in attendance
09:10:28 <acabot> good
09:10:45 <acabot> #info dtardivel has tested Watcher debian packages
09:11:07 <acabot> dtardivel : do we need a doc update regarding packages ?
09:11:08 <dtardivel> yes I tested them with a Docker container debian:experimental image
09:11:29 <dtardivel> acabot: yes I pushed a new changeset this morning
09:11:35 <acabot> ok thx
09:12:01 <jwcroppe> o/
09:12:17 <acabot> any other announcement ?
09:12:33 <jwcroppe> nothing here - next topic?
09:12:43 <acabot> #topic Review Action Items
09:13:18 <acabot> first of all, as it will be a release week next week, we need more reviewers than usual
09:13:45 <jwcroppe> acabot: +1
09:13:48 <acabot> we need to close as many blueprints as possible before EOW
09:14:01 <acabot> watcher specs
09:14:06 <tkaczynski> I'm happy to help with that
09:14:10 <acabot> Make default Planner generic needs reviews
09:14:21 <acabot> #link https://review.openstack.org/#/c/337049/
09:14:24 <jwcroppe> reading now - has a -1 currently
09:14:46 <acabot> #action jed56 add a new PS for https://review.openstack.org/#/c/337049/
09:14:53 <vincentfrancoise> I plan on spending most of the afternoon reviewing
09:14:58 <dtardivel> I can review it as well
09:15:24 <gzhai2> I can have a look
09:15:50 <jinquan> vincentfrancoise: the function code are ready , i will push a patch   after the spec merge
09:16:09 <acabot> vincentfrancoise dtardivel gzhai2 : I would prefer to have your contributions on code reviewing
09:16:27 <acabot> as theses specs are not related to newton-2
09:16:57 <dtardivel> acabot: ok
09:16:57 <vincentfrancoise> acabot: ok
09:17:01 <acabot> jinquan : if the code is ready, please push it for review, you dont have to wait for the final spec
09:17:08 <gzhai2> acabot: No problem.
09:17:24 <jinquan> acabot:oh, i see, ok
09:17:26 <vincentfrancoise> acabot: +1
09:17:42 <gzhai2> acabot: I'm in China openstack bug smash, so need some time for bug fixing.
09:17:42 <acabot> #action jinquan submit code for https://review.openstack.org/#/c/337049/
09:18:04 <acabot> Graph model describing virtual and physical elements in a data center & Consolidation of multiple Action-plans into a single one need reviews
09:18:22 <acabot> but again they are not related to newton-2 so low priority
09:18:30 <acabot> moving to watcher
09:18:38 <acabot> Enable strategy parameters has been merged
09:18:54 <acabot> #link https://review.openstack.org/#/c/297556/
09:18:54 <gzhai2> Thanks for vincent and david's review!
09:19:03 <acabot> thx gzhai2 for your patience ;-)
09:19:22 <acabot> Add continuously optimization needs reviews from core
09:19:31 <acabot> #link https://review.openstack.org/#/c/321411/
09:19:32 <dtardivel> acabot: this is a great discussion about the option to use on CLI side for parameters :)
09:20:02 <acabot> oh yes parameter name...
09:20:11 <dtardivel> gzhai2: proposed -m, --parameters in this changeset, because -p and -P are already used.
09:20:26 <gzhai2> -p is used by period in future:)
09:20:50 <acabot> why -m then ?
09:20:50 <gzhai2> capital options are mostly used by openstack system
09:20:51 <dtardivel> acabot: -p option is used for now for continuous audit feature: --period.
09:20:59 <gzhai2> ParaMeter
09:21:08 <acabot> gzhai2 : lol
09:21:23 <vincentfrancoise> IMHO -p should be used by --parameter whereas period can be renamed -i --interval
09:21:38 <acabot> vincentfrancoise : +1
09:21:57 <vincentfrancoise> it would make much more sense
09:22:00 <dtardivel> gzhai2: Question: could we change -p, --period to -i, --interval in continuous audit feature, and -p, --parameter in audit parameter feature ?
09:22:20 <gzhai2> dtardivel: yes!
09:22:27 <vincentfrancoise> good :)
09:22:43 <dtardivel> gzhai2: yes !!!
09:22:54 <acabot> ok can we do it quickly to avoid merge conflict before friday ?
09:22:55 <gzhai2> Then I'll update with '-p'
09:22:58 <alexchadin> hi guys
09:23:08 <alexchadin> sorry for being late
09:23:18 <vincentfrancoise> alexchadin: hi
09:23:19 <jinquan> alexchadin: hi
09:23:22 <gzhai2> acabot: I can quickly update my 2 PS: cli and doc
09:23:27 <gzhai2> alexchadin:hi
09:23:37 <tkaczynski> alexchadin: hi!
09:23:45 <dtardivel> ostroverkhov: alexchadin could you update your code to use -i, --interval option instead of -p, --period one ?
09:24:03 <jwcroppe> speaking of CLI, will we integrate w/ the openstack CLI ?
09:24:14 <acabot> #action gzhai2 update parameter name as -p
09:24:32 <tkaczynski> jwcroppe: didn't we integrate already?
09:24:53 <vincentfrancoise> jwcroppe: yes the watcher command is also an openstack CLI one
09:24:54 <acabot> #action ostroverkhov update interval option as -i instead of -p
09:24:59 <jwcroppe> if we did, I missed that - ahh cool
09:25:03 <gzhai2> jwcroppe: it is parsed by well-known options first(almost all capital option), then our wathcer parser
09:25:21 <acabot> jwcroppe : yes donc already
09:25:27 <acabot> s/donc/done
09:25:29 <jwcroppe> cool
09:25:52 <gzhai2> openstack command is already in watcher docs
09:26:03 <ostroverkhov> dtardivel: yes, i'll update my code
09:26:14 <acabot> #action dtardivel jed56 vincentfrancoise gzhai2 tpeoples review https://review.openstack.org/#/c/321411/ by EOW
09:26:19 <tkaczynski> jwcroppe: "openstack optimize == watcher" is the command I believe
09:26:45 <dtardivel> tkaczynski: +1
09:26:45 <acabot> tkaczynski : thats right
09:26:49 <vincentfrancoise> tkaczynski: yep
09:27:05 <acabot> Add policies for API access control to watcher project needs more unit tests
09:27:07 <jwcroppe> cool
09:27:19 <acabot> #link https://review.openstack.org/#/c/334163/
09:27:33 <tkaczynski> btw: I also have some changes coming in watcher CLI (in review). do I need to do anything to integrate with openstack CLI or will it happen automatically?
09:27:56 <dtardivel> acabot: hanrong pushed a new patch this morning. But some gate jobs failed....
09:28:12 <acabot> hanrong : can you look at it ?
09:28:47 * acabot seems like hanrong is not here...
09:29:00 <jinquan> she is here
09:29:04 <vincentfrancoise> tkaczynski: basically all command are registered both against the openstack CLI and the watcher CLI so if you update one the other is for free :)
09:29:10 <hanrong> acabot: yes, I am doing it.
09:29:25 <acabot> #action hanrong fix gate jobs on https://review.openstack.org/#/c/334163/
09:29:25 <tkaczynski> vincentfrancoise: +2 :)
09:29:41 <acabot> #action dtardivel jed56 vincentfrancoise gzhai2 tpeoples review https://review.openstack.org/#/c/334163/ by EOW
09:30:09 <acabot> Uniform Airflow migration strategy implementation needs final review from core
09:30:18 <acabot> #link https://review.openstack.org/#/c/324169/
09:30:30 <acabot> #action dtardivel jed56 vincentfrancoise gzhai2 tpeoples review https://review.openstack.org/#/c/324169/ by EOW
09:31:32 <acabot> watcher CLI
09:31:48 <acabot> we already talked about parameter name
09:31:59 <tkaczynski> acabot: do we plan to merge 2 reviews for scoring module? 1 for watcher, 1 for watcher CLI
09:32:40 <acabot> tkaczynski : as scoring engine is now newton-3, I dont ask for reviews
09:33:09 <acabot> tkaczynski : we need to focus on code reviewing for newton-2 as the release is next week
09:33:44 <acabot> Watcher dashboard
09:33:56 <acabot> Add support continuously-optimization needs reviews
09:34:05 <acabot> #link https://review.openstack.org/#/c/327095/
09:34:15 <acabot> will be merged with https://review.openstack.org/#/c/321411/
09:34:45 <acabot> we planned to add global requirements to watcher-dashboard, anyone wants to do that ?
09:35:11 <alexchadin> I've added python-watcherclient to global-requirements
09:35:18 <dtardivel> acabot: I already push a changeset about global requirement for dashboard
09:35:22 <dtardivel> pushed
09:35:29 <acabot> dtardivel : link ?
09:35:41 <dtardivel> #link https://review.openstack.org/#/c/337585/
09:36:10 <acabot> ok I missed this one
09:36:30 <acabot> dtardivel : thx
09:36:35 <dtardivel> acabot: I will propose a new patchset this afternoon to resolve failures
09:37:04 <acabot> #action dtardivel fix issues on https://review.openstack.org/#/c/337585/
09:37:17 <acabot> #topic Blueprint/Bug Review and Discussion
09:37:44 <acabot> #link https://launchpad.net/watcher/+milestone/newton-2
09:37:52 <acabot> 4 BPs are still in review
09:38:18 <acabot> and I would suggest to have things merged before friday EOD
09:38:55 <acabot> then we will have 2 days for testing next week and then submit the release
09:39:15 <gzhai2> tight schedule:)
09:39:28 <acabot> does anyone expect his BP to not met the deadline of friday EOD ?
09:40:00 <acabot> again, we need core reviewers contribs
09:40:17 <acabot> jwcroppe : is tpeoples back ?
09:41:14 <jwcroppe> acabot: I've been in India for 2 weeks so I haven't talked with him.  Has he been on IRC?
09:41:43 <acabot> jwcroppe : not for our last 4 meetings I would say
09:41:59 <jwcroppe> acabot: ok, I'll drop him a note.  He may be on vacation with the US holiday
09:42:13 <acabot> #action acabot move triaged bugs to Newton-3
09:42:30 <acabot> jwcroppe : does he plan to join the mid-cycle ?
09:43:46 <acabot> #topic Open Discussion
09:43:55 <acabot> How to deal with packaging (puppet) when updating conf parameters ?
09:44:01 <jwcroppe> acabot: he will be there
09:44:13 <acabot> vincentfrancoise : did you ask danpawlik about it ?
09:44:24 <acabot> jwcroppe : ok good
09:44:29 <alexchadin> I'd like to discuss defining audit scope with someone
09:44:36 <vincentfrancoise> yes after last meeting I asked him about it
09:45:06 <vincentfrancoise> And basically there isn't any special kind of process
09:45:25 <vincentfrancoise> but the norm on other projects is to reference changing config options in the specs
09:45:50 <diga> hi
09:45:58 <diga> sorry for joining late
09:46:08 <jinquan> diga:hi
09:46:15 <vincentfrancoise> but they also create bugs on their puppet repo to notify that new configuration options should be handled
09:46:25 <diga> jinquan: hi
09:46:29 <acabot> ok we need to be carefull about packaging when writing specs
09:46:58 <vincentfrancoise> yep that's the thing, because it's a completely manual process
09:47:03 <acabot> ok
09:47:13 <jwcroppe> alexchadin: we can discuss audit scope sometime
09:47:19 <acabot> alexchadin : what about audit scope ?
09:47:23 <dtardivel> acabot: vincentfrancoise: I think we have to update section "Other deployer impact" to notify puppet impacts
09:47:27 <diga> I need help on testcase, every test has got successful result at my server but when I push to gerrit, it fails
09:48:03 <diga> https://review.openstack.org/#/c/336390/
09:48:39 <vincentfrancoise> dtardivel: +1
09:48:51 <alexchadin> In spec Vincent Mahe proposed to write BP to Heat to know whether we can work with specified resource types or not
09:49:12 <alexchadin> Found out it this morning: http://developer.openstack.org/api-ref-orchestration-v1.html#resource_type_get
09:49:26 <vincentfrancoise> diga: we can discuss this on #openstack-watcher just after the meeting if you want
09:49:30 <dtardivel> diga: gate-watcher-python35-nv is non voting. It will not impact the merging of your changeset
09:49:46 <diga> dtardivel: okay
09:49:54 <diga> vincentfrancoise: sure
09:50:48 <vincentfrancoise> diga: actually what dtardivel is true, to not mind the python35 tests for now
09:50:50 <acabot> alexchadin : I need to look at this spec again, it was a long time ago ;-)
09:51:23 <jwcroppe> alexchadin: I think we'd want to align with the resource types where appropriate
09:51:27 <alexchadin> IMHO to check whether resource is alive or not we have to use our clients module
09:51:30 <diga> vincentfrancoise: dtardivel : thank you! we can merge the patch :)
09:51:33 <alexchadin> acabot: I understand :)
09:51:41 <jwcroppe> e.g., OS::Nova::Server
09:52:00 <dtardivel> diga: gate-watcher-python35-nv is a new gate job push by openstack-infra, not stable for now
09:52:10 <diga> dtardivel: okay, got it
09:53:24 <acabot> anything else to discuss ?
09:53:40 <gzhai-mobl> db migration
09:53:43 <alexchadin> jwcroppe: we can use "Show resource schema" API method to make sure we can work with this type
09:54:10 <jwcroppe> API from which service?
09:54:21 <alexchadin> jwcroppe: from Heat
09:54:29 <alexchadin> jwcroppe: after that we have to check if proposed resources are alive
09:54:36 <gzhai-mobl> if db schsma changes, need migration with alembic?
09:54:53 <alexchadin> jwcroppe: it can be done through the watcher's clients module
09:55:00 <diga> acabot: I want to work on BP, do we any BP I can start or contribute
09:55:19 <jwcroppe> but do we want to have a dep on Heat for audit scope?
09:55:42 <acabot> diga : actually I did not prioritize BPs right know as we have our mid-cycle in 10 days
09:55:45 <alexchadin> jwcroppe: IMHO I wouldn't want to
09:55:52 <jwcroppe> me either
09:56:12 <alexchadin> jwcroppe: there is another way: we can use keystone to get service list
09:56:12 <diga> acabot: ohh...kk
09:56:32 <diga> acabot: is there any possibility I can join the mid-cycle remotely
09:56:36 <acabot> diga : I think this one https://blueprints.launchpad.net/watcher/+spec/automatic-triggering-audit
09:56:48 <alexchadin> jwcroppe: but there is only service names, not list of service's resources
09:56:53 <diga> acabot: okay, I will go through it
09:57:09 <acabot> diga : will be quite easy to implement strating next week
09:57:18 <jwcroppe> alexchadin: IMO we wouldn't want to use Heat APIs - my thought was that in the template you'd specify a list of the resource types to which you want audit to apply
09:57:19 <alexchadin> jwcroppe: for example, we can't be sure if nova firewall is available
09:57:25 <diga> acabot: okay
09:57:48 <acabot> diga : if you want to join remotely, please complete https://pad.b-com.com/p/watcher-open-meetings with your availability time
09:58:08 <diga> acabot: I will start on that BP, sure
09:58:52 <acabot> tkaczinsky : as you will also be remote, can you add your availabilty in https://pad.b-com.com/p/watcher-open-meetings ?
09:59:04 <jwcroppe> alexchadin: then we don't need to talk to Heat at all for audit scopes
09:59:08 <alexchadin> jwcroppe: Yes, after we have specified a list of resources it should be checked
09:59:19 <acabot> diga : please assign it to yourself if you start working on it
09:59:22 <alexchadin> jwcroppe: I agree
09:59:36 <diga> acabot: sure, thank you!
09:59:42 <acabot> time to end the meeting
09:59:46 <acabot> thank you guys
09:59:51 <acabot> have a good day/night
09:59:59 <alexchadin> bye
10:00:02 <jinquan> :) bye
10:00:06 <acabot> #endmeeting