14:01:22 <acabot> #startmeeting watcher
14:01:23 <openstack> Meeting started Wed Jun 29 14:01:22 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:27 <openstack> The meeting name has been set to 'watcher'
14:01:28 <acabot> hi
14:01:31 <sballe_> o/
14:01:35 <jinquan1> hi
14:01:46 <diga> hi
14:01:52 <gzhai2> hi
14:01:56 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#06.2F29.2F2016
14:01:56 <hanrong1> hi
14:02:04 <jed56> hi
14:02:04 <dtardivel> hi
14:02:11 <edleafe> \o
14:02:14 <vincentfrancoise> o/
14:02:16 <hvprash> hi
14:02:18 <tkaczynski> hi
14:02:34 <acabot> #topic Announcements
14:03:00 <sballe_> One more person joined the meetup: Digambar Patil
14:03:15 <jed56> welcome
14:03:29 <acabot> welcome Digambar
14:03:34 <jinquan1> +1
14:03:35 <gzhai2> welcome
14:03:37 <sballe_> +1
14:03:38 <hvprash> welcome
14:03:56 <acabot> working for Intel ?
14:04:00 <sballe_> no
14:04:06 <vincentfrancoise> welcome
14:04:12 <sballe_> I am assuming it is diga
14:04:31 <sballe_> diga: who are you working for?
14:04:33 <diga> thanks acabot
14:04:38 <diga> Persistent
14:04:46 <sballe_> cool!
14:04:51 <diga> sballe_: My name is Digambar
14:04:53 <diga> :)
14:05:07 <acabot> thx for the intro
14:05:23 <diga> Thank you all
14:05:33 <sballe_> diga: Yes i know. I was refering to your IRC nickname
14:05:46 <diga> sballe_: yep :)
14:05:46 <acabot> #info Watcher packages are available for Red Hat & Debian
14:06:11 <gzhai2> Good news!
14:06:20 <acabot> so danpawlik working on puppet packaging managed to have watcher packages for RDO & Debian (experimental)
14:06:41 <michaelgugino> where are the packages being hosted?
14:06:43 <acabot> should we update our user doc to mention these packages ?
14:07:01 <acabot> michaelgugino : https://packages.debian.org/experimental/python-watcherclient for deban
14:07:27 <vincentfrancoise> acabot: I would say yes
14:07:45 <vincentfrancoise> we currently have a "Installing from Source" and a "Installing from packages: PyPI"
14:08:02 <jed56> +1
14:08:05 <acabot> ok lets create a a new section for it
14:08:10 <vincentfrancoise> so that would seem kind of logic to add a "Installing from packages: Debian" and so son
14:08:11 <sballe_> +1
14:08:21 <vincentfrancoise> s/son/on
14:08:31 <acabot> #action vincentfrancoise add a section "installing from packages" in user guide
14:08:34 <gzhai2> Do we need check debian/redhat doc for watcher?
14:09:04 <acabot> gzhai2 : what do you mean ?
14:09:23 <gzhai2> debian/redhat should have their own openstack doc.
14:09:32 <jed56> gzhai2: yes it a good idea to check the doc with the packages
14:09:35 <gzhai2> install from rpm, and how to config it.
14:10:10 <acabot> anyone wants to test packages ?
14:10:13 <sballe_> what version of RDO and debian is Watcher included in?
14:10:30 <dtardivel> acabot: I can test Debian ones
14:10:40 <acabot> sballe_ : its not included...its available
14:10:53 <jed56> 0.27
14:11:10 <acabot> #action dtardivel test Watcher debian packages and update the install doc if needed
14:11:17 <jed56> 0.26 sorry
14:11:21 <gzhai2> I can try redhat
14:11:39 <acabot> actually I since Debian has 0.27 & RDO 0.26 :-)
14:11:40 <dtardivel> jed56: watcher : python-watcher (0.27.0-2)
14:11:53 <jed56> ah yes :p
14:12:05 <acabot> yes this is because RDO wants final release so 0.26
14:12:38 <acabot> #info 2 weeks away from submission deadline, please register as speakers in , we also need to complete descriptions
14:12:47 <acabot> #link https://etherpad.openstack.org/p/Watcher_abstracts_barcelona2016
14:12:58 <sballe_> acabot: I will work on the abstracts this week.
14:13:00 <acabot> I would like to have 3 speakers for each presentation
14:13:06 <sballe_> +1
14:13:33 <hvprash> thx for reminding. will update it
14:13:36 <acabot> #action sballe_ work on the abstracts for Barcelona summit
14:13:37 <sballe_> https://etherpad.openstack.org/p/Watcher_abstracts_barcelona2016
14:13:44 <acabot> sballe_ : thx
14:14:24 <acabot> dont forget that if the presentation is accepted, every speaker will get a free pass ;-)
14:14:50 <acabot> #info a first draft of mid-cycle agenda is available
14:14:57 <acabot> #link https://etherpad.openstack.org/p/newton-watcher-midcycle
14:15:14 <acabot> feel free to add topics you would like to discuss
14:15:18 <edleafe> acabot: Did Watcher contributors not get ATC passes?
14:15:30 <acabot> there is still a lot of space in the agenda
14:15:35 <acabot> edleafe : actually yes
14:15:45 <acabot> edleafe : some of them at least
14:16:02 <jed56> edleafe: yes
14:16:09 <jed56> we have
14:16:10 <edleafe> OK, good. That's one of the benefits of being in the big tent :)
14:16:20 <jed56> edleafe: +1
14:16:33 <sballe_> +1
14:16:39 <acabot> edleafe : yes it is but to my understanting, it was related to the previous cycle...
14:17:17 <edleafe> Previous, and current up to the date they send out the ATC codes
14:17:28 <acabot> edleafe : ok
14:17:37 <acabot> #info Watcher should respect the Nova policies spec has been discussed with the Nova scheduler team
14:17:38 <edleafe> Since Watcher was in before then, I figured you should be good
14:17:50 <acabot> #link https://review.openstack.org/#/c/329873/
14:18:04 <acabot> edleafe : thx Ed for adding it to the agenda
14:18:16 <acabot> #link http://eavesdrop.openstack.org/meetings/nova_scheduler/2016/nova_scheduler.2016-06-27-14.00.log.html
14:18:52 <michaelgugino> I have already received ATC from other projects, fyi
14:18:58 <acabot> as next steps, bauzas suggests that we drop a line about watcher in Nova mid-cycle agenda #link https://etherpad.openstack.org/p/newton-nova-scheduler
14:18:59 <michaelgugino> for this cycle, I mean.
14:19:10 <sballe_> acabot: +1
14:19:35 <edleafe> acabot: yes, this will certainly be discussed at the midcycle
14:19:39 <acabot> and we submit a backlog spec #link http://specs.openstack.org/openstack/nova-specs/specs/backlog/
14:19:46 <acabot> to explain our problem
14:20:01 <edleafe> No schedule is set yet, but when it is, it would probably be a good time to come join us
14:20:08 <edleafe> since we'll be in the same building
14:20:10 <edleafe> :)
14:20:27 <acabot> edleafe : do you think having a backlog spec on Nova side is a good way to progress ?
14:20:51 <edleafe> Sure - it will give people some background
14:20:57 <acabot> ok
14:21:05 <jed56> ok
14:21:25 <acabot> #action jed56 acabot submit a backlog spec for Nova regarding policies management in Watcher
14:21:42 <acabot> any other announcement ?
14:21:59 <acabot> #topic Review Action Items
14:22:10 <acabot> Update the continuously optimization spec needs reviews from core as its already implemented
14:22:19 <acabot> #link https://review.openstack.org/#/c/330021/
14:22:36 <acabot> sballe_ : can you look at it and W+1 ?
14:22:43 <sballe_> yes
14:22:53 <acabot> #action sballe_ review https://review.openstack.org/#/c/330021/
14:23:02 <acabot> Cluster model objects wrapper needs reviews from core
14:23:08 <acabot> #link https://review.openstack.org/#/c/287019/
14:23:21 <sballe_> ok add me to this one too
14:23:30 <acabot> #action sballe_ jwcroppe review https://review.openstack.org/#/c/287019/
14:23:50 <acabot> Graph model describing virtual and physical elements in a data center & Consolidation of multiple Action-plans into a single one need reviews
14:23:57 <acabot> #link https://review.openstack.org/#/c/298891/
14:24:02 <acabot> #link https://review.openstack.org/#/c/298871/
14:24:22 <acabot> sballe_ : we have to discuss about the implementation of these specs from Intel
14:24:33 <sballe_> I'll review those too since I am preparing a talk about Intel's contribution to Watcher
14:24:43 <acabot> sballe_ : I will add it to midcycle agenda
14:25:04 <sballe_> make sense. the person implementing them will be at the mid-cycle
14:25:08 <acabot> #action sballe_ review https://review.openstack.org/#/c/298891/ & https://review.openstack.org/#/c/298871/
14:25:12 <sballe_> and so will Thijs
14:25:22 <acabot> sballe_ : great ;-)
14:25:29 <jed56> I'm starting to review 298871
14:25:32 <acabot> moving to Watcher
14:25:53 <acabot> #action jed56 review https://review.openstack.org/#/c/298871/
14:26:00 <acabot> Enable strategy parameters is in progress, test feedback requested
14:26:07 <acabot> #link https://review.openstack.org/#/c/297556/
14:26:27 <acabot> vincentfrancoise : I think you are still testing it dont you ?
14:26:57 <vincentfrancoise> acabot: actually it was more dtardivel who was doing the testing on this
14:27:01 <dtardivel> acabot: I tested it on devstack as well
14:27:14 <gzhai2> dtardivel: any issue?
14:27:40 <dtardivel> no, except data output format on console. Please see the last review
14:28:07 <acabot> #action gzhai2 add a new PS to https://review.openstack.org/#/c/297556/
14:28:16 <acabot> Add continuously optimization needs reviews from core
14:28:23 <acabot> #link https://review.openstack.org/#/c/321411/
14:28:44 <acabot> I this this has been reviewed and so can be merged asap
14:28:52 <acabot> s/this/think
14:29:07 <acabot> along with the spec :-D
14:29:34 <acabot> Add scoring engines to database and API layers needs reviews
14:29:35 <jed56> acabot: IMHO, we will be able to merged it soon
14:29:46 <acabot> #link https://review.openstack.org/#/c/330382/
14:30:11 <jed56> you can add me
14:30:15 <vincentfrancoise> I did some reviews on this one
14:30:16 <acabot> tkaczynski : you just submited a new PS, still waiting for reviews I suppose
14:30:35 <acabot> #action jed56 review https://review.openstack.org/#/c/330382/
14:30:47 <sballe_> add me 2
14:30:56 <acabot> #action sballe_ review https://review.openstack.org/#/c/330382/
14:31:07 <tkaczynski> I think I need to add some tests before it can be made +2
14:31:22 <acabot> tkaczynski : ok
14:31:37 <acabot> do you know your current coverage ?
14:31:57 <tkaczynski> I will try to do this this week, so we can close that. Vincent sent me the coverage. can I get that locally too?
14:32:09 <vincentfrancoise> tkaczynski: yes
14:32:10 <jed56> tkaczynski:  tox -e cover
14:32:17 <tkaczynski> great, thanks
14:32:30 <acabot> #action tkaczynski add tests for https://review.openstack.org/#/c/330382/
14:32:40 <acabot> Add policies for API access control to watcher project needs reviews
14:32:48 <acabot> #link https://review.openstack.org/#/c/334163/
14:32:49 <jed56> we should add a new rule in the gate each new patchset have to improve the code coverage :p
14:33:01 <sballe_> +1
14:33:16 <acabot> hanrong1 : thx for this 1st contribution to watcher !
14:33:57 <acabot> hanrong1 : you also need to add tests ;-)
14:34:10 <vincentfrancoise> jed56: I tried to find some coverage ratcheting jobs but there was none
14:34:38 <acabot> Add rally-jobs folder to get rally support needs new tests
14:34:38 <jed56> vincentfrancoise: okay :)
14:34:45 <acabot> #link https://review.openstack.org/#/c/333371/
14:34:55 <acabot> a lot of tests missing today !
14:35:00 <dtardivel> acabot: yes I asked to hanrong1 to push a new pachset on watcher-dasboard which is able to handle watcher policies
14:35:09 <hanrong1> acabot:  Thank you for all help
14:35:34 <acabot> #action hanrong1 submit a new PS on watcher-dashboard to handle policies
14:35:36 <tkaczynski> thanks guys for my reviews too! :)
14:36:00 <hanrong1> hanrong1: I will submit a new patch set for tests.
14:36:41 <acabot> #action hanrong1 submit a new patch set for tests on https://review.openstack.org/#/c/334163/
14:36:51 <acabot> Enable strategy parameter needs a new PS
14:36:57 <acabot> #link https://review.openstack.org/#/c/297557
14:37:27 <acabot> #action gzhai2 submit a new PS for https://review.openstack.org/#/c/297557
14:37:40 <acabot> Add scoring engine commands needs reviews
14:37:47 <acabot> #link https://review.openstack.org/#/c/330385/
14:37:59 <acabot> #action jed56 sballe_ review https://review.openstack.org/#/c/330385/
14:38:08 <acabot> same reviewers for the CLI ;-)
14:38:29 <acabot> Add support continuously-optimization needs a new PS
14:38:36 <acabot> #link https://review.openstack.org/#/c/327095/
14:39:04 <acabot> anyone know the IRC nick for Vladimir ?
14:39:35 <acabot> dtardivel : can you review https://review.openstack.org/#/c/327095/ as you will be working on the dashboard ?
14:40:01 <dtardivel> acabot: yes of course
14:40:10 <vincentfrancoise> acabot: he's not connected but that was something like ostroverkhov
14:40:29 <acabot> #action dtardivel review https://review.openstack.org/#/c/327095/
14:40:48 <acabot> vincentfrancoise : an easy one ;-)
14:41:50 <acabot> I forgot to mention WIP around https://review.openstack.org/#/q/topic:bp/persistent-audit-parameters
14:42:17 <acabot> hvprash michaelgugino : are you waiting for reviews on your code ?
14:42:18 <hvprash> acabot, yeah its in progress. hoping for review next week :)
14:42:25 <hvprash> we are not yet done
14:42:29 <acabot> hvprash : ok thx
14:42:34 <michaelgugino> no, I'm not.  There are some good reviews already, I am going to work on the patch this week
14:42:41 <acabot> great
14:42:51 <acabot> #topic Blueprint/Bug Review and Discussion
14:43:19 <acabot> #info our current milestone is Newton-2  (due July 11th)
14:43:27 <acabot> #link https://launchpad.net/watcher/+milestone/newton-2
14:43:57 <acabot> as we are 2 weeks away from the release, we need to focus on code reviewing and bug fixes
14:44:34 <acabot> we should probably postpone to Newton-3 https://blueprints.launchpad.net/watcher/+spec/persistent-audit-parameters
14:44:48 <acabot> and https://blueprints.launchpad.net/watcher/+spec/cluster-model-objects-wrapper
14:45:11 <acabot> tkaczynski : what about https://blueprints.launchpad.net/watcher/+spec/scoring-module ?
14:45:44 <acabot> hvprash : what do you think about your BP ?
14:45:59 <hvprash> I need to add more details on our use case
14:46:07 <hvprash> then we could discuss
14:46:12 <vincentfrancoise> acabot: does that mean we shouldn't accept any pending changeset from these BPs?
14:46:49 <vincentfrancoise> because the 1st part of my BP could be merged before then I believe
14:46:51 <acabot> vincentfrancoise : no the idea is to focus our effort on completing BPs
14:46:52 <hvprash> acabot, assuming you are asking about this https://blueprints.launchpad.net/watcher/+spec/workload-prioritization-qos
14:46:57 <tkaczynski> acabot: I'm working on it and making progress. will have code for review soon, maybe next week?
14:47:30 <acabot> hvprash : this one will be discussed during the mid-cycle as its a 'large-scope" BP
14:47:37 <hvprash> yes
14:48:17 <acabot> tkaczynski : ok as the freeze will be end of next week, I dont think we will be able to have it in this release
14:48:45 <tkaczynski> acabot: strictly speaking probably not, but soon after. is that okay?
14:49:09 <acabot> vincentfrancoise : we will merge Part 1 if there is no dependency with parts 2 & 3
14:49:33 <acabot> tkaczynski : in that case it will be Newton-3, I'm fine with that
14:49:48 <tkaczynski> but we can merge first 2 changesets
14:49:54 <vincentfrancoise> acabot: no there's none, that's why I already pushed the doc regarding this part
14:49:57 <jed56> acabot: there is no dependency
14:50:36 <acabot> good to know, in this case we will merge vincentfrancoise & tkaczynski current code
14:50:55 <acabot> 10 minutes left for open discussions
14:51:02 <acabot> #topic Open Discussion
14:51:14 <acabot> Global Requirement: is watcher-dashboard project automatically sync with OS Global Requirements ?
14:51:14 <diga> acabot: I am setting up watcher. I am going through the doc it seems you have lot of planned things. I would like to contribute to this project as I have some ideas also but I will start with adding bug fixes or whichever you think better place for me to start
14:51:32 <acabot> #undo
14:51:33 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7f2b3608a490>
14:51:59 <acabot> I forgot to mention that we have bugs open in triaged state
14:52:09 <diga> okay
14:52:16 <sballe_> diga: I am also setting up watcher in my own lab s
14:52:30 <acabot> diga : please have a look at https://launchpad.net/watcher/+milestone/newton-2
14:52:44 <hanrong1> dtardivel: Is adding policies to watcher-dasboard a  part of BP watcher-policies
14:52:46 <acabot> we should have low-hanging-fruit
14:53:04 <dtardivel> acabot: we should sync watcher-dashboard, as discusses with vincentfrancoise  offline.
14:53:06 <dtardivel> hanrong1: yes
14:53:06 <diga> acabot: that should be good starting place
14:53:20 <acabot> diga : https://bugs.launchpad.net/watcher/+bugs?field.tag=low-hanging-fruit
14:53:48 <diga> sballe_: I am setting it with devstack but it seems watche many configuration params
14:53:59 <acabot> dtardivel : are you still talking about policies ?
14:54:01 <sballe_> diga: yeah same here
14:54:20 <diga> acabot: thanks I will pick some
14:54:21 <dtardivel> acabot: sorry. sync with globla requirements
14:54:36 <acabot> ok let me move back to open discussions
14:54:45 <acabot> #topic Open discussion
14:54:58 <acabot> Global Requirement: is watcher-dashboard project automatically sync with OS Global Requirements ?
14:55:29 <dtardivel> acabot: yes it should be :)
14:55:37 <acabot> dtardivel vincentfrancoise : ok so you agreed that we should do it
14:55:42 <acabot> any comment on this ?
14:55:58 <vincentfrancoise> dtardivel: +1
14:56:12 <acabot> #action dtardivel add OS global requirements to watcher-dashboard
14:56:19 <acabot> How to deal with packaging (puppet) when updating conf parameters ?
14:56:32 <acabot> we probably need danpawlik on this
14:57:34 <acabot> the problem is that we need to maintain puppet recipes now
14:57:45 <acabot> and Watcher parameters are still evolving
14:58:25 <jed56> acabot: IMHO,we have to carefully write the "deployer impact" section in the specs
14:58:52 <acabot> jed56 : ok
14:59:19 <jed56> acabot: how to notify the pupper maintainers ?
14:59:29 <acabot> we will probably discuss it again in the rc-final version as packaging will be tested
14:59:38 <jed56> s/pupper/puppet
14:59:50 <jed56> do we need to create bugs  ?
14:59:51 <dtardivel> jed56: acabot there is no specific tag in commit message related to packaging
15:00:05 <jed56> dtardivel: ah :(
15:00:22 <acabot> #action acabot ask packaging team how to deal with parameters
15:00:27 <acabot> time to end
15:00:30 <acabot> thx
15:00:37 <acabot> #endmeeting