09:00:27 <dtardivel> #startmeeting watcher
09:00:28 <openstack> Meeting started Wed Jun 22 09:00:27 2016 UTC and is due to finish in 60 minutes.  The chair is dtardivel. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:31 <openstack> The meeting name has been set to 'watcher'
09:00:31 <vincentfrancoise> o/
09:00:34 <dtardivel> hi
09:00:40 <gzhai2> hello
09:00:41 <brunograz> hi
09:00:49 <alexchadin> o/
09:00:54 <sballe_> Hi
09:01:18 <dtardivel> acabot is not available today. I replace him for this meeting :)
09:01:35 <dtardivel> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#06.2F22.2F2016
09:01:46 <jed56> good UGT morning
09:02:15 * dtardivel what is UGT ?
09:02:20 * jed56 (http://www.total-knowledge.com/~ilya/mips/ugt.html)
09:02:34 <tkaczynski> hi
09:02:40 <hanrong1> hi
09:03:06 <dtardivel> #topic Announcements
09:03:19 <dtardivel> Call for presentations opens for Barcelona summit opened until July, 13. at 11:59PM PDT.
09:03:43 <dtardivel> 3 talks are already proposed on the dedicaded etherpad (#link https://etherpad.openstack.org/p/Watcher_abstracts_barcelona2016)
09:04:20 <dtardivel> 1 Demo and Hands-on lab
09:04:38 <dtardivel> 2 Plans for the O-release and beyond
09:04:47 <gzhai2> Was watcher demo/hands-on accepted for last summit?
09:04:52 <jinquan> hi
09:04:53 <dtardivel> 3 Reduce your TCO with Watcher, a concreter use case
09:05:07 <dtardivel> gzhai2: no
09:05:30 <tkaczynski> gzhai2: but Watcher was not big tent then
09:05:35 <gzhai2> We have chance this time:)
09:05:42 <sballe_> Yes
09:05:44 <gzhai2> yes.
09:06:08 <dtardivel> do you know what is the format of a hands-on talk ?
09:06:44 <alexstav> \o
09:06:51 <sballe_> It is a special lab
09:07:12 <tkaczynski> isn't a hands-on a kind of training? some exercises to do
09:07:26 <sballe_> It is not really a talk they'll treat this as a lab
09:07:57 <sballe_> We will be ask for requirement like people need to bring laptops etc
09:08:37 <sballe_> We'll sit in a room and go over how to Istall etc
09:08:53 <dtardivel> Ok, so we have to prepare carefully  this technical session. I know, by experience, that such session can be tricky when there is a lot of people
09:08:56 <tkaczynski> you can also send an email upfront with instructions how to setup devstack or whatever
09:08:58 <sballe_> We'll need usb drive etc
09:09:09 <jed56> tkaczynski: good idea
09:09:34 <jed56> we also prepare a VirtualBox Image with everything
09:09:47 <jed56> sballe_: +2
09:10:03 <sballe_> tkaczynski: when we did it we setup everything from a usb People will not do homework
09:10:49 <dtardivel> OK, we will see later how to prepare this session if we have a slot at Barcelona
09:10:50 <tkaczynski> I've been in Austin on such hands-ons - some of them were interesting, but there was one really bad. I took notes actually what NOT to do ;)
09:11:12 <jed56> tkaczynski: you can share with us
09:11:18 <sballe_> +1
09:11:22 <gzhai2> tkaczynski:cool
09:11:29 <tkaczynski> sure, will do when the time comes
09:11:33 <jed56> tkaczynski: I'm going to do the hands labs :)
09:11:40 <jed56> so i need these informations :)
09:11:47 <dtardivel> About talk on TCO reduction, jed56 add an item in the Portland agenda
09:12:04 <tkaczynski> jed56: I'll be happy to share my notes :)
09:12:10 <jed56> great!
09:12:59 <jed56> dtardivel: yes ! Basically, I would like that we choose a use case
09:13:11 <jed56> s/a/an
09:13:28 <jed56> oops
09:13:51 <jed56> We want to demonstrate that watcher can reduce the TCO
09:14:17 <jed56> So, we should carefully the strategy
09:14:20 <jed56> select
09:14:51 <jed56> I'm starting to work on PerfkitBenchmaker
09:15:08 <jed56> It seems that we could this took to generate some workloads on a real infrastructure
09:15:22 <jed56> But, what kind of workloads ?
09:15:27 <sballe_> +
09:15:44 <alexchadin> it depends on types of metrics we are using
09:15:48 <jed56> IMHO, we should choose a workload that highlight the use case
09:16:11 <dtardivel> This talk is directly linked to what we should be able to run on OSIC platform in September
09:16:41 <jed56> dtardivel: +1
09:16:47 <sballe_> +1
09:16:54 <dtardivel> sballe_: gzhai2 Do you have news about Intel internal cluster we should be able to use as well ?
09:17:13 <sballe_> No
09:17:30 <sballe_> But gzhai2 is leading that effort
09:17:33 <gzhai2> dtardivel: have reserved. should be available
09:17:54 <dtardivel> ok, great
09:18:19 <gzhai2> I think other users have known it's for watcher in Sep
09:18:50 <dtardivel> Agenda for the mid-cycle is opened #link https://etherpad.openstack.org/p/newton-watcher-midcycle
09:19:02 <dtardivel> You can update it if needed.
09:19:33 <dtardivel> sballe_: Do you have any update about the mid-cycle meeting to share with us ?
09:19:53 <gzhai2> nova also has mid cycle. need discussion with them?
09:19:57 <sballe_> We will have a good attendance
09:20:10 <dtardivel> #info Intel internal cluster should be available for Watcher in September
09:20:16 <sballe_> And gzhai2 will be there
09:20:33 <gzhai2> yes. just get the budget
09:21:00 <dtardivel> gzhai2: +1
09:21:06 <brunograz> dtardivel: sballe_: where the mid cycle meeting is taking place, is it defined?
09:21:35 <sballe_> Yes I Hillsboro or
09:21:54 <brunograz> we didn't attend the previous meeting so we missed that info
09:22:02 <jed56> I just want to let you know that I'm working on the nova-policies spec
09:22:27 <sballe_> What do we want to do with the nova team
09:22:43 <jed56> sballe_: do you have the chance to read https://review.openstack.org/#/c/329873 ?
09:22:47 <sballe_> brunograz: I sent out an email to the mailing list
09:23:03 <sballe_> Will do latter
09:23:13 <jed56> I'm going to amend this specification by the end of the week
09:23:21 <sballe_> jed56: ^^
09:23:30 <sballe_> ok
09:23:35 <brunograz> sballe_: I'm afraid I'm subscribed :O
09:23:50 <brunograz> I'm not *
09:23:55 <jed56> I have took at https://review.openstack.org/#/c/183837/4 more in detail
09:23:55 <sballe_> brunograz: 😄
09:24:11 <jed56> took/look
09:26:09 <dtardivel> about nova-policies spec, we can see that we will have strong debate about what we want from nova project. We should think about the good way to address our requirements to nova team (this is conservative guys :) ...
09:26:22 <tkaczynski> brunograz: https://www.eventbrite.com/e/watcher-newton-mid-cycle-developer-meetup-tickets-25267323244
09:26:36 <gzhai2> dtardivel:+1
09:26:40 <brunograz> tkaczynski: +1
09:26:47 <sballe_> +1
09:27:06 <gzhai2> dtardivel: good if have other project ask same thing
09:27:22 <dtardivel> ... and imagine several scenarios to implement a good dynamic replacement
09:27:50 <sballe_> Can we also talk about integration with congress at the meetup?
09:28:17 <sballe_> I am on my phone so  cannot edit the etherpad
09:29:04 <dtardivel> sballe_: yes if you want.
09:29:22 <dtardivel> sballe_: please update the pad when you will be at office :)
09:29:29 <sballe_> I think it is important
09:29:46 <dtardivel> ok, any other announcements ?
09:30:12 <dtardivel> #topic Review Action Items
09:30:27 <dtardivel> Spec "Audit parameters should be persistent in Db" (#link https://review.openstack.org/#/c/317130/ ) has been merged. Thx to reviewers
09:31:01 <tkaczynski> a friendly reminder about scoring-module reviews :)
09:31:36 <jed56> sballe_:about congress this is an alternative in my specificaiton
09:31:53 <dtardivel> I think Michael Gugino from Walmart started the implementation
09:32:28 <sballe_> Ok
09:32:32 <dtardivel> jed56 amended the specification for BP 'continuously-optimization' (#link https://blueprints.launchpad.net/watcher/+spec/continuously-optimization)
09:32:43 <dtardivel> new spec "Update the continuously optimization" (#link https://review.openstack.org/#/c/330021/).
09:32:58 <dtardivel> This spec needs a final review by core team
09:33:08 <alexchadin> I'm reviewing this
09:33:27 <sballe_> I will review today
09:33:41 <dtardivel> #action alexchadin sballe_ acabot review #link https://review.openstack.org/#/c/330021/
09:33:54 <dtardivel> spec 'Cluster model objects wrapper' (#link https://review.openstack.org/#/c/287019/)
09:34:00 <dtardivel> status: on progress
09:34:30 <vincentfrancoise> on this one, I'm currently doing some sequence diagrams
09:35:04 <vincentfrancoise> so I guess I'll be done by EOD
09:35:40 <dtardivel> vincentfrancoise: ok, thx. so we need core reviewer on this one as well ...
09:36:41 <dtardivel> #action acabot review #link https://review.openstack.org/#/c/287019/ :)
09:37:01 <dtardivel> jed56 proposed a new spec "Watcher should respect the Nova policies" (#link https://review.openstack.org/#/c/329873/)
09:37:08 <dtardivel> the one discussed above
09:37:20 <dtardivel> this spec needs a review by core team as well
09:38:00 <dtardivel> spec "Graph model describing virtual and physical elements in a data center" (#link https://review.openstack.org/#/c/298891/)
09:38:09 <dtardivel> what is the status about this spec ?
09:38:42 <sballe_> He will be at the mid cycle
09:38:46 <jed56> IMHO, this spec seem okay
09:38:55 <sballe_> I believe they are making progress
09:40:10 <dtardivel> ok
09:40:40 <dtardivel> Review on Watcher [ cli | dashboard ] projects
09:40:53 <dtardivel> PS "Enable strategy parameters" (#link https://review.openstack.org/#/c/297556/, #link https://review.openstack.org/#/c/297557)
09:41:02 <dtardivel> state : on progress
09:41:17 <dtardivel> I think gzhai2 waits for new from vincentfrancoise
09:41:21 <gzhai2> dtardivel: will be ok tomorrow
09:41:42 <dtardivel> gzhai2: +1
09:41:56 <gzhai2> vincentfrancoise: you can review it for your comments
09:42:10 <vincentfrancoise> oh ok
09:42:20 <gzhai2> thank you
09:42:26 <dtardivel> #action vincentfrancoise review #link https://review.openstack.org/#/c/297556/
09:42:35 <vincentfrancoise> I'll try to do it by EOW
09:42:45 <dtardivel> #action vincentfrancoise review #link https://review.openstack.org/#/c/297557
09:43:01 <dtardivel> PS "Select destinations filter implementation" (#link https://review.openstack.org/#/c/305596/")
09:43:11 <dtardivel> state : merge conflict
09:43:36 <dtardivel> jinquan: could you push an update to resolve mere conflict please ?
09:43:57 <jinquan> yeah, the work stop, i'm wait for jed56's new spec
09:44:38 <jed56> jinquan: yes, we decided with acabot
09:44:54 <jinquan> i will assign a new BP
09:44:58 <jed56> to wait that we have a better vision for this problem
09:45:06 <dtardivel> jinquan: So, could you set this PS to workflow - 1 | Work In Progress state ?
09:45:20 <jed56> IMHO, I wrote in my spec that select_destinations is not the good approach
09:45:36 <jinquan> dtardivel:ok
09:45:55 <jed56> this is the reason why the blueprint "Select destinations filter implementation" need to wait
09:45:58 <sballe_> jed56: so what are you proposing
09:46:12 <jed56> sballe_: you should read my spec :)
09:46:22 <sballe_> Ok will do
09:46:29 <jinquan> dtardivel: did it already
09:46:30 <jed56> https://review.openstack.org/#/c/329873/
09:46:39 <dtardivel> A new PS 'Add continuously optimization' has been pushed by alexchadin (#link https://review.openstack.org/#/c/321411/).
09:46:50 <dtardivel> Is it compliant with update proposed by jed56 ?
09:47:08 <alexchadin> In some parts
09:47:23 <jed56> yes this is on the way )
09:47:23 <alexchadin> We have decided to implement it in some steps
09:47:35 <dtardivel> alexchadin: ok
09:47:39 <dtardivel> who would like to review it ?
09:48:17 <gzhai2> i can
09:48:28 <jinquan> me too
09:48:30 <jed56> i will
09:48:37 <vincentfrancoise> Yeah I'll make a run through it by EOW as well
09:48:45 <alexchadin> I will appreciate this!
09:48:54 <dtardivel> #action gzhai2 jinquan jed56 vincentfrancoise review #link https://review.openstack.org/#/c/321411/
09:49:03 <dtardivel> kaczynski proposed 2 new PS:
09:49:09 <dtardivel> PS "Add scoring engines to database and API layers" (#link https://review.openstack.org/#/c/330382/)
09:49:17 <dtardivel> PS "Add scoring engine commands" (#link https://review.openstack.org/#/c/330385/)
09:49:27 <dtardivel> who would like to review them ?
09:49:58 <hanrong1> i can
09:50:28 <dtardivel> #action hanrong1 review #link https://review.openstack.org/#/c/321411/ and #link https://review.openstack.org/#/c/330385/
09:50:45 <dtardivel> vincentfrancoise proposed a wishlist PS:
09:50:51 <dtardivel> PS "Added filter operators" (#link https://review.openstack.org/#/c/325794/)
09:51:02 <dtardivel> who would like to review them ?
09:51:06 <dtardivel> me I can :)
09:51:36 <dtardivel> #action dtardivel review https://review.openstack.org/#/c/325794/
09:51:53 <dtardivel> PS "Add importing modules instead of classes" (#link https://review.openstack.org/#/c/332241/) waits for core reviewer
09:52:41 <vincentfrancoise> I'll take that one
09:53:05 <dtardivel> #action vincentfrancoise reviews #link https://review.openstack.org/#/c/332241/
09:53:44 <dtardivel> Any request on reviews ?
09:54:08 <dtardivel> #topic Blueprint/Bug Review and Discussion
09:54:24 <dtardivel> BP "Define policies for accessing Watcher components" (#link https://blueprints.launchpad.net/watcher/+spec/watcher-policies). Can we have a status please ?
09:54:38 <alexstav> vincentfrancoise: thanks!
09:54:52 <hanrong1> Because this BP has no spec file, I don't know what policy rules will be needed
09:54:53 <hanrong1> in watcher project.
09:55:29 <dtardivel> hanrong1: can we discuss together tomorrow on openstack-watcher ?
09:55:38 <hanrong1> ok
09:56:11 <dtardivel> hanrong1: we did not write spec because it's simple to implement (I think) :)
09:56:27 <hanrong1> Are these actions can be performed by only admin in watcher project?
09:56:45 <dtardivel> There are some 'low-hanging-fruit' bugs (#link https://bugs.launchpad.net/watcher/+bugs?field.tag=low-hanging-fruit)
09:56:51 <dtardivel> you're welcome to fix one(s).
09:56:51 <vincentfrancoise> hanrong1: I'd say yes
09:57:18 <hanrong1> vincentfrancoise: Thank you very much
09:57:47 <dtardivel> hanrong1: We have to define, in policies, who can play with watcher CRUD ? So we have to define default roles and match them to CRUD methods
09:58:37 <dtardivel> Sorry we have just 2 minutes for open discussion
09:59:01 <hanrong1> dtardivel: ok, discuss together tomorrow .
09:59:51 <dtardivel> OK, we will take more time next week for open discusssions
10:00:32 <dtardivel> ok thanks a lot for you attention ladies and gentlemen.
10:00:33 <vincentfrancoise> bye
10:00:36 <brunograz> bye
10:00:37 <gzhai2> bye
10:00:48 <dtardivel> And long live to Watcher
10:00:52 <alexchadin> bye
10:00:53 <brunograz> +1
10:00:53 <vincentfrancoise> :)
10:00:55 <brunograz> :D
10:01:05 <tkaczynski> bye
10:01:05 <dtardivel> #endmeeting