14:00:31 <acabot> #startmeeting watcher
14:00:33 <openstack> Meeting started Wed Jun 15 14:00:31 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:37 <openstack> The meeting name has been set to 'watcher'
14:00:40 <acabot> hi
14:00:46 <gzhai-mobl> Hi
14:00:51 <hvprash> Hi
14:00:57 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#06.2F15.2F2016
14:01:20 <tkaczynski> hi
14:01:21 <jed56> hi
14:01:22 <gzhai-mobl> I am on phone,so not stable
14:01:35 <acabot> gzhai-mobl : ok ;-)
14:01:49 <jinquan2> hi
14:01:52 <acabot> #topic Announcements
14:01:53 <sballe_> hi
14:02:37 <acabot> #info Call for presentations opens for Barcelona summit, I set-up an etherpad for propositions
14:02:44 <acabot> #link https://etherpad.openstack.org/p/Watcher_abstracts_barcelona2016
14:03:12 <acabot> I simply copy paste most of the descriptions we had for Austin
14:03:44 <acabot> so we need to update them, I'd like to have at least 3 presentations in Barcelona
14:04:17 <acabot> a Hands-on / a fishbowl session / a concrete use case
14:04:34 <sballe_> what's fishbowl
14:04:50 <jed56> sballe_: +1
14:05:04 <acabot> regarding the fishbowl session, we will be able to add it to the design summit agenda as we are now big-tent
14:05:50 <tkaczynski> cool, but what's that? not japanese food I guess ;)
14:05:50 <sballe_> ok but I am not sure what a fishbowl session is.. just an update of the status of the project?
14:05:50 <acabot> each official project has a fishbowl session during the summit (a large room to get a maximum of contributors and discussions)
14:06:13 <sballe_> ok
14:06:30 <acabot> its a way to give updates on the project and define priorities with a large audience
14:06:41 <sballe_> I am interested in contributing in the use case session. I added my name to that talk
14:06:48 <hvprash> acabot : was sharing this idea with sballe_ last week. will see if we can put together something on walmart use case
14:07:05 <sballe_> hvprash: +1
14:07:16 <acabot> hvprash : it would be great !
14:07:22 <hvprash> thx
14:07:25 <sballe_> tpeoples: are you coming to the meetup? you haven't registered yet
14:07:55 <acabot> #action hvprash complete https://etherpad.openstack.org/p/Watcher_abstracts_barcelona2016 with a Walmart use case
14:08:04 <sballe_> tpeoples: https://www.eventbrite.com/e/watcher-newton-mid-cycle-developer-meetup-tickets-25267323244
14:08:30 <acabot> #info Watcher CLI documentation will be generated on docs.openstack.org next time the release team will tag it
14:08:49 <acabot> FYI, we cannot tag any more Watcher repos
14:09:03 <acabot> only the OpenStack release team can do it
14:09:18 <acabot> so we have to wait for n2 release to generate the CLI doc
14:09:25 <tkaczynski> has the review / contribution process changed?
14:09:40 <acabot> tkaczynski : not at all
14:10:02 <acabot> tkaczynski : we just submit a release to the release team and they tag the repo
14:10:18 <acabot> #info Release notes management has been set-up for Watcher
14:10:19 <tkaczynski> acabot: thanks
14:10:27 <acabot> #link http://docs.openstack.org/releasenotes/watcher/
14:10:35 <acabot> nothing in there for now
14:10:57 <acabot> if you are interested in Reno, you can look at http://docs.openstack.org/project-team-guide/release-management.html#when-to-add-release-notes
14:11:27 <acabot> #info Translation server is up and running, translations are stored on git only above 70% of coverage per language
14:11:34 <acabot> #link https://translate.openstack.org/iteration/view/watcher/master
14:11:49 <acabot> as you can see, we need contributors on translations ;-)
14:12:08 <acabot> we will do it for French !
14:12:33 <acabot> anyone wants to start working on translations ?
14:12:34 <sballe_> lol
14:12:41 <gzhai-mobl> How big is the doc
14:12:44 <sballe_> this is cool!
14:13:00 <acabot> its very easy to do as it is now on Zanata server
14:13:19 <dtardivel> acabot: is there a dedicated team for translation in OpenStack ?
14:13:45 <acabot> dtardivel : not yet, I will ask people from the translation team to look at watcher
14:13:51 <jinquan2> which language translate to?
14:14:03 <acabot> jinquan2 : chinese ?
14:14:26 <acabot> if we can have french and chinese abose 70% it would be nice :-)
14:14:49 <jinquan2> let me think, you know my english:(
14:14:55 <acabot> gzhai-mobl : we dont translate the doc here, its i18n in code
14:15:04 <tkaczynski> acabot: I guess the question was what's the openstack language list
14:15:38 <jed56> I think there is 50 languages
14:16:11 <acabot> tkaczynski : have a look at https://translate.openstack.org/iteration/view/nova/master
14:16:39 <acabot> for Nova we have 12 languages above 50%
14:16:54 <tkaczynski> Polish 0.42% ;)
14:17:15 <dtardivel> FYI, this is a team for French translation: https://wiki.openstack.org/wiki/I18nTeam/team/fr
14:17:17 <acabot> tkaczynski : you should probably work on it ;-)
14:17:41 <acabot> dtardivel : page in french ;-)
14:18:01 <acabot> #info a request has been sent to OSIC for a test cluster in september
14:18:23 <acabot> #link https://etherpad.openstack.org/p/watcher-test-environment-specifications is you want to look at the form request
14:18:41 <acabot> any other announcement ?
14:19:06 <acabot> I think Watcher has been packaged for Debian and I dont have a status
14:19:18 <acabot> so I moved it to open discussions
14:19:35 <acabot> #topic Review Action Items
14:19:43 <acabot> watcher specs
14:20:08 <acabot> Audit parameters should be persistent in Db will be merged soon
14:20:14 <acabot> #link https://review.openstack.org/#/c/317130/
14:20:24 <hvprash> thx for everyones review :)
14:20:29 <hvprash> will start working on it
14:20:36 <acabot> #action jed56 vincentfrancoise confirm +1 on https://review.openstack.org/#/c/317130/
14:20:51 <jed56> this is in my pipeline :)
14:20:55 <acabot> Cluster model objects wrapper needs reviews after work items additions
14:21:06 <acabot> #link https://review.openstack.org/#/c/287019/
14:21:28 <acabot> vincentfrancoise added work items on top of tpeoples work
14:21:53 <acabot> #action jwcroppe sballe_ acabot review https://review.openstack.org/#/c/287019/
14:22:00 <sballe_> on it
14:22:07 <acabot> Watcher
14:22:16 <acabot> Efficacy indicator has been merged
14:22:20 <acabot> #link https://review.openstack.org/#/q/project:openstack/watcher+branch:master+topic:bp/efficacy-indicator
14:22:44 <acabot> dtardivel merged it this morning and it moved all PS in merge conflict...sorry for that
14:23:26 <acabot> Enable strategy parameters needs a new PS
14:23:32 <acabot> #link https://review.openstack.org/#/c/297556/
14:23:52 <acabot> gzhai-mobl : sorry but you will have to rebase it
14:24:18 <acabot> #action gzhai-mobl add a new PS to https://review.openstack.org/#/c/297556/
14:24:30 <acabot> Implement immutable audit_template CRUD needs an update
14:24:36 <acabot> #link https://review.openstack.org/#/c/324652/
14:24:46 <acabot> hvprash : any update on this ?
14:25:19 <hvprash> i guess we could abandon it
14:25:36 <acabot> hvprash : ok please do in this case
14:25:36 <hvprash> it was a logic which mike was working for the immutable audit template
14:26:03 <acabot> #action hvprash abandon the patch https://review.openstack.org/#/c/324652/
14:26:05 <hvprash> the spec has changed and we will re-write
14:26:20 <acabot> hvprash : thx
14:26:21 <sballe_> history
14:26:30 <sballe_> wrong window ;)
14:26:35 <acabot> Add support continuously-optimization needs reviews
14:26:42 <acabot> #link https://review.openstack.org/#/c/327095/
14:26:53 <acabot> jed56 already did
14:27:15 <jed56> FYI, I going to amend the specification
14:27:18 <sballe_> I will review
14:27:31 <acabot> sorry wrong link
14:27:32 <jed56> so you should wait to review the new spec
14:27:45 <acabot> #link https://review.openstack.org/#/c/321411/
14:28:28 <jed56> I will push a new spec tomorrow
14:28:41 <acabot> #action jed56 amend the specification for https://blueprints.launchpad.net/watcher/+spec/continuously-optimization
14:29:30 <acabot> #action alexchadin wait for specifications update before adding a PS to https://review.openstack.org/#/c/321411/
14:29:43 <acabot> Uniform Airflow migration strategy implementation needs reviews
14:29:53 <acabot> #link https://review.openstack.org/#/c/324169/
14:30:25 <acabot> this one is old, does anyone wants to review it ?
14:30:32 <jed56> sorry,I didn't take time
14:30:36 <jed56> to review it
14:30:49 <acabot> #action jed56 review https://review.openstack.org/#/c/324169/
14:30:49 <jed56> you can add me again
14:30:53 <hvprash> +1
14:31:12 <acabot> #action hvprash review https://review.openstack.org/#/c/324169/
14:31:22 <acabot> moving to watcher CLI
14:31:39 <acabot> Enable strategy parameter needs reviews
14:31:44 <acabot> #link https://review.openstack.org/#/c/297557/
14:32:05 <acabot> #action gzhai-mobl add a PS to https://review.openstack.org/#/c/297557/
14:32:38 <acabot> Watcher dashboard
14:32:44 <acabot> Add support continuously-optimization needs reviews
14:32:49 <acabot> #link https://review.openstack.org/#/c/327095/
14:33:28 <acabot> jed56 : I suppose we should also wait for specs update ?
14:33:37 <dtardivel> jed56: +1
14:34:07 <acabot> Watcher puppet
14:34:12 <jed56> I don't think the logic for client part will be impacted
14:34:19 <acabot> jed56 : ok
14:34:29 <jed56> *that
14:34:31 <acabot> who wants to review it ?
14:34:45 <dtardivel> I can
14:34:59 <acabot> #action dtardivel review https://review.openstack.org/#/c/327095/
14:35:19 <acabot> the initial commit of watcher-puppet has been merged
14:35:26 <acabot> #link https://review.openstack.org/#/c/326593/
14:35:48 <acabot> you can now use puppet to deploy watcher !
14:35:54 <acabot> thx to danpawlik
14:36:08 <sballe_> nice!
14:36:14 <acabot> #topic Blueprint/Bug Review and Discussion
14:36:16 <dtardivel> acabot: or packstack :)
14:36:39 <acabot> #info our current milestone is Newton-2
14:36:45 <acabot> #link https://launchpad.net/watcher/+milestone/newton-2
14:37:29 <acabot> hanrong took the BP Define policies for accessing Watcher components, jinquan2 any update on this ?
14:37:45 <acabot> hanrong is a new contributor from ZTE by the way
14:38:11 <jed56> Welcome to hanrong :)
14:38:15 <jinquan2> acabot:she are depolying the watcher envirment
14:38:22 <sballe_> +1
14:38:36 <acabot> jinquan2 : ok did she use devstack ?
14:38:43 <hvprash> welcome hanrong
14:38:52 <jinquan2> yes,use devstack
14:39:15 <jinquan2> she is good at code
14:39:23 <acabot> jinquan2 : ok tell her to not hesitate to submit bug if the doc is unclear or not up-to-date
14:39:51 <jinquan2> ok i will tell she tomorrow
14:39:58 <acabot> Provide a way to filter available hosts that can be targeted for a migration has been deferred due to specs improvements needed
14:39:59 <jinquan2> her
14:40:06 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/select-destinations-filter
14:40:20 <acabot> so jinquan2 was working on this bp
14:41:04 <acabot> and as we are now in the big-tent, the solution we designed during the last mid-cycle regarding select-destination was not good
14:41:09 <sballe_> ls -al
14:41:37 <acabot> so jed56 decided to work on a new spec to define how watcher should interact with Nova in a proper way
14:41:49 <sballe_> +1000
14:42:09 <acabot> and this is something we should have ready before the mid-cycle to engage discussion with the Nova team
14:42:12 <sballe_> jed56: I am happy to help on that spec if you need help
14:42:27 <jed56> sballe => I pushed a first version https://review.openstack.org/#/c/329873/
14:42:28 <acabot> jed56 will submit a first draft
14:42:35 <sballe_> cool1
14:42:36 <acabot> already done ;-)
14:43:08 <acabot> so on this, I think we have to make it clear on our side
14:43:18 <acabot> and then ask nova contributors to review it
14:43:23 <jed56> acabot: +1
14:43:45 <sballe_> acabot: +1
14:43:58 <acabot> I would like to have reviewers on this spec as it is very important for Watcher
14:44:10 <vmahe> +1
14:44:22 <hvprash> +1
14:44:30 <jinquan2> +1
14:44:32 <acabot> #action sballe_ jwcroppe acabot give a first round of feedback on https://review.openstack.org/#/c/329873/
14:44:55 <acabot> #action vmahe hvprash jinquan2 review https://review.openstack.org/#/c/329873/
14:45:25 <acabot> #topic Open Discussion
14:45:47 <acabot> we are one month away from the mid-cycle, I will start working on the agenda
14:46:12 <sballe_> we have 7 people registered
14:46:24 <sballe_> tpeoples: hasn't registered yet
14:46:31 <acabot> #link https://etherpad.openstack.org/p/newton-watcher-midcycle
14:46:36 <sballe_> and tkaczynski will attend via a VideoConf room
14:46:50 <sballe_> so 8 people with tkaczynski
14:46:52 <acabot> please complete the list of subjects you would like to discuss during the mid-cycke
14:47:01 <gzhai-mobl2> I am tbd
14:47:28 <sballe_> We are waiting for gzhai-mobl2 travel approval :)
14:47:56 <acabot> #action sballe_ jed56 jwcroppe tkaczynski edleafe gzhai-mobl2 complete the list of subjects to discuss https://etherpad.openstack.org/p/newton-watcher-midcycle
14:48:12 <acabot> gzhai-mobl2 : it would be great to have you this time �
14:48:24 <gzhai-mobl2> Maybe I can also video conference :)
14:48:49 <sballe_> yes but let's hope you can come in person
14:49:29 <tkaczynski> btw: I made some good progress on scoring module implementation. I started with watcher cli, api and db layer. code is ready, pep8 is clean. I'm ready to send it for review, but I'm also looking at tests, so I don't know how much that will take
14:49:58 <acabot> tkaczynski : great, sorry I forgot to ask
14:50:20 <acabot> tkaczynski : please submit it asap for review
14:50:32 <acabot> tkaczynski : we will be able to add tests later
14:50:59 <jed56> tkaczynski: awesome :)
14:51:10 <tkaczynski> acabot: great, so I will prepare review and send it probably tomorrow
14:51:50 <acabot> #action tkaczynski submit code to review for https://blueprints.launchpad.net/watcher/+spec/scoring-module
14:52:01 <acabot> we will try to have it ready for newton-2 !
14:52:03 * edleafe wanders in after daughter's dentist appointment
14:52:12 <jed56> lol
14:52:34 <tkaczynski> but this is only 1st part! there's a lot more work to do
14:52:41 * jed56 hello world
14:53:04 * acabot jed56 is discovering IRC commands
14:53:18 * sballe_ lol
14:53:27 <acabot> any update regarding Debian/RDO packages ?
14:53:27 * jed56 :)
14:54:00 <acabot> I think we need to find a packager for RDO as there is no dedicated team
14:54:47 <acabot> any other discussion to open ?
14:55:04 <tkaczynski> jed56: what command did you use? I want it too! :)
14:55:12 <jed56> => /me message
14:55:26 <hvprash> acabot, we have some dedicated team working on openstack ansible. I think will be good to have a watcher ansible playbooks
14:55:40 <acabot> hvprash : for sure
14:55:51 <sballe_> +100
14:55:58 * tkaczynski that is pretty cool :)
14:56:06 <acabot> I looks to be the same as puppet, there is a big-tent project related to ansible
14:56:10 <hvprash> in fact mike is a dedicated resource in that project
14:56:15 <hvprash> will talk to our internal team
14:57:00 <hvprash> in fact our internal openstack deployments is using osad
14:57:08 <acabot> #action hvprash look if walmart can provide ansible playbooks for Watcher
14:57:13 <hvprash> so at some point we need watcher to be in too :)
14:57:22 <acabot> osad?
14:57:41 <hvprash> OSAD = openstack ansible deployment
14:57:44 <hvprash> :D
14:57:46 <acabot> ok
14:57:53 <dtardivel> acabot: about RDO packages, we can talk to gpocentek. It released cloudkitty RDO packages
14:58:12 <acabot> dtardivel : ok
14:58:51 <acabot> time to close the meeting
14:58:54 <acabot> thank you
14:59:03 <sballe_> have a great day! thx
14:59:07 <acabot> bye
14:59:09 <tkaczynski> bye
14:59:11 <gzhai-mobl2> Bye
14:59:11 <jinquan2> byebye
14:59:15 * jed56 is going to the coffee break
14:59:19 <acabot> #endmeeting