09:00:03 <acabot> #startmeeting watcher
09:00:03 <openstack> Meeting started Wed Jun  8 09:00:03 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:07 <openstack> The meeting name has been set to 'watcher'
09:00:10 <acabot> hi
09:00:14 <alexchadin> hi
09:00:17 <vincentfrancoise> hi
09:00:18 <jinquan> hi
09:00:20 <ostroverkhov> hi
09:00:32 <jed56> hi
09:00:35 <dtardivel> hi
09:00:51 <junjie> hi
09:01:02 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#06.2F08.2F2016
09:01:12 <hanrong> hi
09:01:28 <acabot> please add anything you like in open discusssions before the end of the meeting
09:01:50 <acabot> #topic Announcements
09:02:09 <acabot> #info Watcher n1 version has been released by the release team but no announcement sent yet
09:02:27 <acabot> I dont know why no mail has been sent
09:02:54 <acabot> I will check with dhellman today
09:03:23 <acabot> #info Watcher documentation is now available on docs.openstack.org #link http://docs.openstack.org/developer/watcher/
09:03:50 <acabot> for now there is only Watcher, I will add watcher CLI soon
09:04:04 <acabot> #action acabot add watcher CLI doc on docs.openstack.org
09:04:19 <alexchadin> specs.openstack.org link is broken
09:04:21 <acabot> #info Watcher specs are available on specs.openstack.org
09:04:37 <acabot> yes because we need a merge to build the repo :-)
09:04:56 <alexchadin> Ah, didn't see;)
09:05:05 <acabot> the gate job is in place but we need to merge a spec to have it run
09:05:19 <acabot> I hope we will have one until end of week
09:05:42 <acabot> #info The Call for Presentations is now open for the upcoming OpenStack Summit in Barcelona, October 25-28 ( submission deadline is July 14th at 6:59 UTC) #link https://www.openstack.org/summit/barcelona-2016/call-for-speakers/
09:05:58 <acabot> does anyone here wants to present Watcher in Barcelona ?
09:06:56 <acabot> #action acabot open an etherpad to write down sessions descriptions for the Barcelona summit
09:07:16 <acabot> #info Mid-cycle details have been announced on the ML #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/096379.html
09:07:38 <acabot> if you plan to come to our mid-cycle, please register now
09:07:52 <acabot> any other announcement ?
09:07:57 <jed56> acabot: I can
09:08:20 <acabot> jed56 : what can you ? :-)
09:08:42 <jed56> does anyone here wants to present Watcher in Barcelona ? yes i can :)
09:09:12 <acabot> #info jed56 would like to present Watcher in Barcelona
09:09:18 <acabot> #topic Review Action Items
09:09:27 <acabot> Watcher specs
09:09:48 <acabot> https://review.openstack.org/#/c/317130/ needs a new PS from hvprash
09:10:10 <acabot> anyone here from walmart ?
09:10:36 <acabot> #info vincentfrancoise will provide work items for Cluster model objects wrapper #link https://review.openstack.org/#/c/287019/
09:10:46 <acabot> #info Graph model describing virtual and physical elements in a data center & Consolidation of multiple Action-plans into a single one need reviews
09:11:09 <acabot> any volunteer to review these specs ?
09:11:33 <acabot> ok moving to watcher code
09:11:52 <acabot> Uniform Airflow migration strategy implementation needs reviews #link https://review.openstack.org/#/c/324169/
09:12:04 <acabot> junjie : is your code ready for reviews ?
09:12:08 <junjie> yes
09:12:22 <acabot> ok who wants to review a new strategy ?
09:12:45 <gzhai-mobl2> I can review consolidation action plan
09:12:54 <jed56> i can review
09:13:11 <acabot> hello gzhai-mobl2
09:13:14 <junjie> great, thanks
09:13:26 <acabot> #action jed56 review https://review.openstack.org/#/c/324169/
09:13:43 <acabot> #action gzhai-mobl2 review https://review.openstack.org/#/c/298871/
09:13:46 <gzhai-mobl2> Hello
09:14:07 <acabot> Add continuously optimization needs reviews from core #link https://review.openstack.org/#/c/321411/
09:14:28 <acabot> alexchadin : I think your code has been reviewed now and need validation from cores
09:14:47 <alexchadin> acabot: vincentfrancoise reviewed it
09:14:54 <acabot> dtardivel : can you review https://review.openstack.org/#/c/321411/ ?
09:14:58 <dtardivel> yes
09:15:19 <acabot> #action review https://review.openstack.org/#/c/321411/ and merge it as vincentfrancoise already reviewed
09:15:20 <alexchadin> acabot: new PS is waiting for new reviews;)
09:15:36 <acabot> #action dtardivel review https://review.openstack.org/#/c/321411/ and merge it as vincentfrancoise already reviewed
09:16:00 <acabot> efficacy indicator need reviews from core #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/efficacy-indicator
09:16:02 <vincentfrancoise> I will review it once again
09:16:20 <acabot> #action vincentfrancoise review https://review.openstack.org/#/c/321411/
09:16:44 <acabot> gzhai-mobl2 : could you review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/efficacy-indicator before next meeting ?
09:17:01 <acabot> dtardivel is currently reviewing it
09:17:06 <dtardivel> acabot: I'm reviewing it
09:17:51 <acabot> gzhai-mobl2 : Enable strategy parameters needs a new PS https://review.openstack.org/#/c/297556/
09:18:12 <acabot> #action gzhai-mobl2 submit a new PS for https://review.openstack.org/#/c/297556/
09:18:30 <acabot> WIP Implement immutable audit_template CRUD needs a status #link https://review.openstack.org/#/c/324652/
09:18:33 <tkaczynski> hi guys, sorry for being late. morning meetings are not in my calendar yet :|
09:18:49 <acabot> #action hvprash provide a status for https://review.openstack.org/#/c/324652/
09:18:53 <gzhai-mobl2> I am doing it
09:18:55 <acabot> tkaczynski : no pb
09:19:00 <vincentfrancoise> hi tkaczynski
09:19:21 <acabot> jinquan : Select destinations filter implementation needs a status #link https://review.openstack.org/#/c/305596/
09:19:40 <jinquan> acabot : OK
09:19:44 <jinquan> I'm modify jed's suggestion about https://blueprints.launchpad.net/watcher/+spec/select-destinations-filter, But have not completed.
09:20:02 <jed56> jinquan: I think i will amend a bit the specification of acabot
09:20:33 <jed56> jinquan:  for you information i currently looking at the nova code
09:20:45 <acabot> #action jed56 jinquan update the spec regarding https://blueprints.launchpad.net/watcher/+spec/select-destinations-filter
09:20:52 <jinquan> jed56: i read your comment in patch set
09:20:58 <jed56> if have any questions don't hesitate
09:21:17 <jinquan> jed56: yes  thankyou :)
09:21:27 <jed56> welcome !
09:21:45 <acabot> as the spec has been approved for mitaka, we will have to copy it to newton before amending it
09:21:58 <jed56> acabot: copy that
09:22:22 <acabot> moving to watcher CLI
09:22:41 <acabot> Add support continuously-optimization needs reviews #link https://review.openstack.org/#/c/321421/
09:23:06 <acabot> Enable strategy parameter needs reviews #link https://review.openstack.org/#/c/297557/
09:23:30 <acabot> Any volunteers to review CLI improvements ?
09:23:40 <jed56> I can review 321421
09:23:53 <acabot> #action jed56 review https://review.openstack.org/#/c/321421/
09:24:22 <acabot> #topic Blueprint/Bug Review and Discussion
09:24:44 <acabot> #info our current milestone is Newton-2 #link https://launchpad.net/watcher/+milestone/newton-2
09:24:59 <acabot> 9 BPs targeted
09:25:30 <acabot> tkaczynski : update needed on Provide a scoring module for Watcher #link https://blueprints.launchpad.net/watcher/+spec/scoring-module
09:26:08 * acabot waiting for tkaczynski comments
09:26:21 <tkaczynski> acabot: update is the same as it was last week - yesterday I've finished working on TAP features, from today moving to Watcher
09:26:56 <acabot> #action tkaczynski start working on scoring module today
09:27:13 <tkaczynski> I would like to define the tasks which I need to do and start executing them, also refresh myself on the changes which happened when I was out
09:27:34 <acabot> #info Define the scope of an Audit as a pool of resources has been assigned to Charlotte Han from ZTE, can we set a target milestone ? #link https://blueprints.launchpad.net/watcher/+spec/define-the-audit-scope
09:27:45 <acabot> jinquan : do you now Charlotte ?
09:27:55 <hanrong> I want to join the watcher community, but I don't know what to do. Jinquan assgined a BP to me, https://blueprints.launchpad.net/watcher/+spec/define-the-audit-scope
09:27:58 <jinquan> yes
09:28:06 <jinquan> she is online now
09:28:17 <acabot> ok welcome hanrong
09:28:30 <jinquan> she want to join the watcher team
09:28:39 <jinquan> so she assign the bp
09:28:47 <dtardivel> welcome hanrong :)
09:28:55 <jinquan> welcome :)
09:28:58 <acabot> hanrong : did you already looked at watcher code ?
09:29:00 <jed56> Welcome
09:29:07 <junjie> welcome
09:29:19 <hanrong> Has not yet been
09:29:20 <gzhai-mobl2> Welcome
09:29:36 <jed56> 欢迎
09:29:41 <vincentfrancoise> lol
09:29:54 <jinquan> jed56: great!!!
09:30:23 <acabot> hanrong : ok in this case I would suggest you to take this BP https://blueprints.launchpad.net/watcher/+spec/watcher-policies to enter Watcher code
09:30:46 <acabot> hanrong : it would be much easier and its in our priorities for newton-2 version
09:31:06 <hanrong> @acabot ok
09:31:29 <acabot> hanrong : or fix bugs as there are some for Newton-2, as you prefer
09:32:30 <acabot> #action hanrong take time to discover Watcher, fix bugs or take the BP https://blueprints.launchpad.net/watcher/+spec/watcher-policies
09:32:37 <hanrong> @acabot Ok, I look at the bug
09:33:19 <acabot> jinquan : so you now have 2 BPs assigned :-), what about https://blueprints.launchpad.net/watcher/+spec/select-destinations-filter ?
09:33:47 <acabot> jinquan : I think you should stay with one BP at a time
09:34:04 <acabot> jinquan : especially if you need to rework specs with jed56 ;-)
09:34:23 <jinquan> ok,
09:34:41 <jinquan> yeah,  just i am very interested in the BP https://blueprints.launchpad.net/watcher/+spec/automatic-triggering-audit.
09:35:02 <acabot> jinquan : ok but do you plan to work on specs for it ?
09:35:41 <jinquan> i can review the specs  if someone  commit specs
09:36:06 <acabot> jinquan : IMHO you should now focus on select_destinations, then move to the other BP
09:36:18 <jinquan> consider that you think  should stay with one BP at a time
09:36:31 <acabot> #info jinquan is interested in contributing to specs for https://blueprints.launchpad.net/watcher/+spec/automatic-triggering-audit
09:36:32 <jinquan> yes, i will unassign the bp
09:36:48 <acabot> jinquan : ok thx
09:37:02 <jinquan> nothing :)
09:37:12 <acabot> #topic Open Discussion
09:37:34 <acabot> now that Watcher is big-tent, should we provide a DB migration tool ?
09:38:12 <acabot> as suggested by brunograz yesterday on IRC, he tried to update watcher without recreating the database
09:38:12 <jed56> IMHO, we can wait the version 1.0 of watcher
09:38:26 <jed56> the first stable version
09:38:44 <jed56> and then, we should provide the db migrations tools
09:38:45 <acabot> jed56 : perfect transition, so should we target a 1.0 version now ?
09:39:18 <dtardivel> jed56: should stable version 1.0 integrate DB migration tool ?
09:39:40 <jed56> no, we should wait the next realase
09:39:49 <jed56> dtardivel: for me yes
09:39:51 * acabot has seen many projects moving to 1.0 in the big tent
09:40:23 <acabot> #info currently Watcher version is 0.27
09:40:24 <jed56> IMHO, watcher should scale and respect the nova policies before to be tagged has 1.0
09:40:58 <tkaczynski> I also think that 1.0 means "production ready", not "big tent" ;)
09:40:59 <acabot> jed56 : I agree with you on nova policies, and it is something we should fix during the mid-cycle
09:41:19 <jed56> what is the next Openstack Release ?
09:41:36 <acabot> jed56 : you mean when ?
09:41:49 <acabot> jed56 : Ocata
09:42:05 <acabot> Ocata will be april 2017
09:42:12 <jed56> so, maybe watcher can manage db migration for Ocata
09:42:22 <jed56> o-1
09:43:02 <jed56> tkaczynski: i agree with you
09:43:15 <alexchadin> jed56: could we discuss rally id issue?
09:43:17 <vincentfrancoise> we need to define what we need to consider watcher as production-ready
09:43:38 <jed56> alexchadin: yes of course
09:43:49 <acabot> tkaczynski : I agree with you, its just that I we want to have more users after the Barcelona summit and moving to 1.x version is better for users
09:44:18 <acabot> alexchadin : yes go ahead with Rally
09:44:38 <alexchadin> Should I submit it as a bug?
09:44:47 <jed56> acabot: why is the better for the users to have 1.0 ?
09:45:06 <acabot> jed56 : users dont install beta software
09:45:15 <alexchadin> jed56: I mean renaming of uuid
09:45:50 <tkaczynski> acabot: but if we name it "1.0" and we are not production ready, then we are beta, no?
09:46:01 <jed56> if watcher is production-ready we can tagged 1.0
09:46:13 <tkaczynski> jed56 +1
09:46:28 <alexchadin> acabot: We will test watcher in july-august on 20 nodes
09:46:41 <acabot> tkaczynski : if we name it 1.0 its because we are production ready, we plan to test watcher on a large cluster in september
09:46:41 <jed56> alexchadin: you can send a mail to the ML regarding the problem with have with Rally
09:46:48 <alexchadin> acabot: in private cloud
09:47:13 <alexchadin> jed56: then push new commit?
09:47:35 <acabot> #info alexchadin will test Watcher on a 20 nodes private cloud in july-august 2016
09:48:01 <jed56> alexchadin: we should wait that the contributors of watcher give theirs opinions
09:48:19 <alexchadin> acabot: we have high hopes for watcher
09:48:32 <acabot> alexchadin : me too ;-)
09:48:37 <alexchadin> jed56: got you
09:49:06 <jed56> IMHO, this is more a Rally problem
09:49:36 <alexchadin> jed56: that's was strange decision, I agree
09:50:14 <vincentfrancoise> alexchadin: As I see it, I would fix this on the Rally side as well as jed56 said
09:50:28 <acabot> junjie : do you plan to work on additional strategies ?
09:51:02 <junjie> not yet
09:51:10 <junjie> will do more this year
09:51:50 <acabot> junjie : ok if you can register your BPs before the mid-cycle it would be great
09:52:08 <acabot> junjie : we will be able to prioritize them
09:52:15 <junjie> got it, i will check with team
09:52:25 <acabot> junjie : thx
09:52:31 <alexchadin> vincentfrancoise: I will discuss this problem with Andrey Kurilin, he is rally senior developer
09:52:48 <jed56> alexchadin: okay
09:52:53 <acabot> tkaczynski : did you manage to get funding for the mid-cycle ?
09:53:39 <tkaczynski> acabot: no, I'm not going. but I will switch my working hours and Susanne will organize a conf call or something
09:53:55 <acabot> tkaczynski : ok thx
09:54:05 <acabot> any other discussion to open ?
09:54:29 <jed56> no for me
09:54:36 <acabot> I forgot to complete OSIC form
09:54:51 <acabot> #action acabot complete the OSIC form by next week
09:55:14 <tkaczynski> acabot: what is OSIC form? is that something everyody must do?
09:55:52 <acabot> tkaczynski : no no its the OpenStack Innovation Center to request a cluster to test Wathcer
09:56:38 <acabot> #info watcher-puppet has been added to gerritbot to get notifications on our IRC channel
09:56:39 <tkaczynski> acabot: ok, thanks
09:56:56 <acabot> so we can close the meeting
09:57:00 <acabot> thx
09:57:02 <acabot> bye
09:57:12 <jinquan> bye
09:57:17 <jed56> bye
09:57:19 <tkaczynski> bye
09:57:23 <danpawlik> bye
09:57:27 <alexchadin> bye
09:57:29 <jed56> have a nice day or afternoon
09:57:34 <danpawlik> u2
09:57:37 <ostroverkhov> bye
09:57:38 <acabot> #endmeeting