14:00:09 <acabot> #startmeeting watcher
14:00:11 <openstack> Meeting started Wed Apr 20 14:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'watcher'
14:00:16 <vincentfrancoise> o/
14:00:18 <acabot> hi
14:00:19 <alexchadin> o/
14:00:26 <edleafe> \o
14:01:01 <acabot> meeting agenda #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#20.2F06.2F2016
14:01:12 * alex_xu curious why no response from the rebot
14:01:36 <jed56> hello
14:01:48 <edleafe> alex_xu: what response were you missing?
14:02:07 <acabot> #topic Announcements
14:02:26 <alex_xu> edleafe: no worries, that is my network problem, huge network delay
14:02:32 <acabot> slides for the summit have been finalized yesterday
14:02:53 <acabot> I will share it on gdrive after our meeting
14:03:25 <acabot> #info agenda for Watcher meetings in Austin is available #link https://wiki.openstack.org/wiki/Design_Summit/Newton/Etherpads#Watcher
14:03:33 <sballe_> o/
14:03:53 <acabot> I hope proposed date are fine for everybody
14:04:10 <acabot> tuesday pm, wednesday am & thursday am
14:04:33 <jwcroppe_> Howdy
14:04:41 <edleafe> acabot: I will be in Nova sessions mostly, but will try to make any Watcher sessions I can
14:04:41 <acabot> please let me know if you want to change the timeslots
14:04:51 <acabot> edleafe : sure, thx ed
14:05:43 <acabot> #info I also opened an etherpad for our discussions #link https://etherpad.openstack.org/p/watcher-newton-design-session
14:06:04 <acabot> feel free to add topics you want to discuss, I plan to complete it y EOW
14:06:54 <jwcroppe> acabot: great
14:07:09 <acabot> any other announcement ?
14:07:54 <acabot> #topic Review Action Items
14:08:25 <acabot> #info scoring module spec has been merged #link https://review.openstack.org/#/c/289880/
14:08:36 <jed56> great!
14:08:47 <acabot> I +2/+1 as sballe_ already +2 it before moving to newton
14:09:12 <jwcroppe> https://review.openstack.org/#/c/307870/ just needs workflow
14:09:47 <acabot> #info Mitaka specs moved to implemented folder
14:10:07 <acabot> sballe_ could you +1 the workflow on https://review.openstack.org/#/c/307870/
14:10:31 <tkaczynski> acabot: sorry for being late, thanks for merging!
14:10:54 <acabot> tkaczynski : sorry for having to wait for me ;-)
14:11:23 <tkaczynski> no worries, it did not block the implementation...
14:11:46 <acabot> #info Provide efficacy indicators looks good, so sballe_ could you do a final review ? #link https://review.openstack.org/#/c/283449/
14:11:48 <jed56> #action sballe review https://review.openstack.org/#/c/307870/
14:12:15 <acabot> #action sballe_ review  https://review.openstack.org/#/c/283449/
14:12:57 <acabot> https://review.openstack.org/301774 & https://review.openstack.org/#/c/286153/ needs reviews from core
14:13:22 <acabot> #action acabot sballe_ jwcroppe review asap https://review.openstack.org/301774 & https://review.openstack.org/#/c/286153/
14:13:49 <jwcroppe> acabot: will do
14:14:02 <acabot> jwcroppe : https://review.openstack.org/#/c/287019/ needs a status, any update on tpeoples side ?
14:14:55 <jwcroppe> acabot: not sure what you mean by 'needs a status' ?
14:15:18 <acabot> jwcroppe : we were waiting for tpeoples additions
14:15:39 <jwcroppe> acabot: agreed - ok.... tpeoples ^^^
14:17:07 <acabot> #action tpeoples complete https://review.openstack.org/#/c/287019/ and retarget for Newton
14:18:08 <acabot> #info on Watcher there is a lot of reviews open on #link https://review.openstack.org/#/q/status:open++branch:master+topic:bp/get-goal-from-strategy
14:18:48 <dtardivel> I reviewed all watcher & python-watcherlcient patchsets
14:19:05 <acabot> thx dtardivel, we need more reviewers on this code
14:19:24 <acabot> sballe_ any reviewer available on Intel side ?
14:19:30 <dtardivel> It works on devstack
14:20:28 <jinquan> acabot i can  reviews some
14:20:32 <tkaczynski> I also did some good amount of code reviews this week
14:20:59 <dtardivel> As discussed with vincentfrancoise, we will add some bug/wishlist later on this feature
14:21:03 <acabot> tkaczinski : thats right :-) thx
14:21:34 <acabot> alexchadin : is https://review.openstack.org/#/c/297590/ still a WIP ?
14:22:08 <alexchadin> acabot: i will remove WIP tag and make some little changes when spec is merged
14:22:15 <vincentfrancoise> tkaczynski, dtardivel thanks for the reviews :)
14:22:32 <acabot> alexchadin: ok I would like to have your spec merged before the summit
14:22:54 <alexchadin> Me too:)
14:23:19 <acabot> https://review.openstack.org/#/c/305596/ needs a new PS
14:23:43 <acabot> #action jinquan add a new PS to https://review.openstack.org/#/c/305596/
14:24:04 <jinquan> ok
14:24:17 <jinquan> push  tomrrow
14:24:47 <vincentfrancoise> jinquan: I'll try and review it when you push it ;)
14:24:49 <acabot> jinquan : ok thx
14:25:00 <acabot> #info there are code impacts on Watcher cli & watcher dashboard from get-goal-from-strategy
14:25:18 <acabot> #topic Blueprint/Bug Review and Discussion
14:25:51 <acabot> #info there are still a couple of specs that need to be re-targeted to Newton
14:26:06 <acabot> I have added comments on them to wake-up the commiter
14:26:24 <acabot> but if its not done by EOW, I will do it myslef
14:26:59 <acabot> so please check that your current open specs are targeted to Newton, thx
14:27:04 <jinquan> vincentfrancoise thank you for your review
14:27:06 <tkaczynski> a friendly reminder about making design decision for the scoring module implementation - I've sent an email to the openstack-dev list :) I would really appreciate your opinion about that
14:27:08 <sballe_> I am back. it is bring kids to work day today at Intel and this meesed up my schedule
14:27:41 <acabot> sballe_ you can show them what an openstack meeting is ;-)
14:27:51 <jed56> acabot: lol
14:27:53 <sballe_> lol
14:28:06 <jed56> tkaczynski: I'm going to friendly reponse to you :)
14:28:15 <jed56> respond
14:28:25 <tkaczynski> jed56: thanks, much appreciated :)
14:28:32 <jed56> again sorry for the delay
14:28:55 <jed56> I hope that tpeoples jwcroppe edleafe ect can also answer
14:28:59 <tkaczynski> no need to sorry, I understand people are busy
14:29:14 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/092437.html
14:29:27 <jed56> because they very deep knowledge of openstack rules
14:29:31 <edleafe> tkaczynski: my question from the last meeting was how often that information changes
14:30:10 <edleafe> IOW, is it changing every minute, or once an hour, or very rarely, or ...
14:30:25 <tkaczynski> edleafe: in my opinion not very often. basically every time somebody will register/unregister/install a scoring plugin
14:31:04 <edleafe> tkaczynski: then it should be written to a database instead of making repeated calls over RPC for something that will rarely change
14:31:21 <edleafe> tkaczynski: keeping the DB entry in sync is a non-issue
14:31:23 <tkaczynski> in production I guess once setup it might work for weeks
14:32:16 <jwcroppe> yeah - sorry for the delayed response, also talking on a phone call now too :)
14:32:38 <tkaczynski> edleafe: thanks for your opinion, point noted :)
14:33:35 <acabot> #info our next milestone is Newton 1 (May 30th) #link https://launchpad.net/watcher/+milestone/newton-1
14:33:58 <acabot> we have 4 BPs already in review
14:34:19 <acabot> so next week, we will have to prioritize BPs
14:34:40 <alexchadin> I looked through https://blueprints.launchpad.net/watcher/+spec/continuously-optimization
14:34:53 <acabot> so if you have any feature you would like in Watcher, please submit a BP by EOW and we will go through it next week
14:35:28 <acabot> alexchadin : yes, this one has been registered by sballe_ and is very important
14:35:41 <acabot> alexchadin : we should definitely have it for Newton
14:35:43 <alexchadin> I had a project that runs algorithms (strategies in Watcher) regulary
14:35:57 <sballe_> yes that is one I am very interested in
14:36:05 <alexchadin> I may take care of it
14:36:29 <acabot> alexchadin : are you going to Austin next week ?
14:36:53 <alexchadin> Unfortunatly not:(
14:37:16 <acabot> ok I will keep on record that you may be interested to implement
14:37:18 <alexchadin> I was so close to it, but there was непредвиденные обстоятельства
14:37:26 <alexchadin> I was so close to it, but there was unseen circumstances
14:37:30 <sballe_> alexchadin: that is fine. I just want to make sure we discuss the design whihc of course we will. it might be good for us to do some white boarding in Austin
14:38:08 <acabot> sballe_: thats what I'm planning to do on wednesday session
14:38:14 <alexchadin> I may be in IRC or smth like this to cooperate with you
14:38:17 <acabot> I will put it in the ertherpad
14:38:22 <acabot> ok
14:38:36 <sballe_> acabot: cool!
14:38:42 <acabot> alexchadin : do not hesitate to write things in the etherpad as well
14:38:59 <alexchadin> acabot: sure
14:39:22 <acabot> sballe_: is Mrittika coming to Austin ?
14:40:20 <acabot> #topic Open Discussion
14:40:53 <sballe_> acabot: Not sure
14:40:59 <acabot> jed56 asked for a new core on specs during my holidays
14:41:16 <sballe_> Because she is not my BU I have not seen the list of attendees
14:41:32 <acabot> I think having 2 cores off at the same time will not happen so often
14:42:03 <acabot> but if anyone wants to candidate as core on Watcher specs, feel free to send a mail on the ML
14:42:45 <alexchadin> ML?
14:42:46 <acabot> Shall we keep uuid field as part of POST method in API?
14:43:01 <acabot> alexchadin : sorry openstack-dev mailing list
14:43:09 <alexchadin> thx
14:43:21 <alexchadin> I asked question about uuid
14:43:43 <dtardivel> Another point about Watcher Mitaka released version. I think we missed to include new version .pot file for tranlation. Do we need to push quickly a new PS ?
14:44:50 <alexchadin> I was pushed this commit https://review.openstack.org/#/c/302293/ last week
14:45:41 <alexchadin> After discussion with vincentfrancoise we decided to keep uuid as optional attribute
14:46:23 <alexchadin> But I think there is some problems with it
14:46:51 <jed56> IMHO, we should remove that in that in the watcher api
14:47:13 <alexchadin> If we provide an ability to user to set uuid field there may be some collisions
14:47:30 <alexchadin> jed56: +1
14:47:44 <jed56> alexchadin: the collision is not a problem
14:49:17 <alexchadin> Should I open a new bug related to this problem?
14:49:30 <jed56> because we will not let the user the possibility
14:49:33 <jed56> to set his uuid
14:50:04 <jed56> ( my opinion )
14:51:02 <vincentfrancoise> jed56: agreed
14:51:17 <vincentfrancoise> So should we make a whishlist bug for it?
14:51:18 <acabot> any action to take on this subject ?
14:51:32 <jed56> vincentfrancoise: we could create a bug
14:51:41 <dtardivel> +1
14:52:00 <jed56> this is not a priority : nice to have :)
14:52:31 <acabot> #action alexchadin submit a bug regarding UUID deletion in watcher API
14:52:31 <alexchadin> Also I can fix it
14:53:08 <jed56> alexchadin: yes of course you can every bugs in watcher you wants :)
14:53:13 <jed56> *fix
14:53:16 <acabot> dtardivel : regarding the pot file, I think we can still release a fix before the summit
14:53:21 <vincentfrancoise> alexchadin: can you put a link to this meeting in the bug description then?
14:53:32 <alexchadin> vincentfrancoise: yeap
14:53:33 <dtardivel> jed56: only triaged ones ;)
14:53:44 <vincentfrancoise> alexchadin: cool :)
14:53:50 <acabot> dtardivel : so it depends if it can be done and merged before EOW
14:54:05 <jed56> dtardivel: yes : -)
14:57:15 <acabot> #info no IRC meeting next week due to the summit
14:57:27 <dtardivel> a new .pot file has been added in one of the bp/get-goal-from-strategy patchsets
14:57:39 <acabot> glad to see you all next week
14:57:49 <alexchadin> Have a nice summit!
14:57:51 <tkaczynski> +2 :)
14:57:55 <jinquan1> +1
14:58:06 <acabot> bye
14:58:10 <jinquan1> BYE
14:58:15 <vincentfrancoise> I'll follow you guys on the etherpad ;)
14:58:17 <tkaczynski> bye
14:58:17 <vincentfrancoise> bye
14:58:20 <acabot> #endmeeting