14:00:15 <jed56> #startmeeting watcher
14:00:16 <openstack> Meeting started Wed Apr  6 14:00:15 2016 UTC and is due to finish in 60 minutes.  The chair is jed56. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:19 <openstack> The meeting name has been set to 'watcher'
14:00:28 <jed56> hi everyone
14:00:29 <sballe_> o/
14:00:33 <AndChat|176409> Hi
14:00:40 <tkaczynski> hi
14:00:47 <jed56> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#04.2F06.2F2016
14:01:04 <vincentfrancoise> o/
14:01:17 <vtech> o/
14:01:33 <jed56> #topic Announcements
14:01:36 <tkaczynski> is jed56 the new acabot? :)
14:01:51 <jed56> tkaczynski: acabot is in holidays :)
14:01:56 <alexchadin> Hi
14:02:09 <jed56> #info we released Watcher mitika-rc-final yesterday with some delay with official schedule.
14:02:21 <jed56> The April 1st was finally a joke ;)
14:02:21 <sballe_> great job everybody
14:02:23 <alexchadin> Great!
14:02:31 <jed56> The RC-final details are available at #link https://launchpad.net/watcher/+milestone/mitaka-rc-final
14:02:40 <jed56> There is three new watcher packages
14:02:54 <jed56> watcher v0.26.0 python-watcherclient v0.22.0 and finally watcher-dashboard v0.2.0
14:03:08 <jed56> The documentation of watcher has been updated (0.26.0) #link https://factory.b-com.com/www/watcher/doc/watcher/index.html
14:03:21 <jed56> thanks everyboy!
14:03:26 <jed56> everybody
14:03:40 <jed56> any other announcement ?
14:04:51 <sballe_> the slides for the summit are close to being done. I have an Intel person review the slides next week
14:05:14 <jed56> sballe_: great! you share again the link please
14:05:18 <jed56> can
14:05:25 <sballe_> let me find it
14:05:30 <jed56> thanks
14:05:46 <sballe_> Here it is: https://docs.google.com/presentation/d/1pGaimFOkpZ66bWH8wWkc5eZLvxFovUj2V3YfZsQMKHE/edit#slide=id.p4
14:06:11 <tkaczynski> it would be good to share some agenda for the summit, especially in context of watcher
14:06:19 <tkaczynski> where/when do we meet etc.
14:07:11 <jed56> tkaczynski: yes it is a good idea, can we organize when acabot will return ?
14:07:37 <sballe_> so my understanding is that we were going ot meet on Tuesday afternoon. But I agree let's have acabot organize that agenda
14:07:49 <tkaczynski> of course, as long as this happens before the summit
14:07:58 <jed56> tkaczynski: yes of course :)
14:08:01 <jed56> #topic Review Action Items
14:08:21 <jed56> There are many specifications which have been reviewed several times. IMHO, we can merge some of them to start the implementation.
14:08:29 <jed56> I would like that these specifications are merged as soon as possible:
14:08:36 <jed56> Watcher Scoring Module  #link https://review.openstack.org/#/c/289880/
14:08:39 <jed56> Provide efficacy indicators #link https://review.openstack.org/#/c/283449/
14:08:44 <jed56> Add Overload standard deviation #link https://review.openstack.org/#/c/286153/
14:08:50 <tkaczynski> jed56 +2 !
14:08:53 <jed56> Who could take some time to look at these reviews in priority, please ?
14:09:05 <sballe_> I will review the scoring engine today
14:09:40 <jed56> sballe_: awesome!
14:09:58 <tkaczynski> I can have a look at the other two if my limited knowledge helps
14:10:02 <sballe_> it takes a long to to review because it is big so I wont; get to the next on euntil tomorrow
14:10:32 <jed56> #action sballe review  #link https://review.openstack.org/#/c/289880/
14:10:34 <vincentfrancoise> I'll try and review some of them as well
14:10:52 <gzhai2> I can review Provide efficacy indicators
14:11:04 <jed56> #action tkaczynski reviews https://review.openstack.org/#/c/283449/  and https://review.openstack.org/#/c/286153/
14:11:17 <jed56> #action ghzai2 review https://review.openstack.org/#/c/283449/
14:11:29 <jed56> We also need to have more more reviews for on Airflow event based migration strategy #link https://review.openstack.org/#/c/275474/
14:12:08 <jed56> tpeoplesvacation: When you plan to send a new patchset for WIP: Cluster model objects wrapper https://review.openstack.org/#/c/287019/
14:12:16 <sballe_> I will look at at: https://review.openstack.org/#/c/275474/
14:12:28 <jed56> #action tpeoplesvacation send a new patchset WIP: Cluster model objects wrapper https://review.openstack.org/#/c/287019/
14:12:49 <jed56> #action sballe review https://review.openstack.org/#/c/275474/
14:13:01 <jed56> We have two new specs from Grigorios Katsaros that need first reviews
14:13:09 <jed56> Graph model describing virtual and physical elements in a data center
14:13:09 <jed56> #link https://review.openstack.org/#/c/298891/
14:13:09 <jed56> Consolidation of multiple Action-plans into a single one
14:13:09 <jed56> #link https://review.openstack.org/#/c/298871/
14:13:20 <sballe_> jed56: are these for now or later release?
14:13:44 <jed56> later release
14:13:55 <jed56> i think
14:14:00 <jed56> but this is my opinion
14:14:18 <sballe_> I'll give link https://review.openstack.org/#/c/298891/ a quick loook but want to focus on things we want to get merged ASAP
14:14:35 <sballe_> jed56: I agree with you on the later
14:15:07 <jed56> sballe_: yes we should focus our effort
14:15:21 <jed56> Since we have released the watcher mitika final the specs are open for Newton
14:15:26 <jed56> #action acabot sballe jwcroppe review #link https://review.openstack.org/#/c/301753/
14:15:40 <jed56> #topic Blueprint/Bug
14:16:25 <alexchad_> i've uploaded bug fix
14:16:26 <alexchad_> https://review.openstack.org/#/c/301190/
14:16:26 <jed56> Many bugs have been merged in  mitika-rc-final thanks to everybody!
14:17:05 <jed56> alexchad_: thanks  i will take a look
14:17:17 <alexchadin> :)
14:17:24 <jed56> We realized that the blueprint get-goal-from-strategy have some lacks in the specification.
14:17:47 <vincentfrancoise> alexchadin: I gave it a +2
14:17:50 <jed56> We will push a new patchset in the watcher-specs asap to tackle the issue of goal syncing and watcher DB schema for goal (the uuid and id problems).
14:17:54 * edleafe is fighting network connectivity today...
14:18:20 <jed56> We noticed that the attribute id is used by oslo.db to handle soft delete feature.
14:18:45 <alexchadin> and this one fix is coming very soon: https://bugs.launchpad.net/watcher/+bug/1532843
14:18:47 <openstack> Launchpad bug 1532843 in watcher "Can create Audit with invalid parameters" [Low,Triaged] - Assigned to Alexander Chadin (joker946)
14:19:55 <jed56> #link https://review.openstack.org/#/c/301774/
14:20:22 <jed56> this is a WiP
14:21:01 <jed56> gzhai2 tpeoplesvacation  we will add uuid and id https://review.openstack.org/#/c/301774/8/doc/source/images/get_goal_from_strategy_class_diagram.png,unified
14:21:14 <vincentfrancoise> gzhai2: In this, we add back the ID and UUID just like tpeoplesvacation was requesting + clarified how we sync goals and strategies with the Watcher DB
14:21:44 <gzhai2> vincentfrancoise: Great!
14:21:46 <jed56> gzhai2: thanks for your reviews
14:22:28 <vincentfrancoise> I actually started to work on making these changes
14:23:04 <vincentfrancoise> So you can work on your BP asap
14:23:40 <gzhai2> vincentfrancoise: My BP?
14:25:18 <vincentfrancoise> gzhai2: yes https://blueprints.launchpad.net/watcher/+spec/optimization-threshold
14:26:00 <gzhai2> vincentfrancoise: you mean I rebased my patch against your patch set?
14:26:01 <vincentfrancoise> gzhai2: because your BP has a dependency on mine
14:26:10 <vincentfrancoise> on yours*
14:26:36 <gzhai2> ok. you mean change the spec accroding to your spec, right?
14:26:49 <vincentfrancoise> gzhai2: when I will be done, yes
14:27:07 <vincentfrancoise> gzhai2: no just your code I mean
14:27:26 <gzhai2> got it.
14:27:33 <jed56> any other bugs or blueprints ?
14:29:34 <jed56> okay let's continue
14:29:38 <jed56> #topic open discussion
14:30:08 <jed56> We have to postpone some blueprints and bugs from mitaka to newton.
14:30:13 <jed56> Do we need to retarget blueprints from Mitaka to Newton in watcher-specs ?
14:30:47 <jed56> IMHO, every can move his own blueprint to newton
14:30:55 <jed56> *everybody
14:31:02 <sballe_> +1
14:31:30 <gzhai2> ok
14:31:30 <jed56> you can rebase your patchset to https://review.openstack.org/#/c/301753/
14:31:53 <jed56> or you can wait that this patchset is merge
14:32:35 <jed56> #action acabot sballe jwcroppe review #link https://review.openstack.org/#/c/301753/
14:32:53 <jed56> Before the Openstack Summit in AUSTIN, we should run a battery of tests on watcher to be sure that everything is working (Watcher and the available strategies).
14:32:57 <jed56> Who could take some time to deploy on test watcher on their own infrastructure ?
14:34:01 <vincentfrancoise> I actually test every single changeset against a multinode devstack
14:34:16 <jed56> vincentfrancoise: did you try every strategies ?
14:34:42 <vincentfrancoise> Yes apart from the outlet temp one since I don't have the IPMI metrics
14:34:44 <gzhai2> I can cover outlet temperature strategy
14:35:06 <sballe_> gzhai2: +1
14:35:06 <jed56> #action gzhai2 test watcher with outlet temperature strategy
14:35:12 <alexchadin> I try strategies sometime
14:35:17 <gzhai2> vincentfrancoise: You need one Node Manager machine:)
14:35:19 <vincentfrancoise> for the vm_workload_conslidation, I just ran it once
14:35:42 <jed56> What is the strategy we wants to show at Openstack Summit ?
14:35:45 <alexchadin> I have test cluster with 4 nodes
14:36:04 <vincentfrancoise> only 2 nodes on my side
14:36:08 <jed56> alexchadin: great! how many VMs ?
14:36:32 <alexchadin> now about 10, can raise up to 100
14:36:49 <vincentfrancoise> I am currently waiting for https://review.openstack.org/#/c/299809/ to be merged so we can have mutinode tempest tests on the gate
14:36:51 <alexchadin> it's just work env
14:37:53 <jed56> #action acabot organize the agenda for the Openstack Summit (where/when/)
14:38:51 <jed56> someone wants to add something ?
14:39:59 <gzhai2> who can review https://review.openstack.org/#/c/292188/
14:40:46 <jed56> #action jed56 vincentfrancoise https://review.openstack.org/#/c/292188/
14:41:01 <gzhai2> thanks!
14:42:04 <tkaczynski> #endmeeting :)
14:42:16 <jed56> yes i think so
14:42:16 <jed56> :)
14:42:19 <jed56> bye
14:42:20 <jed56> #endmeeting