14:01:10 <acabot> #startmeeting watcher
14:01:11 <openstack> Meeting started Wed Mar 30 14:01:10 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:14 <openstack> The meeting name has been set to 'watcher'
14:01:17 <acabot> hello
14:01:23 <brunograz> hi
14:01:25 <gzhai2> hello
14:01:35 <edleafe> #endmeeting\o
14:01:35 <sballe_> o/
14:01:36 <acabot> #info agenda https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F30.2F2016
14:01:40 <edleafe> doh!
14:01:48 <sballe_> o/
14:01:48 <edleafe> \o
14:01:48 <tkaczynski> hi
14:01:56 <acabot> edleafe : nice try;-)
14:01:58 <jed56> (*_*)
14:02:05 <edleafe> acabot: heh
14:02:15 <sballe_> acabot: can you give me access to the slides?
14:02:25 <sballe_> email is sleipnir012@gmail.com
14:02:56 <alexchadin> hi
14:03:03 <tpeoples> Hi
14:03:13 <acabot> sorry just refresh the agenda
14:03:19 <acabot> and the link should work now
14:03:35 <acabot> #topic Announcements
14:04:18 <acabot> #info contributing page https://wiki.openstack.org/wiki/Watcher/Contributing#Blueprints has been updated to reflect discussions of past meetings about bugs and BPs states
14:05:01 <acabot> #info a final version of slides for the OpenStack summit is available at https://docs.google.com/presentation/d/1pGaimFOkpZ66bWH8wWkc5eZLvxFovUj2V3YfZsQMKHE/edit?usp=sharing
14:05:30 <sballe_> +1
14:05:58 <acabot> as the summit schedule is now available, we can start defining meeting times for Watcher
14:06:26 <acabot> we will be 4 people from bcom, dtardivel, vincentmahe, xavier & acabot
14:06:50 <sballe_> intel will be sballe, tkaczynski and nishi
14:07:00 <acabot> who will be there from IBM ?
14:07:07 <sballe_> gzhai2: are you coming too?
14:07:25 <gzhai2> sballe_: No :(
14:07:34 <sballe_> I asked for you to attend so I was hoping you could
14:08:04 <acabot> tpeoples: will you be at the summit ?
14:08:06 <gzhai2> budget...
14:08:14 <sballe_> hmmm
14:08:15 <tpeoples> acabot: jwcroppe, me, i'm guessing edleafe? plus some other people from my team since we're based in austin
14:08:30 <acabot> tpeoples: ok ;-)
14:08:40 <edleafe> I'll be making the long journey from San Antonio...
14:08:49 <acabot> ok
14:08:51 <sballe_> lol
14:09:07 <acabot> can we start freezing timeframes for meeting or its too early ?
14:09:09 <sballe_> my family will be going ot San Antonio sightseeing while I am at OpenStack
14:09:22 <sballe_> acabot: sure.
14:09:38 <tpeoples> +1
14:09:40 <jinquan> zte will be  me
14:09:50 <sballe_> acabot: I won;t be there Fri due to a personal commitement
14:09:53 <acabot> I had a discussion with hvprash from walmart to set up a meeting on tuesday afternoon
14:10:08 <acabot> jinquan: great to have you there
14:10:16 <sballe_> acabot: Tues afternoon +1
14:10:38 <sballe_> acabot: do we know when the brown bag is?
14:10:39 <jinquan> My main concern is to learn  : )
14:10:46 <acabot> I think we can set a meeting 2 to 6pm tuesday
14:11:02 <sballe_> +1
14:11:33 <acabot> and then plan other meetings on wednesday and thursday
14:11:52 <acabot> so no Watcher meeting on monday
14:12:10 <edleafe> I'll be buried in the nova design summit meetings, but will try to make some Watcher sessions
14:12:36 <acabot> #info Watcher team will met at the summit on Tuesday 2-6pm in the developer lounge
14:12:50 <acabot> any other announcement ?
14:13:23 <acabot> #topic Review Action Items
14:13:48 <acabot> #info "Achieved goal should be returned by each strategy" has been merged
14:13:57 <acabot> thx for the quick review
14:14:14 <gzhai2> acabot: when to merge its code?
14:14:22 <vincentfrancoise> gzhai2: the specs
14:14:39 <acabot> gzhai2: im speaking about the specs now
14:14:50 <gzhai2> sorry.
14:15:09 <acabot> we need reviews on https://review.openstack.org/#/c/286153/ & https://review.openstack.org/#/c/289880/
14:15:25 <acabot> alexstav : thx for adding comments to your last PS
14:16:02 <acabot> tkaczynski : as jed56 did a lot of reviews on the scoring module, we will now review it with dtardivel
14:16:20 <dtardivel> +1
14:16:33 <tkaczynski> acabot: thanks!
14:16:41 <acabot> #action dtardivel review https://review.openstack.org/#/c/289880/
14:16:47 <acabot> #action acabot review https://review.openstack.org/#/c/289880/
14:16:51 <tpeoples> acabot: for the specs that are being pushed to N, shall we abandon from the mitaka directory and add them to the newton dir?
14:17:05 <jed56> tpeoples +1
14:17:19 <acabot> tpeoples : yes we will have to do that but next week as we are still on the mitaka cycle
14:17:21 <edleafe> tpeoples: generally yes - just re-propose for Newton
14:17:39 <acabot> tpeoples: I would ask you to do it next week
14:17:55 <tpeoples> k. my point being i know my BP won't make M so... ok.
14:17:58 <jed56> tkaczynski i will a review the last patchset but for me it  was good
14:18:01 <jed56> :)
14:18:07 <jed56> good job
14:18:37 <acabot> who wants to review https://review.openstack.org/#/c/286153/ ?
14:19:35 <tkaczynski> jed56 thanks :)
14:19:46 <gzhai2> acabot: I can have a look.
14:20:13 <dtardivel> acabot: I think we need now core reviewer on this patchset
14:20:17 <acabot> #info https://review.openstack.org/#/c/283449/ was locked due to licensing issues, but finally its ok so can we merge it ?
14:20:30 <tpeoples> acabot: yes
14:20:40 <acabot> #action gzhai2 review https://review.openstack.org/#/c/286153/
14:21:22 <tpeoples> acabot: spoke with joe, he was fine with it after i explained it to him, but he must not have had time to remove his -1
14:21:24 <acabot> sballe_ : could you please have a look at https://review.openstack.org/#/c/283449/ ? I think its important
14:21:37 <seanmurphy> i can review something if you like
14:22:08 <acabot> #action seanmurphy review https://review.openstack.org/#/c/283449/ thx sean ;-)
14:22:13 <seanmurphy> np
14:22:16 <seanmurphy> by eow?
14:22:39 <jed56> acabot before to merge 283449 we should take some comments into account (   global_score = (nb_empty_nodes/nb_migrations*100) => need to handle the case when this is 0.)
14:22:54 <acabot> edleafe: can we have specs merged in MItaka but implement in Newton ?
14:23:30 <edleafe> Generally, you re-propose specs that didn't get implemented in a given cycle
14:23:44 <edleafe> It's usually automatic approval
14:23:56 <acabot> seanmurphy : ok so before our next meeting would be fine
14:23:58 <edleafe> But sometimes project priorities can change between cycles
14:24:17 <seanmurphy> acabot: ack - will do before next meeting
14:24:23 <edleafe> The re-approval just helps assure that the old spec is still where you want to go
14:24:39 <acabot> edleafe: ok thx
14:25:00 <acabot> tpeoples: https://review.openstack.org/#/c/287019/ when do you plan to make additions ?
14:25:46 <tpeoples> acabot:  it's been on my list just haven't gotten to it yet. i'll put up a non-WIP by tomorrow
14:26:19 <acabot> #action tpeoples set a non-WIP work on https://review.openstack.org/#/c/287019/
14:26:29 <acabot> moving to watcher code
14:26:51 <acabot> the strategy from seanmurphy's team has been merged
14:26:58 <acabot> congrats to the team
14:27:02 <seanmurphy> cool - thanks!
14:27:05 <brunograz> +1
14:27:53 <acabot> #info vincentfrancoise has added a lot of code on the BP "The achieved goal should be returned by each strategy"
14:28:03 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/get-goal-from-strategy
14:28:07 <seanmurphy> we need to take stock and see how and where we can continue to contribute further
14:28:14 <seanmurphy> you will hear more from us!
14:28:28 <acabot> seanmurphy : I hope so !
14:28:31 <gzhai2> acabot: do we plan to merge it in M?
14:28:48 <acabot> gzhai2 : actually it is my plan
14:29:06 <acabot> but do you think the team will be able to review all the code by friday ?
14:29:15 <dtardivel> gzhai2: we need reviewers :)
14:29:30 <gzhai2> Sure. I can try and review this patch series.
14:30:00 <acabot> if we want to have this BP implemented in M (it would be a great improvement), we need reviewers in the next 2 days !
14:30:04 <vincentfrancoise> FYI, I still have 2 changeset to finish and push: 1 for strategies API and the other one for the doc update
14:30:26 <tpeoples> i'll review
14:30:29 <acabot> who will be able to review this code by EOW ?
14:30:38 <vincentfrancoise> which will make a total of 8 changesets
14:30:49 <acabot> #action gzhai2 review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/get-goal-from-strategy asap
14:30:59 <acabot> #action tpeoples review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/get-goal-from-strategy asap
14:31:15 <acabot> #action dtardivel review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/get-goal-from-strategy asap
14:32:13 <acabot> https://review.openstack.org/#/c/297556/ also needs reviews but as it is nested with the current work from vincentfrancoise, I think we will move it to N
14:33:07 <acabot> https://review.openstack.org/#/c/292188/ need a new PS as there is a merge conflict and additional reviews
14:33:38 <gzhai2> i'll ask junjie
14:33:55 <gzhai2> But still need another round review after it.
14:34:00 <acabot> #action junjie submit a new PS for https://review.openstack.org/#/c/292188/
14:34:13 <acabot> gzhai2: yes
14:35:00 <acabot> on watcher client, there are 2 reviews open linked to "The achieved goal should be returned by each strategy" & "Enable strategy parameters "
14:35:19 <acabot> so we already discussed them previously
14:35:24 <jinquan> i will review after  junjie submit a new PS for https://review.openstack.org/#/c/292188/
14:35:49 <acabot> #action jinquan review https://review.openstack.org/#/c/292188/
14:36:19 <acabot> #info Watcher-dashboard will be impacted by The achieved goal should be returned by each strategy implementation in Watcher, we need a contributor to work on it
14:36:58 <acabot> if we merge this BP in M, we need to fix watcher-dashboard before the summit
14:37:17 <acabot> anyone who wants to work on it ?
14:37:56 <acabot> always hard to find someone who wants to work on horizon :-D
14:38:09 <acabot> #topic Blueprint/Bug Review and Discussion
14:38:31 <acabot> #info RC-Final target 5 BPs & 9 bugs and is due on April 1st https://launchpad.net/watcher/+milestone/mitaka-rc-final
14:39:36 <acabot> after our discussion today, we can keep https://blueprints.launchpad.net/watcher/+spec/get-goal-from-strategy & https://blueprints.launchpad.net/watcher/+spec/basic-cloud-consolidation-integration
14:39:51 <acabot> jinquan : what about https://blueprints.launchpad.net/watcher/+spec/select-destinations-filter ?
14:39:54 <tkaczynski> acabot: scoring module BP is not targeted?
14:40:18 <acabot> tkaczynski : we moved it to N last week
14:40:22 <jinquan> i am start coding from 29.march
14:40:53 <acabot> tkaczynski : did I made a mistake ?
14:41:03 <tkaczynski> acabot: I thought that we want to get BP now and implementation in N
14:41:19 <jinquan> i think it need take a few days for me
14:41:39 <acabot> tkaczynski : yes sorry, what I'm focusing right now is what we have implemented in M
14:41:49 <tkaczynski> acabot: from my perspective it doesn't really matter. but I'd like to close working on the BP and start implementing it
14:42:12 <tkaczynski> so as long as the BP will get merged soon, I'm good
14:42:23 <acabot> jinquan : ok so I suppose you wont be able to deliver it before April 1st right ?
14:43:16 <jinquan> acabot, yes  :(
14:43:34 <acabot> gzhai2: ok to move https://blueprints.launchpad.net/watcher/+spec/optimization-threshold to N ?
14:43:52 <tkaczynski> sballe_: do you think we need to have scoring module BP for Mitaka?
14:44:20 <gzhai2> acabot: ok. But I want a try as this patch is not so big:)
14:44:44 <gzhai2> acabot: but it depends on progress of vincent's patch series.
14:45:19 <acabot> gzhai2 : the problem I see is that we will merge vincentfrancoise code on Friday and you wont have time to integrate it before we freeze the rc-final
14:45:37 <gzhai2> acabot: ok.
14:45:42 <gzhai2> move to N
14:45:45 <acabot> #action acabot move 3 BPs from Mitaka RC-final to Newton-1
14:45:56 <jed56> sorry about that gzhai2
14:46:09 <acabot> #topic Open Discussion
14:46:41 <acabot> Should we split in different repos the framework code and the available strategies ?
14:47:29 <acabot> as we start to have more and more strategies available on watcher, it would be nice to separate reviews from Watcher framework and strategies
14:47:54 <gzhai2> currently it's ok i think.
14:48:07 <acabot> what do you think about having a dedicated repo for strategies implementation ?
14:48:18 <gzhai2> Who'll maintain the new strategy repo?
14:48:37 <acabot> it will be one more repo with client and dashboard
14:49:12 <tpeoples> i'm not sure we'll get much benefit from that. i'd rather keep them together tbh, at least for the time being if nothing other than for simplicity
14:49:28 <acabot> the idea is mostly to separate concerns, reviewing strategies is very different tha watcher framework
14:50:26 <jed56> the main idea is to have the "core" strategies and the others and to facilitate the "incubation"
14:50:32 <gzhai2> How deep you separate them? A total new project with client/dashboard/API?
14:50:34 <tkaczynski> acabot tpeoples: I think having a separate repo for strategies will dogfood the strategy pluggability
14:50:50 <dtardivel> acabot: Could we maintain only a list of available strategy into a new Watcher wiki section. Each strategy implementation will have its dedicated GIT repo, outside Watcher one.
14:51:15 <jed56> maybe is to early ?
14:51:18 <tkaczynski> we need a simple way to add strategies to watcher as plug-ins, including goals and everything
14:51:19 <seanmurphy> to me this looks too decoupled
14:51:35 <acabot> it would be nice to have core reviewers for strategies (not the same as the framework core)
14:51:40 <seanmurphy> i think it is better to keep the together for now
14:51:42 <tpeoples> i agree with seanmurphy. maybe we can plan to discuss this at the summit?
14:51:53 <acabot> tpeoples : +1
14:51:58 <jed56> +1
14:52:05 <seanmurphy> i think the strategy code would soon become orphaned
14:52:12 <acabot> its probably to early now, I will add it to the agenda for the summit
14:52:38 <acabot> seanmurphy : its a big risk
14:53:08 <alexchadin> +1
14:53:09 <acabot> any other open discussion for today ?
14:53:52 <dtardivel> acabot: if we create a new repo, who will maintain it later ? not the core team ...
14:54:49 <acabot> dtardivel : I think we need to define a specific core team for maintaining strategies
14:55:09 <acabot> dtardivel : so we need more people involved ;-)
14:56:59 <jed56> acabot i agree
14:57:17 <acabot> ok so thank you everyone
14:57:23 <acabot> have a good day/night
14:57:27 <tkaczynski> bye
14:57:32 <gzhai2> thank you acabot
14:57:32 <vincentfrancoise> bye
14:57:40 <acabot> #endmeeting