14:00:40 <acabot> #startmeeting watcher
14:00:41 <openstack> Meeting started Wed Mar 23 14:00:40 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:45 <openstack> The meeting name has been set to 'watcher'
14:00:49 <acabot> hi everyone
14:00:54 <jinquan> hi
14:00:56 <edleafe> o/
14:00:58 <vincentfrancoise> o/
14:00:59 <tpeoples> o/
14:01:00 <vtech_> o/
14:01:00 <seanmurphy> hi all
14:01:19 <sballe_> o/
14:01:37 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F23.2F2016
14:01:39 <tkaczynski> hi
14:01:56 <jed56> hi
14:02:19 <acabot> #topic Announcements
14:02:51 <acabot> #info we released Watcher RC-1 yesterday (3 days later than the official schedule)
14:02:58 <acabot> sorry for that
14:03:15 <acabot> our next target is RC-final (April 1st)
14:03:20 <acabot> and its not a joke ;-)
14:03:27 <sballe_> :)
14:03:34 <seanmurphy> ;-)
14:03:52 <alexchadin> hi
14:04:06 <hvprash> hi
14:04:17 <acabot> #info Slides for the Austin summit are available for reviews #link https://docs.google.com/presentation/d/1xzuIgmvRXiwTxv4R0al8DZoFd7u6OA6hx6aUrid7JPw/edit?usp=sharing
14:05:08 <acabot> sballe_: do you want me to integrate Joe & Sean comments ?
14:05:25 <acabot> xavier already did updates yesterday
14:05:28 <sballe_> yes thta is my plans. I have been sick the last 3 days
14:05:51 <sballe_> but feeling better today
14:06:02 <acabot> #action sballe_ integrate comments in Austin slides
14:07:03 <acabot> #info PTL election has ended and I'm the only candidate so if anyone is against nominating myself, please say something now ;-)
14:07:16 <tpeoples> :D
14:07:28 <sballe_> I would nominate you too
14:07:48 <sballe_> you have done a great job
14:07:55 <acabot> thx
14:08:10 <acabot> #info acabot will be Watcher PTL for Newton
14:08:11 <tkaczynski> +1 for acabot :)
14:08:18 <vincentfrancoise> +2
14:08:31 <sballe_> +1
14:08:43 <jinquan> +1
14:08:47 <alexchadin> +1
14:24:17 <acabot> ok in this case just synchronise yourself to avoid rebasing
14:24:26 <vincentfrancoise> gzhai2: I can push a first version by EOD so you can compare
14:24:44 <gzhai2> vincentfrancoise: merged?
14:24:46 <vincentfrancoise> gzhai2: but it's not ideal
14:24:54 <vincentfrancoise> no just push for review
14:25:14 <gzhai2> ok. I'll have a look. Other issues do you have?
14:25:28 <tkaczynski> vincentfrancoise: if we are talking about few days to implement that, it will not affect me really. I should be able to use your changes easily
14:25:47 <acabot> #action vincent francoise push code for 'Achieved goal should be returned by each strategy' asap
14:25:50 <vincentfrancoise> gzhai2: I don't have any strategy_para_info
14:26:06 <acabot> #action vincentfrancoise push code for 'Achieved goal should be returned by each strategy' asap
14:26:06 <vincentfrancoise> tkaczynski: you are much less affected by this than gzhai2
14:26:23 <gzhai2> vincentfrancoise: I'll add it:) If we just conflict with strategy, I think it's ok.
14:26:39 <tkaczynski> vincentfrancoise: this is why I'm saying I'm good :)
14:26:47 <acabot> #action sballe_ jwcroppe BIG PRIORITY review https://review.openstack.org/#/c/293862/
14:27:17 <sballe_> ok
14:27:34 <acabot> alexstav: https://review.openstack.org/#/c/286153/ needs a new PS based on last reviews
14:27:47 <acabot> #action alexstav add a new PS for https://review.openstack.org/#/c/286153/
14:28:07 <alexchadin> alexchadin*
14:28:26 <acabot> WIP: Cluster model objects wrapper needs reviews https://review.openstack.org/#/c/287019/
14:28:39 <acabot> #action alexchadin add a new PS for https://review.openstack.org/#/c/286153/
14:29:01 <tpeoples> #action tpeoples to submit non-WIP review for https://review.openstack.org/#/c/287019/
14:29:05 <acabot> tpeoples: I think you can start working on work items
14:29:06 <alexchadin> I'll add it tomorrow or by friday
14:29:09 <tpeoples> i will start on implementation this week as well
14:29:24 <acabot> tpeoples: cool
14:29:37 <seanmurphy> regarding https://review.openstack.org/#/c/287019/ - i had point abt integration with notification system
14:29:38 <acabot> please update the BP status on launchpad
14:29:44 <tpeoples> will do acabot
14:29:45 <seanmurphy> is this an architectural change?
14:30:05 <tpeoples> no seanmurphy, it has been part of the architecture plans
14:30:25 <seanmurphy> ok - i did not realize this
14:30:27 <tpeoples> there was always an intention to have watcher connected to the same message bus as all other services
14:30:35 <seanmurphy> ok - got it
14:31:02 <acabot> Add specification for Watcher Scoring Module needs reviews https://review.openstack.org/#/c/289880/
14:31:28 <acabot> thanks tkaczynski for your detailed answers
14:31:46 <acabot> it would be great to have more reviewers on the scoring module
14:32:27 <dtardivel> acabot: I will review it
14:32:27 <tkaczynski> acabot: sure, I'm trying to keep this up to date and improve the spec. thanks to jed56 for his comments!
14:32:52 <acabot> #action dtardivel acabot review https://review.openstack.org/#/c/289880/
14:33:02 <hvprash> i will review too
14:33:13 <acabot> Provide efficacy indicators is locked on licences discussion https://review.openstack.org/#/c/283449/
14:33:32 <acabot> #action hvprash review https://review.openstack.org/#/c/289880/
14:34:03 <acabot> tpeoples : there is a concern from IBM about licenses
14:34:16 <acabot> tpeoples : any update on this ?
14:34:40 <tpeoples> acabot: no, let me ask joe when i talk to him next
14:34:52 <tpeoples> he's traveling internationally
14:34:56 <acabot> #action jwcroppe clarify the license problem on https://review.openstack.org/#/c/283449/
14:35:18 <acabot> thats it for specs
14:35:25 <tpeoples> just took a look, don't think it'll be an issue really
14:35:37 <tpeoples> aren't other projects starting to look into using voluptuous as well?
14:36:15 <acabot> #info regarding watcher and python-watcherclient, a couple of bugs have been fixed
14:36:59 <jed56> I think zull
14:37:06 <jed56> is using voluptuous
14:37:15 <tpeoples> yeah, i don't think there's an issue. i'll ask him what was up there
14:37:24 <acabot> ok thx
14:37:26 <jed56> https://github.com/openstack-infra/zuul/blob/master/requirements.txt#L12
14:37:32 <acabot> #topic Blueprint/Bug Review and Discussion
14:38:06 <acabot> the RC-final details are available at #link https://launchpad.net/watcher/+milestone/mitaka-rc-final
14:38:17 <jed56> monasca is using also voluptuoushttps://github.com/openstack/monasca-api/blob/master/requirements.txt#L18
14:38:26 <acabot> as you can see, we wont be able to deliver everything by end of next week !
14:38:41 <dtardivel> voluptuous was part of global requirement, before we decided to use it. Is it not a sufficient guarantee ? what is the condition to introduce new lib into global requirements ?
14:39:11 <tpeoples> it should be sufficient dtardivel. i don't know what jwcroppe had an issue with really
14:39:57 <acabot> gzhai2: do you plan to implement "Allow specification of threshold defining when optimization is needed" for rc-final ?
14:40:09 <gzhai2> yes
14:40:33 <gzhai2> The due date?
14:40:55 <acabot> we need to have the code avaiable for review by EOW
14:41:10 <acabot> to have one full week to review and merge
14:41:10 <gzhai2> No problem.
14:41:15 <acabot> thanks
14:42:00 <acabot> tpeoples: I suppose I can postpone the object wrapper to Newton right ?
14:42:27 <acabot> tkaczynski : same for scoring module
14:42:42 <tpeoples> yeah. i'll start working on it but getting that done *and* reviewed by april 1st is not going to happen
14:43:17 <acabot> seanmurphy: your code has been reviewed but dtardivel is still working on it
14:43:28 <seanmurphy> ok - cool - thanks
14:43:35 <acabot> so we were not able to merge it last week
14:43:44 <acabot> but it will be merged for mitaka
14:44:00 <tkaczynski> acabot: yes, scoring module (implementation) has no way to happen before April 1st. the spec is still not approved
14:44:09 <acabot> vincentfrancoise can you assign yourself "The achieved goal should be returned by each strategy" .
14:44:11 <acabot> ?
14:44:29 <vincentfrancoise> acabot: ok will do it now
14:44:47 <acabot> alexchadin: when do you plan to submit your code for review ?
14:45:08 <alexchadin> Once my spec pass, no?
14:45:24 <alexchadin> I already have a code and unit-tests
14:45:25 <acabot> alexchadin: I know that your code is already on github ;-)
14:45:30 <alexchadin> yeeees
14:45:36 <sballe_> lol
14:45:49 <alexchadin> Should I publish it?
14:45:56 <alexchadin> To the gerrit
14:46:07 <acabot> alexchadin: you can submit it as WIP
14:46:24 <acabot> and I will move the BP to Newton
14:46:41 <acabot> as the specs need more work
14:46:57 <acabot> I suggest to move all low priority bugs to Newton cycle
14:47:11 <alexchadin> Where can i submit it as WIP? At launchpad?
14:47:35 <acabot> just add a "WIP" at the beginning of your commit message
14:47:45 <acabot> and submit it to gerrit
14:48:00 <dtardivel> and pass WORKFLOW indicator tp -1
14:48:06 <dtardivel> to -1
14:48:09 <alexchadin> Oh, okay, i'll do it tomorrow
14:48:10 <acabot> #action alexchadin submit the code for Watcher Overload standard deviation algorithm as WIP
14:48:49 <acabot> #action acabot clear the rc-final BP and bugs priorities according to meeting logs
14:49:04 <acabot> #topic Open Discussion
14:49:15 <acabot> What is the good practice to re-assign a bug to someone ?
14:49:52 <tpeoples> leave a comment on launchpad asking the status. if you don't hear within a reasonable time (a day, two days?) then just move it to the other person
14:49:58 <tpeoples> imo
14:50:06 <dtardivel> tpeoples: +1
14:50:17 <sballe_> +1
14:50:25 <gzhai2> yes. ask current owner if want to reassign.
14:50:28 <tpeoples> don't want to just move it since the person may have a changeset locally they haven't pushed up yet
14:50:55 <jinquan> +1
14:51:06 <vincentfrancoise> +1
14:51:09 <jed56> +2
14:51:36 <acabot> #info when a bug should be reassigned, leave a comment on launchpad asking the status. if you don't hear within 2 days then just move it to the other person
14:51:39 <dtardivel> Can we just remove the assignee, and let someone else take the bug later ?
14:52:22 <acabot> dtardivel: IMO, you can set it as unassigned
14:52:28 <gzhai2> assigne to nobody should be ok.
14:52:31 <dtardivel> perfect
14:52:34 <jinquan> It should also be acceptable
14:52:36 <tpeoples> i think that might make sense. i know looking at other projects i initially skip over looking to work on bugs that have owners
14:52:38 <tpeoples> so yeah
14:53:37 <acabot> edleafe: I saw you got a -1 on https://review.openstack.org/#/c/276840/
14:54:11 <acabot> do you plan to get more reviewers on this ?
14:54:29 <dtardivel> acabot: I will have a look on bugs and add re-assign comment if necessary
14:54:40 <edleafe> acabot: yeah, now that Newton is open, I'll push more for it
14:54:50 <sballe_> edleafe: thx +1
14:55:01 <jinquan> acabot:  Is appropriate to start coding now ? because https://review.openstack.org/#/c/283449/ has something need discuss
14:55:07 <acabot> #action dtardivel reassign bugs after acabot priority check
14:55:22 <acabot> edleafe : thx
14:55:45 <vincentfrancoise> acabot: shouldn't we re-open undone Mitaka BPs to now target Newton in watcher-specs?
14:55:47 <acabot> jinquan: I think you can start coding
14:56:19 <jinquan> ok
14:56:40 <acabot> jinquan: there is a dependency on vincentfrancoise work
14:56:42 <jed56> jinquan: IMHO, you need to discuss with vincentcrnoise
14:56:52 <acabot> jinquan: I will add it in launchpad
14:57:15 <jinquan> get it
14:57:24 <acabot> jinquan: so please review vincentfrancoise code before starting implementing this
14:57:30 <vincentfrancoise> acabot: just added the dependency on launchpad
14:57:35 <jed56> beacause there is dependency for getting the indicators from pythonwatcherclient
14:57:48 <jed56> acabot :thansk
14:57:51 <acabot> jinquan : there is an open BP with specs merged here https://blueprints.launchpad.net/watcher/+spec/select-destinations-filter
14:58:30 <acabot> jinquan: it could be a good way to enter Watcher code
14:58:41 <acabot> with a bit of stevedore to deal with
14:58:53 <jinquan> ok  i will read it thank you
14:59:18 <acabot> thank you
14:59:30 <acabot> time to close the meeting
14:59:34 <jed56> bye
14:59:35 <acabot> bye
14:59:36 <vincentfrancoise> bye everyone
14:59:38 <tkaczynski> bye
14:59:39 <alexchadin> ину
14:59:40 <sballe_> bye
14:59:41 <alexchadin> bye
14:59:43 <hvprash> bye
14:59:43 <gzhai2> bye
14:59:43 <seanmurphy> bye!
14:59:46 <acabot> #endmeeting