14:00:31 <acabot> #startmeeting watcher
14:00:32 <openstack> Meeting started Wed Mar  9 14:00:31 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:36 <openstack> The meeting name has been set to 'watcher'
14:00:47 <acabot> hi
14:00:49 <sballe_> o/
14:00:51 <vtech> o/
14:00:55 <brunograz> o/
14:01:07 <alexchadin> o/
14:01:25 <acabot> agenda for today https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F09.2F2016
14:01:54 <acabot> please do not hesitate to add items in the agenda before the meeting
14:02:32 <acabot> alexchadin : I did not mention your spec as you are offline last week but if you need to discuss it, please add it to the agenda
14:02:54 <alexchadin> I already added it
14:03:02 <alexchadin> about 10 minutes ago
14:03:23 <acabot> :-)
14:03:30 <acabot> I didn't see it, thx
14:03:34 <alexchadin> :)
14:04:01 <dtardivel> hi
14:04:06 <tkaczynski> hi
14:04:12 <acabot> my team will join the meeting in 2 minutes (we were in another meeting just before)
14:04:24 <hvprash> hi
14:04:43 <acabot> #topic Announcements
14:04:45 <jed56> hi
14:04:47 <edleafe> o/
14:05:20 <acabot> #info mitaka-3 version has been released last week
14:05:40 <acabot> there is only one new package (watcher)
14:05:47 <seanmurphy> hi guys
14:06:00 <acabot> available as version 0.24 on pypi and launchpad
14:06:13 <vincentfrancoise> o/
14:06:24 <dtardivel> and docker hub ;)
14:06:35 <acabot> all the documentation and docker images have been updated
14:06:42 <seanmurphy> new relative to what?
14:06:42 <acabot> thx to dtardivel
14:06:45 <seanmurphy> mitaka-2?
14:07:21 <acabot> seanmurphy: yes I mean we didn't release new packages for watcher-dashboard and python-watcherclient for mitaka-3
14:07:50 <acabot> so only the watcher package has been updated
14:07:55 <seanmurphy> ah, ok - good stuff - got it
14:08:02 <vmahe> hi
14:08:25 <acabot> #info our talk has been accepted for the summit #link https://www.openstack.org/summit/austin-2016/summit-schedule/events/7108
14:08:30 <acabot> this is a great news
14:09:00 <jed56> congratulation to everybody :)
14:09:03 <dtardivel> +1
14:09:32 <tkaczynski> :)
14:09:40 <edleafe> \o/
14:09:41 <sballe_> +1
14:09:53 <acabot> sballe_: we should probably set up a conf call next week to discuss the content and share it with you guys as soon as possible
14:10:14 <sballe_> acabot: yes thta was my plans as well as work on a first draft today
14:10:34 <sballe_> Also I would like to figure out if we should do a brown bag talk
14:10:46 <acabot> #action sballe_ start working on a first draft of slides for the summit
14:10:46 <sballe_> with the other submission that wasn't accepted
14:11:07 <sballe_> it is just a 10 mins talk but it would allow for more PR around watcher
14:11:07 <seanmurphy> well done guys!
14:11:52 <sballe_> I suggest that we have authors that are not on the accepted talk do the bown bag
14:12:11 <acabot> sballe_: I think we can register for a brown bag talk to give a quick overview of Watcher but not to run the hands-on lab
14:12:30 <sballe_> yes I agree. the hands on lab or the demo migth be too muhc
14:12:35 <sballe_> much
14:12:47 <acabot> #info unfortunately our hands-on lab has not been selected
14:12:52 <sballe_> :-(
14:13:18 <acabot> but maybe we can schedule a quick demo of 10 minutes max at the end of our talk
14:13:19 <sballe_> Intel didn't select it either for our both due to being too early in the cycle
14:13:33 <acabot> ok
14:13:38 <sballe_> Once we are under the big test all this will be a slam dunk
14:13:40 <jed56> you can maybe display a short video (demo)
14:14:08 <sballe_> jed56: I agree we could do a quick overview and the a short vide
14:14:11 <sballe_> video
14:14:30 <acabot> #action acabot set up a conf call to discuss the content of the talk
14:14:32 <sballe_> jed56: will you take on to submit to the brown bag?
14:15:17 <acabot> #action acabot register for a brown bag session with Watcher demo
14:15:47 <acabot> #info PTL election should start on friday https://wiki.openstack.org/wiki/PTL_Elections_March_2016
14:16:11 <acabot> as we are not in the big tent, we cant use the official repo of the foundation
14:16:41 <acabot> I suggest we use the ML for nominations
14:16:50 <acabot> by March 17th
14:16:58 <jed56> sballe: I will not be at the Openstack Summit
14:17:55 <acabot> if there are multiple candidates, we will find a tool for voting
14:18:22 <acabot> #action acabot ask for PTL nominations on the ML
14:19:05 <acabot> #info WSME is not maintained and we use it in Watcher http://lists.openstack.org/pipermail/openstack-dev/2016-March/088658.html
14:19:33 <acabot> according to this thread there is not really an alternative to WSME
14:19:56 <vincentfrancoise> the guys from Sahara are apparently using flask
14:20:09 <vincentfrancoise> see #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/088802.html
14:20:57 <sballe_> acabot: I nominate and vote for you
14:21:02 <acabot> anyone here has experienced flask ?
14:21:16 <acabot> sballe_ : thx ;-)
14:21:17 <sballe_> we used it in LBaaS and Akanda is using it too.
14:21:26 <hvprash> i have worked on flask earlier
14:22:15 <acabot> hvprash : great, any idea about the effort to move from WSME to flask ?
14:22:18 <sballe_> Pecan is the alternative rigth
14:22:41 <acabot> we are using Pecan & WSME in Watcher
14:22:53 <alexchadin> Having some project with flask, good experience about it
14:23:02 <hvprash> acobot, though i am still a newbie in watcher can go through the wsme code and take a stab
14:23:33 <acabot> ok can we open a wishlist bug on this or a BP is needed ?
14:23:34 <jed56> +1
14:23:58 <sballe_> +1
14:24:17 <vincentfrancoise> IMHO, we just need to do one to set in stone the API validation bit
14:24:40 <acabot> #action alexchadin hvprash have a look at the impact of moving from WSME to Flask
14:24:47 <seanmurphy> we’ve used it in some project before - it’s lightweight, well designed and easy to use
14:24:54 <jed56> we can maybe wait that an another  openstack project to do it : )
14:25:05 <jed56> acabot do you know if there is a deadline ?
14:25:29 <vincentfrancoise> Also, people may suggest some other alternatives. SO I would wait another week or so before spending some time on flask
14:25:37 <acabot> jed56: no deadline yet as WSME is still usable
14:25:40 <dtardivel> jed56: I don't think wsme is declared as deprecated for now
14:25:57 <jed56> so, IMHO we can wait :)
14:26:04 <dtardivel> +1
14:26:14 <vincentfrancoise> +1
14:26:22 <acabot> ok lets check this ML thread next week for alternatives
14:26:52 <jed56> #action acabot check ML for WSME
14:27:00 <acabot> #info Watcher stated as a ported to Python 3 project on RDO blog #link http://blogs.rdoproject.org/7894/status-of-python-3-in-openstack-mitaka
14:27:29 <jed56> thanks vincentfrancoise for the initial effort :)
14:27:40 <acabot> #info new milestones discussed last week were added to launchpad
14:28:02 <acabot> next milestone is RC-1 targeted for March 18th
14:28:19 <acabot> any other annoucement ?
14:28:25 <acabot> announcement
14:29:00 <acabot> #topic Review Action Items
14:29:39 <acabot> workload balance migration strategy spec has been reviewed multiple times #link https://review.openstack.org/#/c/276586/
14:30:19 <acabot> IMHO, I dont think its perfect right now but we need to start implementing
14:31:14 <acabot> sballe_: any news regarding Junjie contributions ?
14:31:23 <sballe_> yes
14:31:49 <sballe_> Junjie will work on Workload stratgey and edwin on threadshold. We got that straightn out last week
14:32:54 <sballe_> edwin is in a all week hackathon so he can't attend. He presented Wtahcer and people got excite
14:32:57 <sballe_> excited
14:33:13 <acabot> ok so Junjie will work on implementing the workload strategy ?
14:33:19 <sballe_> yes
14:33:40 <acabot> ok so we need to update the spec as Edwin was stated as the main contributor
14:33:42 <sballe_> there was some confusion but we got it back on the rigth track
14:34:19 <sballe_> Junjie: spec+code for stratgegy. Edwin spec+code on optimization threashold
14:34:20 <acabot> #action junjie update the assignee for the workload balance spec as junjie
14:34:39 <acabot> sballe_: seems a lot easier to me :-)
14:35:02 <sballe_> yeah me 2
14:36:09 <acabot> #action gzhai2 start implementing optimisation threshold
14:36:52 <acabot> alexstav: Add Overload standard deviation strategy spec is open for reviews right ?
14:37:02 <alexchadin> Yeap:)
14:37:12 <seanmurphy> i can review if it helps
14:37:30 <acabot> #action sballe_ jwcroppe acabot seanmurphy review https://review.openstack.org/#/c/286153/
14:37:37 <alexchadin> I've made implementation already
14:38:05 <alexchadin> It works!
14:38:08 <acabot> alexchadin : thats great, wait for the reviews on your spec before pushing the code on Watcher repo
14:38:20 <alexchadin> Yeah-yeah, of course
14:38:43 <acabot> but thats great to hear that you have been able to deliver a new strategy for Watcher !
14:39:24 <alexchadin> I've made science article based on that algorithm
14:39:36 <acabot> Provide efficacy indicators needs reviews #link https://review.openstack.org/#/c/283449/
14:40:03 <acabot> alexchadin : if the article is public, please add a link in your spec
14:40:54 <acabot> who wants to review the efficacy indicators specs ?
14:41:26 <acabot> :-)...so I will !
14:41:37 <alexchadin> acabot: Okay, i'll add it lately
14:41:43 <alexchadin> later*
14:41:50 <acabot> #action acabot review https://review.openstack.org/#/c/283449/
14:42:20 <acabot> WIP: Cluster model objects wrapper needs reviews #link https://review.openstack.org/#/c/287019/
14:42:44 <acabot> tpeoples is sick today but he is waiting for feedback on this work
14:43:05 <jed56> acabot i will review this spec next week
14:43:29 <acabot> edleafe: it seems you uploaded the last PS right ?
14:43:49 <edleafe> acabot: yeah, that was to fix it
14:43:58 <acabot> #action jed56 review https://review.openstack.org/#/c/287019/
14:43:59 <edleafe> I seem to somehow have deleted the spec from PS 2
14:44:04 <dtardivel> acabot: I will review Taylor's spec also
14:44:19 <acabot> #action dtardivel review https://review.openstack.org/#/c/287019/
14:44:40 <acabot> edleafe: ok
14:45:01 <acabot> Add specification for Watcher Scoring Module needs reviews #link https://review.openstack.org/#/c/289880/
14:45:22 <sballe_> I will review
14:45:34 <acabot> tomasz: can we start reviewing it ?
14:45:38 <jed56> me too next week
14:45:43 <tkaczynski> definitely!
14:46:06 <acabot> #action sballe_ acabot jed56 review https://review.openstack.org/#/c/289880/
14:46:27 <tkaczynski> I'd appreciate your feedback and I will start working on implementation anyway
14:46:29 <acabot> Provide a way to filter available hosts that can be targeted for a migration needs a spec, this one is on my side
14:46:39 <acabot> sorry for the delay
14:46:55 <acabot> #action acabot submit a spec for https://blueprints.launchpad.net/watcher/+spec/select-destinations-filter
14:47:33 <acabot> as you can see there are a lot of specs in review, so please everyone take some time to review them
14:47:59 <acabot> it will avoid losing time when the code will be reviewed
14:48:40 <acabot> on Watcher vincentfrancoise is still working on db purge engine #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/db-purge-engine
14:49:05 <acabot> vincentfrancoise: do you think we can set this BP as implemented by EOW ?
14:49:22 <vincentfrancoise> they are currently waiting for reviews
14:49:51 <vincentfrancoise> so I'm waiting for feedbacks
14:50:29 <acabot> and you already had feedback from tpeoples and dtardivel
14:50:40 <acabot> anyone wants to review this code ?
14:51:15 <vincentfrancoise> yeah I'm mainly waiting for a review from tpeoples to see if my changes are OK to him
14:51:54 <dtardivel> acabot: I'm testing again db purge latest patch on devstack
14:51:54 <acabot> ok as gzhai is away all the week, we can probably merge it as soon as tpeoples is back
14:52:36 <acabot> #action dtardivel tpeoples review code on db purge engine https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/db-purge-engine
14:53:01 <acabot> Integrated consolidation strategy with watcher needs reviews #link https://review.openstack.org/#/c/289259/
14:53:37 <acabot> brunograz vtech : thx a lot for your contribution
14:53:57 <jed56> +1 next week :)
14:54:01 <acabot> brunograz vtech  : can we start reviewing your code ?
14:54:12 <brunograz> acabot: yes
14:54:20 <acabot> ok thx
14:54:39 <brunograz> the code is failing on jenkins becuase the code for the bug is not merged yet
14:54:51 <acabot> #action jed56 review https://review.openstack.org/#/c/289259/
14:55:10 <sballe_> I'll review that one too
14:55:21 <acabot> #action sballe_ review https://review.openstack.org/#/c/289259/
14:55:26 <sballe_> thx
14:55:31 <brunograz> thanks ;-)
14:55:34 <acabot> #topic Blueprint/Bug Review and Discussion
14:55:45 <jed56> brunogrz you can link your patchset
14:55:45 <acabot> 5 minutes left on bugs
14:56:21 <brunograz> #link https://review.openstack.org/#/c/288465/
14:56:40 <acabot> #info 37 bugs have been fixed in mitaka-3 release
14:56:42 <sballe_> acabot  have a quick update in the open topic.
14:57:05 <acabot> #topic Open discussions
14:57:10 <sballe_> :)
14:57:10 <jed56> I want to says that you can link to patchset 288465 with 289259
14:57:28 <vincentfrancoise> brunograz: as jed56 said, can you rebase your strategy PS on top of the bug so that both pass the tests? (I can help you out on #openstack-watcher if you want)
14:57:34 <sballe_> The nova live migraion people are interested in understand how they can work with us
14:57:57 <sballe_> they are from Intel and I am meeting to dicuss initial stuff tomorrow
14:58:07 <brunograz> vincentfrancoise: yes, we can do it - we talk abt this offline
14:58:12 <sballe_> so this is just as an FYI
14:58:18 <dtardivel> acabot: just a remark about bugs. Take care about waiting for "triaged" step before working on a bug. Or if it's critical, please contact Core team to have a quick statement ...
14:58:23 <acabot> sballe_ : looks great, is edleafe in the discussion ?
14:58:23 <vincentfrancoise> brunograz: ok
14:58:43 <edleafe> acabot: not yet :)
14:58:51 <acabot> #info about bugs. Take care about waiting for "triaged" step before working on a bug. Or if it's critical, please contact Core team to have a quick statement ...
14:58:52 <sballe_> acabot: not yet since this is intel internal only for now. Will bring edleafe in for our next meeting
14:59:05 <sballe_> edleafe: heads up :)
14:59:17 <acabot> ok thx
14:59:22 <dtardivel> bye
14:59:30 <sballe_> already ? bye
14:59:30 <edleafe> sballe_: ready! :)
14:59:33 <jed56> I think we need to fix our tempest gate  (devstack)
14:59:45 <acabot> we can have a f2f meeting in Auustin on this topic
14:59:45 <sballe_> edleafe: :)
14:59:53 <brunograz> bye
14:59:53 <sballe_> +1
14:59:55 <vincentfrancoise> bye
15:00:08 <sballe_> bye
15:00:11 <hvprash> bye
15:00:11 <acabot> #endmeeting