14:00:08 <acabot> #startmeeting watcher
14:00:09 <openstack> Meeting started Wed Jan 20 14:00:08 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <openstack> The meeting name has been set to 'watcher'
14:00:15 <vincentfrancoise> o/
14:00:16 <acabot> hi
14:00:20 <brunograz> hi
14:00:23 <dtardivel> o/
14:00:23 <edleafe> \o
14:00:34 <jed56> -o/
14:00:51 <slaweq> hello
14:01:04 <jwcroppe_> o/
14:01:18 <acabot> our agenda for today https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#01.2F20.2F2016
14:01:25 <tkaczynski> hi
14:01:36 <vmahe> hi
14:02:16 <acabot> #topic Announcements
14:02:27 <tpeoples> \\o
14:02:33 <acabot> quick update regarding mitaka-2
14:02:54 <acabot> #info : 11 BPs en 41 bugs targeted for mitaka-2
14:03:00 <sballe> o/
14:03:17 <acabot> it is more BPs than Nova project :-)
14:03:24 <acabot> so thanks to all of you
14:03:31 <jwcroppe> +10000
14:03:39 <sballe> one quick annoucement from Intel. bzhou has decided to leave intel and will be replaced with edwin ...
14:03:59 <acabot> just to remind you that we had only 3 BPs for mitaka-1 !
14:04:04 <sballe> I cannot remember edwin;s irc
14:04:14 <gzhai> I'm edwin
14:04:24 <acabot> hella gzhai
14:04:31 <gzhai> hello
14:04:31 <sballe> Welcome gzhai :-)
14:04:34 <acabot> welcome
14:04:43 <vtech> o/
14:04:45 <jed56> Welcome gzhai!
14:04:47 <tpeoples> hi gzhai
14:04:57 <vincentfrancoise> welcome gzhai :)
14:05:03 <gzhai> hello all:)
14:05:18 <sballe> acabot: I am working with nishi and team to get the bps in asap. she has been super busy reworkign the story around the demo and showing it to senior folks at intel
14:05:19 <acabot> gzhai : could you please register to watcher drivers ? https://launchpad.net/~watcher-drivers
14:05:36 <gzhai> acabot: ok
14:05:47 <acabot> sballe: is gzhai the new Intel core contrib ?
14:05:56 <sballe> yes please
14:06:05 <sballe> acabot:  yes please
14:06:35 <acabot> #action dtardivel update gzhai & bzhou core dev status on launchpad
14:06:47 <sballe> bzhou told me he still want to work on watcher when he moves over to his new company but I think let's see if they let him and maybe he can earn his core status the regular way
14:06:54 <acabot> I suppose we remove the core feature to bzhou ?
14:07:08 <acabot> sballe : +1
14:07:17 <tkaczynski> hi Tomasz here, should I also register to watcher drivers?
14:07:29 <acabot> #action acabot reassign BPs & bugs to gzhai
14:07:32 <sballe> tkaczynski: Welcome too
14:07:52 <sballe> yes please register to watcher drivers tkaczynski
14:08:09 <acabot> tkacynski : hi Tomasz, yes you can
14:08:34 <jed56> everybody can register to watcher drivers for  contributing : -)
14:08:35 <acabot> #action gzhai tkaczynski register to watcher-drivers
14:08:46 <acabot> any other annoucement so far ?
14:09:04 <sballe> no from me
14:09:14 <acabot> #topic Review Action Items
14:09:17 <jwcroppe> just that it will be nice to see everyone in Austin in two weeks :)
14:09:47 <acabot> jwcroppe : :-D, we will be 10 in Austin which is great !
14:09:50 <sballe> +1'
14:09:50 <dtardivel> tkaczynski: what is your username on Launchpad ?
14:11:10 <jwcroppe> btw, for mid-cycle - we will order lunch in every day
14:11:18 <sballe> +10000
14:11:19 <tkaczynski> dtardivel I don't have username there yet
14:11:22 <acabot> we need a status on https://blueprints.launchpad.net/watcher/+spec/optimization-threshold, gzhai do you plan to take it ?
14:11:24 <sballe> so working lunches ;-)
14:11:42 <acabot> sballe : ok ;-)
14:11:58 <gzhai> acabot: I assume that
14:12:03 <tkaczynski> I'm just starting to organize myself here, looking around :)
14:12:13 <sballe> is bzhou in the meeting?
14:12:19 <acabot> gzhai : ok thx
14:12:42 <gzhai> sballe: seems no
14:12:58 <sballe> gzhai: ok I was just checking
14:13:14 <sballe> so gzhai thx for taking that over
14:13:27 <acabot> #info the spec regarding efficacy indicator is in review #link https://review.openstack.org/#/c/266446/ but I need to add work items
14:14:42 <seanmurphy> i have a basic q which i think touches on this
14:14:45 <jwcroppe> acabot: thanks, any other urgent specs to review?
14:15:04 <seanmurphy> do we assume that there can be multiple strategies which can achieve a specified goal then?
14:15:18 <seanmurphy> and the efficacy indicator is the way of arbitrating between them
14:15:19 <seanmurphy> ?
14:15:20 <acabot> jwcroppe : no
14:15:47 <acabot> seanmurphy : I think we should discuss that in specs
14:15:49 <jwcroppe> I think we decided that we'd start with 1 strategy<-->1 goal to start with ?
14:15:56 <seanmurphy> ok
14:16:03 <seanmurphy> that seems more reasonable to me
14:16:07 <acabot> jwcroppe: right
14:16:26 <acabot> #info a lot of improvement on Watcher doc is ongoing with many reviews
14:16:51 <acabot> jwcroppe: I'd like to have your review on https://review.openstack.org/#/c/266461/
14:17:17 <acabot> vmahe did a great job putting sequence diagrams in Watcher doc
14:17:36 <sballe> I need to leave. Sorry about that
14:17:47 <acabot> and I think its important for everyone who wants to understand how Watcher is working right now
14:17:57 <acabot> sballe: ok
14:18:03 <gzhai> sballe: bye
14:18:15 <acabot> #action jwcroppe review https://review.openstack.org/#/c/266461/
14:18:32 <sballe> bye
14:18:34 <jwcroppe> acabot: will do
14:19:02 <acabot> #info dynamic loading of Actions handlers in the Watcher Applier feature is now available in Watcher
14:19:17 <jwcroppe> that's excellent
14:19:32 <acabot> but there is still  a bit work to do
14:19:42 <acabot> on contract and oslo
14:19:49 <jwcroppe> acabot: in mid-cycle can we carve out an hour time slot (maybe one evening Mon/Tue) to see demo of some of these new feature?
14:19:50 <seanmurphy> is there a list of known actions?
14:20:25 <acabot> jwcroppe : yes I will add on hour of demo time on tuesday
14:20:41 <jwcroppe> ok, great - we can make it maybe last topic in evening
14:20:48 <jed56> You can take a look to the entry points
14:20:57 <jed56> but we can update the documentation to list them
14:21:16 <jed56> we have ( Migrate,Nop, Sleep, Change hypervisor State )
14:21:27 <seanmurphy> jed56: perhaps i can discuss this offline with you - thanks
14:21:37 <jed56> https://github.com/openstack/watcher/blob/master/setup.cfg#L49
14:21:53 <acabot> #info vincentfrancoise has set up Tempest in Watcher
14:22:07 <jed56> seanmurphy : yes of course
14:22:12 <acabot> and he needs reviews on https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/tempest-basic-set-up
14:22:42 <acabot> anyone want to review tempest ?
14:22:53 <tpeoples> yeah i will when i get time
14:23:08 <acabot> #action tpeoples review Tempest set up https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/tempest-basic-set-up
14:23:19 <acabot> tpeoples: thx
14:23:41 <acabot> #info tpeoples is working on external API versionning WIP
14:24:00 <tpeoples> yeah, hoping to get that done in the next 1-2 days
14:24:12 <tpeoples> i decided to follow what magnum is doing with their clients
14:24:20 <tpeoples> think that will get us the flexibility we need
14:24:32 <acabot> tpeoples: it would be great to have it for mitaka-2
14:24:42 <jwcroppe> tpeoples: can you put me on the review for that when you post it up?
14:24:43 <tpeoples> yep, will try :)
14:25:41 <acabot> #info watcher-client has been updated to reflect changes in Watcher
14:25:55 <jed56> tpeoples : what are the clients you want to support ?
14:26:15 <jed56> neutron, keystone, ... ?
14:26:16 <tpeoples> jed56: just going to do nova, ceilometer, glance, cinder for now
14:26:25 <tpeoples> but it will be easy to add more
14:26:30 <tpeoples> +keystone
14:26:30 <jed56> okay cool
14:26:53 <acabot> there is still on review open on watcher-client #link https://review.openstack.org/#/c/266473/
14:27:37 <acabot> seanmurphy : do you want to share your work in progress now ?
14:27:52 <seanmurphy> we have not had much to update tbh
14:27:52 <gzhai> tpeoples: means watcher-client can call nova/ceilometer's API?
14:27:58 <seanmurphy> we said we would produce a spec for today
14:28:11 <seanmurphy> on how to implement our load consolidation mechanism in watcher
14:28:17 <seanmurphy> we will produce a draft of it later
14:28:32 <tpeoples> gzhai: implicitly yes, but you won't be able to do `watcher ceilometer-meter-list` or anything like that
14:28:41 <seanmurphy> i sent a link of the draft gdoc to you so you can see
14:28:43 <acabot> seanmurphy : seems great, thx for the update
14:28:47 <tpeoples> just that there will be a standard way to fetch other project's clients from the watcher backend
14:28:54 <jed56> seanmurphy : you can follow the doc ( https://github.com/openstack/watcher/blob/master/doc/source/dev/plugins.rst)
14:28:54 <seanmurphy> tbh it’s our first time writing such a spec
14:29:05 <seanmurphy> so we’re not sure if we’re hitting all the right notes
14:29:10 <gzhai> tpeoples: got it.
14:29:17 <seanmurphy> jed56: thanks - will do
14:29:38 <seanmurphy> the process is that we git push to watcher-specs, right?
14:30:13 <acabot> seanmurphy : no :-p
14:30:41 <edleafe> tpeoples: is the watcher API stable enough yet to consider controlled versioning, like microversions?
14:30:45 <acabot> #action seanmurphy look at https://wiki.openstack.org/wiki/Watcher/Contributing#Your_first_commit
14:30:54 <seanmurphy> ok - will do
14:31:14 <tpeoples> i would say not yet edleafe
14:31:19 <acabot> seanmurphy : we will iterate on your spec through Gerrit
14:31:26 <seanmurphy> ok
14:31:33 <edleafe> tpeoples: ok, I didn't think so.
14:31:48 <acabot> seanmurphy : please push it for reviews in watcher-specs/specs/mitaka/approved folder
14:32:02 <jwcroppe> edleafe: IIRC, when we discussed that in Tokyo, we decided to get through the POCs and determine which APIs, etc. are really needed, which need to be updated, etc. and do some 'clean up' before we get to the full-blown microversions, etc. that folks will expect once 'big tent'
14:32:02 <seanmurphy> right - and it should follow the format in https://github.com/openstack/watcher-specs/blob/master/specs/mitaka-template.rst
14:32:36 <acabot> seanmurphy : yes
14:32:38 <edleafe> jwcroppe: that sounds sane
14:32:49 <acabot> #topic Blueprint/Bug Review and Discussion
14:33:24 <acabot> I'd like to have a quick bug list review for mitaka-2 as we still have 17 bugs opened
14:33:33 <acabot> #link https://launchpad.net/watcher/+milestone/mitaka-2
14:34:01 <tkaczynski> dtardivel: I added myself to watcher drivers, waiting for approval
14:34:38 <jwcroppe> acabot: need to attend another meeting, will review any new action items you post for me... I will also review the spec later this afternoon referenced earlier
14:34:48 <dtardivel> tkaczynski: done
14:35:21 <acabot> we need folks for #link https://bugs.launchpad.net/watcher/+bug/1536191 #link https://bugs.launchpad.net/watcher/+bug/1525830 #link https://bugs.launchpad.net/watcher/+bug/1523513
14:35:24 <openstack> Launchpad bug 1536191 in watcher "Bad place for checking goal existence when creating a new audit template" [Low,New]
14:35:26 <openstack> Launchpad bug 1525830 in watcher " Refactored Watcher codebase to add py34 support" [Low,Confirmed]
14:35:27 <openstack> Launchpad bug 1523513 in watcher "Add tests to primitive" [Medium,In progress]
14:36:13 <acabot> and https://bugs.launchpad.net/watcher/+bug/1521636
14:36:14 <openstack> Launchpad bug 1521636 in watcher "MessagingCore - reference to a self.client only defined in children" [Low,In progress]
14:37:43 <acabot> tpeoples: you want to talk about https://bugs.launchpad.net/watcher/+bug/1510188 ?
14:37:44 <openstack> Launchpad bug 1510188 in watcher "Creation of a watcher audit with an unknown audit template generates bad error" [Low,Confirmed] - Assigned to Taylor Peoples (tpeoples)
14:38:07 <tpeoples> yeah, so the fix for this is a tad more complicated i think
14:38:37 <tpeoples> a user could use an audit template to create an audit, then update the audit template to use a totally other goal
14:38:44 <tpeoples> and the audit has no trail of that change
14:38:56 <tpeoples> so the history of the audit would make no sense
14:39:38 <tpeoples> likewise, if someone deletes the audit template, the audit has no way to "know" what goal it had originally
14:40:06 <vincentfrancoise> tpeoples: It's kind of linked to #link https://bugs.launchpad.net/watcher/+bug/1532843 then
14:40:07 <openstack> Launchpad bug 1532843 in watcher "Can create Audit with invalid parameters" [Low,Confirmed]
14:40:21 <tpeoples> i propose that the audit template is simply a holder of the metadata for the audits, and when an audit is created it copies over that metadata so there is no hard link there
14:40:27 <acabot> tpeoples: true but is it the problem targeted by this bug ?
14:40:30 <tpeoples> but i think that is going to require a BP
14:41:01 <acabot> tpeoples: right we need a BP & specs
14:41:01 <tpeoples> yes acabot, because if i fix it, it has implications for listing audits when doing the validation of the audit template
14:41:21 <jed56> +1
14:41:35 <acabot> tpeoples : could you submit a BP wih your first assumption ?
14:41:47 <tpeoples> yes. i will outline the problem in more words
14:42:11 <tpeoples> but long story short, i'm not going to get that bug done since i think we need a more complete solution
14:42:32 <acabot> #action tpeoples submit a BP regarding audit template history management
14:42:49 <acabot> tpeoples : ok I will schedule it for mitaka-3
14:42:55 <tpeoples> sounds good acabot
14:43:16 <acabot> #action acabot schedule https://bugs.launchpad.net/watcher/+bug/1532843 & https://bugs.launchpad.net/watcher/+bug/1510188 for mitaka-3
14:43:18 <openstack> Launchpad bug 1532843 in watcher "Can create Audit with invalid parameters" [Low,Confirmed]
14:43:19 <openstack> Launchpad bug 1510188 in watcher "Creation of a watcher audit with an unknown audit template generates bad error" [Low,Confirmed] - Assigned to Taylor Peoples (tpeoples)
14:43:37 <acabot> #topic Open Discussion
14:43:41 <dtardivel> tpeoples: acabot not sure. bug is only bad return error
14:44:06 <dtardivel> when we try to create an audit with a bad audit template name.
14:44:12 <acabot> dtardivel: you want to fix it with the good error code ?
14:44:45 <tpeoples> the fix for that would break the listing audits (if there are any audits with deleted audit templates)
14:45:08 <dtardivel> I think we can try to return the correct error status in that case. and create a new BP about how to store data for history
14:45:29 <dtardivel> acabot: yes
14:45:43 <dtardivel> acabot: this is the scope of the bug
14:46:19 <tpeoples> dtardivel: let's discuss in irc after the meeting
14:46:26 <acabot> tpeoples: ok
14:46:38 <acabot> cross-project liaison
14:46:58 <acabot> I think it would be great to start having a cross project liaison for Watcher
14:47:19 <acabot> the weekly meeting is at 9pm UTC
14:47:46 <acabot> I'm sure I will be able to atend at 10pm my time
14:47:50 <tpeoples> acabot: there was a note on the ML about this.  it looks like the PTL's were encourage to attend the meeting, but if you aren't interested / can't make the meeting then we should find someone else to do it
14:47:55 <acabot> anyone would be interested in doing it ?
14:48:11 <tpeoples> jwcroppe or sballe may be interested in that role?
14:48:34 <acabot> I suppose but none of them is here :-D
14:49:20 <acabot> #action jwcroppe sballe would you be interested in being cross-project liaison for Watcher ?
14:49:34 <acabot> they will discover it ;-)
14:49:45 <tpeoples> :P
14:50:42 <acabot> slaweq: how is it going with watcher ?
14:51:19 <tpeoples> acabot: what's it?
14:51:58 <acabot> slaweq is one of our first Watcher user ;-)
14:52:12 <acabot> but I'm not sure he is still with us
14:52:14 <jed56> (OVH)
14:52:50 <tpeoples> wow i totally misread your last comment, too early :D
14:53:37 <acabot> I just relealized I forgot to mention taskflow integration by jed56
14:54:22 <acabot> #info taskflow integration is now in review #link https://review.openstack.org/#/c/264142/
14:54:22 <tpeoples> thanks for working on that jed56
14:55:05 <acabot> as we plan to release mitaka-2 on friday EOD, we will need to merge a lot of code tomorrow
14:55:38 <acabot> so please try to review most of the code before
14:56:08 <tpeoples> +1 acabot, lots to do today
14:56:10 <acabot> and set it to -1 if you dont want something to be merged in mitaka-2
14:57:09 <acabot> #info 21 reviews open waiting for mitaka-2
14:58:37 <acabot> #info mid-cycle agenda is available on #link https://wiki.openstack.org/wiki/Watcher_mitaka_mid-cycle_meetup_agenda#Agenda
14:59:06 <acabot> even if you dont plan to be there, please add subjects you would like to be discussed
14:59:23 <acabot> its time to close the meeting
14:59:26 <acabot> thank you
14:59:30 <acabot> bye
14:59:32 <tpeoples> talk to you later
14:59:38 <tkaczynski> bye
14:59:40 <vincentfrancoise> bye
14:59:46 <jed56> bye
14:59:51 <acabot> #endmeeting