14:00:07 <acabot> #startmeeting watcher
14:00:08 <openstack> Meeting started Wed Jan  6 14:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:11 <openstack> The meeting name has been set to 'watcher'
14:00:13 <acabot> hi
14:00:18 <dtardivel> hi
14:00:23 <bzhou> hi
14:00:25 <brunograz> hi
14:00:33 <jed56> hello
14:00:35 <acabot> our agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#01.2F06.2F2016
14:00:42 <jwcroppe> \o
14:00:42 <vincentfrancoise> o/
14:00:50 <sballe> o/
14:00:51 <edleafe> \o
14:00:52 <acabot> happy new year !
14:00:54 <jwcroppe> o/
14:00:58 <sballe> +1
14:00:59 <jwcroppe> greetings
14:01:00 <tpeoples> o/
14:01:01 <dtardivel> bonne année !
14:01:26 <acabot> a lot of things to do today, lets start
14:01:40 <acabot> #topic annoucements
14:02:11 <acabot> #info mid-cycle meetup details are available and shared with the community
14:02:37 <acabot> please register on eventbrite asap if you plan to joins us
14:02:57 <alexstav> Hi guys! :)
14:03:59 <edleafe> link to eventbrite?
14:04:03 <acabot> #info Intel POC has been demonstrated and we will submit a talk for the OpenStack summit related to the demo
14:04:23 <seanmurphy> v cool - well done!
14:04:24 <acabot> #link https://www.eventbrite.com/e/watcher-mitaka-mid-cycle-developer-meetup-tickets-19885187130
14:04:30 <sballe> thanks for you help with getting the poc ready1
14:05:11 <jwcroppe> sballe: cool - any video/details we can see?
14:05:20 <vmahe> hello
14:05:20 <acabot> #info you can look at the video of watcher UI on https://drive.google.com/file/d/0B_h5gjY7WQPMTHZ5dVYybTA3MlE/view
14:05:21 <sballe> that will be the next step.
14:05:45 <sballe> jwcroppe: we are woking on the story around the demo and willl make a movie
14:05:59 <jwcroppe> sballe: great!
14:06:20 <edleafe> sballe: cool!
14:06:32 <jwcroppe> edleafe: https://wiki.openstack.org/wiki/Watcher_mitaka_mid-cycle_meetup_agenda for link to event brite
14:06:54 <edleafe> jwcroppe: acabot beat you to it :)
14:07:05 <sballe> lol
14:07:08 <acabot> after the POC, we know that anyone can add a new strategy in Watcher :-)
14:07:15 <sballe> +1
14:07:19 <bzhou> +1
14:07:26 <jwcroppe> +100
14:07:28 <edleafe> jwcroppe: I'll probably only be able to make it up for 1 day, though
14:07:53 <jwcroppe> edleafe: no prob - would be good to have you
14:07:55 <acabot> edleafe: if you can be there on wednesday
14:08:00 <sballe> edleafe: we can custmize the agenda. I wil be there the 3rd and 4th
14:08:27 <acabot> #topic Review Action Items
14:08:38 <sballe> acabot: jwcroppe I am trying to have Thijs, Nishi and one more person attend the mid-cycle
14:09:13 <acabot> jed56 & vincentfrancoise did a great clean-up in reviews before end of year
14:09:20 <sballe> +1
14:09:24 <jwcroppe> +1
14:09:28 <jwcroppe> thanks guys!
14:09:34 <sballe> +100
14:10:07 <acabot> our current target is mitaka-2 set to January 20th
14:10:11 <dtardivel> new tag 0.22.0 has been created on watcher ( > new pypi package available)
14:11:17 <acabot> https://review.openstack.org/#/c/257189 has been merged but needs improvements (see comments)
14:12:34 <acabot> bzhou: how to you plan to integrate comments ?
14:12:57 <bzhou> yes, we will work on improvements based on demo feedback, thanks.
14:13:06 <acabot> bzhou: do you need a new BP ?
14:13:46 <acabot> this BP https://blueprints.launchpad.net/watcher/+spec/optimization-threshold is one part
14:14:15 <bzhou> acabot: no, the major code is there. Some comments are out of control of watcher, e.g. using nova scheduler filters/weighers
14:14:24 <acabot> bzhou: I'm concerned about having (poc code) in Watcher master branch
14:15:04 <jwcroppe> I think the thresholds are ultimately part of the host aggregate metadata, so that you can have different thresholds for different groups?
14:15:23 <tpeoples> bzhou: we should still be calling into the scheduler to get the possible hosts from its point of view.  the fact that watcher doesn't define the filters doesn't matter
14:15:43 <sballe> acabot: I am not sure it is a problem since it is work in progress and people don't have to use it
14:15:53 <bzhou> the threshold is not part of outlet strategy
14:16:18 <jwcroppe> tpeoples: +1000
14:16:24 <tpeoples> isn't it taking action when the temp reaches a certain value?
14:16:32 <acabot> sballe: ok but we have identified improvements on this code and I dont want to lose it as the review has been merged
14:17:17 <tpeoples> +1
14:17:33 <acabot> sballe: I'd like to know how bzhou will continue working on it and be able to track it (BP or specs or bugs...)
14:17:33 <jed56> +1
14:17:47 <jwcroppe> acabot: I agree, we need a plan to get that PoC code removed I think... would be nice pre end of Mitaka
14:18:05 <bzhou> tpeoples: nova-scheduler has no energy aware filters or weighers
14:18:33 <bzhou> so we have to use our own filters before we can upstream any energy aware filters/weighers
14:18:39 <acabot> jwcroppe: I dont think we need to remove it, its one possible strategy that can be used but there is still work to do on it
14:18:46 <tpeoples> bzhou:  sure, that would be on the specific implementation to handle.  we can't be migrating VMs to hosts that the nova scheduler defines as not valid though
14:18:56 <tpeoples> that's why we still need to use the scheduler
14:18:59 <sballe> I suggest a BP to track
14:19:00 <tpeoples> to get the possible hosts
14:19:17 <jed56> tpeoples:+1
14:19:22 <jwcroppe> bzhou: right, we need the scheduler to get the possible hosts per its filters, and then you can add more filters/logic beyond the scheduler
14:19:23 <bzhou> tpeoples: do we have nova api to get possible hosts?
14:19:25 <tpeoples> i.e., we can't ignore all the other filters that already exist
14:19:25 <edleafe> you can always add custom filters
14:19:35 <edleafe> in addition
14:19:42 <jwcroppe> bzhou: yes, scheduler API has 'select_destinations'
14:19:53 <bzhou> is it a public API?
14:19:58 <jwcroppe> yes, rpcapi
14:20:33 <acabot> bzhou: ok could you submit a BP asap related to nova filters usage ?
14:20:35 <bzhou> maybe I am wrong, but I thought rpcapi is not designed to be used by other projects?
14:20:46 <edleafe> bzhou: correct
14:20:49 <acabot> bzhou : we will have to write a spec for it and will iterate on it
14:21:11 <edleafe> right now scheduler is internal to nova
14:21:15 <sballe> bzhou: I agree rpc is too low
14:21:48 <jwcroppe> edleafe: it's standard practice for OpenStack projects to use rpcapis, IIRC ... same queue
14:22:03 <sballe> jwcroppe: it is?
14:22:14 <bzhou> we do plan to add energy aware filters into nova-scheduler, but I don't we can make it in Mitaka
14:22:24 <sballe> the other issue we have with using rpcapi is that now we are really tied to openstak
14:22:30 <edleafe> jwcroppe: my understanding is that cross-project is via API
14:22:34 <acabot> #action bzhou submit a BP to use nova filters in the inlet temperature strategy
14:22:35 <sballe> +1
14:22:35 <jwcroppe> sballe: I've seen it done several times.  And it's the only option right now for interacting with the scheduler
14:23:03 <bzhou> jwcroppe: do you know where I can find it?
14:23:15 <edleafe> jwcroppe: a reference would be helpful
14:23:18 <sballe> I thinkg we are better off not using rpcapi but let's discuss durign the review of the spec
14:23:19 <bzhou> acabot: got it, thanks
14:23:20 <jwcroppe> Sorry, I don't want to go into the weeds here :)  But, I think the alternative of not using the scheduler rpcapi leaves us open to many 'gotchas' since we are making bad placement decisions
14:23:54 <sballe> jwcroppe: I disagree but we can discuss on the spec
14:24:51 <acabot> lets move this tech discussion on gerrit
14:24:52 <edleafe> I'll ask for ideas in #openstack-nova
14:24:57 <sballe> and if you can get us some references it will help to
14:25:06 <jwcroppe> sballe: sounds good - my concern is that if there are 10 filters defined that indicate hosts should *not* be candidates, but we relocate VMs to them anyway, seems like we defied the placement rules.  From my experience so far, that would result in trying to placement VMs in locations they shouldn't be running
14:25:39 <jwcroppe> bzhou: I'll dig up some examples
14:26:01 <sballe> I like the idea of using the nova filters
14:26:10 <sballe> I am just not sure about rcpapi
14:26:19 <edleafe> sballe: +1
14:26:34 <acabot> lets move on watcher specs please
14:26:41 <jwcroppe> acabot: +1
14:26:46 <sballe> +1
14:27:04 <acabot> could we merge the spec related to Intel POC ? https://review.openstack.org/#/c/252268/
14:27:33 <sballe> yes.
14:27:34 <acabot> as it is already implemented
14:27:35 <bzhou> jwcroppe: thanks
14:27:36 <seanmurphy> the select destinations spec indicates that it is part of a larger effort to split out the scheduler - in this context, it would seem to be reasonable to use the rpcapi - https://specs.openstack.org/openstack/nova-specs/specs/kilo/approved/sched-select-destinations-use-request-spec-object.html (not from any particular deep knowledge/insight - just a quick search)
14:28:49 <jwcroppe> acabot: I think so, let's give until EOW for final review comment?
14:28:51 <acabot> submited in kilo and pending approval on launchpad :-(
14:29:09 <bzhou> it's not implemented yet
14:29:33 <acabot> jwcroppe: ok for EOW
14:29:50 <acabot> we need reviews on this spec https://review.openstack.org/#/c/257494/
14:29:57 <acabot> to start implementing
14:30:10 <sballe> are we talking EOW for https://review.openstack.org/#/c/252268/? i lost the context for EOW
14:30:15 <bzhou> as I know, the current nova-scheduler subteam's focus on Mitaka is the mitaka/approved/request-spec-object-mitaka.rst
14:30:21 <acabot> this will allow anyone to add custom actions (the same way as we can add custom strategies)
14:30:43 <jwcroppe> will look today
14:30:52 <sballe> same here
14:30:53 <acabot> sballe: yes https://review.openstack.org/#/c/252268/ for EOW
14:31:10 <acabot> #action acabot merge https://review.openstack.org/#/c/252268/ by EOW
14:32:20 <acabot> specs from cdupont and brunograz must be reviewed also
14:32:55 <edleafe> bzhou: the focus is on cleaning up the interface with nova; request-spec object is a part of that
14:32:57 <sballe> ok
14:33:33 <acabot> #action sballe acabot jwcroppe review https://review.openstack.org/#/c/257494/ https://review.openstack.org/#/c/260552/ https://review.openstack.org/#/c/258608/
14:34:00 <acabot> #topic Blueprint/Bug Review and Discussion
14:34:07 <bzhou> edleafe: agree, thanks
14:34:39 <seanmurphy> acabot: we did not produce spec yet - iiuc we had until jan 20
14:35:10 <acabot> seanmurphy: yes I have it in mind
14:35:33 <acabot> we will have to update the data model of Watcher to allows custom actions, do you think we need to handle a migration ?
14:35:40 <seanmurphy> cool - keeping on top of things ;-)
14:36:11 <alexstav> Guys, I wanna to discuss bug with [user|project]_domain_name variable in watcher/common/keystone.py
14:36:14 <acabot> as we are still in v0.x, I think we can drop the DB when updating
14:36:22 <alexstav> #link https://bugs.launchpad.net/watcher/+bug/1530790
14:36:24 <openstack> Launchpad bug 1530790 in watcher "making configurable user|project]_domain and [user|project]_domain_ID " [High,Confirmed] - Assigned to Alexander Stavitskiy (alexstav)
14:36:26 <tpeoples> imo, no acabot - too early.  but that may break the intel POC, so if they would want to migrate?
14:37:23 <jed56> tpeoples : +1
14:37:26 <tpeoples> alexstav:  can you hold that for open discussion
14:37:29 <jwcroppe> acabot: +1 ... drop db for now
14:37:32 <acabot> alexstav: we will come back to it after BPs review, thx
14:37:45 <sballe> jwcroppe: +1
14:38:00 <acabot> sballe bzhou : your opinion about db migration ?
14:38:17 <tpeoples> she said +1 :)
14:38:29 <sballe> but bzhou has the final say
14:38:29 <acabot> ok :-D
14:38:34 <sballe> so I'll let him
14:38:37 <alexstav> acabot tpeoples: Sorry, I thought topic is about bug/bp :)
14:39:40 <bzhou> sorry, what is the db migration?
14:39:51 <acabot> we will start integrating taskflow in Watcher applier, just to confirm that we dont need a spec for it
14:40:18 <sballe> bzhou: can you answer the question above from acabot
14:40:25 <acabot> bzhou: adding custom actions will impact the data model and we dont want to provide a migration tool
14:40:53 <acabot> bzhou: I just want to be sure that you can drop the DB and recreate it for the POC
14:41:35 <bzhou> I think it should be ok
14:41:51 <acabot> bzhou : ok could you also update the state of https://blueprints.launchpad.net/watcher/+spec/outlet-temperature-based-strategy ?
14:42:13 <tpeoples> acabot:  i think the other BP / spec that jed56 is working on can include using taskflow as part of the spec. they are intertwined
14:42:38 <acabot> tpeoples: yes it is
14:42:55 <acabot> tpeoples: we will try to separate the reviews
14:43:28 <jwcroppe> tpeoples: +1000 for task flow
14:43:30 <acabot> this BP (https://blueprints.launchpad.net/watcher/+spec/external-api-versioning) is targeted for mitaka-2 but has no Assignee, does anyone wants to start it ?
14:43:50 <bzhou> acabot: I don't have permission to update the state
14:44:37 <acabot> bzhou: OK strange, I set it as implemented as you will create a new one
14:44:45 <tpeoples> acabot: i can take that
14:45:07 <acabot> #action tpeoples start working on https://blueprints.launchpad.net/watcher/+spec/external-api-versioning
14:45:13 <acabot> tpeoples: thx
14:46:05 <acabot> alexstav: we need updates on your BPs  https://blueprints.launchpad.net/watcher/+spec/watcher-overload-underload & https://review.openstack.org/#/c/258608/
14:46:27 <acabot> alexstav: there is still no spec submitted on watcher-specs
14:46:40 <acabot> alexstav: is it still alive ?
14:47:20 <alexstav> acabot: yes, it is. We'll start work on this BP after holidays.
14:47:32 <dtardivel> bzhou: you are not member of Watcher Drivers team.
14:47:38 <acabot> alexstav : the 2 BPs ?
14:48:07 <dtardivel> #action dtardivel add bzhou into Wather Drivers team
14:48:15 <acabot> alexstav: by the way thats a great news !
14:48:36 <alexstav> acabot: overload/underload at first, than watcherclient :)
14:48:43 <acabot> so lets have a 5 minutes bugs discussion
14:48:54 <bzhou> dtardivel: thanks:-)
14:48:57 <acabot> https://bugs.launchpad.net/watcher/+bug/1530790
14:49:01 <openstack> Launchpad bug 1530790 in watcher "making configurable user|project]_domain and [user|project]_domain_ID " [High,Confirmed] - Assigned to Alexander Stavitskiy (alexstav)
14:49:29 <alexstav> Thanks. I  solved the problem of authorisation in Keystone. Problem was not in my creds or keystone configuration.  When Watcher gets credentials for KeystoneClient() in /watcher/common/keystone.py, he sends keystone_authtoken params. Some of them he takes from watcher.conf file, and some sets manually (eg. user_domain_name and project_domain_name). So the problem was that I had domain name ‘Default’, but not ‘default’.
14:49:46 <alexstav> So why wouldn’t we add project_domain_id and user_domain_id to watcher.conf, like this is done in the configuration files of other projects (like nova.conf, neutron.conf, etc.)?
14:50:13 <dtardivel> alexstav: yes this is the final solution
14:50:19 <jed56> alexstav : +1 you can push a patchset
14:50:21 <bzhou> +1
14:50:34 <alexstav> I created small patch at my local repo, it works with Liberty :)
14:50:41 <acabot> ok solved ? :-D
14:50:47 <alexstav> :D
14:51:03 <bzhou> as we are talking about keystone, I'd like to discuss https://review.openstack.org/#/c/260354/
14:51:15 <alexstav> I had solved another problem in this patch.
14:51:21 <alexstav> Ups, sorry.
14:52:02 <jed56> bzhou: yes with david will take a look we have to test it
14:52:06 <alexstav> #link https://github.com/Stavitsky/watcher/commit/0ead5de97e5a102e7e1a0b4851d3aa753a4816f7 Here it is my small patch. Watcher didn't migrate VMs with shared storage.
14:52:24 <dtardivel> bzhou: I will make some tests on devstack multi node conf to validate your assumption
14:52:24 <bzhou> ok, thanks
14:52:46 <jed56> bzhou sorry for delay to response
14:52:51 <dtardivel> alexstav: please submit a patchset to gerrit
14:52:53 <acabot> alexstav: we use gerrit for code reviews, please read https://wiki.openstack.org/wiki/Watcher/Contributing
14:53:00 <alexstav> Cause in Primitives-class in watcher/decision_engine/planner/default.py there are no differ between LOVE_MIGRATE and COLD_MIGRATE values.
14:53:36 <alexstav> Yep, i'll do that. I wanna to discuss the problem.
14:53:46 <jed56> how do you make love_migration ? :p
14:53:50 <acabot> alexstav: thx
14:53:53 <alexstav> АХАХХАХА
14:53:56 <alexstav> ahahah
14:54:08 <alexstav> Sorry, a mean LIVE_MIGRATION
14:54:12 <acabot> :-D
14:54:15 <alexstav> :D
14:54:34 <dtardivel> https://bugs.launchpad.net/watcher/+bug/1510179
14:54:36 <openstack> Launchpad bug 1510179 in watcher "Can not create an audit template with same name after deleting it previously." [Medium,Confirmed] - Assigned to Zhenzan Zhou (zhenzan-zhou)
14:54:45 <acabot> #action alexstav submit patchset on gerrit for https://bugs.launchpad.net/watcher/+bug/1530790
14:54:46 <openstack> Launchpad bug 1530790 in watcher "making configurable user|project]_domain and [user|project]_domain_ID " [High,Confirmed] - Assigned to Alexander Stavitskiy (alexstav)
14:54:54 <tpeoples> vincentfrancoise:  are you still working on https://blueprints.launchpad.net/watcher/+spec/tempest-basic-set-up ?  i passed that to you before break, but wondering if i can / should take it back unless you've made some progress?
14:54:57 <acabot> #topic open discussions
14:55:01 <jed56> alexstav : This code will be removed with the bp dynamic actions
14:55:18 <dtardivel> bzhou: are you working on it ?
14:55:28 <alexstav> jed56: what code?
14:55:39 <acabot> #info sballe proposed 2 talks for the Austin summit (https://etherpad.openstack.org/p/Watcher_abstracts_austin2016)
14:55:50 <bzhou> yes, but I'm blocked at db migration testing
14:56:20 <jed56> alexstav: you talk it after the meeting on openstack-watcher
14:56:21 <vincentfrancoise> tpeoples: yes I didn't work on it much but I'm currently on it, so I guess I'll carry on
14:56:23 <acabot> I will propose an agenda for the mid-cycle for our next meeting
14:56:24 <bzhou> are we going to use a new db schema?
14:56:40 <tpeoples> dtardivel: jed56: can you guys review the devstack plugin when you get time?  i'd like to get that merged
14:56:44 <bzhou> then I don't need to worry about db migration
14:56:48 <sballe> acabot: I have a couple of items that I would liek to the agenda
14:57:11 <dtardivel> tpeoples: I'm working on it this afternoon :)
14:57:22 <sballe> I'll ping you Friday morning since I am traveling all day tomorrow.
14:57:24 <acabot> sballe: OK feel free to add them on the wiki page
14:57:33 <tpeoples> thanks dtardivel
14:57:34 <acabot> sballe: ok
14:57:37 <sballe> acabot: ^^ or send you an email
14:57:46 <acabot> sballe: ok too
14:57:51 <sballe> :)
14:58:10 <tpeoples> ok vincentfrancoise, thanks
14:58:33 <acabot> any other subject in 2 minutes ?
14:58:44 <sballe> not for me
14:58:58 <acabot> #action jed56 dtardivel review devstack plugin
14:59:09 <bzhou> acabot: are we going to use a new db schema without migration?
14:59:27 <seanmurphy> is there a set of features expected for the mitaka release/roadmap somewhere
14:59:28 <acabot> bzhou: yes
14:59:51 <acabot> seanmurphy: https://blueprints.launchpad.net/watcher/mitaka
14:59:56 <seanmurphy> thanks
15:00:11 <acabot> thank you, bye
15:00:15 <sballe> bye
15:00:17 <bzhou> thanks
15:00:18 <acabot> #endmeeting