13:59:54 <acabot> #startmeeting watcher
13:59:55 <openstack> Meeting started Wed Dec  9 13:59:54 2015 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:59 <openstack> The meeting name has been set to 'watcher'
14:00:00 <acabot> hi
14:00:07 <vtech> o/
14:00:08 <tpeoples> o/
14:00:22 <jed56> o/
14:00:34 <seanmurphy> hi guys
14:00:41 <acabot> our agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#12.2F9.2F2015
14:00:42 <sballe> o/
14:00:46 <vincentfrancoise> o/
14:00:51 <bzhou> hi
14:01:03 <acabot> more people every week for the roll call ;-)
14:01:44 <acabot> #topic Announcements
14:02:06 <cdupont> hi all
14:02:14 <dtardivel> hi
14:02:18 <acabot> our mid-cycle meetup will take place at IBM Austin february 2-5
14:02:25 <sballe> +1
14:02:39 <acabot> an eventbrite is available for registration
14:02:51 <acabot> thx to jwcroppe for hosting it
14:03:42 <acabot> sballe: I think we can start spreading the event around us
14:03:54 <sballe> agreed
14:04:20 <acabot> we will provide details for accommodations through a wiki page next week
14:04:52 <acabot> Watcher code as been tagged last friday as it was the mitaka-1 deadline
14:05:16 <seanmurphy> acabot: what specifically does this mean?
14:05:23 <seanmurphy> (in one sentence)
14:06:16 <dtardivel> seanmurphy: new pypi package are available (0.21.0 for watcher and 0.20.0 for python-watcherclient)
14:06:16 <acabot> we try to stick to the OpenStack release schedule so we release software every 2 months (3 releases between each summit)
14:06:45 <seanmurphy> got it - thanks
14:07:05 <acabot> it is not mandatory as we are not under the big tent but it is a good way to complete BP thanks to the deadline ;-)
14:07:30 <acabot> doc and packages are updated when we tag the software
14:07:33 <acabot> as well
14:07:46 <acabot> any other announcement ?
14:08:26 <acabot> #topic Review Action Items
14:08:59 * edleafe wanders in late
14:09:11 <acabot> a lot of code refactoring has been done after the glossary merge
14:09:54 <acabot> please review all related patches https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/glossary-related-refactoring,n,z
14:10:07 <tpeoples> will spend some time this week reviewing those
14:10:51 <acabot> #action tpeoples review code refactoring https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/glossary-related-refactoring,n,z
14:11:15 * sballe will do the same
14:11:32 <acabot> #action sballe review code refactoring https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/glossary-related-refactoring,n,z
14:11:40 <bzhou> I will review those too
14:11:41 <mehdi__> will do the same
14:11:47 <sballe> +1
14:12:04 <acabot> tpeoples submitted a devstack plugin
14:12:22 <dtardivel> I will test it
14:12:24 <acabot> it needs to be tested and reviewed
14:12:41 <acabot> ot> #action mehdi__ review code refactoring https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/glossary-related-refactoring,n,z
14:12:53 <acabot> #action mehdi__ review code refactoring https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/glossary-related-refactoring,n,z
14:13:13 <tpeoples> dtardivel: you'll need to get the commit into your local git repo and then use that local repo as the path with enable_plugin
14:13:17 <acabot> #dtardivel review https://review.openstack.org/#/c/254584/
14:13:24 <acabot> #action dtardivel review https://review.openstack.org/#/c/254584/
14:13:25 <cdupont> I can also review :)
14:13:50 <tpeoples> dtardivel: you'll also need to clone  python-watcher-client into the same directory as watcher due to some path lookup reasons
14:13:50 <acabot> cdupont: devstack ?
14:14:04 <sballe> all the more people who can review the better
14:14:15 <cdupont> OK
14:14:18 <acabot> sballe: +1
14:14:29 <acabot> #action cdupont review https://review.openstack.org/#/c/254584/
14:14:30 <dtardivel> tpeoples: ok
14:14:39 <tpeoples> ask me if you have questions
14:15:39 <acabot> I'd like to thank Darren & G�bor who fixed many low hanging fruit bugs
14:15:53 <cdupont> tpeoples: how hard is it to install?
14:15:55 <acabot> if you can give your IRC name it would be great ;-)
14:16:49 <tpeoples> cdupont: not very, it's only hard now because you'll need to pull down my changes into your local git repo since they aren't merged yet, then use that repo instead to enable the plugin
14:17:09 <cdupont> OK great
14:17:46 <acabot> to find low hanging fruit bugs : https://bugs.launchpad.net/watcher/+bugs?field.tag=low-hanging-fruit
14:18:42 <acabot> on watcher specs, there are 2 reviews in progress
14:19:26 <jed56> https://review.openstack.org/#/q/status:open+watcher-specs,n,z
14:19:29 <acabot> bzhou: it seems there is a problem on this one (the last PS) https://review.openstack.org/#/c/252268/
14:19:43 <acabot> bzhou: could you fix it ?
14:20:03 <bzhou> ok. I will work with Junjie to fix it
14:20:10 <acabot> ok thx
14:20:11 <sballe> bzhou: +1
14:20:43 <acabot> the other one is just a move into implemented folder for telemetry, sballe, can you +2 today ?
14:21:02 <sballe> yes
14:21:06 <acabot> thx
14:21:06 <sballe> which spec?
14:21:24 <acabot> #action sballe review https://review.openstack.org/#/c/254130/
14:21:49 <acabot> #action bzhou fix review https://review.openstack.org/#/c/252268/ (last PS)
14:22:27 <acabot> #topic Blueprint/Bug Review and Discussion
14:23:05 <acabot> tpeoples: you had to split the BP https://blueprints.launchpad.net/watcher/+spec/well-defined-interfaces
14:23:15 <tpeoples> I spent a bit of time looking at our use cases to try and split this up and it seems like a lot of things already have well-defined interfaces, so I didn't want to create BPs that are useless.
14:23:26 <tpeoples> The Strategy abstraction allows us to define different optimization algorithms already given the current state of the cloud; the cluster model collector allows us to define different ways to get the current state (metrics).
14:23:38 <tpeoples> The one thing that I thought could use some work is how actions are defined, and I think we should try and use taskflow for these to get a well-defined interface as well as for other reasons.  See https://blueprints.launchpad.net/watcher/+spec/use-taskflow for more details.
14:24:33 <jed56> tpeoples  I agree
14:24:34 <vmahe_> I agree that we should have a look at taskflow project and see if it fits our needs
14:25:05 <jed56> about taskflow I want to understand how we can implement our own planner strategy
14:25:33 <acabot> #action vmahe_  jed56 look at the taskflow project to see if it fits Watcher needs
14:25:46 <acabot> does any one of you already experienced taskflow ?
14:25:56 <tpeoples> i have used it a bit
14:26:11 <acabot> in which context ?
14:26:44 <tpeoples> running concurrent tests that had a bunch of dependencies.  we also use it for the nova-powervm driver
14:26:53 <acabot> ok
14:27:30 <acabot> we have a couple of new BPs these week
14:27:30 <tpeoples> i think we'll find it suits our needs :).  a lot of what we're doing in code we'd get out of the box with it.  let's discuss more next week
14:27:46 <acabot> tpeoples: ok
14:28:08 <tpeoples> acabot:  before we move on, what do we want to use with the well-defined-interfaces BP?
14:28:13 <tpeoples> want to do*
14:29:04 <tpeoples> mark as obsolete?
14:29:26 <acabot> tpeoples: we have things to change regarding interfaces between watcher components
14:29:46 <acabot> tpeoples: but I think its a big "spec" work
14:30:17 <tpeoples> ok
14:31:02 <acabot> I suggest to keep this BP in the list and update it with a more precise scope (like one component) and use it as a test
14:32:20 <acabot> we have 3 new BPs
14:32:26 <acabot> the first one is https://blueprints.launchpad.net/watcher/+spec/efficacy-indicator
14:32:37 <acabot> any comment on this one ?
14:33:05 <acabot> should we have a spec for it ?
14:33:45 <tpeoples> +1 to efficacy over efficiency.  yes, i think a spec is necessary to outline how it's going to be implemented
14:33:56 <dtardivel> +1
14:34:02 <jed56> +2
14:34:22 <acabot> #action acabot start a spec for  https://blueprints.launchpad.net/watcher/+spec/efficacy-indicator
14:34:25 <sballe> +2
14:34:38 <acabot> 2nd https://blueprints.launchpad.net/watcher/+spec/watcher-ui
14:34:52 <acabot> integration of Watcher in Horizon
14:35:03 <acabot> we already have a beta version on our side
14:35:09 <sballe> we might need to talk to the horizon tea,
14:35:15 <sballe> s/team
14:35:28 <sballe> acabot: maybe you could do a demo so we can see it
14:35:58 <acabot> sballe: sure I will provide a video for next meeting
14:36:07 <sballe> acabot: +1
14:36:22 <tpeoples> we'll want to integrate that into the devstack plugin as a horizon plugin at some point, jfyi
14:36:27 <acabot> #action acabot record a video of Watcher UI before next meeting
14:36:45 <acabot> tpeoples: absolutely
14:37:11 <acabot> and then the 3rd : https://blueprints.launchpad.net/watcher/+spec/basic-cloud-consolidation-integration
14:37:38 <acabot> seanmurphy has submitted it
14:37:55 <seanmurphy> we would like to see if we can implement our earlier work on watcher
14:38:03 <seanmurphy> understand what is required to realize it on watcher
14:38:09 <seanmurphy> and implement it
14:38:29 <seanmurphy> acabot suggested doing it for the m-3 mar 3 date
14:38:34 <seanmurphy> which we can do
14:38:37 <seanmurphy> m-2 is a bit soon for us
14:38:55 <seanmurphy> as we have commitments from now into early jan
14:39:16 <sballe> seanmurphy: sounds good
14:39:22 <acabot> seanmurphy: can we have reviewed specs on it by 21st jan ?
14:39:35 <sballe> +1
14:39:35 <seanmurphy> yes - this should be possible i think
14:39:39 <acabot> and then implem for mitaka-3
14:39:43 <acabot> ok great
14:39:45 <seanmurphy> right
14:39:46 <tpeoples> i think jwcroppe and i would probably be interested in helping with a CPU util-based algorithm
14:40:06 <seanmurphy> i will need to look at some examples to make sure i structure them properly etc
14:40:08 <acabot> tpeoples: do you mean on the same BP ?
14:40:18 <seanmurphy> we’d be happy work with anyone on it
14:40:51 <jed56> :)
14:40:54 <tpeoples> acabot: yeah (even though this BP isn't "reactive")
14:41:02 <acabot> #action seanmurphy start a spec for https://blueprints.launchpad.net/watcher/+spec/basic-cloud-consolidation-integration
14:41:15 <cdupont_> related to the consolidation I have some questions
14:42:10 <cdupont_> shall I? :)
14:42:16 <seanmurphy> shoot
14:42:24 <acabot> cdupont_: sure
14:42:43 <cdupont_> we also started two BPs on a consolidation language/grammar
14:43:04 <seanmurphy> ok
14:43:05 <cdupont_> I rretro-engineered a bit Watcher code
14:43:24 <cdupont_> at the moment there is a data model implemented
14:43:38 <cdupont_> what I'm not sure is how it can be extended t suit our needs
14:44:13 <sballe> cdupont_: can you clarify?
14:45:13 <cdupont_> how the data model of Watcher can be extended, i.e. what if I need more infos on a VM, for example it's last migration time
14:45:25 <jed56> cdupont : this a good question
14:45:26 <jed56> :)
14:45:34 <acabot> cdupont_: we are still waiting for a spec regarding the grammar stuff
14:46:38 <acabot> cdupont_: it would be easier to iterate on gerrit
14:46:43 <cdupont_> the grammar for consolidation rules?
14:46:55 <jed56> We need to write a BP about how to extend to data model depending the need
14:46:55 <acabot> yes
14:47:04 <cdupont_> +1
14:47:43 <jed56> we will never have a universal model
14:48:18 <cdupont_> it's not trivial really :)
14:48:22 <jed56> We can maybe provided like CloudSim some generic model
14:48:26 <acabot> this BP https://blueprints.launchpad.net/watcher/+spec/watcher-consolidation-grammar has been accepted but you need to write a spec to give us details about what you are planning to do
14:48:43 <cdupont_> OK
14:49:00 <cdupont_> this is about the grammar for consolidation rules
14:49:12 <acabot> specs are in watcher-specs repo, you will find templates available
14:49:46 <cdupont_> i.e. "this VM must not move", "those two VMs must stay together", etc.
14:49:54 <sballe> +1 on the spec
14:50:09 <acabot> cdupont_: ok so seanmurphy will start a spec on consolidation algo and you will be able to ask questions regarding the data model through gerrit ok ?
14:50:36 <cdupont_> it's OK
14:50:46 <seanmurphy> works for me
14:50:49 <acabot> any update on https://blueprints.launchpad.net/watcher/+spec/watcher-consolidation-rules-api ?
14:50:59 <jed56> if have question regarding data model you can use #openstack-watcher
14:51:19 <acabot> Michele is set as assignee but I dont know who he is
14:51:43 <cdupont_> acabot: It's Federico. I don't know of any update
14:51:59 <acabot> ok I will send a mail
14:52:05 <cdupont_> OK
14:52:23 <acabot> anyone from Servionica ? https://blueprints.launchpad.net/watcher/+spec/watcher-overload-underload
14:53:08 <acabot> #topic Open Discussion
14:53:26 <seanmurphy> meetings over holiday period?
14:53:54 <vmahe_> we don't know what holiday means :-)
14:54:09 <vincentfrancoise> vmahe_: lol
14:54:14 <seanmurphy> haha
14:54:15 <acabot> dtardivel will handle the meeting next week and sballe will do it around christmas
14:54:20 <tpeoples> acabot: i want to work on https://blueprints.launchpad.net/watcher/+spec/tempest-basic-set-up if no one already has
14:54:20 <seanmurphy> ok
14:54:26 <seanmurphy> so basically business as usual
14:54:41 <seanmurphy> meeting will take place same bat time, same bat channel
14:54:49 <jed56> vmahe : how to make a work a better place with so many holidays :)
14:54:53 <seanmurphy> thanks
14:54:55 <jed56> word
14:55:11 <acabot> #action tpeoples start working on https://blueprints.launchpad.net/watcher/+spec/tempest-basic-set-up
14:55:51 <tpeoples> there's the translation BP too, but I think that's pretty low priority at this point
14:55:53 <acabot> there is also an open BP on translation, anyone interested ? ;-)
14:56:09 <acabot> tpeoples: +1
14:56:23 <tpeoples> i'm interested in that but don't want to grab it at this point :)
14:56:37 <bzhou> anyone want to work on https://blueprints.launchpad.net/watcher/+spec/optimization-threshold? Or I am going to take it.
14:57:20 <acabot> bzhou: I think it is deeply related with your PoC, it would be great to have you on this one
14:57:37 <bzhou> acabot: yeah
14:57:44 <jed56> +1
14:58:07 <acabot> #action bzhou start working on https://blueprints.launchpad.net/watcher/+spec/optimization-threshold?
14:58:08 <sballe> bzhou: +1
14:58:36 <tpeoples> would anyone else like the openstackgerritbot to sit in our channel, or would it annoy people?  i'm not sure if it's even possible, might have to spin up our own bot for it, but i can find out
14:59:02 <sballe> I am not sure what that means?
14:59:07 <acabot> tpeoples: I already did it ;-) https://review.openstack.org/#/c/254765/
14:59:25 <acabot> but the CI failed so I'm waiting...
14:59:26 <sballe> lol
14:59:28 <tpeoples> awesome acabot
14:59:58 <tpeoples> sballe: it's a bot that puts a message to the channel when someone submits a patchset
15:00:06 <acabot> thanks for this great meeting
15:00:13 <jed56> thanks :)
15:00:18 <tpeoples> ttyl
15:00:19 <cdupont_> tks
15:00:22 <acabot> bye
15:00:23 <seanmurphy> bye guys!
15:00:25 <bzhou> thanks
15:00:26 <cdupont_> bye
15:00:28 <acabot> #endmeeting