14:00:52 <acabot> #startmeeting watcher
14:00:52 <openstack> Meeting started Wed Nov 25 14:00:52 2015 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:57 <openstack> The meeting name has been set to 'watcher'
14:00:59 <acabot> hi
14:01:03 <edleafe> hi
14:01:06 <brunograz> hi
14:01:10 <vtech> hi
14:01:10 <vmahe_> hi
14:01:12 <bzhou> hi
14:01:18 <seanmurphy> hi guys
14:01:33 <jwcroppe> hi
14:02:00 <acabot> our agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F25.2F2015
14:02:42 <jed56> hi
14:03:00 <dtardivel> Bonjour
14:03:06 <alexstav_> o/
14:03:08 <vincentfrancoise> Hi
14:03:16 <ashavskiy> o/
14:03:23 <jwcroppe> o/
14:03:27 <alexchadin> o/
14:03:37 <ostroverkhov> o/
14:03:46 <acabot> #topic Announcements
14:04:13 <acabot> regarding the mid-cycle meetup, we have to wait for sballe for updates
14:04:26 <sballe> I am here
14:04:33 <sballe> sorry about that.
14:04:34 <acabot> ho sorry
14:04:53 <sballe> I haven't heard anything and I cannot get an answer so let's assume he cannot host it
14:05:20 <jwcroppe> sballe: sounds good - do we want to pursue IBM - in Austin, TX?
14:05:21 <sballe> acabot: I was doing something else and forgotto join on time :-)
14:05:21 <acabot> ok so do we have an alternative in the same area ?
14:05:28 <sballe> jwcroppe: +1-
14:05:33 <sballe> definetly
14:05:40 <sballe> Austin is awesome
14:05:47 <sballe> especilly in the winter
14:06:09 <acabot> Austin is not very easy for us regarding planes...
14:06:14 <sballe> Boston is a problem in the winter because travel is unpredictable because if the weather
14:06:27 <sballe> acabot: like Rennes for us ;-)
14:06:29 <jwcroppe> sballe: I had preliminary discussions with my team and that should be possible, but I will confirm
14:06:35 <acabot> sballe: ok
14:06:50 <jwcroppe> acabot: the best option is to get to Heathrow and I believe there is a direct flight from there to AUS
14:06:58 <jed56> sballe : nice catch :)
14:07:01 <sballe> acabot: CDG --> Boston --> Austin
14:07:13 <acabot> jwcroppe: ok so lets confirm Austin next week ?
14:07:25 <sballe> jed56: lol
14:07:48 <seanmurphy> i think it’s unlikely that we would be able to attend a US-based f2f, unfortunately
14:07:57 <jwcroppe> acabot: yes, will try - it's US holiday this week so quite empty, but I will have those discussions next week and hopefully have confirmation by week of 12/7
14:08:35 <acabot> #action jwcroppe confirm availability for hosting the mid-cycle in Austin by 12/7
14:09:02 <sballe> jwcroppe: can we do it the week of Feb 2?
14:09:15 <acabot> seanmurphy: we will use public etherpad during the meetup so you will be able to follow our discussions
14:09:20 <jwcroppe> sballe: I had that week and previous week as options
14:09:52 <sballe> jwcroppe: Yeah I have some other travel tentatively planned for the week before in Portland.
14:10:29 <acabot> we have a new wiki page related to Watcher architecture v2 #link https://wiki.openstack.org/wiki/WatcherArchitecturev2
14:10:36 <jwcroppe> sballe: we can try the week of 2/2... Tue-Thurs
14:10:37 <sballe> acabot: cool!
14:10:44 <jwcroppe> acabot: nice
14:10:46 <sballe> jwcroppe: perfect. thx
14:10:50 <acabot> its a draft
14:11:15 <acabot> and the diagram on top is our first diagram using Dia (thx vmahe for doing it) ;-)
14:11:51 <acabot> vmahe will soon push the source code in watcher doc and we will be able to review and update it
14:12:04 <vmahe_> right
14:12:14 <jwcroppe> vmahe_: very nice
14:12:15 <acabot> unfortunately we will have to update the diagram on the wiki manually for now
14:12:40 <vmahe_> you'll need to install Dia which is available on many systems
14:12:40 <sballe> vmahe_: Great job! the diagram looks great
14:12:42 <acabot> but its better than exporting it from ppt ;-)
14:12:56 <sballe> acabot: +100 lol
14:13:18 <jwcroppe> so v2 arch is our target arch for Mitaka?
14:13:19 <vmahe_> the drawback with Dia is that the source code of the diagram is XML and not easily readable
14:13:44 <sballe> I really like v2! it is a much cleaner architecture
14:13:46 <vmahe_> but you can also draw sequence diagrams and class diagrams
14:14:03 <vmahe_> and this is what Nova team uses :-)
14:14:11 <sballe> vmahe_: I am a big fan of sequemce diagram to explain the API interactions
14:14:23 <vmahe_> right, i'll work on it later
14:14:44 <jed56> sballe : vhmahe his also a big fan :)
14:15:02 <sballe> :0
14:15:04 <sballe> :0
14:15:05 <acabot> so of course, feel free to complete this new wiki page
14:15:06 <sballe> ;)
14:15:20 <jwcroppe> v2 arch = mitaka goal?
14:15:30 <acabot> jwcroppe: yes
14:15:44 <jwcroppe> acabot: cool - thx
14:15:49 <edleafe> I'm a little confused on the diagram - where is the input from the monitoring/metering?
14:16:53 <acabot> edleafe: the idea of putting this picture is just to give you an overview of the output of dia
14:17:10 <acabot> edleafe: the diagram needs to be updated
14:17:18 <vmahe_> yes, the diagram needs to be refined and a focus on the metering part must be done
14:17:26 <edleafe> acabot: ah, thanks. Thought I needed more coffee or something :)
14:17:32 <acabot> just to say "OK lets use this tool for our diagrams"
14:17:41 <jwcroppe> edleafe: lol
14:17:52 <jwcroppe> where is the dia source btw?
14:17:58 <sballe> I think I need more coffee too
14:18:18 <acabot> jwcroppe: will be in watcher doc folder today
14:18:46 <jwcroppe> great, will look - in git?
14:18:47 <acabot> before we review actions, just a quick reminder on code reviews
14:19:08 <acabot> please use workflow -1 when your code is a work in progress
14:19:25 <acabot> and do not review code when the workflow is set to -1
14:19:54 <acabot> #topic Review action items
14:19:58 <vmahe_> jwcroppe: yes, the source code will be in some subfolder of watcher/doc
14:20:12 <jwcroppe> +1
14:20:24 <sballe> +1
14:20:36 <bzhou> +1
14:20:53 <acabot> ceilometer integration is now merged (specs and code)
14:21:05 <edleafe> \o/
14:21:30 <sballe> o/
14:21:44 <sballe> This is a great step. thanks jed56 acabot dtardivel
14:21:54 <sballe> and vincentfrancoise
14:22:08 <acabot> the code has been merged before the specs (sorry about that), we will do it in the right order next time ;-)
14:22:23 <jwcroppe> yes - very good.  yeah, need to follow process :)
14:22:27 <sballe> acabot: no big deal this time
14:22:55 <acabot> loading strategies is also merged
14:22:58 <sballe> jwcroppe: migth disagree
14:23:06 <sballe> acabot: +1
14:23:07 <acabot> ths to vincentfrancoise and jed56
14:23:13 <sballe> +1
14:23:45 <acabot> there is a current review on the glossary https://review.openstack.org/#/c/246370/
14:23:55 <seanmurphy> can we have a one liner on what the ceilometer integration provides?
14:24:28 <acabot> this is becoming really important because we need to do code refactoring when we will all agree on this glossary
14:24:32 <bzhou> thanks b-com team. I am using the new code to setup my environment
14:25:19 <acabot> seanmurphy: Ceilometer integration allows Watcher to collect metrics from Ceilometer instead of using its own metering chain
14:25:24 <vmahe_> yes, the glossary is important because we need to make sure everybody shares the same definitions of business objects regarding Watcher and names of the technical components
14:26:14 <jwcroppe> will review today
14:26:15 <vmahe_> we have renamed the ex "State DB" into a more comprehensive word "Cluster Data Model"
14:26:23 <sballe> vmahe_: I will take another pass at it today
14:26:31 <acabot> so if everybody can review the glossary before end of week it would be great
14:26:40 <bzhou> why we use "cluster" not "cloud"?
14:26:43 <seanmurphy> acabot: …and puts them in watcher db, right? with some further aggregation/processing, i guess…
14:27:19 <edleafe> bzhou: because everything, including Watcher, is part of the cloud
14:27:22 <vmahe_> ok, I'm currently taking into account seanmurphy reviews
14:27:59 <jed56> seanmurphy : the metrics are stored into the ceilometer backend
14:28:07 <seanmurphy> vmahe_: i will review the glossary - currently working on it
14:28:15 <bzhou> edleafe: I thought cluster has a specific word and may imply some meaning to people
14:28:16 <vmahe_> bzhou : because "Cloud" is a too confusing word, it means a lot of things depending on who you talk to
14:28:37 <vmahe_> we have defined the word "Cluster" in the Glossary
14:28:44 <sballe> vmahe_: BTW so does Cluster
14:29:11 <acabot> #action sballe jwcroppe edleafe seanmurphy bzhou alexstav_ acabot review the glossary #link  https://review.openstack.org/#/c/246370/
14:29:23 <edleafe> bzhou: true, but it's impossible to find a word that doesn't have another meaning. That's why a glossary is helpful to learn what is meant within Watcher when we use it
14:30:00 <acabot> edleafe: +1
14:30:08 <sballe> edleafe: to me as long as we agree on Cluster or Cloud and we define it in the glossary we should be fine
14:30:21 <vmahe_> I couldn't find an official word hich means an Openstack Controller + some Compute nodes. Is there anu ?
14:30:24 <vmahe_> any ?
14:30:44 <edleafe> sballe: of course, but we should always try to settle on the term that is less potentially confusing
14:30:59 <brunograz> vmahe_: Compute cluster I guess
14:31:07 <edleafe> sballe: "cloud" is so overused that most people won't understand
14:31:30 <vmahe_> and we don't intend to optimize the whole Cloud, right ? :-)
14:31:58 <sballe> edleafe: so is Cluster because many places people are using Cloud and Cluster for the same ;-)
14:32:20 <vmahe_> we'll make the Cloud a better place (for those who know the "Silicon Valley serie"
14:32:20 <sballe> vmahe_: The thing is that down the road I can see us optimize storage  or the Datacenter
14:32:57 <sballe> We can use Cluster as long as it include storage
14:33:09 <acabot> +1
14:33:10 <vmahe_> sballe: yes, you're totally right. But today what we put in the Glossary is what is available in Watcher
14:33:18 <sballe> Intel's interet is beyond the compute cluster
14:33:36 <edleafe> sballe: http://dilbert.com/strip/2011-01-07
14:34:00 <vmahe_> Once the Intel blueprints are implemented and merged, we can update the Glossary consequently, no ?
14:34:03 <sballe> edleafe: love it lol
14:34:07 <jed56> lol
14:34:29 <sballe> Glossary will be hard to change once the project is going
14:34:51 <sballe> I would like the Glossary to be a long term thing
14:34:59 <vmahe_> I'm not sure because the Glossary may sometimes be related to what features are in Watcher
14:35:39 <vmahe_> I will be a living document, like the devs, tests, specs, ...
14:36:04 <acabot> sballe: not sure we can fix long term definitions as the product will evolve, I think we should keep what's working in Watcher in the glossary and update it all the way
14:36:27 <sballe> like I said as long as Cluster includes storage and is not a compute cluster I can be talked into using the word Cluster
14:36:40 <sballe> acabot: ^^
14:37:03 <edleafe> just as long as we don't overload 'aggregate' any more than it is :)
14:37:16 <acabot> sballe: ok lets continue the discussion on Gerrit ;-)
14:37:26 <vmahe_> ok, I'll add some words about the storage part in the glossary but note that today Watcher Applier does not control Cinder or Swift, only Nova
14:37:29 <jwcroppe> +1
14:37:35 <jed56> acabot +1
14:37:42 <edleafe> acabot: yes, Gerrit comments are more useful
14:37:46 <acabot> #topic Blueprint/Bug Review and Discussion
14:38:31 <acabot> as there are now many BP on launchpad, we should define series
14:38:39 <acabot> to fix deadlines for BP
14:39:04 <acabot> we can use the same series as other OpenStack projects like Mitaka-1, 2, 3 every 2 months
14:39:20 <sballe> acabot: +1
14:39:27 <acabot> or use any other kind of versioning like 0.22, 0.22.1
14:40:05 <acabot> do you want to stick to OpenStack versioning ?
14:41:05 <acabot> or you dont care... :-)
14:42:19 <dtardivel> acabot: 0.22.0 0.22.1 are tags, reflecting adding new feature implementation
14:42:44 <acabot> ok, we will use the OpenStack versioning for BP
14:42:49 <dtardivel> acabot: Mitaka-1, 2, 3 are targeted releases
14:43:11 <acabot> #action acabot add series in launchpad with Mitaka-N model
14:43:17 <jwcroppe> +1
14:43:39 <dtardivel> an we have to define which BP and bugs we want to target for each release I think
14:43:51 <acabot> +1
14:44:04 <edleafe> dtardivel: that's true, but some projects release when the code is ready, while others follow a fixed release
14:44:21 <edleafe> dtardivel: so the question is target dates vs. whenever ready
14:44:28 <edleafe> for releases
14:44:48 <jwcroppe> i think for where Watcher is now, we target whenever ready
14:44:59 <sballe> +1
14:45:03 <bzhou> jwcroppe:+1
14:45:04 <dtardivel> +1
14:45:13 <acabot> jwcroppe: and we use only BP priority ?
14:45:23 <acabot> for ordering
14:46:47 <acabot> Intel's BP needs to be split in 4 BPs, sballe am I right ?
14:47:02 <sballe> yes bzhou is working on it
14:47:11 <acabot> ok great thanks bzhou
14:47:15 <sballe> bzhou: took this over from nishi and I
14:47:27 <bzhou> sballe: got it
14:47:43 <sballe> :-)
14:47:51 <acabot> the BP https://blueprints.launchpad.net/watcher/+spec/well-defined-interfaces is probably to large and we also need to split it for each watcher component
14:48:09 <sballe> bzhou: you are working with junjie on this right?
14:48:19 <bzhou> sballe: yes
14:48:25 <sballe> perfect thx
14:48:30 <tpeoples> acabot:  i can take that
14:48:40 <acabot> ok, great
14:48:53 <sballe> bzhou: and you guys are starting on the watcher-specs. right?
14:48:56 <tpeoples> #action tpeoples split up https://blueprints.launchpad.net/watcher/+spec/well-defined-interfaces
14:48:57 <acabot> #action split https://blueprints.launchpad.net/watcher/+spec/well-defined-interfaces for each Watcher component
14:49:10 <acabot> #action tpeoples split https://blueprints.launchpad.net/watcher/+spec/well-defined-interfaces for each Watcher component
14:49:15 <tpeoples> :)
14:49:38 <acabot> #action bzhou split https://blueprints.launchpad.net/watcher/+spec/nishi-ahuja-energy-efficienct-dc is 4 BPs
14:50:34 <acabot> we plan to add a BP to display a performance indicator to Watcher
14:51:07 <acabot> I mean like "this actions plan will allows you to save 10%..."
14:51:20 <jed56> performance indicator regarding the goal we want to achieve
14:52:18 <acabot> anyone from create-net today ?
14:53:26 <acabot> last point, we should set a priority for this BP https://blueprints.launchpad.net/watcher/+spec/watcher-add-actions-via-conf
14:54:10 <bzhou> sballe: yes, creating specs under watcher-specs. One question is that we may not be able to link more than one specs to one bp. But it's not a big deal anyway.
14:54:13 <sballe> bzhou: do we need that BP for our q4 poc?
14:54:40 <sballe> https://blueprints.launchpad.net/watcher/+spec/watcher-add-actions-via-conf
14:54:46 <jwcroppe> spec<-->BP is 1-1
14:55:23 <sballe> bzhou: that is why we are diciding up the big BP into 4 smaller ones
14:55:36 <sballe> s/dividing
14:55:41 <acabot> sballe: one thing you should keep in mind for your poc is that we dont apply actions today
14:56:31 <acabot> sballe: you will get an actions plan from Watcher
14:56:47 <bzhou> the watcher-add-actions-via-conf could help for our q4 poc, but as I know, currently it only use migrate meta-action
14:56:58 <acabot> sballe: but we won't run the actions as its really "infrastructure" dependant
14:57:03 <sballe> acabot: I agree and was going to write that but then had t fix some typos and you text came out first
14:57:22 <acabot> sballe: ok
14:57:23 <bzhou> acabot: so it means we only support advisory mode atm?
14:57:33 <acabot> bzhou: yes
14:58:14 <tpeoples> Do I need to write a spec for https://blueprints.launchpad.net/watcher/+spec/devstack-plugin ? it won't be affecting anything public and shouldn't be changing the actual watcher code, so, seems like a candidate for a trivial spec
14:58:49 <acabot> tpeoples: not sure you need a spec for that
14:59:02 <tpeoples> i don't think i do :P
14:59:33 <acabot> you can start working on it, I will set it as started
14:59:46 <bzhou> tpeoples: it's quite straightforward, so it's ok to just implement it:-)
14:59:51 <acabot> we are running out of time
14:59:52 <jwcroppe> yeah, no spec needed for that
15:00:13 <acabot> open discussions on our channel if you like
15:00:13 <edleafe> tpeoples: there aren't a number of ways to do that, so no spec is needed
15:00:16 <acabot> thank you
15:00:30 <acabot> #endmeeting