17:04:09 <tjones> #startmeeting vmwareapi
17:04:10 <openstack> Meeting started Wed May 28 17:04:09 2014 UTC and is due to finish in 60 minutes.  The chair is tjones. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:13 <openstack> The meeting name has been set to 'vmwareapi'
17:04:30 <tjones> ok lets go!  thanks garyk for kicking out cinder.  i was distracted
17:04:33 <browne> hi
17:04:37 <tjones> who else is here?
17:04:42 <rgerganov> howdy
17:04:42 <garyk> hi
17:05:00 <tjones> anyone from HP here?
17:05:00 <garyk> sorry for missing the last few weeks - travel, summit, family ...
17:05:06 <tjones> no worries gary
17:05:11 <tjones> glad to hav eyou back
17:05:19 <arnaud> hi
17:05:54 <tjones> ok lets get going.  BP first
17:05:59 <tjones> https://bugs.launchpad.net/nova/+bug/1322926
17:06:01 <uvirtbot> Launchpad bug 1322926 in nova "Hyper-V driver volumes are attached incorrectly when multiple iSCSI servers are present" [High,Triaged]
17:06:10 <tjones> what??
17:06:14 <tjones> #undo
17:06:16 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x247af90>
17:06:28 <tjones> try again
17:06:31 <tjones> https://review.openstack.org/#/q/status:open+project:openstack/nova-specs+message:vmware,n,z
17:06:48 <tjones> these are BP in review
17:07:07 <tjones> anyone have one they want to discuss?
17:07:25 <garyk> tjones: i need to make a few updates after commens to the spbm spec
17:07:42 <arnaud> tjones, who continues the ephemeral disk support?
17:08:00 <tjones> arnaud: i was just typing that
17:08:02 <garyk> arnaud: i'll take that one
17:08:11 <arnaud> ok
17:08:30 <tjones> garyk: can you update the link with you as owner?
17:08:43 <garyk> tjones: sure.
17:08:47 <arnaud> garyk, if you too busy, I can look take it (just to let you know :))
17:09:10 <garyk> arnaud: i am always busy. lets load balance
17:09:10 <tjones> ok j-1 is coming in something like 2 weeks.  clearly non of these are going to make it, but i would like to have an understanding of which are j-2 and j-3
17:10:10 <tjones> garyk: sounds like spbm could make j-2.  maybe ephemeral since it is pretty small.  anyone around for the others?
17:10:24 <tjones> kiran, vincent,??
17:10:47 <tjones> ok lets move on
17:10:58 <tjones> #link https://blueprints.launchpad.net/openstack?searchtext=vmware
17:11:01 <tjones> approved BP
17:11:11 <tjones> spawn refactor….  so close....
17:11:40 <garyk> nice to see that it is moving
17:11:43 <tjones> waiting on 1 last +2 on test for spawn and power_off
17:11:48 <garyk> hopefully it will get the relevant review cycles.
17:12:07 <tjones> vuil: i think you have the ball next for finishing phase 2 and then phase 3 right?
17:12:28 <rgerganov> there was an email about this effort on openstack-dev
17:12:30 <garyk> tjones: i think that vui us is a meeting
17:12:38 <vuil> yep. sorry I was on a call.
17:12:40 <tjones> duh - he just told me that
17:12:44 <garyk> he is working on the additional phases
17:13:00 <vuil> Yep reorg-ing the patches. Should send them out within the next two days.
17:13:01 <garyk> rgerganov: do you have a link to that mail?
17:13:36 <tjones> vuil: excellent.  once you have posted, lets all review like mad and try to get this in j-1.  I suspect that is too agressive but we can give it a shot
17:14:24 <garyk> tjones: the hot plug code has been in review for a while. sadly no scores
17:14:25 <rgerganov> garyk: http://osdir.com/ml/openstack-dev/2014-05/msg01891.html
17:14:47 <tjones> the other 2 approved BP are use-oslo (not ready for review) and hot-plug.
17:15:01 <garyk> rgerganov: thanks
17:15:01 <rgerganov> garyk: I have some concerns about the hotplug; I think we need to add some classes
17:15:18 <tjones> #action please review https://review.openstack.org/#/c/59365/
17:15:32 <garyk> rgerganov: ok, i think that you mentioned it on the review. i'll take a look at that again
17:15:46 <rgerganov> garyk: ok, great
17:15:50 <tjones> #action please review https://review.openstack.org/#/c/91005/ (related to hot plug)
17:15:57 <tjones> anything else on BP ?
17:16:26 <garyk> tjones: i am not sure if the esx deprecation should be a BP
17:16:46 <garyk> i am in the process of drawing up a plan. when it is ready i'll send it to the list
17:17:01 <tjones> garyk: mikal just wanted am email to the ML on how users could move from using the ESX driver to the VC driver
17:17:30 <tjones> i suspect this work is large enought for the BP though.  do you disagree?
17:17:33 <garyk> tjones: ok, i'll send that soon. just need to flush out a few issues
17:18:00 <garyk> i think that it can be done without a bp, i'd just like to send a plan to the list for more clarity to others
17:18:08 <tjones> ok
17:18:20 <tjones> lets move to bugs then
17:18:23 <tjones> #topic bugs
17:18:25 <tjones> https://bugs.launchpad.net/nova/+bugs?field.tag=vmware
17:18:27 <tjones> we have a ton
17:18:30 <tjones> 69
17:19:07 <tjones> this does not seem to be going down - we are really stagnant with bugs
17:19:19 <rgerganov> I can take a bug if someone is overloaded
17:19:22 <tjones> i am going to organize a bug day next week for over overall
17:19:48 <arnaud> tjones, the problem is that some bugs overlap with the refactoring
17:19:59 <tjones> arnaud: yes unfortunaltely you are right
17:20:01 <browne> rgerganov: i have a few assigned to me.  i can give you one of mine if you link
17:20:25 <browne> like
17:20:28 <arnaud> browne, same here
17:20:31 <tjones> this is our most critical bug #link https://bugs.launchpad.net/nova/+bug/1321381
17:20:32 <uvirtbot> Launchpad bug 1321381 in nova "VMware: Ports are not cleaned up after reschedule" [High,Confirmed]
17:20:33 <garyk> tjones: arnaud: i do not think that the refactor should stop us from solving bugs.
17:20:33 <rgerganov> browne: you have one about memory leaks, do you mind to take it?
17:20:49 <browne> rgerganov: sure all yours
17:20:49 <garyk> we will need to backport to icehouse in most cases
17:21:10 <rgerganov> ok, I will give it a try
17:21:21 <tjones> lets focus on bugs that do not touch the spawn method for now.  there are plenty
17:21:38 <garyk> tjones: we are still investigating.
17:21:41 <browne> rgerganov: i assigned to you
17:21:50 <rgerganov> browne: ok
17:21:50 <tjones> #action take a look at your bugs and if you are not activly working on them, remove your name from assignee
17:21:53 <garyk> that is incidently on havana.
17:22:04 <arnaud> can we list the bugs that are not assigned and need to be fixed?
17:22:13 <tjones> of the 69 bugs, only 20 are unassigned.  I think we are all sitting on bugs that we are not working on
17:22:16 <arnaud> (important)
17:22:47 <tjones> here is the unassinged list http://tinyurl.com/oet5xkm
17:23:00 <arnaud> awesome thks tjones
17:23:16 <tjones> ok anything else on bugs?
17:24:11 <tjones> i just unassigned my 2 bugs because i had not touched them in a month.  please do the same
17:24:11 <garyk> i have a critivial one in review
17:24:23 <tjones> link please?
17:24:25 <garyk> https://review.openstack.org/86115
17:24:56 <tjones> why critical?
17:25:15 <tjones> #action - please review http://tinyurl.com/oet5xkm
17:25:18 <tjones> #undo
17:25:19 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x2452310>
17:25:19 <garyk> it eats away a tone of space on the datastore - that is takes up twice the amout of space
17:25:26 <tjones> #action please review https://review.openstack.org/#/c/86115/
17:25:34 <tjones> good one
17:26:06 <rgerganov> is it OK to write unit tests for vmops.py in test_driver_api.py?
17:26:13 <tjones> #topic open discussion
17:26:20 <rgerganov> I got the impression that some of the core reviewers disagreed on that
17:26:21 <tjones> rgerganov: why not write them in vmops?
17:26:49 <tjones> rgerganov: yes i have something from matt on that.  let me dig it up
17:26:56 <vuil> should write in test_vmops.py
17:27:53 <rgerganov> that was the reason to -1 https://review.openstack.org/#/c/86115/ but wasn't completely sure
17:28:16 <tjones> i can't find it
17:29:11 <tjones> i think we need to continue to add tests to test_vmops
17:30:04 <tjones> anytihng else for discussion?
17:30:32 <tjones> Im going to start sending out a weekly email on vmwareapi so it's clear to everyone what we are doing and what our priories are.
17:32:12 <tjones> ok if nothing else.....
17:32:20 <tjones> we can have 1/2 hour back
17:32:56 <tjones> going once….
17:33:33 <tjones> ok thanks for joining everyone.  have a nice week
17:33:37 <tjones> #endmeeting