17:03:52 <hartsocks> #startmeeting VMwareAPI
17:03:53 <openstack> Meeting started Wed Nov 27 17:03:52 2013 UTC and is due to finish in 60 minutes.  The chair is hartsocks. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:58 <openstack> The meeting name has been set to 'vmwareapi'
17:04:15 <hartsocks> Hi everyone. Let's do a short meeting today b/c the holiday coming up.
17:04:20 <hartsocks> Who's around?
17:04:29 <tjones> hi hartsocks
17:04:39 <rgerganov> hello
17:04:56 <garyk> yo
17:05:15 <danflorea> hey
17:05:23 <syerrapragada> hi
17:06:34 <hartsocks> Let's just hop through these topics #bugs #blueprint (of the week) and #opendiscussion
17:06:43 <hartsocks> #topic bugs
17:06:53 <hartsocks> Last week we said we would follow up on 2 bugs...
17:07:16 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1252827
17:07:18 <uvirtbot> Launchpad bug 1252827 in openstack-vmwareapi-team "VMWARE: Intermittent problem with stats reporting" [Critical,In progress]
17:07:31 <hartsocks> I got asked to bump this down to "High" priority in Nova.
17:07:38 <hartsocks> But this is "Critical" for us.
17:07:40 <hartsocks> So …
17:07:52 <garyk> https://review.openstack.org/#/c/58705/
17:08:02 <hartsocks> VMwareAPI-Team shows it as critical.
17:08:17 <hartsocks> garyk: *awesome*
17:08:47 <hartsocks> We had a phone-based group chat on what was going on with that bug...
17:08:52 <danflorea> Nice. Now we need some of that karma with reviews.
17:09:08 <garyk> +1
17:09:11 <hartsocks> our best guess right now is that the root cause is property collectors and property filters are session specific...
17:09:39 <tjones> there's only one guy signed up to review.  so please add yourselves
17:09:42 <hartsocks> so, we need to retry, not at the failed method level directly, but we need to reset-up the whole session or whole sequence of calls.
17:10:38 <tjones> hartsocks: not to rathole but if that were true wouldn't ALL retries fail?
17:10:56 <hartsocks> *potentially*
17:11:07 <hartsocks> Right now we're better off fixing this in a one-off.
17:11:34 <tjones> but if this turns out to be true we better get a BP in for fixing this right :-D
17:12:05 <hartsocks> I have a general strategy I would like to propose but, I'll table it for another venue.
17:12:08 <garyk> we need to do analysis of the logs on the vc and esx. at the moment we are working on adding these to the report logs. that will help crystalize theories etc
17:12:16 <tjones> by "right" i mean for other cases
17:12:29 <tjones> not that garyk didn't do it "right" :-D
17:12:57 <garyk> heh - i never do it right
17:13:03 <tjones> LOL
17:13:17 <hartsocks> garyk: functioning and real beats imaginary and perfect *every* time!
17:13:28 <garyk> :)
17:14:01 <hartsocks> Okay, so that's a biggie bug. I brought attention to with the Nova Core that we'll want their help getting it approved fast.
17:14:17 <hartsocks> Also we mentioned… *digs for link*
17:14:50 * hartsocks groans, lost browser tabs
17:15:07 <hartsocks> bug/1195139
17:15:18 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1195139
17:15:20 <uvirtbot> Launchpad bug 1195139 in openstack-vmwareapi-team "vmware: error when using postgresql as DB" [High,In progress]
17:15:37 <hartsocks> I was asked to bump this down from Critical to "high" as well.
17:15:52 <garyk> that is in review and just needs to be approved
17:15:54 <hartsocks> So I've put it under VMwareAPI-Team so we can set our own priorities.
17:15:59 <garyk> the docker issue for the same thing was approved
17:16:08 <garyk> but i guess that is how it goes
17:16:15 <hartsocks> Nice. I'll be sure to whine… er… mention it.
17:16:21 <garyk> we have 2 +2's on this one and a ton of +1's….
17:16:50 <hartsocks> In general, it is practically impossible for a nova driver to have a "Critical" bug under the new priority scheme.
17:17:07 <hartsocks> I don't agree with it, but if we bump against that too much I don't expect good will.
17:17:30 <tjones> why has this one not merged with 2 +2?
17:17:58 <garyk> joe wanted an extra core reviewer to take a look.
17:18:02 <tjones> oh ok
17:18:15 <hartsocks> The second +2 doesn't necessarily equal "approved" BTW.
17:18:21 <hartsocks> It often can.
17:18:25 <hartsocks> But not always.
17:18:53 <hartsocks> I bumped that to "Critical" on our side.
17:19:07 <hartsocks> It will show as High/Critical in our reports.
17:19:37 <hartsocks> Anything else or any other bugs we need to look at?
17:20:09 <tjones> my remote debug thing - i need to ask russellb to remove his -2
17:20:29 <hartsocks> link?
17:20:44 <tjones> digging
17:20:52 <tjones> https://review.openstack.org/#/c/56287/
17:20:58 <tjones> #link https://review.openstack.org/#/c/56287/
17:21:00 <hartsocks> nice.
17:21:17 <danflorea> We need to also push on reviews to get bugs merged. Is that a different topic?
17:21:32 <hartsocks> #action ping russellb on https://review.openstack.org/#/c/56287/ to remove -2
17:21:53 <garyk> danflorea: agreed. we have the multi dc issue which has been in review (not really reviewed) for nearly 2 months
17:22:05 <hartsocks> I've been slacking a bit on my biweekly reports… so...
17:22:24 <hartsocks> #action get more reports to nova-core asking for their reviews
17:22:51 <tjones> it's not just core - it's +1s too.  we need to get better as at doing reviews
17:22:54 <hartsocks> danflorea: I usually mail the mailing lists twice a week on Mondays and Friday in the AM on our in-flight reviews.
17:23:10 <tjones> as == at
17:23:18 <danflorea> Thanks. Agree that we also need the +1's
17:23:30 <garyk> yeah agreed.
17:23:49 <hartsocks> If you're in this meeting you are officially part of our elite cadre of ninja reviewers.
17:23:58 <hartsocks> Go!
17:24:07 <tjones> hartsocks: im going to mod your report to print the names of who needs to review so we can send that info out to gently remind people to review
17:24:16 <hartsocks> nice.
17:24:51 <hartsocks> I post my review - report code here: https://github.com/hartsock/nova-reports
17:24:59 <tjones> yes i have synced it
17:25:03 <hartsocks> for anyone interested in doing reports like these.
17:25:11 <hartsocks> tjones: more for the list than you ;-)
17:25:21 <tjones> ja
17:25:53 <hartsocks> Any other buggy news?
17:26:20 <hartsocks> #topic blueprints
17:26:45 <hartsocks> last week we said: "ogelbukh, tjones, hartsocks, (and anyone else interested) to discuss config validation"
17:26:59 <hartsocks> so that hasn't happened. I'm guessing we'll follow up next week?
17:27:30 <hartsocks> #link https://blueprints.launchpad.net/nova/+spec/config-validation-script … link btw
17:27:46 <hartsocks> Does anyone have a BP they need to discuss this week?
17:27:46 <ogelbukh> I hope so
17:28:21 <garyk> there are 2 currently in review
17:28:25 <garyk> 1. diagnostics
17:28:30 <garyk> 2. image aging
17:28:31 <hartsocks> ogelbukh: short week this week, so we'll necessarily have to push things out. sorry.
17:28:40 <garyk> the former has been waiting for a while
17:28:44 <hartsocks> garyk: awesome. Links?
17:29:01 <garyk> sec
17:29:24 <garyk> diagnostics - https://blueprints.launchpad.net/openstack/?searchtext=vmware-vm-diagnostics
17:29:39 <ogelbukh> we actually prepared change to oslo.config for types checks, and started designing more complicated cross-services inspections
17:30:01 <garyk> cache management - https://blueprints.launchpad.net/openstack/?searchtext=vmware-image-cache-management
17:30:19 <ogelbukh> i'll update the etherpad and/or drop a message to ML when we have something we could discuss
17:30:28 <ogelbukh> probably next monday
17:30:51 <tjones> ogelbukh: sounds good
17:30:52 <vuil> vsan support : https://blueprints.launchpad.net/nova/+spec/vmware-vsan-support
17:31:00 <hartsocks> ogelbukh: awesome. let's try and talk about that early next week before this meeting comes around again.
17:31:13 <ogelbukh> ok
17:31:32 <tjones> vuil:  is vsan ready for i-1?
17:31:47 <tjones> garyk: i think diags and cache are ready for i-1
17:32:15 <vuil> The implementation is mostly there, need to factor out into smaller patches.
17:32:29 <hartsocks> we need to target these to a release to get any core attention.
17:32:32 <garyk> yup. the cache i have one outsnading item which will be ready by tomorrow (i owe vui two weeks of work :))
17:32:37 <vuil> Also need to test against a new vsphere with a bug fix that the patch would need
17:33:50 <hartsocks> okay, FYI: https://wiki.openstack.org/wiki/Icehouse_Release_Schedule
17:33:52 <vuil> Seems we should get the bp review process started
17:34:11 <hartsocks> I-1 is december 5th which is really really close.
17:34:47 <vuil> ah.. missed that. no in that case no, more an icehouse-2 thing then, given we have some internal dependencies too.
17:34:47 <hartsocks> I-2 is Jan 23rd which … while not as close … is tight because of the holiday breaks in there.
17:35:18 <tjones> yeah - so for i-1 we have a handful of bugs and 2 BP we would like to get in
17:35:42 <tjones> in 1 week (with a holiday for some of us)
17:36:12 <hartsocks> So early next week our priorities should be reviews, reviews, reviews, and soliciting Core reviews once we get things in shape.
17:36:17 <garyk> our next holiday this side of the world is in april
17:36:42 <hartsocks> I live in cyberspace, everyday is a party.
17:36:48 <garyk> heh
17:36:59 <hartsocks> :-)
17:37:38 <hartsocks> Yeah, so a lot of us will be in and out the next two months and we should plan for that.
17:38:13 <hartsocks> Next week during this meeting we can focus on the 2 BP we have for i-1 then.
17:38:32 <hartsocks> Then we'll turn to vSAN.
17:38:49 <hartsocks> And the config validation work which we're just getting started on.
17:38:54 <tjones> and hopefully config stuff
17:39:00 <hartsocks> :-)
17:39:13 <danflorea> As an overall thing to think about is moving code to Oslo. That may affect more than one BP.
17:39:36 <tjones> danflorea: good point
17:40:44 <hartsocks> we do have code that will be common for any vSphere product. There is apparently an established OpenStack way of moving project code around … I've been looking into it anyway.
17:41:32 <hartsocks> It will be good to lay out want common elements we can move out of individual VMwareAPI related drivers into a common lib.
17:42:18 <danflorea> Ok. Oslo stuff will be a project by itself. But as we start working on more BPs for IceHouse, it's something to keep in mind that your code may end up getting shifted to Oslo.
17:42:49 <hartsocks> modular and portable is the rule of the day I guess… :-)
17:43:07 <hartsocks> any other BP discussion?
17:43:49 * hartsocks counts to 10 before switching topics
17:43:56 <hartsocks> #topic opendiscussion
17:44:55 <hartsocks> Okay. I wanted today to be a short meeting for a short week. We have a lot to pick up later. It looks like we need to focus on our reviews…
17:45:23 <hartsocks> any stray topics on anything at all we should keep in mind before next week?
17:46:44 <tjones> any bugs needing triage today?
17:48:02 <hartsocks> We have a few. But, I was leaving the work for another time.
17:48:07 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1255355
17:48:08 <uvirtbot> Launchpad bug 1255355 in nova "VMware: Instances stuck in spawning when insufficient disk space" [Undecided,New]
17:48:37 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1249519
17:48:38 <uvirtbot> Launchpad bug 1249519 in nova "VMware: deleting instance snapshot too soon leaves instance in Image Uploading state" [Undecided,Confirmed]
17:48:51 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1243222
17:48:53 <uvirtbot> Launchpad bug 1243222 in nova "VMware: Detach after snapshot leaves volume in inconsistent state" [Undecided,Confirmed]
17:49:43 <hartsocks> these are all related to disks it seems… folks working with disk related scenarios a lot lately I gather?
17:51:10 <hartsocks> okay. we know what we'll do first thing next meeting I guess.
17:51:13 <danflorea> I would mark both of those bugs as High from our point of view.
17:51:38 <hartsocks> danflorea: presuming we can reproduce them of course…
17:51:43 <vuil> perhaps the behavior when an exception is thrown is now handled different in the upper layers. I will take a look at the first one.
17:51:51 <vuil> Easily produceable.
17:51:57 <danflorea> Yes, of course. Assuming they are valid, etc. Not critical but stuff that should work.
17:52:32 <vuil> I will take a look at the first two.
17:53:12 <hartsocks> Looks like only one hasn't been reproduced already.
17:53:38 <vuil> I think we can mark 1243222 as a dupe of 1252967
17:54:01 <vuil> Unless there is any other aspect to the problem we want to track in 1243222
17:54:16 <hartsocks> danflorea: just a reminder they (nova core) won't let us keep a "Critical" on anything we find that affects only our driver. So we have the VMwareAPI-Team sub project so we can assign our own public priorities.
17:54:27 <hartsocks> vuil: looking...
17:55:40 <hartsocks> hmm… okay… I don't think I understand how these are different so it looks like a dupe to me.
17:56:06 <vuil> deleting vm snapshot after nova snapshot has the side effect of restoring the volume to the correct state
17:56:15 <hartsocks> let's take that off-line.
17:56:27 <hartsocks> I really did want to end this meeting early :-)
17:56:38 <tjones> :-D
17:56:57 <vuil> you still have the power… for 4 mins
17:57:10 <hartsocks> #action vuil and garyk to follow up on whether bug/1243222 and bug/1252967 are the same.
17:57:33 <hartsocks> okay… 1 minute early is still early right? :-)
17:57:53 <hartsocks> #action bug triage for next week
17:58:01 <hartsocks> and I'm ending the meeting on that
17:59:01 <hartsocks> We're over in #openstack-vmware if you have anything you aren't 100% sure belongs in #openstack-nova …
17:59:08 <hartsocks> #endmeeting