17:00:53 <hartsocks> #startmeeting VMwareAPI
17:00:54 <openstack> Meeting started Wed Sep 25 17:00:53 2013 UTC and is due to finish in 60 minutes.  The chair is hartsocks. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:58 <openstack> The meeting name has been set to 'vmwareapi'
17:00:58 <hartsocks> who's about?
17:01:07 <hartsocks> tjones1, hey!
17:01:14 <tjones1> hey back
17:01:26 <AndroUser2> I am around
17:01:36 <AndroUser2> That i am gary
17:02:02 <hartsocks> heh
17:02:03 <tjones1> AndroUser2 == garyk?
17:02:11 <AndroUser2> Will be home in 10 minutes
17:02:16 <hartsocks> does the /nick command work?
17:02:16 <tjones1> lol
17:02:21 <AndroUser2> Yes
17:02:31 <hartsocks> Oh, you're incognito.
17:02:34 <hartsocks> okay.
17:03:00 <hartsocks> Anybody else about?
17:03:00 <garyk> That worked ! Thanks
17:03:24 <hartsocks> garky, groovy
17:04:29 <garyk> I am in a car on the way home - not sure hiw the conbection will behace
17:04:45 <tjones1> tisk tisk - no txt n drive
17:05:09 <garyk> It is not even my phone :)
17:05:13 <hartsocks> wow
17:05:16 <hartsocks> dedicated.
17:05:27 <vuil> hi all
17:05:37 <hartsocks> vuil, hey
17:05:45 <garyk> I am considering the openstack powered by vmware tatoo
17:05:53 <hartsocks> *lol*
17:05:54 <tjones1> ROTFL
17:06:14 <twoputt> lol
17:06:33 <hartsocks> #action get approval for official "OpenStack powered by VMware" tattoos for the team.
17:06:46 <hartsocks> #undo
17:06:47 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x32fc0d0>
17:06:55 <garyk> :)
17:06:57 * hartsocks joking
17:07:40 <garyk> Last week has been great for reviews
17:07:56 <garyk> Kudos to russellb and the team
17:07:58 <hartsocks> Yes in deed.
17:08:04 <vuil> ditt
17:08:08 <vuil> ditto
17:08:17 <hartsocks> So we're in feature freeze. I'm going leave any blueprint discussion to the open discussion bit at the end.
17:08:27 <hartsocks> #topic bugs
17:08:42 <hartsocks> Here's the bug report I ran this morning:
17:08:43 <hartsocks> http://paste.openstack.org/raw/47507/
17:09:07 <hartsocks> We've got two reviews "ready for core"
17:09:19 <hartsocks> (that means we're all in agreement)
17:09:35 <hartsocks> Everything else has cleared or merged already!
17:10:08 <hartsocks> The rest are all reviews we have to still look at ourselves or need to revise.
17:10:17 <tjones1> i rebased https://review.openstack.org/47503 but am running into test issues.  I need tests for https://review.openstack.org/46400 (having a lot of trouble figuring out how to do it - help appreciated)
17:10:54 <hartsocks> #help for https://review.openstack.org/#/c/47503/
17:11:18 <garyk> I can look a bit later
17:11:28 <hartsocks> cool.
17:11:33 <tjones1> actually it was https://review.openstack.org/46400 that i could use help with.  I need to look into why the tests that i didn't touch are failing for https://review.openstack.org/#/c/47503/
17:11:34 <garyk> We need to get reviews for the opaque networks
17:12:16 <hartsocks> okay.
17:12:20 <garyk> Tjones i will look in abiut 20 min whrn i can have a real keyboard
17:12:27 <hartsocks> #undo
17:12:28 <openstack> Removing item from minutes: <ircmeeting.items.Help object at 0x32f6b50>
17:12:32 <hartsocks> #help for https://review.openstack.org/46400
17:12:34 <vuil> looking at the test failures now
17:13:41 <hartsocks> okay, we can triage these on #openstack-vmware later.
17:13:48 <vuil> sure
17:13:56 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1217541
17:13:57 <uvirtbot> Launchpad bug 1217541 in nova "vmwareapi drivers - most summary fields need not be set" [High,In progress]
17:13:59 <hartsocks> and
17:14:16 <hartsocks> #link https://bugs.launchpad.net/bugs/1226211
17:14:17 <uvirtbot> Launchpad bug 1226211 in nova "VMware: some API's return only data on the first cluster and not the correct cluster" [High,In progress]
17:14:52 <hartsocks> as our two open bugs marked "critical" in our VMwareAPI-Team sub-project
17:15:04 <garyk> they are both in review - latter was approved - had to rebase
17:15:51 <garyk> Jenkins us a nightmare today - took about 8 hours for tge gating to pass
17:16:18 <hartsocks> yeah, I've noticed it's lagging. There was some chatter on the other channels about it being in trouble.
17:17:55 <hartsocks> let me run down the bugs we've tagged as "should have"
17:18:13 <hartsocks> #link  https://bugs.launchpad.net/bugs/1226052
17:18:16 <uvirtbot> Launchpad bug 1226052 in openstack-vmwareapi-team "VMware: VM creation ignores the size of the flavor root disk" [High,In progress]
17:18:50 <hartsocks> that looks like gary again!
17:18:54 <garyk> In review after rebase
17:19:07 <hartsocks> did it ever get some +2 attention?
17:19:32 <garyk> Dan smith had comments tgat i addressed
17:19:38 <hartsocks> okay good.
17:19:59 <hartsocks> only 2 more bugs on my list that are "should have"
17:20:08 <hartsocks> #link https://bugs.launchpad.net/bugs/1207064
17:20:10 <uvirtbot> Launchpad bug 1207064 in openstack-vmwareapi-team "VMWare : Disabling linked clone does not cache images on the datastore" [High,In progress]
17:20:26 <hartsocks> tjones1, is that the one you just mentioned?
17:20:36 <tjones1> that is the one i rebased and am having failed tests (on places i did not change)
17:20:47 <hartsocks> okay
17:20:51 <hartsocks> good.
17:20:55 <tjones1> it was a simple rebase - i think i have an env issue.  i should get it done soon
17:21:14 <hartsocks> last one...
17:21:17 <hartsocks> #link https://bugs.launchpad.net/bugs/1199954
17:21:19 <uvirtbot> Launchpad bug 1199954 in openstack-vmwareapi-team "VCDriver: Failed to resize instance" [Medium,In progress]
17:21:48 <hartsocks> that's gary's too… looks like some feedback from Dan Smith.
17:22:25 <hartsocks> So, anybody have an opinion on other bugs in progress?
17:22:39 <garyk> hi, i am back.
17:22:45 <hartsocks> hey.
17:23:10 <hartsocks> I was just about to solicit opinions on priority order for other bugs.
17:23:21 <hartsocks> Is there something important I've missed?
17:23:22 <garyk> sorry, just had to move from car to office
17:23:36 <vuil> bug 1229994: I am working on a fix and will send it out for review today
17:23:38 <uvirtbot> Launchpad bug 1229994 in nova "VMwareVCDriver: host in maintenance mode may cause snapshot failure" [High,New] https://launchpad.net/bugs/1229994
17:24:12 <vuil> it can use a confirmation by someone
17:24:25 <garyk> vuil: i'll take a look at it
17:24:40 <vuil> thx
17:25:41 <hartsocks> vuil, wasn't tagged "vmware" BTW
17:26:02 <vuil> oops.
17:26:06 <hartsocks> np
17:26:24 <vuil> I wil do… of course you did.
17:26:35 <hartsocks> I've been working this bug:
17:26:39 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1227825
17:26:41 <uvirtbot> Launchpad bug 1227825 in nova "datastore selection bug - fills first disk only" [High,In progress]
17:27:20 <hartsocks> This was reported via email by someone in the field. My goal was to create as targeted a fix as possible.
17:28:25 <hartsocks> Another bug …
17:28:28 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1214850
17:28:30 <uvirtbot> Launchpad bug 1214850 in nova "vmware driver selection of vm_folder_ref does not account for datastore" [High,In progress]
17:28:56 <garyk> hartsocks: looks like it close
17:29:08 <hartsocks> this one was something I was going to leave for Icehouse-1 but I think it might be more important.
17:30:36 <hartsocks> garyk, yeah, it was *supposed* to be simple.
17:30:44 <hartsocks> :-p
17:30:58 <vuil> severity wise 1227825 probably higher than this 1214850.
17:31:27 <hartsocks> I agree.
17:31:46 <hartsocks> I don't have that level of granularity without pulling in the other project.
17:32:36 <hartsocks> I feel like me declaring this a "Critical" or "must have" bug is a bit of conflict of interest since I'm working on it myself :-p
17:33:13 <hartsocks> So, should I mark this "Critical" or "High" on the VMwareAPI-subteam project?
17:35:06 <vuil> No sure, high maybe? I was going to work on this one today as well. Want me to do that?
17:35:07 <hartsocks> If it wasn't me working on it I suppose I wouldn't hesitate to call it "Critical" so I will.
17:35:47 <hartsocks> vuil, I'm just trying to not bias the priority cue because I'm partial to my own work.
17:36:23 <tjones1> lol
17:36:51 <hartsocks> I probably over think these things.
17:38:12 <hartsocks> vuil, I marked the bug you mentioned as "High" because you can work around the issue but it is a likely failure any enterprise would see without a fix. (assuming Gary confirms it)
17:39:28 <hartsocks> I'm going to mark https://bugs.launchpad.net/nova/+bug/1214850 for rc1 as soon as we can get a patch up for it. I'll try and push my patch for it today if Vuil doesn't mind.
17:39:30 <uvirtbot> Launchpad bug 1214850 in nova "vmware driver selection of vm_folder_ref does not account for datastore" [High,In progress]
17:39:32 <vuil> Sounds reasonable.
17:40:00 <hartsocks> okay. I feel reasonably democratic now. :-)
17:40:16 <vuil> by all means go ahead!
17:40:43 <hartsocks> Any other bugs we missed, or might be higher priority than we have marked?
17:41:57 <hartsocks> Okay, we have 3 bugs still in triage...
17:42:05 <hartsocks> #help for https://bugs.launchpad.net/nova/+bug/1230047
17:42:07 <uvirtbot> Launchpad bug 1230047 in nova "VMware: errors spawning large amounts of VMs" [Undecided,New]
17:42:35 <hartsocks> Looks like that one is from Ryan in our test team.
17:43:15 <hartsocks> Can someone else confirm that one?
17:44:07 <garyk> hartsocks: i have not seen that problem
17:44:31 <garyk> i ran into issues with the execption handling (trying to fix the bug
17:44:39 <hartsocks> okay.
17:45:04 <hartsocks> If I leave that an action item for myself I can get back to it until late Friday or early Monday if everyone else is busy.
17:45:19 <garyk> https://review.openstack.org/#/c/47743/ - basically when there is an exception on nova compute the exception will be moved to n-api
17:45:40 <garyk> this results in another exception when the Vim object is accessed - a deepcopy call is invoked
17:45:54 <hartsocks> huh.
17:46:28 <garyk> please look at https://bugs.launchpad.net/nova/+bug/1228847
17:46:29 <uvirtbot> Launchpad bug 1228847 in nova "VMware: VimException: Exception in __deepcopy__ Method not found" [High,In progress]
17:46:32 <garyk> you can see the stack trace
17:47:06 <garyk> basically it is easily reproduced - when nova network has no more ips and a new VM is deployed
17:47:28 <garyk> in ryans case it was an exception from the VC that threw the same error
17:47:37 <hartsocks> so… duplicate?
17:47:51 <garyk> i am not 100% sure
17:48:03 <garyk> in his case we need to get the trace from nova network.
17:48:32 <hartsocks> #action follow up on https://bugs.launchpad.net/nova/+bug/1230047 is it a duplicate of https://bugs.launchpad.net/nova/+bug/1228847
17:48:33 <uvirtbot> Launchpad bug 1230047 in nova "VMware: errors spawning large amounts of VMs" [Undecided,New]
17:49:06 <hartsocks> okay, that's a todo for one of us.
17:50:01 <hartsocks> Last two bugs that need triage:
17:50:08 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1209090
17:50:11 <uvirtbot> Launchpad bug 1209090 in nova "create VM instances failed  by  vmwareapi.VCDriver" [Undecided,Incomplete]
17:50:23 <hartsocks> This looks like a vanilla SOAP error we already took care of.
17:51:07 <hartsocks> last one...
17:51:10 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1217716
17:51:12 <uvirtbot> Launchpad bug 1217716 in nova "VMware: unable to boot an instance from .vmdk on ESX 5.1 host" [Undecided,Incomplete]
17:51:24 <hartsocks> that one troubles me more because I don't understand it.
17:52:29 <hartsocks> I *think* it's a non issue.
17:53:21 <hartsocks> okay.
17:53:34 <hartsocks> no need to get in discussion on that one.
17:53:40 <hartsocks> #topic open discussion
17:54:50 <hartsocks> any old thing to discuss while we're all paying attention at the same time :-)
17:55:10 <tjones1> oh - someone was having trouble with snapshots
17:55:11 <tjones1> https://ask.openstack.org/en/question/5274/snapshot-failure-with-vmwarevcdriver/?sort=latest
17:55:35 <tjones1> i told them to grab vui's latest but they are still having different issues now.
17:55:43 <tjones1> vui did you take a look?
17:57:27 <vuil> seems like the same thing cross posted to openstack-dev and the bug thread. I followed up in the bug thread. I am guessing probably a environment related error.
17:57:56 <hartsocks> Well… for what it's worth, when I saw this... I manually tested snapshot based on the master branch recently, it worked in my instance, so I felt this was probably some edge case.
17:58:37 <tjones1> yeah me too
17:58:45 <tjones1> just thought the logs may have a hint
17:59:51 <hartsocks> We currently don't get too much admin or "help desk" style traffic yet. I'm sure this will change.
17:59:52 <vuil> while testing myself I was reminded of a different issue with the maintanence mode host which is why I filed 1229994. But does not look like he hit that.
18:00:01 <vuil> Logs triple posted, not entirely useful.
18:00:34 <hartsocks> We probably need to push changes that will make things easier to diagnose.
18:00:39 <vuil> Pretty much if we encounter and error uploaded to glance or in our cleanup code, glance rolls back and delete trace of that snapshot
18:01:20 <hartsocks> ugh. yes. That leaves us with no forensic evidence to make a diagnosis from.
18:01:25 <vuil> I asked for nova compute log which is where the evidence will be. But like I said, probably env issues.
18:01:52 <hartsocks> We should probably have a bug or blueprint or bug-set that covers diagnostics.
18:02:12 <tjones1> ja
18:02:39 <hartsocks> Okay, we're out of time.
18:02:44 <hartsocks> Thanks for attending.
18:02:49 <tjones1> adois
18:02:51 <hartsocks> #endmeeting