17:01:19 <hartsocks> #startmeeting VMwareAPI
17:01:20 <openstack> Meeting started Wed May 29 17:01:19 2013 UTC.  The chair is hartsocks. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:23 <openstack> The meeting name has been set to 'vmwareapi'
17:01:29 <hartsocks> #topic salutations
17:01:40 <hartsocks> Greetings! Who is around to talk about VMwareAPI?
17:02:14 <ssshi> hi
17:02:14 <hartsocks> heh.
17:02:32 <hartsocks> hi
17:02:52 <hartsocks> I know Dan W. is traveling. Do we have anyone from HP here?
17:02:58 <kirankv> Hi
17:04:54 <hartsocks> that everyone?
17:05:15 <hartsocks> (this will be a short meeting then… kinda feel bad for kicking #cinder out now)
17:05:56 <ssshi> I'm just here to see you guys talking about the progress...
17:06:12 <hartsocks> okay...
17:06:14 <hartsocks> #topic Blueprint followups
17:06:26 <hartsocks> #link https://blueprints.launchpad.net/nova/+spec/multiple-clusters-managed-by-one-service
17:06:31 <hartsocks> and
17:06:38 <hartsocks> #link https://blueprints.launchpad.net/nova/+spec/accurate-capacity-of-clusters-for-scheduler
17:07:08 <hartsocks> kirankv: how is the copyright issue coming?
17:07:38 <Eustace> Copyright issue is still with Legal
17:07:43 <kirankv> well the concerned team is looking into it
17:08:10 <hartsocks> Any idea how long it might be? Will this cause problems hitting H-2 with these?
17:08:31 <kirankv> we will be posting the patches and hopefully we should have it sorted by that time frame
17:09:35 <hartsocks> please be sure to allow enough time for back-and-forth on the reviews. Lots of people will be looking at these.
17:10:15 <kirankv> yes, this week we should be able to post a patch set with most of the review comments addressed
17:10:50 <kirankv> The other reviews that have got multiple +1s are still not getting approved as well
17:10:59 <kirankv> how do we take them forward
17:11:20 <hartsocks> For the record, can you post links for the chat log?
17:11:45 <hartsocks> We need to get russellb to give his +2 to some of these.
17:12:06 <hartsocks> I noticed a comment from russellb related to:
17:12:09 <kirankv> https://review.openstack.org/#/c/29396/
17:12:17 <hartsocks> #link https://blueprints.launchpad.net/nova?searchtext=vmware
17:12:27 <kirankv> https://review.openstack.org/#/c/29552/
17:12:36 <kirankv> #link https://review.openstack.org/#/c/29552/
17:12:56 <hartsocks> where he mentioned that 4 of our blueprints are assigned to the same person...
17:13:11 <hartsocks> I presume that in fact the whole team is working on these?
17:13:26 <russellb> hartsocks: none are proposed for havana right now ... i kicked them back for whatever reason, once they're ready for me to review again, re-propose
17:13:41 <russellb> they need to be assigned to whoever is doing the work, have a milestone target set, and then proposed for the havana series
17:13:46 <kirankv> the cluster and resource pool related blueprints are part of the patchset that is now marked work in progress
17:14:50 <hartsocks> Hmm… locks like I can't fiddle with these very much.
17:15:34 <hartsocks> so… let's list what we need to do to these...
17:15:39 <kirankv> well they all are stuck due to the copyright concern
17:15:47 <hartsocks> 1) assign to the person doing the work...
17:16:02 <hartsocks> 2) yep… address that copyright concern...
17:16:24 <hartsocks> 3) assign a milestone target of H-2
17:16:43 <hartsocks> I can't do these steps since I'm not on the blueprint. Who can?
17:17:37 <hartsocks> Are we really completely stuck until that copyright comes off?
17:18:24 <russellb> the assignee can update them
17:18:26 <russellb> or you can ping me
17:18:52 <russellb> and yes, the copyright statement is completely useless AFAIK, and with no indication from the submitters of what purpose it was supposed to serve, i'm not accepting it ...
17:18:57 <russellb> nobody else does it
17:19:06 <russellb> our LegalFAQ now says don't do it
17:19:11 <kirankv> For esx-resource-pools-as-compute-nodes and Multiple VMware vCenter Clusters managed using single compute service, we are positive to make it to H2 since the patch set has been reviewed and we are in the process of addressing all review inputs
17:20:07 <russellb> hartsocks: you could submit your own blueprint, worded your own way, and then get the patch(es) updated to reference that blueprint
17:20:27 <russellb> and then we just close the problematic ones as superseded
17:21:08 <hartsocks> kirankv: how would you feel about this? Do you think that will cause any problems?
17:21:44 <russellb> it's kind of a silly thing to have the code have to block on
17:21:51 <russellb> so i'd recommend that so we can move on
17:22:21 <Eustace> The copyright is meant to indicate that the bp is submitted by an HP employee
17:22:42 <kirankv> hartsocks: I can get back to you on this by tomorrow
17:22:47 <Eustace> Is the Legal Wiki indicative of the legal stand of Openstack Foundation
17:23:24 <hartsocks> kirankv: okay. If I don't hear from you by this time tomorrow, I'll just do as russellb indicates and we can move forward that way.
17:23:33 <russellb> the LegalIssuesFAQ addresses that last question ... https://wiki.openstack.org/wiki/LegalIssuesFAQ
17:23:37 <russellb> (is it an official opinion)
17:23:51 <russellb> no, it is not
17:23:56 <hartsocks> kirankv: it is just paperwork… but I understand some companies might track these things on some people's performance reviews.
17:24:22 <hartsocks> Okay, so we have an action plan there and we can finally unblock these two Havana-2 milestone blueprints.
17:24:27 <Eustace> Then what is the Legal stand
17:24:34 <russellb> hartsocks: hopefully based on the code, not blueprint paperwork
17:24:44 <kirankv> well it not performance reviews in our case
17:24:53 <russellb> who files blueprint paperwork isn't terribly meaningful
17:24:55 <hartsocks> russellb: I try not to presume. You never know.
17:25:10 <russellb> i'm not presuming anything, i'm just stating my opinion on the usefulness of such a thing :-)
17:25:17 <hartsocks> *lol*
17:25:47 <hartsocks> Okay, then we're agreed, this whole copyright business can get cleared up quickly and isn't of any consequence?
17:26:04 <russellb> it *can* be, will it be?  not in my hands
17:26:19 <russellb> hopefully i've at least made my stance clear
17:26:20 <Eustace> If the copyright is not the Legal stahd of the openstack foundation then there is no reason to block checkins
17:27:31 <ssshi> https://blueprints.launchpad.net/glance/+spec/hypervisor-templates-as-glance-images , this bp was also targeted at havana-2, should we add something in nova to support its validation?
17:27:51 <russellb> we don't need official legal opinion on every little thing, this was consensus on the legal discussion mailing list
17:28:09 <russellb> and as the PTL, it's my domain to set the rules on what can and can not go in
17:28:13 <kirankv> ssshi: yes some changes are required in the nova driver
17:28:22 <hartsocks> #link https://blueprints.launchpad.net/glance/+spec/hypervisor-templates-as-glance-images
17:28:26 <russellb> anyway, *moves on*
17:28:43 <Eustace> I'm sure I can update this Wiki and get this point removed... So then there is no validity of the copyright issue
17:28:58 <Eustace> The checkins should be thne allowed against the original BP
17:29:12 <ssshi> kirankv: and any bp on the nova side for this glance bp?
17:29:38 <hartsocks> Eustace: can we also distribute the blueprint's assignee's between your team members actually doing the work?
17:29:53 <Eustace> Kiran is doing all the work...
17:30:05 <hartsocks> You have one developer?
17:30:15 <Eustace> He is very productive :)
17:30:16 <kirankv> ssshi: https://blueprints.launchpad.net/nova/+spec/deploy-vcenter-templates-from-vmware-nova-driver
17:30:31 <kirankv> hartsocks: its assigned to the person working on it :)
17:30:38 <Eustace> yes
17:30:56 <Eustace> and we can get all the patches in for H2
17:31:43 <kirankv> the other patches are smaller and they all depend on the patch for multi cluster support using single service
17:31:52 <kirankv> thats the reasonw e are holding them up
17:31:58 <hartsocks> Well, we've targeted 2 of the blueprints for H2. Based on how well that went, you have 2 more… and a glance patch...
17:32:36 <hartsocks> … and it sounds like ssshi has identified a 3rd nova bp that needs to be written...
17:33:00 <kirankv> we've worked around the glance part, so changes would not be needed on the glance driver, doc updates only
17:33:15 <russellb> Eustace: the fact that you can vandalize the wiki to remove a point that was the result of a discussion on a mailing list is the worst argument i've heard.  you're killing me.
17:33:59 <hartsocks> ?
17:34:14 <hartsocks> … reads through backlog ...
17:35:26 <kirankv> hartsocks: the nova changes required and asked by ssshi are addressed by #link https://blueprints.launchpad.net/nova/+spec/deploy-vcenter-templates-from-vmware-nova-driver
17:35:43 <russellb> hartsocks: sorry, was looking elsewhere for a bit, didn't mean to interrupt, *shuts up now*
17:35:44 <Eustace> The only point that I'm trying to make here is that this is not a Legal stand. Blocking a BP just because of a copyright is not right. I never meant to actually modify the Wiki :)
17:36:02 <russellb> Eustace: but it's *my* stance
17:36:12 <russellb> and I get to decide the rules for nova :-)
17:36:17 <russellb> and my stance is based on consensus
17:36:52 <hartsocks> kirankv: what's the target on this?
17:37:10 <kirankv> What we have seen is that we need to do quite soe refactoring to our UTs similar to how it is done for KVM libvirt driver, to write UTs quickly, right now it takes quite some effort to get the UTs done
17:37:50 <hartsocks> can we get an in-progress patch for review so the community can participate?
17:37:53 <kirankv> A week after the the multi cluster checin goes through we will have the patches updated for the other bps
17:38:15 <hartsocks> So...
17:38:28 <hartsocks> H-3 target?
17:38:42 <hartsocks> Can you put that in the BP?
17:39:04 <kirankv> well i can post them as work in progress once ive finished update the new patch set for the existing two bps this week
17:39:23 <ssshi> kirankv: what does UT stand for?
17:39:27 <hartsocks> Do you know what "Milestone target" is for?
17:39:38 <kirankv> ok, will mark them for H3
17:39:43 <hartsocks> Thank you.
17:39:53 <kirankv> Unit Tests
17:39:53 <Divakar> UT = Unit Test
17:39:56 <hartsocks> Please remove those Copyright lines.
17:40:08 <ssshi> got that. thanks.
17:41:06 <hartsocks> If they are not gone this week I will simply create new blueprints that russellb will approve… we can work from there. This will allow me to perform the project management and milestone target setting as well.
17:41:20 <russellb> hartsocks: sounds good, thanks
17:41:50 <hartsocks> Any more on blueprints before we move on?
17:42:32 <hartsocks> Okay.
17:42:42 <yaguang> I have create a blueprint https://blueprints.launchpad.net/nova/+spec/improve-vmware-disk-usage
17:43:30 <hartsocks> hmm… I'm not sure I understand this blueprint...
17:44:19 <yaguang> this to support  ephemeral   disk for instance
17:44:21 <kirankv> yaguang: do you want to make it par with libvirt behaviour?
17:44:31 <yaguang> yes
17:44:43 <yaguang> does it make sense ?
17:45:07 <kirankv> so you plan to add the difference between the image size and the flavor as as second disk?
17:45:39 <yaguang> yes
17:46:11 <yaguang> vm root size should be based on flavor
17:46:22 <yaguang> and has nothing with  the image size
17:46:30 <Divakar> You can extend the size of the existing disk as well
17:47:34 <hartsocks> Hmm… let's take this into #openstack-vmware for design discussion. This could go a number of different ways.
17:47:34 <ssshi> I'm wondering how to specify the root/ephemeral size if we were to deploy from vcenter templates.
17:48:31 <hartsocks> Whatever you discuss, put it in the blueprint so the discussion doesn't end up locked in IRC but makes it back to the rest of the community.
17:48:54 <yaguang> ok
17:49:36 <hartsocks> I'll put a note to follow up on this next week.
17:49:47 <hartsocks> #action follow up on https://blueprints.launchpad.net/nova/+spec/improve-vmware-disk-usage
17:49:49 <kirankv> yaguang: which milestone are you targeting this bp for?
17:50:22 <hartsocks> hey… over on #openstack-vmware with you! :-) target would be based on size-of-work which is based on design...
17:50:30 <yaguang> H2
17:50:58 <yaguang> yes, so it's early to set the milestone right now
17:51:42 <yaguang> we may need more discussion  for this
17:51:56 <hartsocks> yep. H2 might be realistic, but it probably isn't.
17:52:26 <hartsocks> I'm really glad the blueprint discussion has gotten lively (and messy) that's a good sign.
17:53:11 <hartsocks> Let's keep up the good work here and try and conform to what the Nova community needs from us. They have rules we need to follow. Let's try and follow them unless we have a solid reason to argue for different.
17:53:40 <hartsocks> We're running short on time.
17:54:49 <hartsocks> I'll ask that you use the #openstack-vmware channel to discuss issues in IRC when you need to, but remember to document changes in the BP. If anyone needs help writing things up my English is pretty good. I can help out if you need it.
17:55:19 <hartsocks> I do want to switch to a quick bug discussion.
17:55:26 <hartsocks> #topic high priority bugs
17:55:56 <hartsocks> Is there anything *not* assigned that is blocking users, customers, etc? that is not being addressed?
17:57:36 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1180044
17:57:37 <uvirtbot> Launchpad bug 1180044 in nova "nova boot fails when any VMware vCenter managed datacenter or container object is empty" [High,Confirmed]
17:58:25 <hartsocks> I am working on this next. Has anyone else observed this issue? It turns out this may be peculiar to a sub-set of users.
17:58:43 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1183192
17:58:47 <uvirtbot> Launchpad bug 1183192 in nova "VMware VC Driver does not honor hw_vif_model from glance" [Critical,In progress]
17:59:02 <yaguang> I am working on this
17:59:34 <hartsocks> Looks like you need some reviews.
18:00:06 <hartsocks> Okay. I guess we're out of time.
18:00:21 <hartsocks> #openstack-vmware is open for people who still need to talk.
18:00:46 <hartsocks> … feel free to use that or set up meeting times in there. We can report them back to the official meeting later.
18:00:56 <hartsocks> See you next week. Same time, same channel.
18:01:00 <hartsocks> #endmeeting