08:00:10 <ifat_afek> #startmeeting vitrage
08:00:11 <openstack> Meeting started Wed Jul 20 08:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:15 <openstack> The meeting name has been set to 'vitrage'
08:00:20 <ifat_afek> Hi everyone
08:00:44 <nofar_schnider> hi!
08:00:58 <alexey_weyl> Hello there :)
08:01:25 <elisha_r> hi
08:01:27 <idan_hefetz> Hi!
08:01:52 <ifat_afek> Our agenda today:
08:01:58 <ifat_afek> * Status and Updates
08:02:03 <ifat_afek> * Open Discussion
08:02:22 <ifat_afek> #topic Status and Updates
08:02:39 <ifat_afek> Some short updates on my behalf
08:03:00 <ifat_afek> Vitrage mascot selection - we selected a few candidates: Butterfly, Tree, Parrot, Suricata
08:03:16 <ifat_afek> I'm waiting for OpenStack representative to approve them, and then we will vote
08:03:25 <ifat_afek> #link https://etherpad.openstack.org/p/vitrage-mascot
08:03:45 <ifat_afek> Yesterday I got emails for P and Q release naming polls. Check if you got ones too
08:03:59 <ifat_afek> Who wants to update?
08:04:15 <danoffek> Hi again
08:04:17 <danoffek> I'll update :
08:04:37 <danoffek> Added basic heat stack support, pre testing.
08:05:37 <danoffek> I'll add stack resource support after testing heat stack, to be able to show a full entity graph with VMs / other related to their relevant stacks, and to be able to do fulRCA
08:06:07 <danoffek> Between heat and nova / cinder entities
08:06:35 <ifat_afek> danoffek: that's great, heat stacks will add a lot to vitrage
08:06:48 <ifat_afek> BTW, is there a blueprint for that?
08:07:06 <danoffek> I'll add heat blueprint today
08:07:14 <ifat_afek> danoffek: cool, thanks
08:07:39 <ifat_afek> #action danoffek add heat blueprint
08:08:24 <idan_hefetz> I will update
08:08:41 <idan_hefetz> Vitrage templates has a new action 'mark_down', it allows the use of the nova notifier to send a force down API for a specific compute, still need to add tempest
08:09:02 <idan_hefetz> it is pushed to master and stable/liberty
08:09:15 <idan_hefetz> That's it :)
08:09:22 <nofar_schnider> I'll update
08:09:37 <nofar_schnider> elisha_r and I are working on the templates for Zabbix
08:09:38 <ifat_afek> idan_hefetz: great. this is needed for Doctor use cases
08:10:13 <nofar_schnider> The templates Fuel has for Zabbix are a big help
08:11:46 <nofar_schnider> We're using them and we will also add more if we need
08:13:01 <nofar_schnider> Other than that, we add YAMLs to define the alarms we need which connects the entities in Vitrage
08:13:45 <ifat_afek> nofar_schnider: you mean vitrage templates?
08:13:47 <nofar_schnider> the YAML is the vitrage template of course
08:14:05 <nofar_schnider> There's plenty to do :)
08:14:22 <ifat_afek> nofar_schnider: great, thanks
08:14:48 <alexey_weyl> Great, I will update
08:15:17 <alexey_weyl> I am working on 2 things at the moment
08:15:39 <alexey_weyl> 1. I am working on adding another tempest to the gate that will check the datasources tempests
08:15:51 <alexey_weyl> at the moment we only have the api tempest
08:16:14 <alexey_weyl> 2. I am working on making Vitrage work in liberty
08:16:28 <ifat_afek> alexey_weyl: that's great, our coverage will be much more signiricant with datasources tempests
08:16:39 <alexey_weyl> That includes the Vitrage processes themself and the horizon as well which means some work on the vitrage-dashboard
08:17:15 <alexey_weyl> Both of the tasks are near to be finished
08:17:21 <alexey_weyl> Thats it
08:17:34 <ifat_afek> alexey_weyl:great, thanks
08:18:41 <ifat_afek> Anyone else wants to update?
08:19:48 <emalin> hi
08:20:07 <emalin> I'm using vitrage in some other project without openstack
08:20:36 <emalin> And enjoy has great features of deduced state and RCA
08:20:40 <emalin> has=his
08:20:56 <ifat_afek> emalin: :-)
08:21:24 <emalin> I already install vitrage rpm in non openstack env, and it actually works !!
08:22:25 <emalin> I also plan to integrate vitrage with open id authentication protocl
08:22:26 <ifat_afek> emalin: wow! can you share some details?
08:22:48 <emalin> which will replace keystone authentication in my env
08:23:08 <ifat_afek> emalin: and how are you running it now without keystone?
08:23:30 <emalin> It's NFVO project
08:23:44 <alexey_weyl> Wow, That is Great!!! :)
08:23:52 <emalin> With RHEL 7.2
08:24:13 <emalin> Currently we disabled authentication.
08:25:12 <emalin> But in the future I want to use similar approach for authentication like the one that used in Mistral
08:25:29 <ifat_afek> emalin: this sounds great
08:25:49 <emalin> Another nice thing. I use non flat data in vitrage graph nodes, but using immutable dict
08:26:06 <emalin> but=by
08:26:35 <ifat_afek> emalin: you mean you put on the vertices properties which are dictionary?
08:26:43 <emalin> I would share the code in vitrage mailing list
08:26:59 <ifat_afek> emalin: that's a great idea
08:27:00 <emalin> ifat_afek - yes
08:27:41 <emalin> That is my updated
08:27:43 <emalin> update
08:28:25 <nofar_schnider> nice emalin. I'm waiting to see the code on the list!
08:29:21 <ifat_afek> emalin: thanks!
08:29:28 <ifat_afek> Anyone else wants to update?
08:31:05 <ifat_afek> #topic Open Discussion
08:31:14 <ifat_afek> Anything you would like to raise?
08:33:40 <ifat_afek> So I guess we are done for today
08:33:45 <ifat_afek> Goodbye :-)
08:33:52 <nofar_schnider> bye guys
08:33:57 <danoffek> by guys
08:34:00 <elisha_r> bye.
08:34:26 <ifat_afek> #endmeeting