08:00:38 <ifat_afek> #startmeeting vitrage
08:00:38 <openstack> Meeting started Wed Mar 30 08:00:38 2016 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:40 <alexey_weyl> Hi
08:00:42 <openstack> The meeting name has been set to 'vitrage'
08:01:43 <ifat_afek> Hi everyone :-)
08:01:56 <lhartal> hi all
08:02:02 <elisha_r> hi
08:03:46 <idan_hefetz> hi
08:04:39 <ifat_afek> #topic Current status
08:04:56 <ifat_afek> We have a new demo, with deduced alarms, deduced states and RCA 
08:05:06 <elisha_r> great!
08:05:10 <ifat_afek> I sent it to openstack, pinpoint and doctor. You can find it in vitrage wiki page, or here:
08:05:13 <elisha_r> saw it, was very cool
08:05:17 <ifat_afek> #link https://www.youtube.com/watch?v=vqlOKTmYR4c
08:05:18 <eyalb> hi all
08:05:32 <alexey_weyl> Great Demo :)
08:05:46 <ifat_afek> I updated the list of our blueprints, closed the ones that are already implemented
08:06:01 <ifat_afek> Please open new blueprints for the tasks you are currently working on.
08:06:07 <ifat_afek> #action make sure you have a blueprint for your current task
08:06:16 <ifat_afek> Newton suggested schedule was published. You can find it here:
08:06:27 <ifat_afek> http://releases.openstack.org/newton/schedule.html
08:06:33 <eyalb> nice
08:06:54 <emalin> hi
08:07:03 <ifat_afek> Aodh updates: I still didn't push my aodh fixes from the demo. having environment problems. will try to do it today
08:08:17 <idan_hefetz> I'm still on the aodh notifier, it is not finished yet, but deduced alarms are created in aodh, so that's nice
08:08:28 <ifat_afek> cool!
08:08:35 <idan_hefetz> hopefully will end by next week
08:09:01 <ifat_afek> idan_hefetz: great, thanks
08:09:41 <eyalb> i am still working on the neutron plugin
08:09:53 <ifat_afek> eyalb: and how is it progressing?
08:10:14 <eyalb> just wrote the synchronizer
08:10:26 <eyalb> still need to do the transformer
08:10:35 <eyalb> and also listen to event bus
08:10:40 <eyalb> for updates
08:10:58 <eyalb> also need to write a blueprint for the plugin
08:11:13 <ifat_afek> eyalb: cool, thanks
08:11:27 <elisha_r> A developer guide for how to do Nagios configuration within devstack has been pushed, awaiting review
08:11:43 <elisha_r> sorry - I'll go next
08:11:46 <elisha_r> A developer guide for how to do Nagios configuration within devstack has been pushed, awaiting review
08:11:56 <elisha_r> Making this part of the Vitrage stack should not be too difficult, and I'll be working on this in the coming days, though at low priority as other tasks take precedence as we approach the Austin Summit
08:13:00 <elisha_r> Regarding this automation, we've also decided to make the decision of whether or not to install/uninstall nagios as part of stack/unstack a parameter the user can set as they wish.
08:13:10 <ifat_afek> elisha_r: cool, I'll try to review your configuration guide today or tomorrow
08:13:34 <ifat_afek> elisha_r: we should discuss this indeed
08:14:24 <elisha_r> I agree. #action continue automatic installation of nagios in vitrage stack
08:14:35 <elisha_r> Another thing is that, at long last (yes, I know this has been said before) today we should be pushing also the evaluator design to gerrit. Let's hope :)
08:15:16 <ifat_afek> elisha_r: :-)
08:15:44 <elisha_r> Finally, work has started on dealing with inter-template interactions - e.g., overlapping templates that can impact the same resource in opposing ways.
08:16:45 <mkoushnir> Hi.
08:16:51 <elisha_r> we will probably need to take a simple and limited approach for the Austin date, and take a more comprehensive approach for the Newton release.
08:16:56 <danoffek> hi
08:17:02 <mkoushnir> My devstack machine still don't work and I wait for help from Eyal.
08:17:18 <mkoushnir> The code of 3 topology tempest test and one alarm test is finished, but I can't check it.
08:17:20 <elisha_r> Once there is a clear goal, I'll add documentation (perhaps a blueprint)
08:17:23 <elisha_r> thats it
08:17:40 <ifat_afek> elisha_r: great, thanks. overlapping templates is an interesting topic
08:18:29 <ifat_afek> mkoushnir: great that you finished writing the tests
08:18:53 <eyalb> mkoushnir: I will help u :-)
08:19:35 <alexey_weyl> Marina,
08:20:00 <alexey_weyl> I am planning to work on TEMPESTS from now for one and a hlaf week
08:20:03 <mkoushnir> Thanks, Eyal
08:20:21 <alexey_weyl> I am planning to sit with you and work on the tempests with you, and on other tests as well
08:20:45 <ifat_afek> alexey_weyl: great. any other updateS?
08:21:12 <alexey_weyl> In addition, I have added a plugin for Cinder, and we have a volume connected to an instance in the topology
08:21:15 <alexey_weyl> :)
08:21:22 <mkoushnir> Alosha,  I know. The meeting today 13:30
08:21:23 <ifat_afek> alaxey_weyl: cool!!
08:21:49 <ifat_afek> who else wants to update?
08:22:09 <lhartal> I want
08:22:42 <lhartal> this wee I will start to work on nova set state notifier
08:22:56 <ifat_afek> lhartal: this is very important to doctor use case
08:23:46 <lhartal> yes I know. I need to understand the Nova API and hopefully by the end of the wee I'll finish it
08:25:39 <lhartal> Also we want to add plugins.conf that will enable to add/remove and disable/enable plugins easily
08:26:09 <lhartal> also it will support the one-to-many realationship (one synchronizer to many transformers)
08:26:32 <lhartal> thats all
08:26:35 <lhartal> :)
08:26:51 <ifat_afek> lhartal: great, thanks
08:27:02 <ifat_afek> anyone else wants to update?
08:28:12 <ifat_afek> I don't see Eddie here, but I can update that he started checking vitrage intensively. we will soon have bugs in our list...
08:28:41 <ifat_afek> and another update: Guy is about to start writing the entities graph UI
08:28:57 <ifat_afek> #topic Review action items
08:29:11 <ifat_afek> • elisha_r decide about our approach to nagios installation as part of devstack installation
08:29:45 <elisha_r> as I wrote above, this will be delegated to the user to decide based on properties in the vitrage settings file
08:29:54 <ifat_afek> • lhartal support template validation
08:31:22 <lhartal> Currently it has a lower priority
08:32:32 <ifat_afek> lhartal: ok
08:32:36 <ifat_afek> • record a new demo
08:32:43 <ifat_afek> this was done :-)
08:32:49 <ifat_afek> #topic Next Steps
08:33:07 <ifat_afek> nothing much to say here. we should finish our tasks for the demo in austin
08:33:33 <ifat_afek> #topic Open Discussion
08:33:39 <ifat_afek> anyone wants to discuss anything?
08:37:00 <ifat_afek> ok, so goodbye :-)
08:37:11 <elisha_r> bye
08:37:19 <alexey_weyl> good bye my friends :)
08:37:23 <alexey_weyl> Comrads :)
08:37:34 <ifat_afek> #endmeeting