09:00:30 <elisha_r> #startmeeting vitrage
09:00:31 <openstack> Meeting started Wed Mar 16 09:00:30 2016 UTC and is due to finish in 60 minutes.  The chair is elisha_r. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:34 <openstack> The meeting name has been set to 'vitrage'
09:00:43 <elisha_r> Hi everyone :-)
09:01:07 <lhartal> hello :)
09:01:09 <idan_hefetz> good morning elisha_r and everyone!
09:03:13 <elisha_r> Our agenda: * Current status * Review action items * Next steps  * Open Discussion
09:03:23 <elisha_r> Our agena:
09:03:30 <elisha_r> * Current status
09:03:35 <elisha_r> * Review action items
09:03:36 <alexey_weyl> hello
09:03:42 <elisha_r> * Next steps
09:03:48 <elisha_r> * Open Discussion
09:04:09 <emalin> hi
09:05:05 <elisha_r> Hi
09:05:21 <elisha_r> #topic Current status
09:05:33 <elisha_r> I'll start.
09:05:49 <elisha_r> So this week was very productive. We completed the scenario evaluator, with three actions (raise_alarm, set_state and add_causal_relationship). This effectively gives us support for deduced alarms, deduced states and RCA.
09:06:10 <elisha_r> For all of these we have support in the Vitrage Horizon
09:06:16 <elisha_r> We plan on uploading a demo of these features this week.
09:06:44 <elisha_r> Also, ifat and ohad presented all of this at the OPNFV Hackfest this week, which went very well to the best of my understanding.
09:06:47 <emalin> Bravo
09:07:23 <elisha_r> We're finalizing the documentation for this feature, hope to upload it by the end of the week.
09:08:24 <elisha_r> That's it from me.
09:08:31 <elisha_r> Anyone else have updates?
09:09:10 <danoffek> RPC chapter finished for now. We have everything supported except for the schedualer / conductors which will not be in this phase.
09:09:30 <elisha_r> sounds great!
09:11:25 <elisha_r> danoffek - is there a clear idea of when the remaining features will be supported?
09:12:30 <danoffek> I have a clear idea when it won't. in the near 2 months I see no future development in this area
09:12:38 <elisha_r> ok. thanks
09:12:58 <idan_hefetz> I'll update
09:13:02 <idan_hefetz> Currently on the Notifiers and Aodh notifier blueprint.
09:13:13 <idan_hefetz> Bus messaging infra is ready, so that the evaluator sends messages to the bus regarding deduced alarms.
09:13:29 <idan_hefetz> Also, I've added a 'vitrage-notifier' service that listens to these messages.
09:13:40 <idan_hefetz> Currently working on the vitrage-notifier so it will have Ceilometer client to create and update aodh alarms.
09:14:46 <idan_hefetz> To create the client i'm adding the 'service credentials' to the configuration so that we have a keystone client to create the other clients (such as nova and ceilometer)
09:14:58 <idan_hefetz> That's it
09:15:17 <elisha_r> great progress!
09:16:14 <elisha_r> so, what remains in order for the notifier to be fully operational?
09:17:13 <idan_hefetz> I need to address the actual creation of the aodh alarms by the client
09:17:38 <idan_hefetz> and do some refactoring so syncronizers use the keystone client
09:18:22 <elisha_r> cool.
09:18:27 <elisha_r> anyone else?
09:20:00 <emalin> I will update
09:20:20 <emalin> We are going to use vitrage in nfvo system
09:20:54 <emalin> We would need ability to load new plugins that are not part of vitrage oprigianl code
09:21:36 <emalin> I'm meaning they porbably won't be part of vitrage repository since the nfvo system is not part of openstack at all
09:22:16 <elisha_r> so, do you plan on adding a blueprint for vitrage to support this?
09:22:19 <ayaho> hi
09:22:22 <emalin> We may also want plugable authorization method
09:23:32 <emalin> @elisha_r regards plugin - we still need to learn the current capabilities of vitrage
09:23:51 <emalin> If it's not supported yet, we will create new blueprint
09:23:58 <elisha_r> ok. sounds good
09:24:17 <emalin> Regards authorization, I pretty sure we will need new blueprint
09:24:54 <emalin> We heard there thoughts about changing the transformers to yaml files
09:25:29 <emalin> Is it going to happen in the coming days?
09:26:40 <lhartal> I have done POC on that and hopefully in the near future (not coming days) I will insert it
09:28:31 <emalin> OK
09:28:53 <elisha_r> ok. any more updates?
09:30:30 <elisha_r> #topic Review action items
09:31:13 <elisha_r> elisha_r upload documentation for evaluator
09:31:30 <elisha_r> This will hopefully take place this week
09:32:03 <elisha_r> #topic Next Steps
09:32:56 <elisha_r> The evaluator is done for basic functionality of deduced an RCA. However, there are several important features we still need to get a more stable and robust evaluator
09:33:33 <elisha_r> The main two we should consider next are support for NOT in the scenario condition, and dealing with template overlap
09:35:09 <elisha_r> I think it would be a good idea to plan for these, perhaps add relevant blueprints for this.
09:35:13 <elisha_r> that;s it from me
09:35:15 <elisha_r> anyone else?
09:36:28 <lhartal> I have whish list: I want to add Template Content Validation and templates API
09:36:33 <danoffek> I'm adding new templates to the basic templates list
09:38:13 <elisha_r> #action support template validation
09:38:44 <elisha_r> (not sure I'm using the hash sign correctly...)
09:39:00 <elisha_r> #topic Open Discussion
09:39:11 <elisha_r> anyone have something to discuss?
09:39:52 <amir_gur> bye
09:40:21 <elisha_r> ok. bye everyone...
09:41:15 <lhartal> bye bye
09:41:20 <elisha_r> #endmeeting