09:00:28 <ifat_afek> #startmeeting vitrage
09:00:30 <openstack> Meeting started Wed Mar  9 09:00:28 2016 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:33 <openstack> The meeting name has been set to 'vitrage'
09:00:39 <ifat_afek> Hi everyone :-)
09:00:58 <idan_hefetz> Hi all!
09:01:02 <eyalb> hi
09:01:17 <elisha_r> hello!
09:01:23 <alexey_weyl> Hi
09:01:30 <lhartal> hi all :)
09:05:09 <ifat_afek> #topic Current status
09:05:17 <ifat_afek> I'll start with aodh
09:05:37 <ifat_afek> Last week I finished writing the two aodh blueprints, for snapshot plugin and notifier.
09:05:45 <ifat_afek> I joined ceilometer IRC meeting and asked them to review it. They seemed interested, but didn’t review our blueprints yet
09:05:55 <ifat_afek> #link https://review.openstack.org/#/c/287686/2/specs/mitaka/synchronizer-aodh-get-all.rst
09:06:01 <ifat_afek> #link https://review.openstack.org/#/c/287861/2/specs/mitaka/aodh-notifier.rst
09:06:14 <ifat_afek> I started the implementation of aodh plugin. Basic implementation is working, but the alarms are still not connected to resources
09:06:25 <idan_hefetz> First, Graph Notifier blueprint still requires some integration with the Evaluator, and will be closed soon.
09:07:10 <idan_hefetz> Second, regarding Aodh-Notifier blueprint, i will share my design later on today
09:07:49 <idan_hefetz> we had some advances with bus notifications, that will make it easier to implement
09:08:13 <omer_etrog> hi
09:08:41 <ifat_afek> idan_hefetz: cool
09:09:07 <ifat_afek> Ohad and I are preparing to the hackfest next week. And we are all working on preparing a demo
09:09:53 <ifat_afek> My part is of course to make sure nagios and aodh work
09:10:18 <ifat_afek> Other news: We got a comment to monasca blueprint from Roland Hochmuth, their PTL. They plan to implement something that will help us in the integration
09:10:24 <ifat_afek> #link https://review.openstack.org/#/c/253920/
09:12:30 <eyalb> monasca told me that that they started working on a feature for periodic notification
09:12:38 <eyalb> which can be good for us
09:12:56 <eyalb> I also added a readme file for the vitrage client
09:13:00 <eyalb> thats all
09:13:16 <ifat_afek> eyalb: I saw it, thanks. already added a link to this page in our wiki
09:13:26 <ifat_afek> who wants to update next?
09:14:10 <lhartal> I will update, for me and elisha_r
09:14:46 <lhartal> we are at the very last stages of finishing the evaluator, end to end
09:15:52 <lhartal> should have the set_state and rca actions supported by the end of the day, and the raise_alarm as well, though without the support of the notifier which is still in development
09:16:32 <lhartal> we will also add several initial templates into the default vitrage deployment.
09:16:37 <lhartal> that's it for now.
09:17:41 <ifat_afek> lhartal: great!!
09:18:22 <ifat_afek> so you mean we will see the deduced alarms in vitrage tree, but not in external sources like aodh (since the notifier is not finished yet)
09:18:24 <ifat_afek> ?
09:21:15 <lhartal> yes - right now we will see the Vitrage alarms only in Vitrage graph. Also, as I wrote, The AODH notifier is in developing stage so in the mear future we will be able to see deduced alarms in AODH
09:21:44 <ifat_afek> but once you are done, we will see them in the UI, right?
09:22:33 <lhartal> yes, in the alarms screen.
09:22:43 <ifat_afek> this is great
09:22:54 <ifat_afek> who wants to update next?
09:23:24 <alexey_weyl> I will update
09:23:47 <alexey_weyl> I have finished to work on the states and they are working.
09:24:07 <alexey_weyl> Now i am preparing 2 environments for the demo for OPNFV
09:24:43 <alexey_weyl> Due to that I am working on the integration of all the parts in Vitrage
09:24:58 <ifat_afek> alexey_weyl: great, thanks
09:25:33 <omer_etrog> I will update for Alon
09:25:40 <ifat_afek> omer_etrog: maybe you can update?
09:25:57 <ifat_afek> :-)
09:26:32 <omer_etrog> He add new icons and colors according to the alert severity
09:27:36 <omer_etrog> We are supporting @alexey_weyl in the installation
09:28:40 <omer_etrog> and I`m done
09:28:55 <ifat_afek> omer_etrog: thanks
09:29:25 <ifat_afek> noam_bloom is not here today. I know that he finished the first part of plugins loading from conf file, but still has some work to do
09:29:41 <ifat_afek> any other updates anyone?
09:30:24 <ifat_afek> ok, moving on
09:30:29 <ifat_afek> #topic Review action items
09:30:40 <ifat_afek> 1. ifat_afek update aodh blueprints
09:30:46 <ifat_afek> this is finally done :-)
09:30:53 <ifat_afek> 2. define what information that should appear in the alarms list
09:31:18 <ifat_afek> not done yet. we should do it once we see nagios alarms, aodh alarms and vitrage alarms together. hopefully today
09:31:26 <ifat_afek> #action define what information that should appear in the alarms list
09:31:41 <ifat_afek> 3. eyalb_ copy vitrage API documentation to the developer guide
09:32:28 <eyalb> yes still need to do it
09:32:36 <eyalb> I did it for the cli
09:33:20 <ifat_afek> eyalb: ok, thanks. you also documented the api in the blueprints, which are still open because we hope to get external reviews
09:33:25 <ifat_afek> moving on
09:33:30 <ifat_afek> #topic Next Steps
09:34:40 <ifat_afek> I think that next week we should record a new demo with all the cool functionalities - deduced alarms, deduced states and rca
09:35:02 <elisha_r> cool - can't wait to see it :)
09:35:49 <ifat_afek> #action record a demo with deduced alarms, deduced states and rca
09:35:55 <ifat_afek> anything else?
09:36:17 <ifat_afek> #topic Open Discussion
09:36:28 <ifat_afek> anything you want to discuss?
09:39:00 <ifat_afek> ok, so we're done
09:39:10 <eyalb> bye
09:39:15 <alexey_weyl> Bye bye all
09:39:16 <ifat_afek> bye everyoen
09:39:17 <elisha_r> bye
09:39:19 <ifat_afek> everyone
09:39:45 <ifat_afek> #endmeeting