09:00:58 <ifat_afek_> #startmeeting vitrage
09:00:59 <openstack> Meeting started Wed Jan 27 09:00:58 2016 UTC and is due to finish in 60 minutes.  The chair is ifat_afek_. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:03 <openstack> The meeting name has been set to 'vitrage'
09:01:17 <ifat_afek_> Hi everyone :-)
09:01:36 <lhartal> hi all :)
09:01:59 <elisha_r> hello
09:02:35 <amir_gur> Hi
09:03:23 <idan_hefetz> Hi
09:05:42 <omer_etrog> hi
09:05:48 <adi__> hi
09:06:06 <eyalb> hi
09:06:10 <ifat_afek_> #topic Current status and progress
09:07:25 <ifat_afek_> I don’t have many updates today
09:07:36 <emalin> hi
09:07:46 <ifat_afek_> I started checking Aodh solution that gordc suggested when I talked with him on their IRC channel. Still in progress
09:07:51 <nadav_yakar> hi
09:08:06 <ifat_afek_> updates anyone?
09:08:12 <eyalb> I will update
09:08:35 <eyalb> I added tests to the vitrage api
09:08:47 <eyalb> at the moment only get version
09:09:01 <eyalb> will add the get topology later
09:09:32 <alexey_weyl> Hello :)
09:09:37 <eyalb> with authentication later
09:09:46 <eyalb> that it
09:09:52 <ifat_afek_> great, thanks
09:09:52 <elisha_r> My update: Liat and I worked on the Vitrage Template (for RCA and deduced alarms, etc.) format, and uploaded it to github for review.
09:10:09 <ifat_afek_> looks good, I already reviewed it
09:10:24 <ifat_afek_> let's wait for other reviews before we approve it
09:10:47 <elisha_r> Got a few comments over the past few days, which will be updated there as well, hopefully in the next few days
09:11:09 <elisha_r> sure. will wait to get more before approving.
09:11:20 <elisha_r> that's it
09:11:29 <omer_etrog> I will update
09:12:00 <omer_etrog> we add installation process for vitrage-dashboard in devstack
09:12:03 <ifat_afek_> thanks elisha_r
09:12:04 <lhartal> I think we should start to work on it.. no need to wait for approving
09:12:22 <ifat_afek_> omer_etrog: cool! this is an important progress
09:12:45 <ifat_afek_> lhartal: right. you can start working, and if there are minor changes in the design you can change it later
09:13:16 <ifat_afek_> omer_etrog: any other updates on the ui?
09:14:08 <elisha_r> lhartal: I agree
09:14:31 <omer_etrog_> sorry, need to check the installation of python-vitrage in horizon
09:14:55 <emalin> I have no updates today
09:15:07 <ifat_afek_> emalin: thanks
09:15:41 <omer_etrog_> Alon is adding Legend to the sunburest
09:16:07 <omer_etrog_> and I`m done..
09:16:17 <ifat_afek_> omer_etrog_: thanks
09:16:24 <ifat_afek_> who else wants to update?
09:16:45 <alexey_weyl> me
09:16:57 <lhartal> I want
09:17:03 <alexey_weyl> We have published our first use case demo
09:17:19 <alexey_weyl> You can find it in Vitrage Wiki
09:17:34 <ifat_afek_> alexey_weyl: cool!!
09:17:46 <lhartal> do you have a link?
09:18:00 <ifat_afek_> alexey_weyl: you can write it with #link in the beginning
09:19:05 <lhartal> my updates: last week I worked on new design for the transformers
09:19:27 <lhartal> I did a POC and it looks very good
09:19:37 <lhartal> the main idea is that the transformers will be a YAML configuration files (instead of python code)
09:19:52 <lhartal> a transformer engine will load the files, parse them and create Entity Transformer object (per transformer file)
09:20:07 <lhartal> the problem was when we needed to add logic to each transformer. This makes the change too complicated and it requires to create a new blueprint
09:20:31 <lhartal> it becomes a complicated change requires us to open blueprint
09:20:40 <ifat_afek_> lhartal: do you have an example for such a logic?
09:21:07 <lhartal> yes
09:22:18 <lhartal> when the value is composed of several fields
09:22:42 <lhartal> when the key is the value itself
09:23:07 <lhartal> when the path to the vallue is dynamic
09:23:25 <ifat_afek_> lhartal: ok... makes sense to create a blueprint indeed
09:24:05 <lhartal> Also I started to work on loading the templates files into vitrage
09:24:17 <lhartal> thats all :)
09:24:20 <ifat_afek_> lhartal: thanks
09:24:23 <mkoushnir> The first tempest test for graph waiting in git review for approve
09:24:36 <ifat_afek_> mkoushnir: great!!
09:26:53 <mkoushnir> next step is e2e scenario - with real setup or simulator - create several instanses and hosts - create graph and full validation
09:27:13 <ifat_afek_> mkoushnir: this is an important step. we must have these tempest working in order to say we really completed a use case
09:27:34 <ifat_afek_> once the first one-two tests work, other people might write more tempest tests
09:27:55 <ifat_afek_> any other updates anyone?
09:29:25 <ifat_afek_> ok, let's move on
09:29:27 <ifat_afek_> #topic Review action items
09:29:43 <ifat_afek_> • ifat_afek continue discussions with Aodh
09:29:47 <ifat_afek_> this is in progress
09:30:13 <ifat_afek_> #action ifat_afek_ check aodh integration and update the blueprints
09:30:27 <ifat_afek_> • finalize get topology API
09:30:39 <ifat_afek_> we are waiting for PinPoint response. No action on our side for now
09:30:48 <ifat_afek_> #topic Next Steps
09:31:23 <ifat_afek_> I think it's a good time to review our next use case, go over the blueprints, and re-prioritize them
09:31:54 <lhartal> I agree with you
09:32:02 <eyalb> so do i :-)
09:32:24 <ifat_afek_> #action review our use cases, blueprints and priorities
09:34:13 <Ohad> yes I agree, we need to start work on plug-in for Nagios and HW failures such as switch failure, etc
09:34:34 <ifat_afek_> Ohad: right
09:34:39 <ifat_afek_> #topic Open Discussion
09:35:00 <ifat_afek_> anything someone wants to talk about?
09:36:12 <ifat_afek_> so I guess we are done for today
09:36:29 <ifat_afek_> goodbye everybody
09:36:53 <eyalb> bye
09:37:35 <mkoushnir> bye
09:38:12 <ifat_afek_> #endmeeting