09:00:41 <ifat_afek> #startmeeting vitrage
09:00:42 <openstack> Meeting started Wed Dec 16 09:00:41 2015 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:46 <openstack> The meeting name has been set to 'vitrage'
09:01:06 <ifat_afek> Hi everyone :-)
09:01:10 <emalin> hi
09:01:16 <ifat_afek> Today’s agenda:
09:01:20 <idan_hefetz> ין
09:01:22 <elisha_r> hello
09:01:24 <alexey_weyl> Hello :)
09:01:26 <idan_hefetz> hi :)
09:01:35 <emalin> -:)
09:01:49 <amir_gur> Hi
09:01:54 <eyalb> hi
09:02:47 <ShaharTesterChoi> Hi
09:03:11 <lhartal> hey
09:04:50 <Ohad> hi
09:05:06 <ifat_afek> Hi again. Our agenda:
09:05:14 <ifat_afek> * Current status and progress from last week
09:05:25 <ifat_afek> * Review action items
09:05:35 <ifat_afek> * Next steps
09:05:53 <ifat_afek> * Open Discussion
09:06:08 <ifat_afek> #topic Current status and progress from last week
09:06:21 <ifat_afek> First a reminder: Gerrit will be upgraded today at 17:00 UTC, and will be down for a few hours
09:06:58 <ifat_afek> It turns out that networkx is already a part of OpenStack :-)
09:07:04 <marina_> Hi
09:07:13 <ifat_afek> a project named TaskFlow is already using it (version 1.0), which means we can use it too without a need for someone to approve it (as a 3rd party library)
09:07:57 <ifat_afek> My update: I verified that we can create a semi-event alarm with no alarm actions and set its state from the api.
09:08:16 <emalin> great
09:08:20 <ifat_afek> No notifications are sent about the state change, but for mitaka we don’t need them.
09:08:32 <ifat_afek> . I’m still checking if there are better alternatives. Once I’m done, I’ll update ceilometer blueprint.
09:08:55 <ifat_afek> We had a meeting with Marina and Eliran, who explained to us the basics of tempest tests.
09:09:03 <ifat_afek> Marina, do you want to update?
09:09:41 <marina_> My update: The vitrage_tempest_tests folder appears temporarily under "vitrage project", but it's purely tempest tests for rca block.
09:10:02 <ifat_afek> cool, thanks
09:10:47 <ifat_afek> BTW, some of us got a mail where we can select a name for N* release
09:11:09 <ifat_afek> Who else wants to update?
09:11:10 <umargolin> Also the "O" release
09:11:15 <emalin> We had another vitrage synchronizer desgin meeting, and we need to learn the some oslo components to proceed
09:12:09 <emalin> I also check the ability of ceilometer to monitor switches
09:12:24 <ifat_afek> any interesting conclusions?
09:12:30 <emalin> Not yet
09:12:35 <ifat_afek> ok
09:13:25 <elisha_r> I've been working on upgrading the mock functionality, to match the updated format of nova synchronizer info.
09:13:40 <elisha_r> and in the process, also supporting more "logical" flows
09:13:57 <elisha_r> hope to get it done in a few days, bugs allowing :)
09:14:03 <elisha_r> thats it
09:16:05 <eyalb> I am still working on authentication and authorization of the client and server
09:17:09 <eyalb> we need to figure out what are the roles for authorization for our api
09:17:43 <eyalb> who can see the the topology for example
09:17:52 <eyalb> thats it
09:18:09 <ifat_afek> Ohad, what do you think?
09:19:40 <Ohad> good point - we need to further look in it. I think that we can start with admin.
09:20:03 <ifat_afek> makes sense
09:20:40 <idan_hefetz> Eyal, Elisha and I have defined the minimal functionality needed at this point to allow graph queries for the first use case.
09:20:51 <idan_hefetz> That is, perform a query by depth with filtering over the the edges and vertices properties.
09:21:08 <ifat_afek> great
09:21:30 <emalin> Eyal regards your question, I think we need to filter the resources the user see by his project
09:22:27 <ifat_afek> but does it make sense that a customer can see the topology of the entire system? we need to think about it...
09:22:54 <ShaharTesterChoi> QA team started working on creating basic tempest tests which will later on be integrated and monitor our progress when things will start running on Vitrage
09:23:02 <umargolin> Only Amanda can see the entire system.
09:23:08 <ifat_afek> regarding the alarms, emalin you are right - each customer should see the relevant alarms
09:23:17 <emalin> Who is Amanda ?
09:23:52 <elisha_r> You don't know who Amanda is?
09:24:39 <ifat_afek> ShaharTesterChoi thanks!
09:25:55 <emalin> I think that each member should see the vitrage RCA relevant to his project
09:26:29 <ifat_afek> of course. the question is what if the root cause is an alarm that belongs to the admin
09:27:31 <umargolin> Amanda is the datacenter owner. I agree that each user should only see resources that he's aloowed to use. We do need to think who to give access to the full picture as this has lots of value. Could be per deployment
09:27:41 <ifat_afek> we should check what is OpenStack policy regarding visibility of admin resources to the projects
09:28:15 <Ohad> I think that a customer should see the alarm belong to admin (example: host alarm) just for what relevant to him but not the entire system.
09:28:46 <umargolin> Problem is that a host may serve more then one tennant
09:29:21 <Ohad> maybe a customer should not see all information for admin resources but at least to know that this alarm/s are part of the root cause pattern,
09:30:55 <omer_etrog> we should keep our policy as we do in cloudband
09:30:56 <ifat_afek> Ohad, I agree. so let's make it the behavior for now
09:31:29 <ifat_afek> let's move on. who else wants to update?
09:31:37 <omer_etrog> we need to enforce it in the UI and API?
09:32:05 <ifat_afek> the API will make the decisions I think
09:32:29 <ifat_afek> based on the user that called this API
09:32:53 <omer_etrog> great
09:32:59 <ifat_afek> omer_etrog, any updates regarding the UI progress?
09:33:14 <emalin> Makes sense
09:33:58 <omer_etrog> we in a process to create a POC for the entity graph
09:34:47 <ifat_afek> great, thanks
09:34:53 <ifat_afek> any other updates anyone?
09:35:21 <ifat_afek> let's move on to the action items
09:35:26 <ifat_afek> #topic Review action items
09:35:39 <ifat_afek> • ifat_afek check Aodh integration workaround and update Ceilometer blueprints
09:36:03 <ifat_afek> this is in progress. like I already said, I have a workaround, but still looking for a better solution
09:36:26 <ifat_afek> #action ifat_afek check Aodh integration workaround and update Ceilometer blueprints
09:36:37 <ifat_afek> • decide how to implement list alarms UI
09:36:52 <ifat_afek> For now the decision is that there will be Vitrage UI for list alarms (different from the ceilometer horizon UI that ^Gal^ checked).
09:37:07 <ifat_afek> Vitrage UI will get the list of alarms from Aodh
09:37:18 <ifat_afek> • start discussing the tempest tests
09:37:40 <ifat_afek> Done, need to continue the discussions.
09:38:37 <ifat_afek> • finalize synchronizer design
09:38:52 <emalin> synchronizer design is in progress
09:39:17 <ifat_afek> • checkin a basic synchronizer FW for the vitrage graph to interface with and see that we are on the same page
09:39:36 <emalin> It's also in progress
09:39:39 <ifat_afek> this was nadav_yakar's action item, and he is on vacation. let's wait for his update
09:40:01 <ifat_afek> #action nadav_yakar checkin a basic synchronizer FW for the vitrage graph to interface with and see that we are on the same page
09:40:11 <ifat_afek> • elisha_r end-to-end API flow for the first use cases
09:40:36 <elisha_r> Idan, eyal and I have started looking into this, as idan updated
09:42:29 <ifat_afek> • create puppet-vitrage project (maty)
09:43:21 <ifat_afek> Aya's response (she has a technical problem to connect): still in progress. the puppet has a new convention, we will be the first ones to use it, so it takes more time
09:43:46 <ifat_afek> Aya: we are waiting for +2 on our change
09:44:01 <ifat_afek> #topic Next Steps
09:45:20 <ifat_afek> we should go on with the tempest tests, and understand what kind of tests we want to write
09:46:42 <ifat_afek> we should also start thinking about our documentation - developer's guide, how to, etc.
09:47:17 <ifat_afek> #action ifat_afek check how we should add vitrage documentation
09:47:18 <lhartal> Please notice that we added Vitraege Exception and a list of Vitrage errors. You can use it in your code and you can add new relevant errors
09:48:04 <ifat_afek_> anything else?
09:48:26 <ifat_afek_> I noticed that we did not yet talk about the set-state use case. We don’t even have a blueprint for it. Note that it means that the topology view will show Nova state for all entities, and not the vitrage deduced state.
09:50:24 <lhartal> Good point - lets scedule a meeting and to disccuss on it and next Vitrage use case
09:50:29 <ifat_afek_> ok
09:50:46 <ifat_afek_> #action decide on Vitrage next use cases
09:50:54 <ifat_afek_> #topic Open Discussion
09:51:05 <ifat_afek_> anything?
09:51:17 <ifat_afek_> goodbye then :-)
09:51:22 <amir_gur_> bye
09:51:25 <alexey_weyl> Bye :)
09:51:30 <emalin> see you next week
09:51:33 <emalin> :)
09:51:35 <lhartal> goodbye :)
09:52:37 <ifat_afek_> #endmeeting
09:53:41 <Ohad> #endmeeting
09:53:47 <lhartal> #endmeeting
09:54:32 <ifat_afek> #endmeeting