08:59:36 <ifat_afek> #startmeeting vitrage
08:59:37 <openstack> Meeting started Wed Nov 11 08:59:36 2015 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:59:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:59:40 <openstack> The meeting name has been set to 'vitrage'
09:00:19 <emalin> hello all
09:00:24 <ifat_afek> Hi everyone, welcome to vitrage weekly meeting. Posting a link to the agenda:
09:00:27 <nadav_> hello
09:00:32 <mgrosz> hellow
09:00:36 <ifat_afek> #link https://wiki.openstack.org/wiki/Meetings/Vitrage#Agenda_for_the_next_meeting
09:00:48 <ifat_afek> #topic Meeting Summaries
09:00:58 <ifat_afek> Let’s go over the meetings we had during the last week, and see how we progressed.
09:01:13 <ifat_afek> We had a meeting with everyone involved in Vitrage project. We went over the high-level architecture, and decided about the responsibilities of the different teams.
09:02:22 <ayah> hi
09:02:38 <eyalb> hello
09:02:56 <alexey_weyl> We had a blueprints meeting, and decided on the blueprints that needs to be done for mitaka. In addition we thought of more blueprints which will be done if we will have the time
09:03:29 <alexey_weyl> The blueprints can be seen in our launchpad and also in github and gerrit under vitrage-specs
09:04:03 <alexey_weyl> if anyone has any reviews on the blueprints it will be great.
09:04:26 <alexey_weyl> We are planning to finish the the blueprints reviews until the next meeting
09:05:18 <alexey_weyl> #link https://blueprints.launchpad.net/vitrage
09:05:41 <alexey_weyl> this is the link to the blueprints in launchpad
09:05:52 <ifat_afek> Thanks. Nadav, can you update about Vitrage Synchronizer meetings?
09:06:05 <nadav_yakar> we have written the synchronizer blueprint and gerrit design
09:06:47 <nadav_yakar> these assumes the synchronizer need to deduce the changes out of OS services which returns only a snapshot,
09:07:20 <nadav_yakar> but now we are checking which notifications are revealed over the message bus,
09:07:50 <nadav_yakar> which may enhance our design
09:07:55 <elisha_rosenswei> have you started to consider non-OS syncronizers as well?
09:08:23 <elisha_rosenswei> OS = OpenStack
09:08:26 <emalin> we are consider them
09:08:44 * omer_ slaps AlonHeller around a bit with a large fishbot
09:09:31 <emalin> We would need to use rest api call to get the data from them
09:09:50 <ifat_afek> Alon, can you update about the meeting regarding Vitrage UI in horizon?
09:11:21 <AlonHeller> I created the UI blueprint for  the system health, and started to setup the devstack
09:12:25 <elisha_rosenswei> you can see it here:
09:12:28 <elisha_rosenswei> #link https://blueprints.launchpad.net/vitrage/+spec/ui-system-health-sunburst
09:13:41 <emalin> Alon, do you already know how are you going to implement it ?
09:13:48 <AlonHeller> Omer will create today the blueprint for UI-RCA
09:14:35 <AlonHeller> Not yet @emalin, Working on that
09:14:36 <nadav_yakar> for whoever is interested, following is the most up-to-date synchronizer gerrit review - http://docs-draft.openstack.org/44/243244/1/check/gate-vitrage-specs-docs/22618ff/doc/build/html/specs/mitaka/vitrage-synchronizer.html#change-notificationshttp://docs-draft.openstack.org/44/243244/1/check/gate-vitrage-specs-docs/22618ff/doc/build/html/specs/mitaka/vitrage-synchronizer.html#change-notifications
09:15:17 <nadav_yakar> #link - http://docs-draft.openstack.org/44/243244/1/check/gate-vitrage-specs-docs/22618ff/doc/build/html/specs/mitaka/vitrage-synchronizer.html#change-notifications
09:17:12 <ifat_afek> Regarding the status of our blueprints, I see that most blueprints were rewritten in gerrit, and match our updated architecture.
09:17:31 <ayah> alon please add a link to the gerrit
09:17:42 <ifat_afek> #action ifat_afek make sure we finish updating our blueprints in the following days
09:17:59 <ifat_afek> #topic Openstack Procedures
09:18:41 <ifat_afek> During the last week we configured our openstack environments, and have our meetings in the official openstack channel. Thanks mgrosz and alexey_weyl
09:19:08 <ifat_afek> #topic Next Steps
09:19:21 <mgrosz> Work that has been done till now: new vitrage, vitrage-specs, vitrage-dashbaord (UI) rpoject are already in github, ready for your code. Note the temaplate in vitrage-specs for new specifications - tests check all titles from the temaple do exist. I still need to push the initial files in the dashboard project.Later, once it wil be relevant, I will
09:19:21 <mgrosz> also add the vitrage client project (python-vitrageclient).
09:20:12 <mgrosz> (sorry for the typos...)
09:20:22 <emalin> nice work
09:20:32 <ifat_afek> Thanks Maty
09:21:05 <ifat_afek> There are several issues we need to address next.
09:21:20 <ifat_afek> . First, once we finish writing down all blueprints, we should meet and assign blueprints to the developers that plan to implement them.
09:22:47 <ifat_afek> We should also finish the discussions regarding the synchronizer architecture, and update its blueprint.
09:23:41 <emalin> We saw nice openstack project that has code we can use in the syncronizer
09:24:16 <emalin> It called search light
09:24:52 <alexey_weyl> We plan to finish all blueprints review until the next meeting
09:25:09 <danoffek> can we reuse that code ?
09:25:29 <nadav_yakar> #link https://wiki.openstack.org/wiki/Searchlight
09:25:31 <emalin> This project collect data form OpenStack services for build search DB
09:26:04 <emalin> We can use the same logic for our synchronizer
09:26:54 <elisha_rosenswei> cool
09:26:59 <emalin> We would examine the project in the coming days
09:27:13 <mrunge> emalin, there should be a hook or a notifier. I sounds so ugly to copy code and re-use it in the same way
09:27:34 <mrunge> or you should get in touch with searchlight folks to make that code a library
09:27:35 <nadav_yakar> #action talk with them at room openstack-searchlight
09:28:00 <alexey_weyl> Thanks mrunge :)
09:28:08 <emalin> I would get in touch with them
09:28:26 <mrunge> I believe, you're not alone with the same request. gnocchi or ceilometer should have the same issue
09:28:45 <mrunge> (or the other way around, searchlight should hook into ceilo or gnocchi)
09:29:38 <emalin> We would try to reuse the code of one of these projects
09:30:09 <ifat_afek> interesting input, thanks mrunge
09:30:54 <mrunge> you're welcome. I was just stating, others might have the same issue as you guys, no need to re-invent the wheel again
09:31:17 <emalin> 10x
09:32:32 <ifat_afek> thanks, let's move on
09:32:35 <ifat_afek> Once we are done with the high level architecture, we should start talking about the interfaces between the different components.
09:33:06 <ifat_afek> Anyone from Doctor or PinPoint joined our meeting?
09:33:51 <ifat_afek> We should contact Doctor and PinPoint guys, and ask them to review our blueprints. It is important to see that our architecture can match their requirements.
09:34:16 <alexey_weyl> I will talk with Doctor guys
09:34:57 <ifat_afek> ok, I'll talk with PinPoint guys
09:35:30 <ohad> OPNFV summit this week. we will continue discussions with them next week.
09:35:52 <ifat_afek> ok. So let me summarize our action items:
09:36:05 <ifat_afek> #action all finish the discussions regarding the synchronizer, and optionally update its blueprint
09:36:20 <ifat_afek> #action all assign blueprints to developers
09:36:50 <ifat_afek> #action alexey_weyl contact Doctor guys, ask them to review our blueprints
09:37:15 <ifat_afek> #action ifat_afek contact PinPoint guys, ask them to review our blueprints
09:37:45 <ifat_afek> #topic Open Discussion
09:37:53 <ifat_afek> Anything else?
09:38:50 <AlonHeller> @mrunge, do you have any experience with AngularJS Horizon plugin ?
09:39:03 <mrunge> a little AlonHeller
09:39:47 <mrunge> the situation is quite clear here, you folks should build a plugin for horizon
09:39:49 <AlonHeller> OK, I'll talk with you in private. Maybe you can help me.
09:39:58 <mrunge> sure
09:40:19 <mrunge> hmm, maybe we should move that to #openstack-horizon?
09:40:37 <AlonHeller> Sure
09:40:44 <mrunge> it's nothing super secret, right? it's open source, let's keep it open
09:41:03 <AlonHeller> No secrets
09:41:14 <mrunge> ;-)
09:43:08 <robcresswell> I'm also around to give pointers on the Horizon work
09:43:25 <robcresswell> If you needed advice etc :)
09:44:14 <mrunge> pointer: https://developer.ibm.com/opentech/2015/10/08/add-angularjs-dashboard-plugin-openstack-horizon/
09:44:34 <danoffek> thanks !
09:44:45 <AlonHeller> Thanks I moved to the #openstack-horizon group
09:45:17 <nitzikow> thanks mrunge, robcresswell. we also want to add a screen for active alerts to ceilometer, i saw your reply on email for the open blueprint
09:45:34 <robcresswell> I wasn't sure if that was the same bp
09:45:55 <nitzikow> yes we are checking it with the guys who opened it
09:46:01 <mrunge> ugh. the situation with ceilometer is a bit unfortunate currently
09:46:25 <ifat_afek> why? can you explain?
09:46:47 <mrunge> uhm, currentl metering support in horizon is quite unusable
09:46:59 <nitzikow> the vitrage project should use or leverage a screen of active alerts. we must use the ceilometer for that
09:47:14 <nitzikow> *alarms
09:47:16 <mrunge> we're not managing alarms at all
09:47:24 <mrunge> but we would like to do
09:47:30 <mrunge> *hint*
09:47:58 <nitzikow> we will be happy to work on that :)
09:48:11 <mrunge> awesome!
09:48:12 <ifat_afek> we need to have alarms list in horizon, because we would like to show RCA on alarms
09:48:42 <mrunge> so managing alarms would probably be a blueprint for current horizon
09:49:13 <ifat_afek> yes
09:49:45 <robcresswell> mrunge: There is a bp for it already, which is being revived by someone
09:50:17 <mrunge> oh great robcresswell
09:50:18 <danoffek> we have blueprints for it
09:50:27 <alexey_weyl> ok, we'll check it
09:51:25 <robcresswell> #link https://blueprints.launchpad.net/horizon/+spec/ceilometer-alarm-management-page
09:51:37 <ifat_afek> thanks!
09:51:49 <robcresswell> np :)
09:53:03 <elisha_rosenswei> I will check what the current status us, and coordinate with AlonHeller to push this bp forward
09:53:11 <ifat_afek> cool, thanks
09:53:21 <elisha_rosenswei> *us* = is
09:53:31 <ifat_afek> #action elisha_rosenswei check horizon alarm management blueprint
09:53:54 <ifat_afek> anything else?
09:54:40 <amir_gur> I don't think so
09:54:46 <ifat_afek> ok, so goodbye everybody, see you next week
09:54:48 <ayah> see you next week
09:55:01 <ifat_afek> #endmeeting