17:00:16 <jcoufal> #startmeeting UX
17:00:17 <openstack> Meeting started Mon Jun  2 17:00:16 2014 UTC and is due to finish in 60 minutes.  The chair is jcoufal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:20 <openstack> The meeting name has been set to 'ux'
17:00:27 <jcoufal> Hi all!
17:00:38 <adi> hello!
17:01:01 <jrist> o/
17:01:09 <david-lyle> o/
17:01:13 <jackib> Hi!
17:01:22 <Toshi> Hi!
17:01:39 <gothicmindfood> o/
17:01:49 <davlaps> o/
17:02:06 <jcoufal> #topic Welcome
17:02:26 <jcoufal> I would love to welcome you all to the historically first OpenStack UX meeting.
17:03:20 <jcoufal> It's great to see all of you here and I hope it will help us to organize our efforts better and to move things forward
17:03:50 <lblanchard> hi all!!
17:04:08 <krotscheck> o/
17:04:16 <jcoufal> As long as this is our first meeting, let me just mention few facts how this is supposed to look like:
17:04:40 <jcoufal> 1) Meetings are going to happen twice a month. At this moment it is scheduled for 1st and 3rd Monday in a month at 1700 UTC at this channel.
17:04:58 <julim> hi all
17:04:59 <jcoufal> There is a possibility for a change (alternating) which we will discuss later today
17:05:22 <jcoufal> 2) Agenda for each meeting is always available at this link: https://wiki.openstack.org/wiki/Meetings/UX
17:05:49 <jcoufal> Feel free to add any topic which you are interested in and which you want to discuss at the following meeting
17:06:32 <jcoufal> 3) At the end of each meeting there will be space for open discussion where we can discuss any topics which were not scheduled
17:07:06 <jcoufal> 4) Log for our meetings will be stored at following address: http://eavesdrop.openstack.org/meetings/ux/
17:08:04 <jcoufal> That's all from the introduction. Does anybody have any question regarding meeting organization?
17:08:35 <lblanchard> all sounds good to me!
17:09:00 <jcoufal> Great, let's move on
17:09:11 <jcoufal> #topic Meeting Time
17:09:41 <jcoufal> So based on the poll (http://doodle.com/3m29dkn3ef2em5in) I selected this time as the candidate for our meetings
17:09:54 <jcoufal> though there are still people who can't make it this time
17:10:14 <jcoufal> I also asked people to fill themselves into timezone overview, so we can make the time the most convenient to all
17:10:30 <jcoufal> here is the etherpad: https://etherpad.openstack.org/p/ux-meetings
17:10:48 <jcoufal> We have very wide range of timezones
17:11:01 <jcoufal> for example for adi, it is pretty late night at this very moment
17:11:13 <jcoufal> so the suggestion is to alternate the times
17:11:33 <adi> 22:41, still not bad ;)
17:11:55 <lblanchard> adi: ooo that's pretty late :)
17:12:11 <jcoufal> 1st monday in a month at 1700 UTC, 3rd wednesday in a month at 1500 UTC
17:12:40 <jcoufal> with alternating mondays and wednesday we should cover all interested participants and still majority of us should be able to attend
17:12:46 <jcoufal> thoughts?
17:12:50 <stevedoll> those work for me
17:12:52 <jackib> works for me!
17:12:57 <GregHint> Works for me!
17:13:05 <david-lyle> +1
17:13:15 <adi> works
17:13:32 <lblanchard> +1
17:13:43 <Toshi> +1
17:13:57 <gothicmindfood> +1
17:14:05 <lblanchard> although I might miss a few just due to pure confusion on my part ;)
17:14:23 <julim> +1 but may miss some based on timing
17:14:36 <jcoufal> Looks like one voice agreement :)
17:15:01 <jcoufal> lblanchard, julim: I will try to remind the meetings at least from the beginning
17:15:09 <jcoufal> also mention next meeting time at the end of each meeting
17:15:23 <lblanchard> jcoufal: sounds great…we can all try to do the same in the UX channel maybe
17:15:23 <julim> that would be good jcoufal
17:15:27 <jacalcat> OK for me.
17:15:45 <jcoufal> perfect
17:15:50 <lblanchard> jcoufal: plus the wiki will show next meeting
17:16:09 <jacalcat> Would it be possible to send out meeting invitations as well?
17:16:17 <jcoufal> #action jcoufal to reflect meeting times in wiki, ical, etc.
17:16:38 <jcoufal> jacalcat: if you add to the etherpad your e-mail addresses, I can add you as participants
17:16:46 <david-lyle> jacalcat: you can sync with the openstack meetings calendar as well
17:16:47 <lblanchard> jacalcat: I haven't seen meeting invites within OpenStack much at all…I've normally just created personal ones for my calendar
17:16:48 <jcoufal> https://etherpad.openstack.org/p/ux-meetings
17:16:58 <lblanchard> david-lyle: ah right openstack calendar!
17:17:17 <jcoufal> david-lyle: yeah, though it is pretty full :)
17:17:19 <lblanchard> david-lyle: I did that once and got flooded with them all…but maybe there is a way to only choose uX
17:17:21 <david-lyle> https://www.google.com/calendar/ical/bj05mroquq28jhud58esggqmh4@group.calendar.google.com/public/basic.ics
17:17:29 <david-lyle> just decline the ones you don't want
17:18:08 <jcoufal> small reminder - currently we have just mondays, I need to arrange the change for mon&wed
17:18:17 <david-lyle> advantage is all invite times are in UTC and work correctly even over DST switches
17:18:33 <jcoufal> david-lyle: yeah, that is much safer option
17:18:41 <jcoufal> those time shifts are sometimes confusing
17:19:30 <jcoufal> #link https://www.google.com/calendar/ical/bj05mroquq28jhud58esggqmh4@group.calendar.google.com/public/basic.ics - meetings calendar if you want to sync up on meeting times
17:19:44 <jcoufal> great, all agreed let's move on
17:20:05 <jcoufal> I will jump a little bit in the agenda and get back to the second topic later
17:20:15 <jcoufal> #topic StoryBoard and UX
17:20:19 <krotscheck> HI
17:20:29 <jcoufal> Hey krotscheck
17:20:42 <krotscheck> Sorry, I’m interrupting. Go ahead.
17:21:20 <jcoufal> Np. We already discussed using StoryBoard at the Summit and we agreed that we can jump to using it right away
17:21:39 <jcoufal> The advantage for storyboard is that we can provide usability feedback
17:21:57 <jcoufal> And we have nothing to loose if we switch from current launchpad to storyboard now
17:21:58 <lblanchard> +1 to that, unless anyone has been poking around and has found that there are major blockers that we have in Launchpad that don't exist in Storyboard today
17:22:09 <lblanchard> but I didn't find anything…current Storyboard looks great to me!
17:22:27 <jcoufal> Apart from some small suffering as Thierry mentioned :)
17:22:34 <jcoufal> So we have also blessing from infra team
17:22:49 <lblanchard> jcoufal: what's the small suffering? Getting items into Storyboard?
17:22:52 <jcoufal> It is just matter of allowing UX project in StoryBoard which got a bit complicated
17:23:03 <jcoufal> lblanchard: I guess he meant usability :)
17:23:09 <lblanchard> jcoufal: haha
17:23:13 <krotscheck> The biggest hurdle seems to be that the existing project configuration automatically creates a git repository. https://review.openstack.org/#/c/96549/
17:23:43 <lblanchard> krotscheck: hmm yes, we probably don't need that…is this an issue? Or can is just remain empty?
17:23:52 <david-lyle> I think a git repo actually would be useful
17:24:05 <david-lyle> for storing finalized designs
17:24:10 <lblanchard> david-lyle: that gets into the discussion of where we store our files :)
17:24:28 <jcoufal> david-lyle: it was objected, that git might be problematic for larger binary files
17:24:30 <krotscheck> lblanchard: Depends on who you ask. I’m ambivalent, I just want to see you guys squared away and happy.
17:25:11 <krotscheck> jcoufal, lblanchard, david-lyle: I can see a case being made for a docs-style repo (similar to *-specs) where persona work can go, but I’m not certain the toolchain is UX friendly.
17:25:31 <jcoufal> lblanchard: I know that Jim was against setting a git repo if it is not needed
17:25:34 <krotscheck> Aside: Current story for UX team features is here: https://storyboard.openstack.org/#!/story/85
17:25:52 <david-lyle> jcoufal, because of versioning??
17:26:23 <lblanchard> jcoufal, david-lyle, krotscheck: Perhaps we could use it for our design templates? It would be a small number of files, wouldn't get huge.
17:26:36 <jcoufal> david-lyle: I believe it was mostly because of user experience when storing and requesting changes
17:26:51 <jcoufal> krotscheck: is there a problem in setting a project without git repo and if we decide to store files there to add one later?
17:26:57 <david-lyle> krotscheck: my concern is the finalized design documents now live on an askbot server not maintained by openstack, this is problematic
17:27:36 <krotscheck> jcoufal: The problem is that the toolchain doesn’t know how to do that yet, and I don’t know enough about jeepyb yet to make that happen.
17:27:42 <lblanchard> david-lyle: +1 we have decided to stop askbot for final designs…but have come back to using personal storage and links in ML for now…which isn't a great final solution either
17:27:55 <david-lyle> I don't know that the iteration takes place using git, but the result could be stored, but it could get large
17:27:58 <jcoufal> krotscheck: and the problem with having an empty repo?
17:28:30 <krotscheck> jcoufal: I don’t know.
17:28:42 <krotscheck> jcoufal: Ask on infra?
17:28:49 <jcoufal> will do
17:29:31 <jcoufal> #action jcoufal discuss git repo issues so we can move UX project under StoryBoard
17:29:52 <jcoufal> after that we should be able to migrate things from launchpad and smoothly move to StoryBoard
17:30:14 <jcoufal> everybody is in favor of storyboard? :)
17:30:22 <jcoufal> (I guess I should have asked earlier) :)
17:31:46 <Toshi> Sure!
17:31:56 <lblanchard> +1
17:32:16 <jcoufal> alright, moving on
17:32:38 <jcoufal> #topic Wireframes Review Tool
17:33:03 <jcoufal> There is suggestion that we can start using InVision for reviewing our wreframes
17:33:13 <jcoufal> Couple of people already used it in the past
17:33:23 <adi> okay
17:33:34 <lblanchard> has anyone else worked with this tool?
17:33:46 <lblanchard> it isn't opensource…so I didn't know if that would be a blocker
17:33:53 <jackib> yep, I have
17:33:57 <julim> do we all need to use the same tool, or would it make sense for any tool to be used but to publish to a common format, e.g. JPG, PDF, etc.
17:34:02 <lblanchard> or if anyone has used any opensource tool similar for reviewing designs and having comments, history
17:34:14 <lblanchard> julim: no, this is just uploaded images
17:34:20 <julim> ah lblanchard
17:34:25 <Toshi> Can we use it free of charge?
17:34:26 <jackib> there is a chance we could get a free version donated to the community
17:34:34 <lblanchard> this tool is just for the review piece
17:34:35 <julim> Auto-Awesome (works on several browsers) would be fairly easy (free) too
17:34:39 <julim> and allows annotation
17:34:51 <lblanchard> julim: keeps history of versions?
17:35:03 <julim> lblanchard - I don't believe so
17:35:04 <jcoufal> julim: I don't think we *have to* use the same tool, but it would be easier for people - they will be used to the same workflow
17:35:55 <adi> as far as review goes, its okay. I thought InVision was pretty complex to design
17:36:18 <julim> ok jcoufal. makes sense if folks are collaborating on the same design to use the same tool.
17:36:37 <lblanchard> adi: have you found anything that would work better?
17:36:46 <jcoufal> this is the tool btw: http://www.invisionapp.com/
17:37:00 <lblanchard> I'm definitely open to any tool…this seemed to be the front-runner…then I noticed krotscheck was using it for storyboard too
17:37:10 <gothicmindfood> there have been some rumblings about people not wanting to use non-open-source tooling at all
17:37:12 <lblanchard> krotscheck: did you all try any other tools?
17:37:13 <gothicmindfood> for an open-source project
17:37:26 <lblanchard> gothicmindfood: I'm happy to use an open-source tool for this
17:37:31 <lblanchard> gothicmindfood: just haven't found one :(
17:37:41 <gothicmindfood> lblanchard: yeah, when I've heard the rumblings, I've pointed that out :)
17:37:41 <krotscheck> lblanchard: Nope, I got an invite from piet, and said “Good enough, back to work"
17:37:46 <jcoufal> I used it some time ago, didn't check how far away actually it evolved
17:37:53 <lblanchard> krotscheck: ah okay
17:38:14 <jackib> We could look at what ubuntu does. I think they use some combo of balsamic and wiki
17:38:15 <lblanchard> well maybe folks can keep an eye out and do some research on open-source tools in this space?
17:38:35 <jackib> so all designs and I think older versions along with critique is in one place
17:38:39 <lblanchard> jackib: +1 Although I think balsamic is $$
17:38:45 <adi> i've used balsamiq and pencil
17:38:47 <jackib> yep it is
17:38:56 <lblanchard> but great idea to try and understand what other opensource designers are doing
17:39:09 <jackib> FYI - https://wiki.ubuntu.com/Touch/CoreApps/Design
17:39:12 <lblanchard> adi: I tried pencil out…but it's more for wireframing
17:39:17 <lblanchard> rather than sharing/reviewing
17:39:33 <jcoufal> the same for balsamiq I would say
17:39:36 <adi> correct. like i said, invision is fine for reviewing
17:39:49 <jcoufal> Regarding open-source: One of the things is, that if they decide to shut down the service, we are going to lose all history
17:40:00 <jcoufal> It is always better if we can host the tool on openstack servers
17:40:26 <jcoufal> though as lblanchard we havn't found any suitable open-source tool yet
17:40:33 <jackib> that is a big downside
17:41:19 <lblanchard> krotscheck: perhaps a feature of storyboard :) :)
17:41:37 <lblanchard> comments on images, revision history of images?
17:41:38 <gothicmindfood> in my industry, we like to call that scope-creep lblanchard ;)
17:41:45 <lblanchard> gothicmindfood: haha
17:41:54 <lblanchard> gothicmindfood: yes, and wishful thinking on my part
17:42:13 <krotscheck> lblanchard: https://storyboard.openstack.org/#!/story/85
17:42:28 <gothicmindfood> krotscheck did allow for asset upload in that story ^^
17:42:30 <jackib> but we need something. maybe a few people can do a bit of research on alternatives/pros/cons?
17:42:41 <jcoufal> I tend to say - keep searching, we can use whatever works for everybody until we find something
17:42:54 <jcoufal> is there anybody willing to do the research?
17:43:06 <adi> i can
17:43:21 * gothicmindfood would but I'm a ux n00b
17:43:25 <jackib> I have little time right now. But I can contribute what I already use/know about
17:43:28 <gothicmindfood> adi: would love to help out to help me learn more!
17:43:46 <adi> gothic: alright
17:44:02 <jcoufal> great! we have volunteers
17:44:03 <lblanchard> if someone identifies some tools, I'm happy to review a few of them to help out
17:44:20 <Toshi> Basic question, what is the requirement for that tools compared to pdf wireframe review?
17:44:23 <jcoufal> will you guys cooperate (probably in some etherpad) and put something together?
17:44:38 <adi> jcoufal - yes
17:44:40 <jcoufal> Toshi: great point, we should start with listing the requirements down
17:44:57 <gothicmindfood> https://etherpad.openstack.org/p/uxtools
17:44:59 <adi> yes, requirements / parameters against which we do the research
17:45:07 <gothicmindfood> let's do it there ^^
17:45:10 <jcoufal> awesome!
17:45:21 <Toshi> Great!
17:45:25 <jcoufal> #link https://etherpad.openstack.org/p/uxtools - UX tools research
17:46:25 <jcoufal> #action adi, gothicmindfood to keep the ball rolling on wireframing review tool research
17:46:38 <jcoufal> everybody else is ofcourse welcome to contribute
17:46:47 <jcoufal> we need feedback from everybody
17:47:02 <jcoufal> moving on
17:47:14 <jcoufal> #topic UX in CLI and API
17:47:30 <jcoufal> UX is broad area
17:47:41 <jcoufal> we are contributing the most in GUI
17:48:11 <jcoufal> but there is need for UX also in CLI, API, DX (dev exp), etc
17:48:31 <adi> interesting
17:48:35 <jackib> we are so short handed already though
17:48:49 <jcoufal> it was mentioned multiple times on both previous summit as well
17:48:54 <jcoufal> people are asking for help there
17:49:08 <gothicmindfood> jcoufal: which projects in particular?
17:49:22 <lblanchard> nova is definitely interested
17:49:26 <jcoufal> but as jackib mentioned, we don't have enough people
17:49:35 <adi> Question: What do you mean by UX for CLI - Does it mean translating CLI requests (inputs) via UX?
17:49:45 <jackib> there's a big need and I think it's cross project. like getting consistency
17:49:55 <jcoufal> gothicmindfood: well if we talk about API's experience, I would say definitely all should be interested because of consistency
17:50:06 <gothicmindfood> that makes sense
17:50:11 <jcoufal> but lblanchard mentioned, nova is an example
17:50:27 <jcoufal> adi: mostly consistency
17:50:30 <lblanchard> yes, another example would be helping the OpenStackClient project…
17:50:34 <jcoufal> at least that's the start
17:50:36 <lblanchard> they already have HCI guidelines: https://wiki.openstack.org/wiki/OpenStackClient/HumanInterfaceGuidelines
17:50:45 <lblanchard> but we could help here…as well
17:51:02 <jcoufal> because at the moment, if you look at listing function, nova, glance and heat have different commands for it
17:51:06 <jcoufal> if I remember correctly
17:51:10 <lblanchard> so it's a matter of…does anyone have time? Should we try to evangelize UX in these groups somehow where we wouldn't have to focus 100% on it…
17:51:23 <jcoufal> lblanchard: good question
17:51:41 <jcoufal> Is there anybody interested and willing to work on APIs and/or CLIs?
17:52:02 <jackib> we have a developer advocacy group at rackspace interested in this. maybe they can help out
17:52:25 <lblanchard> I'm also wondering if there is a way to ask folks on each team if anyone has interest in UX
17:52:30 <jcoufal> Or at least start with evangelization, talking  about it, gathering people together with same interest
17:52:38 <lblanchard> jcoufal: +1
17:53:00 <jackib> +1
17:53:15 <jcoufal> I can start the ball rolling by sending some mails to the mailing list and we can see if there is somebody willing to help, join
17:53:34 <Toshi> +1
17:53:36 <julim> +1
17:53:41 <jcoufal> any other suggestions about what we can do more?
17:53:54 <lblanchard> it would be a huge step for the component teams to know that we don't just focus on GUI/Horizon and would be happy to at least give small feedback in other areas (since we don't have enough people to have someone focus 100% on it)
17:53:56 <jcoufal> jackib: would be great - can you talk to them if they are willing to help?
17:54:05 <jcoufal> lblanchard: +1
17:54:17 <jackib> sure thing
17:55:19 <jcoufal> perfect
17:55:25 <jcoufal> #topic Open Discussion
17:55:41 <jcoufal> any other topics to discuss in remaining 4 minutes?
17:56:17 <jackib> jcoufal - thanks for setting this up
17:56:19 <lblanchard> wow, great job everyone on getting through those 4 major topics in an hour!
17:56:21 <adi> jcoufal : im good for nwo
17:56:29 <lblanchard> jcoufal++
17:57:34 <jcoufal> thanks everybody for attending and your participation
17:57:56 <jcoufal> Next meeting: Wednesday, June 18th, 1430 UTC (half an hour earlier because of conflicts), #openstack-meeting-3
17:58:10 <adi> thanks people. talk to you soon!
17:58:14 <lblanchard> catch you all 2 weeks from Wednesday!
17:58:28 <jcoufal> #endmeeting