14:00:04 <mpiwowarczy> #startmeeting trove
14:00:05 <openstack> Meeting started Wed Oct 17 14:00:04 2018 UTC and is due to finish in 60 minutes.  The chair is mpiwowarczy. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'trove'
14:00:23 <mpiwowarczy> Hello All
14:00:32 <cezary_zukowski> Hi :)
14:00:57 <mpiwowarczy> today I will be chair on weekly meeting, dkrol will not show up today
14:01:09 <mpiwowarczy> lets wait few minutes for the others
14:01:14 <mpiwowarczy> #topic roll call
14:01:21 <cezary_zukowski> sure, cheers
14:04:50 <mpiwowarczy> looks like only two of us today
14:04:57 <mpiwowarczy> ok, let's start
14:05:08 <mpiwowarczy> #topic Recent changes and reviews
14:06:08 <mpiwowarczy> I noticed new bulk changes according to enabling python 3.7 unit tests
14:06:26 <mpiwowarczy> and there appears unstable tests for py37 in python-troveclient
14:06:38 <mpiwowarczy> #link https://review.openstack.org/#/c/610807/
14:07:10 <mpiwowarczy> looks it is trove specyfic issue and only trove folks can fix that
14:07:29 <cezary_zukowski> yupi, something for us
14:07:35 <mpiwowarczy> #action Fix tests for py37 in python-troveclient
14:08:27 <mpiwowarczy> there was also needed change related to unstable gate-tests
14:08:57 <mpiwowarczy> it was related to new version of oslo.messaging
14:09:08 <cezary_zukowski> what is this group of tests linked to, i.e. "gate-tests"?
14:09:22 <cezary_zukowski> ah, ok
14:10:17 <cezary_zukowski> Could you provide more details or  a link to the issue?
14:10:22 <mpiwowarczy> I mean each tests executed via trovestack gate-tests
14:10:45 <mpiwowarczy> sure
14:10:51 <mpiwowarczy> here you are https://review.openstack.org/#/c/609981/
14:12:01 <mpiwowarczy> actually, there way aslo unstable unit tests, so not only gate-tests was affected
14:12:30 <mpiwowarczy> thanks for Fan Zhang and Dariusz Krol for support in review :)
14:13:42 <mpiwowarczy> ok, anything more about the new changes?
14:13:56 <cezary_zukowski> with respect to https://review.openstack.org/#/c/609981/ seems that all "Zuul gate" are passing now, and only trove-scenario-mariadb-multi fails
14:14:34 <mpiwowarczy> yeah, it is already fixed and merged to master
14:15:04 <mpiwowarczy> have a look on the status in upper-left corner :)
14:15:05 <cezary_zukowski> I enhanced the documentation on building Trove images, ready for being pushed, but waiting for the access to being able to push
14:15:47 <cezary_zukowski> mpiwowarczy: still learning Gerrit :)
14:16:20 <mpiwowarczy> :)
14:16:37 <mpiwowarczy> as for documentation, we have separate topic, lets talk about this later
14:17:07 <cezary_zukowski> I am planning to write more lik estep-by-step guide, however, like "building trove images from scratch" - the current one is overwhelming for newcomers, I think (at least for me, it was)
14:17:19 <cezary_zukowski> ah okay
14:17:43 <cezary_zukowski> so nothing to add
14:17:51 <mpiwowarczy> ok, lets move on
14:17:56 <mpiwowarczy> #topic Documentation
14:19:20 <mpiwowarczy> quite so, documentation status it is what I would like to ask
14:19:43 <cezary_zukowski> Yeah, so as I said, it would be convenient to have step-by-step guide that introduces into the topic, explains how and what partiuclar 'elements' do (what is installed in subsequent steps, etc.)
14:21:05 <mpiwowarczy> yeah, this is a very important part due to newcomers
14:21:42 <cezary_zukowski> And it should start with some introduction on how to build images at all, definitelly involving building simple DIB images (https://docs.openstack.org/diskimage-builder/latest/)
14:21:46 <mpiwowarczy> could you give a link, where it will be placed?
14:22:20 <cezary_zukowski> mpiwowarczy: any etherpad could be good to start?
14:23:07 <mpiwowarczy> sure, etherpad will be a good choice
14:24:30 <mpiwowarczy> you can create new one and link it to trove-general
14:24:31 <mpiwowarczy> https://etherpad.openstack.org/p/trove-general
14:25:34 <cezary_zukowski> ok, I will, many thanks
14:28:21 <mpiwowarczy> something more about documentation?
14:28:54 <cezary_zukowski> I have a question that refers to building images, do you have idea why tarball images hosting was suspended?  http://tarballs.openstack.org/trove/images/README
14:29:14 <cezary_zukowski> if not, we could continue
14:30:24 <cezary_zukowski> or maybe it's better question for Trove revitalization - "official" Trove images
14:31:23 <mpiwowarczy> hmm, no idea, need to be checked somewhere in documentation
14:31:32 <cezary_zukowski> sure, np
14:31:44 <mpiwowarczy> #topic Trovestack redesign
14:31:59 <mpiwowarczy> dont see much changes at this topic
14:32:33 <mpiwowarczy> Dariusz shared his status on building images in devstack plugin
14:32:39 <mpiwowarczy> https://review.openstack.org/#/c/606960/
14:33:04 <mpiwowarczy> it is still in progress but work goes ahead
14:33:22 <mpiwowarczy> change will be ready to review soon
14:33:54 <cezary_zukowski> Yeah, it's cool that he started working on this, especially that he was able to set up all those environment variables in a meaningful way :)
14:34:18 <cezary_zukowski> (it was challenging)
14:34:32 <cezary_zukowski> Anyway, I have faced recently: https://docs.google.com/spreadsheets/d/1Jz6TnmRHnhbg6J_tSBXv-SvYIrG4NLh4nWejupxqdeg/edit
14:35:17 <cezary_zukowski> Could we track the status of this task anyhow? :)
14:36:03 <cezary_zukowski> of those tasks*
14:36:28 <mpiwowarczy> it looks interesting
14:37:24 <mpiwowarczy> propose to discuss this on next week with more members
14:37:43 <cezary_zukowski> Sure :) As you said - interesting topics
14:38:08 <mpiwowarczy> #action Discuss tasks tracking method
14:39:42 <mpiwowarczy> thanks, good ideas are always valuable :)
14:39:56 <mpiwowarczy> lets more to another topic
14:40:00 <mpiwowarczy> #topic Python 3 first support
14:40:09 <mpiwowarczy> this is what im working on
14:40:40 <mpiwowarczy> I have on my table task with functional test on python3
14:40:47 <mpiwowarczy> still in progress
14:41:17 <cezary_zukowski> Cool :) Many issues encountered when migrating from p2 to p3?
14:41:35 <cezary_zukowski> Could you describy what are "functional test" or "tests"/
14:41:37 <cezary_zukowski> ?
14:42:11 <mpiwowarczy> a lot of small but heartache issues :)
14:42:53 <cezary_zukowski> I can imagine :-D Have you tried https://docs.python.org/2/library/2to3.html? (I am just curious)
14:44:37 <mpiwowarczy> yes, it is helpful but only for very first issues, later there appears more less obvious issues
14:45:02 <mpiwowarczy> as for tests and functional test
14:45:46 <mpiwowarczy> there is a little mess with the naming
14:46:21 <cezary_zukowski> np, please explain if not overly compound
14:46:39 <mpiwowarczy> functional test are tests executed on via trovestack (gate-tests)
14:46:53 <mpiwowarczy> there are also unit-tests (executed via tox)
14:47:19 <mpiwowarczy> I will improve this naming on etherpad with python3-first goals https://etherpad.openstack.org/p/trove-python-3
14:47:40 <cezary_zukowski> ok, many thanks
14:47:42 <mpiwowarczy> or I will add comments
14:48:17 <mpiwowarczy> ok, do you have any other topics today?
14:48:29 <cezary_zukowski> mpiwowarczy: one more thing, could you provide any resource on tox (in the context of OpenStack/Trove)? I realized this is very common topic, and want to read more.
14:49:46 <cezary_zukowski> Besides, I do not have further inquiries :)
14:50:45 <mpiwowarczy> tox definition is placed in root directory of trove repository in tox.ini file
14:50:56 <mpiwowarczy> there are also definied all types of tests
14:51:08 <cezary_zukowski> ok thanks, I will check out
14:51:20 <mpiwowarczy> but I am afraid that this is not written down anywhere
14:51:30 <cezary_zukowski> I see
14:51:55 <mpiwowarczy> but it is quite simple to understand :)
14:52:17 <cezary_zukowski> That's good :)
14:52:45 <mpiwowarczy> ok, let's end here
14:52:51 <mpiwowarczy> many thanks for coming :)
14:53:32 <cezary_zukowski> Sure, one step toward Trove being great :) Many thanks too!
14:53:45 <mpiwowarczy> bye o/
14:53:57 <cezary_zukowski> \o see you next week!
14:54:02 <mpiwowarczy> #endmeeting