14:00:40 <dkrol> #startmeeting trove
14:00:44 <openstack> Meeting started Wed Sep 19 14:00:40 2018 UTC and is due to finish in 60 minutes.  The chair is dkrol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:48 <openstack> The meeting name has been set to 'trove'
14:00:52 <dkrol> #topic roll call
14:01:13 <dkrol> let's wait for others
14:08:00 <mpiwowarczy> looks no one more today
14:08:10 <dkrol> yes, so we can start :)
14:08:17 <dkrol> #topic Recent changes and reviews
14:08:47 <dkrol> I've create a new etherpad
14:08:52 <dkrol> #link https://etherpad.openstack.org/p/trove-general
14:09:13 <dkrol> to collect links about other etherpads
14:09:51 <bzurkowski> Hmm
14:10:07 <mpiwowarczy> good step to organize all already created notes
14:10:20 <bzurkowski> It's a good idea, but pad is still hidden from the public
14:10:26 <mpiwowarczy> and good for newcomers
14:10:33 <bzurkowski> We could consider adding links to wiki page or something
14:10:37 <dkrol> we can put in on wiki or something
14:11:18 <mpiwowarczy> dkrol: IMHO its not good idea
14:11:34 <dkrol> mpiwowarczy: why not ?
14:11:48 <mpiwowarczy> there is no any authentication and anyone would be able to put any changes
14:12:44 <bzurkowski> mpiwowarczy: That's a good point
14:13:12 <dkrol> but this should be public anyway
14:13:28 <dkrol> we can try to moderate it but all etherpads are public
14:13:41 <dkrol> and I didn't see any issues so far
14:14:20 <mpiwowarczy> if it is so we can try
14:14:43 <bzurkowski> Take a look at how cinders handles pads: https://wiki.openstack.org/wiki/Cinder#Etherpads
14:14:43 <mpiwowarczy> in worst case we are alwas able restore previous version
14:14:56 <bzurkowski> They have separate section titled "Etherpads"
14:15:07 <dkrol> this looks nice
14:15:22 <dkrol> looks like a lot of effort
14:16:12 <dkrol> let's start with something small :)
14:16:18 <mpiwowarczy> Im for that in trove project
14:17:28 <mpiwowarczy> czukowski asked last time for documentation contribution
14:18:09 <dkrol> I think he is reviewing current documentation to see how it can be improved
14:18:48 <dkrol> anyway - I was looking for recent changes - https://review.openstack.org/#/q/project:openstack/trove
14:19:26 <dkrol> for the last week - there are mostly python3-first changes
14:20:13 <dkrol> it looks like python3-first champions are doing their job very well
14:20:20 <dkrol> and they are very active
14:20:25 <dkrol> what is great
14:21:10 <mpiwowarczy> dkrol: yes, Doug Hellmann made a lot of work
14:22:35 <dkrol> mpiwowarczy: please check https://review.openstack.org/#/c/601565/ for unit testing
14:23:47 <dkrol> do you have anything to share about current progress ?
14:25:06 <bzurkowski> Unfortunatelly I didn't have time to progress with Tempest plugin
14:25:15 <bzurkowski> dkrol: Thanks for review
14:25:50 <mpiwowarczy> dkrol: I will take a look for this chanhe
14:26:05 <dkrol> bzurkowski: these were small issues
14:26:30 <dkrol> so there should be little work to fix it
14:26:54 <bzurkowski> dkrol: Yes, it should't take long
14:27:00 <bzurkowski> I'm looking forward to see reviews from other contributors as well
14:27:02 <dkrol> but I don't remember if zuul runs these tests automatically right now ?
14:27:31 <bzurkowski> dkrol: Yes it is
14:27:48 <dkrol> ok, great
14:27:50 <bzurkowski> That's why trove-tempest-plugin job failed
14:28:21 <bzurkowski> We cannot merge this change before preparing the testing env
14:28:46 <dkrol> hmm... what change is needed ?
14:28:52 <dkrol> guest image building ?
14:30:19 <bzurkowski> dkrol: Yes, guest image building, setting Tempest workspaces etc.
14:30:55 <dkrol> will you handle this ?
14:31:13 <bzurkowski> This is related to trovestack redesign
14:31:57 <bzurkowski> As far as I know, mpiwowarczy already started investigating on this
14:32:20 <dkrol> ok
14:32:38 <bzurkowski> We can fix the change and leave it as it is - failing, and in the meantime start working on the testing env
14:33:33 <dkrol> I see
14:33:41 <bzurkowski> After we setup the testing env Tempest scenario will eventually pass
14:34:23 <dkrol> ok, let's switch to python3-first
14:34:56 <dkrol> mpiwowarczy: how this is going on ?
14:35:45 <mpiwowarczy> pretty good, we have merged two changes yesterday https://review.openstack.org/#/c/572986/ and https://review.openstack.org/#/c/575229/
14:35:59 <dkrol> great
14:36:17 <dkrol> how far are we from the finish ?
14:36:37 <mpiwowarczy> I have also investigate gate-tests executed on trovestack - they are running under python2
14:37:49 <bzurkowski> #link https://etherpad.openstack.org/p/trove-python-3
14:37:56 <mpiwowarczy> dkrol: hard to said precisely
14:38:29 <mpiwowarczy> need to review current python3-first tasks and compare with plan
14:38:58 <mpiwowarczy> I will update etherpad soon if any tasks are finished
14:39:15 <dkrol> can we close any task from the etherpad ?
14:39:24 <mpiwowarczy> but berore need to summarize current status
14:39:49 <mpiwowarczy> it depends
14:40:32 <mpiwowarczy> There are functional test jobs running under python 3 - this could be closed for trove if we agree that trovestack tests will be still under python2
14:40:51 <dkrol> I was thinking about unit tests
14:42:01 <mpiwowarczy> currently thay are executed under python 3.5 as I remember
14:42:17 <mpiwowarczy> probably we need to have https://review.openstack.org/#/c/601565/  merged
14:42:59 <dkrol> and if we merge it, we can tick unit tests ?
14:43:37 <mpiwowarczy> yes :)
14:43:49 <dkrol> great
14:43:52 <bzurkowski> We also need to determine what "wiki tracking page" means
14:44:11 <dkrol> what about unit tests for trove python client ?
14:44:11 <mpiwowarczy> if we assume that trovestack will be deprecated, the functional test will be also done
14:45:31 <dkrol> for functional tests I believe we need to have some functional tests running with python3
14:45:42 <dkrol> right now we don't have any
14:46:59 <bzurkowski> In my opinion, we should at least try to port trovestack tests to Python 3
14:47:20 <dkrol> I agree with bzurkowski
14:47:36 <mpiwowarczy> troveclient tox is also executed in python3.5 for now
14:47:39 <bzurkowski> Run tests with newer version of Python and see what happens, how much work needs to be done
14:48:07 <mpiwowarczy> https://review.openstack.org/#/c/601562/ need to be merged to have them in 3.6
14:48:10 <dkrol> ok, lets switch topic since we are running out of time :)
14:48:27 <dkrol> #topic trovestack redesign
14:48:46 <dkrol> we discuss it and we updated https://etherpad.openstack.org/p/trovestack-redesign
14:49:16 <dkrol> we decided not to touch trovestack script
14:49:36 <dkrol> and we will start with adding guest image building to trove devstack plugin
14:49:44 <dkrol> it should be our priority
14:49:55 <dkrol> and "Modify Zuul jobs to use trove devstack plugin to build guest images"
14:50:10 <dkrol> let's focus on this first
14:50:15 <dkrol> and then we will see
14:50:34 <dkrol> but if I understand it correctly this should be sufficient for trove tempest tests to pass
14:50:38 <dkrol> is it right ?
14:51:17 <mpiwowarczy> it should be enought
14:51:55 <bzurkowski> What about Tempest workspaces?
14:52:07 <bzurkowski> We need to generate them before running the test suite
14:52:42 <dkrol> tempest requires workspaces so there should be a place for generating them
14:52:53 <dkrol> maybe a pre-tempest job ?
14:52:56 <dkrol> or something
14:53:25 <bzurkowski> I guess, we should add some Tempest-related playbook that would be executed in pre-run
14:53:43 <bzurkowski> Or extend playbooks that are being used at the moment
14:54:06 <dkrol> let's identify how it is running right now ?
14:54:26 <bzurkowski> Similarly to: https://github.com/openstack/trove/blob/master/roles/trove-devstack/tasks/main.yml
14:55:32 <bzurkowski> It's a role and it's being executed from: https://github.com/openstack/trove/blob/master/playbooks/trove-devstack-base.yaml
14:56:00 <bzurkowski> This playbook is, in turn, executed by Zuul job
14:56:46 <bzurkowski> https://github.com/openstack/trove/blob/master/.zuul.yaml#L100
14:57:35 <dkrol> it doesn't look like rocket science to me :)
14:58:02 <bzurkowski> dkrol: It's a piece of cake :)
14:58:04 <dkrol> it seems we are out of time for today
14:58:09 <dkrol> let's summary
14:58:27 <dkrol> #action merge python3-first changes
14:59:20 <dkrol> add guest image building to devstack plugin
14:59:52 <dkrol> investigate where to add workspace generation in tempest
15:00:14 <dkrol> we need to finish :)
15:00:14 <mpiwowarczy> dkrol: lets create action for these two points
15:00:26 <dkrol> #action add guest image building to devstack plugin
15:00:32 <dkrol> #action investigate where to add workspace generation in tempest
15:00:34 <dkrol> not sure
15:00:47 <dkrol> see you
15:00:48 <dkrol> #endmeeting