14:00:10 <zhaochao> #startmeeting trove
14:00:11 <openstack> Meeting started Wed Aug  1 14:00:10 2018 UTC and is due to finish in 60 minutes.  The chair is zhaochao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <openstack> The meeting name has been set to 'trove'
14:00:21 <zhaochao> #topic roll call
14:00:42 <wangyao> zhaochao  hi
14:00:48 <zhaochao> #topic roll call
14:00:50 <zhaochao> wangyao: hi
14:01:00 <dkrol> Hello All
14:01:05 <Marcin_> hi there
14:01:15 <zhaochao> dkrol: Marcin_ Hi
14:01:55 <zhaochao> gang: bzurkowski hi
14:02:45 <zhaochao> glad to have a much bigger gather today
14:02:55 <wangyao> yes
14:03:21 <zhaochao> wangyao: :)
14:03:34 <gang> hi
14:03:37 <zhaochao> gang: hi
14:03:46 <pierte> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! https://williampitcock.com/
14:03:51 <zhaochao> OK, let's start
14:04:13 <zhaochao> #topic Rocky goal updates
14:04:16 <bzurkowski> Hello
14:04:28 <zhaochao> bzurkowski: hi
14:04:57 <zhaochao> last week, we have passed the rocky milestone-3
14:06:42 <zhaochao> though I still made a mistake that for troveclient, milestone-3 should come with the stable branch created
14:06:43 <zhaochao> the release team will help on that
14:06:43 <zhaochao> I also merged some patches in the trove-tempest-plgin
14:06:43 <zhaochao> those could be the first steps for integration tests migrating
14:07:27 <zhaochao> thanks to bzurkowski dkrol and some other guys co-authored those patches who are not here
14:07:27 <dkrol> that would be great
14:08:49 <zhaochao> dkrol: yes, as I stated in the comment of https://review.openstack.org/#/c/583252/ and on the ML topic about leadership transfer, the other patches still have to wait more changes inside the trove repo
14:09:48 <zhaochao> and we have some patches active in the trove and troveclient repo
14:10:27 <zhaochao> #link https://review.openstack.org/#/c/586528/
14:11:00 <zhaochao> from dkrol , will fix https://bugs.launchpad.net/trove/+bug/1395523
14:11:06 <openstack> Launchpad bug 1395523 in OpenStack DBaaS (Trove) "Replication setup silently fails if Swift as Remote Storage is not available" [High,In progress] - Assigned to Dariusz Krol (d.krol)
14:11:11 <zhaochao> Maciej have put a +2 vote on that
14:12:25 <zhaochao> but the main problem is we're still in feature freeze(till the rocky stable branch created)
14:12:46 <zhaochao> conventionally we should only merge critical bug fixes for now
14:13:17 <dkrol> does it mean we cannot merge bug fixes ? as it is a bug with a high priority tag
14:13:22 <zhaochao> I personally not thinking bug #1395523 as critical
14:13:22 <openstack> bug 1395523 in OpenStack DBaaS (Trove) "Replication setup silently fails if Swift as Remote Storage is not available" [High,In progress] https://launchpad.net/bugs/1395523 - Assigned to Dariusz Krol (d.krol)
14:13:36 <zhaochao> dkrol: ^
14:13:47 <dkrol> ok, I see
14:13:55 <zhaochao> dkrol: yes, the priority is high
14:14:05 <zhaochao> but we could discuss on that
14:14:50 <zhaochao> as noted from the mail posted by the release team
14:16:36 <zhaochao> another patches are from gang
14:16:39 <dkrol> sure we can discuss it. We just wanted to start our contribution by adding additional tests and fixing important bugs as they can be merged
14:17:56 <gang> Zurkowski gives some good advises about the two patch.
14:20:01 <zhaochao> dkrol: yes, bug fixing is always important, let's hear more opinions from other team members
14:20:31 <zhaochao> gang: wangyao bzurkowski Marcin_ do you have time to take look at https://review.openstack.org/#/c/586528/
14:21:06 <wangyao> yes  will check
14:21:16 <zhaochao> we should decide whether we could merge it now, we're past the milestone-3
14:21:25 <Marcin_> I will have a look too
14:21:25 <bzurkowski> zhaochao: That change already got +1 from me
14:22:04 <zhaochao> wangyao: thanks
14:22:10 <zhaochao> gang: yes, I was just going to talk about the extend-proterties patches
14:22:10 <zhaochao> bzurkowski: got that, thanks
14:22:28 <zhaochao> #link https://review.openstack.org/#/c/536684/
14:22:39 <zhaochao> #link https://review.openstack.org/#/c/583125/
14:25:42 <zhaochao> I think we could take more time on these 3 patches in recent days, to make sure whether we could merge them or not
14:25:56 <bzurkowski> Yes, these changes definitely deserve a fresh review from somebody since are not far for being ready for merge.
14:26:59 <zhaochao> and some new patches bzurkowski in the trove-tempest-plugin, they're not affected by the rocky schedule, as we are not releasing it before
14:27:56 <zhaochao> bzurkowski: yes, I'll also take time on them, thanks for your participation these days
14:28:32 <dkrol> I will try to review them too
14:29:17 <zhaochao> OK, that's all from me for the projects update, I have another two topics not added to the agenda next: one about the PTL election, another one about the team members
14:29:33 <zhaochao> but do you have more topics on the project updates?
14:29:41 <zhaochao> before we could change the topic?
14:29:54 <Marcin_> nothing from me
14:30:13 <dkrol> I'm ok with changing the topic
14:30:46 <zhaochao> OK
14:30:56 <zhaochao> #topic PTL election
14:31:30 <zhaochao> I had post a topic on the ML, I think all of us should have read it already
14:31:40 <wangyao> yes
14:31:54 <zhaochao> and dkrol also submitted his nomination to the election repo
14:32:14 <zhaochao> dkrol: thanks
14:32:24 <zhaochao> #link https://review.openstack.org/#/c/587333/
14:32:56 <zhaochao> however according to the election policy, the nomination is rejected by the TC
14:33:34 <zhaochao> thought 'The TC can take this into account when appointing a candidate as PTL fro the Trove project.' is stated by the comment
14:34:14 <zhaochao> I think as the other current active member are not going to hold the PTL position
14:34:47 <zhaochao> dkrol should be the best and only candidate
14:36:06 <wangyao> agree
14:36:13 <Marcin_> +1
14:36:23 <bzurkowski> +1
14:36:36 <gang> agree give my +1
14:37:09 <zhaochao> OK, so I will ask the TC about what's exact policy about appointing a candidate for a project
14:37:50 <zhaochao> and try to persuade TC to accept dkrol as an valid candidate
14:37:54 <dkrol> if there is no other candidate than we should send an email to TC about our specific case
14:38:31 <dkrol> zhaochao: I agree, could you send an email about it ?
14:39:47 <zhaochao> dkrol: OK. I'll begin with responding the comment of the nomination patch
14:40:03 <zhaochao> dkrol: if neccessary, I'll post another topic on the ML
14:40:17 <dkrol> zhaochao: thank you, this should be ok also
14:41:22 <duckgoose24> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! https://williampitcock.com/
14:41:48 <zhaochao> dkrol: yes, we'll try our best for that
14:42:29 <zhaochao> #action zhaochao try to ask TC for accepting dkrol as a valid PTL candidate
14:43:14 <zhaochao> OK, next topic
14:43:21 <zhaochao> #core team members
14:44:47 <zhaochao> in fact, I would like to accept our new contributors as core members
14:45:29 <zhaochao> however as it's still quite a short time after they're joining us
14:45:51 <zhaochao> according to the stackalytis
14:45:55 <zhaochao> http://stackalytics.com/?metric=marks&module=trove-group
14:46:20 <Matrixiumn> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! https://williampitcock.com/
14:46:20 <zhaochao> http://stackalytics.com/?metric=commits&module=trove-group
14:47:10 <zhaochao> I'm not sure whether it's appropriate by now
14:47:31 <zhaochao> so what do you guys think about this?
14:48:32 <zhaochao> we only have 3 current core members here, :(, so, what do you think? gang wangyao
14:48:34 <Guest42247> With our IRC ad service you can reach a global audience of entrepreneurs and fentanyl addicts with extraordinary engagement rates! https://williampitcock.com/
14:48:38 <bzurkowski> zhaochao: You are right that stats are not on our side
14:49:18 <zhaochao> bzurkowski: yes, I'm also sorry for that
14:49:42 <bzurkowski> In my case, stats would be much higher if I voted more on changes
14:50:05 <bzurkowski> For now I only added comments
14:50:15 <wangyao> I'm fine and we need new members to help review patches since we always have no time for trove.
14:50:39 <zhaochao> bzurkowski: oh, I see, yes, just add your vote every time
14:50:53 <bzurkowski> I definitelly will
14:52:08 <zhaochao> bzurkowski: dkrol Marcin_ please do more reviews on the existing patches, though most of them are not active now, but those may also helps
14:52:10 <bzurkowski> Anyway, having me and other team members as core member would significantly facilitate the development process
14:53:56 <zhaochao> yes, bzurkowski is very active these days, and I also believe he could be a valid candidate for a core member
14:54:08 <zhaochao> wangyao: gang what do you think?
14:54:34 <bzurkowski> Unfortunatelly the current state of the project is not conducive for gaining stats...
14:55:39 <zhaochao> bzurkowski: yes, we have very few new patches these days
14:55:44 <wangyao> yea, recently bzurkowski do a lot works, thanks. +1
14:56:33 <gang> +1. In my opinion, I think they could help a lot. So, +2
14:57:55 <gang> Korl: Just add some comments on https://review.openstack.org/#/c/586528
14:57:55 <zhaochao> OK, then we could at least propose bzurkowski as a core member
14:58:20 <zhaochao> dkrol: is that OK for you?
14:58:43 <wangyao> congratulation!
14:58:57 <dkrol> gang: good point, thanks
14:59:14 <Marcin_> it's fine by me :)
14:59:17 <dkrol> zhaochao: yes, it is ok with me
14:59:23 <zhaochao> OK
14:59:41 <zhaochao> I'll update the team member list asap
14:59:45 <dkrol> and we will also work on code reviews as well :)
14:59:52 <zhaochao> #agreed accept bzurkowski as a core member
14:59:58 <zhaochao> dkrol: thanks, :)
15:00:11 <zhaochao> OK, it's over the time again
15:00:19 <zhaochao> we have to stop here today
15:00:20 <gang> agree.
15:00:21 <bzurkowski> Thank you, I'm very glad
15:00:40 <zhaochao> bzurkowski: congratulation!
15:00:51 <zhaochao> OK, let's stop here.
15:01:02 <zhaochao> thanks, everyone!
15:01:06 <zhaochao> Good night!
15:01:09 <dkrol> thanks
15:01:11 <Marcin_> thanks, bye
15:01:16 <gang> Good night!
15:01:18 <bzurkowski> Thank you and bye
15:01:28 <zhaochao> #endmeeting