14:00:27 <zhaochao> #startmeeting trove
14:00:28 <openstack> Meeting started Wed Jun  6 14:00:27 2018 UTC and is due to finish in 60 minutes.  The chair is zhaochao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:31 <openstack> The meeting name has been set to 'trove'
14:00:49 <wangyao> Haven't seen all of you for a long time
14:00:50 <fanzhang> Hi, zhaochao
14:00:54 <zhaochao> #topic roll call
14:00:56 <zhaochao> fanzhang: hi
14:01:04 <zhaochao> wangyao: hi
14:01:08 <wangyao> hi
14:01:11 <songjian1994> o/
14:01:13 <fanzhang> Hi wangyao so busy these days?
14:01:19 <gang> o/
14:01:28 <wangyao> yeah :(
14:01:30 <zhaochao> songjian1994: gang hi
14:01:43 <gang> zhaochao: hi
14:01:48 <songjian1994> hi
14:01:52 <fanzhang> Me too🙁
14:01:53 <zhaochao> finnaly we have a big gater today, :)
14:02:08 <fanzhang> LOL
14:02:08 <gang> :)
14:02:21 <wangyao> haha
14:02:38 <zhaochao> :) I think we could start now
14:02:55 <zhaochao> #topic Rocky goal updates
14:03:31 <zhaochao> fanzhang: songjian1994 wangyao please take a look at the log of the last weekly meeting
14:03:42 <zhaochao> http://eavesdrop.openstack.org/meetings/trove/2018/trove.2018-05-30-14.00.log.html
14:04:11 <wangyao> all right
14:04:50 <zhaochao> gang and I talked about only focusing on some of the goals, as it looks like all of us don't have much time on the community activities
14:06:00 <zhaochao> please put your opinions, and we could make a conclusion on that topic
14:06:13 <fanzhang> Startling to have some spare time recently. So will get back to upstream contributions
14:06:25 <fanzhang> Soon..
14:06:36 <zhaochao> fanzhang: that's greate
14:07:12 <zhaochao> I also got many email notifications about patchset updating, thanks, everyone
14:07:52 <zhaochao> fanzhang: thanks for update the patch for migrating cryptography
14:08:19 <fanzhang> I noticed the gate jobs’ failure,but have no clue what’s the reason. You said that may be the image building,but I did not find the log
14:08:33 <zhaochao> for that patch, I was thinking just completely removing cryptograph now
14:08:54 <zhaochao> fanzhang: no, the updated patchset failed because not updating unittests
14:08:56 <gang> agree
14:09:01 <wangyao> I don't find logs in troveclient
14:09:10 <fanzhang> Oh,right,I wanted to tell you about the patch set earlier this day, sorry, forgot to do so
14:09:30 <gang> we could stop support some old version
14:09:51 <wangyao> I agree with last week what you talks about, too.
14:10:56 <fanzhang> A follow up patch to remove the requirement or doing so in one change, I am ok to both.
14:11:40 <zhaochao> wangyao: thanks, is there any other goals you prefer to achieve?
14:13:02 <fanzhang> It should be enough for me to complete the bp 😂
14:13:34 <zhaochao> fanzhang: yes, according to the updated bug/maillist thread, maybe it's better to just remove cryptograph completely(as they want to remove it from requirements list)
14:14:49 <wangyao> I just want finish this --TroveClient - OSC migration, I have been delayed for a long time, really sorry~
14:15:01 <zhaochao> OK, for the rocky updates, I'm sorry that I am still not able to do something, but I did look though the patchset list from time to time
14:15:05 <fanzhang> Will commit a new patch set tomorrow if you don’t have much time to do so.
14:15:42 <fanzhang> What about the gate jobs..
14:15:46 <zhaochao> fanzhang: please do, thanks, you could add yourself to the co-author
14:16:03 <zhaochao> fanzhang: I'm just going to talk about that
14:16:13 <fanzhang> LOL
14:17:16 <zhaochao> firstly songjian1994 and I noticed the gate jobs failed weeks ago, and I came up with this: https://review.openstack.org/569405
14:17:52 <wangyao> By the way,Improve cluster supporting  is a huge work. I'm afraid it's more difficult to finish
14:18:13 <zhaochao> this patch should fix the mysql gate jobs, I added wf-1 because we need some more unittests for the changes
14:18:24 <songjian1994> Yes, I noticed the patch and saw your comment
14:18:45 <fanzhang> wangyao there will be many smaller bps of cluster supporting I guess
14:19:39 <zhaochao> wangyao: agree, we could split that to many smaller ones, can do what we can finish in the Rocky cycle
14:19:52 <fanzhang> New unit tests? Of which functions...I don’t see the failure of gate jobs on this patch.
14:20:54 <zhaochao> songjian1994: yes, thanks, please help review (or take it if you have time and resource on it), :)
14:21:39 <zhaochao> fanzhang: that patch add a new hook mechannism, so new unitests is neccessary
14:22:00 <songjian1994> Ok will help review (finishing it may be a bit difficult for me...)
14:22:22 <zhaochao> however we have another problem for gate jobs
14:23:01 <fanzhang> Emmm....
14:23:50 <zhaochao> the patch from wangyao for troveclient failed by the new problem, I added a comment before
14:24:07 <zhaochao> recheck won't help
14:24:24 <wangyao> yeah I see, But I have no idea how to fix it
14:24:56 * zhaochao just look for the patch caused the problem
14:25:16 <fanzhang> Same here.i saw your comments,but didn’t find the error logs
14:25:58 <zhaochao> the problem caused by a patche merged recetly in DIB
14:25:59 <zhaochao> https://review.openstack.org/#/c/568697/
14:26:47 <zhaochao> let me look for the error log
14:27:58 <zhaochao> http://logs.openstack.org/73/560373/3/check/trove-functional-mysql/e1d5df8/job-output.json.gz
14:28:14 <zhaochao> search for "https://cloud-images.ubuntu.com/SHA256SUMS"
14:28:44 <fanzhang> Please link it for easy notes
14:29:30 <zhaochao> OK
14:29:41 <zhaochao> #link https://review.openstack.org/#/c/568697/
14:30:43 <zhaochao> the change in DIB make trovestack failed to build images
14:31:52 <zhaochao> #link https://github.com/openstack/trove/blob/master/integration/scripts/functions_qemu#L36-L37
14:32:36 <zhaochao> we have to change lines in the above location to follow the DIB change
14:33:22 <zhaochao> and as the previous problem ( mysql restore, caused by xbstream) and this new one both will fail gate jobs
14:34:16 <zhaochao> we have to combine two changes into one commit, it's bad, but we have no choice...
14:36:05 <fanzhang> Thanks for the detail investigation:)
14:36:11 <songjian1994> Maybe we can solve the problem of DIB first, and then solve the problem of mysql, for example, temporarily set the mysql gate to no vote?
14:37:01 <zhaochao> songjian1994: yes, that will also work
14:37:09 <wangyao> big +1 for zhaochao, I was stunned
14:39:49 <zhaochao> songjian1994: Oh, I just forgot mysql jobs are both in check and gate jobs, and usually gate jobs cannot be set to non-voting, though it should hurt as it's only a workaround
14:39:52 <zhaochao> wangyao: :)
14:40:53 <zhaochao> fanzhang: wangyao If you have some time available, could you help to fix the gate failures?
14:41:45 <songjian1994> It turns out that I didn’t know this before
14:41:52 <fanzhang> Anyway, have to solve it no matter what. Will try :)
14:45:04 <zhaochao> songjian1994: like some convention(and in fact we can set gate jobs to be non-voting), I learned that by patching jobs for trove-dashboard in the project-config repo...
14:45:07 <zhaochao> fanzhang: thanks
14:46:21 <zhaochao> OK, for the Rocky milestone-2, it's scheduled this week, but as we didn't get many patches after milestone-1, I think it should be fine to skip this tag
14:46:50 <zhaochao> Any suggestions for that?
14:47:02 <wangyao> it may be a bit difficult for me to fix the gate, I'll learn from fanzhang
14:47:31 <wangyao> ski will be a good choice
14:48:27 <wangyao> ski--> skip
14:48:37 <fanzhang> So we have no choice but skipping this tag
14:48:46 <zhaochao> wangyao: if you setup a working environment by trovestack, to simulate gate jobs could be easier, :)
14:49:55 <zhaochao> songjian1994: gang what about you?
14:50:01 <wangyao> will try if I have enough time :)
14:50:38 <songjian1994> Also, time is the biggest problem
14:50:42 <gang> like fanzhang said, we have no choice
14:51:27 <zhaochao> Yes, then let's skip it
14:52:57 <wangyao> hope we have many patches  for the Rocky milestone-3
14:53:04 <wangyao> :)
14:53:20 <zhaochao> wangyao: yes
14:54:32 <zhaochao> #agreed As we didn't have many patches merged after Rocky milestone-1, let's skip Rocky milestone-2
14:54:54 <zhaochao> any other topics about rocky goals?
14:55:11 <gang> notice that recently there some new committer for trove, looks good.
14:55:34 <gang> how about this one https://bugs.launchpad.net/trove/+bug/1763567
14:55:34 <openstack> Launchpad bug 1763567 in OpenStack DBaaS (Trove) "Trove CLI doesn't support listing instance by project/all with admin" [Wishlist,New]
14:56:04 <wangyao> that's great
14:56:56 <wangyao> The focus of our work is not on trove, we need more new committers
14:57:05 <zhaochao> gang: it's great for new contributor to help Trove, though maybe we don't have much support for them
14:57:47 <fanzhang> As we actually have not much support either 😂
14:58:23 <gang> so I change the importance of this bug to wishlist.
14:58:52 <gang> But I think it's a good suggestion.
14:59:18 <fanzhang> Time up
14:59:26 <zhaochao> gang: yes, listing all instances may be useful
14:59:35 <zhaochao> O, yes, time 's up
14:59:36 <fanzhang> Leave it for tomorrow:j
14:59:43 <fanzhang> :)
14:59:49 <gang> 0.0
15:00:01 <wangyao> So have a good night guys
15:00:25 <songjian1994> good night
15:00:26 <zhaochao> just add your comments to the bug if you're intrested on that
15:00:33 <zhaochao> thanks, everyone
15:00:34 <gang> OK
15:00:35 <zhaochao> good night
15:00:41 <gang> night
15:01:00 <zhaochao> #endmeeting