14:00:17 <zhaochao> #startmeeting trove
14:00:18 <openstack> Meeting started Wed Apr 18 14:00:17 2018 UTC and is due to finish in 60 minutes.  The chair is zhaochao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:21 <openstack> The meeting name has been set to 'trove'
14:00:31 <zhaochao> #topic roll call
14:01:05 <gang> hi
14:01:18 <zhaochao> gang: hi
14:01:53 <zhaochao> looks like today we only very few people to the meeting...
14:02:06 <gang> yes...
14:02:16 <kumarmn> hi
14:02:35 <zhaochao> wait some minutes for others to show up
14:02:38 <zhaochao> kumarmn: hi
14:03:25 <fanzhang_> hi sorry for a little bit late
14:04:01 <zhaochao> fanzhang_: :)
14:05:41 <zhaochao> OK, let's start
14:05:57 <zhaochao> #topic Rocky goal updates
14:06:58 <zhaochao> This week we're on rocky milestone-1, so I may have to submit some patches for it
14:07:50 <zhaochao> in the first and a half months of rocky cycle, we may don't have many changes
14:08:12 <fanzhang_> There are some patches from you, and great work!
14:08:55 <zhaochao> fanzhang_: thanks
14:09:28 <fanzhang_> Should we approve the nova file injection bp before rocky milestone-1? Maybe I can start developing ?
14:09:30 <kumarmn> zhaochao: You do have to submit a patch to the openstack/releases repository
14:09:32 <kumarmn> https://github.com/openstack/releases
14:09:56 <kumarmn> Take a look at the README.
14:10:20 <zhaochao> kumarmn: thanks, I'm just going to ask, anything more about the milestone ?
14:10:30 <zhaochao> fanzhang_: I think you could start developing
14:10:52 <kumarmn> something like 'tox -e venv -- new-release rocky trove milestone'
14:11:11 <fanzhang_> zhaochao  sure, I guess I have to code step by step :)
14:11:24 <kumarmn> That will take care of trove and trove-dashboard. I believe for python-troveclient, you have to create the snapshot yourself.
14:11:29 <zhaochao> fanzhang_: I approved the bp, and will wait for another week for the other core members to approve it
14:12:17 <zhaochao> kumarmn: where should I run the tox command , in trove repo or the releases repo ?
14:12:33 <kumarmn> releases repo
14:12:41 <fanzhang_> zhaochao thanks :) really appreciate that anyone can help review this spec :https://review.openstack.org/#/c/557583/
14:12:48 <zhaochao> kumarmn: got that, thanks
14:13:18 <zhaochao> #action zhaochao have to do the tasks about Rocky milestone-1
14:13:44 <gang> fangzhang: so, need a workflow+1?
14:13:58 <fanzhang_> #action fanzhang_ should start coding about nova file injection spec.
14:14:25 <fanzhang_> I'd like you actually review this spec first :)
14:14:28 <zhaochao> and for the global goal, mox-removal
14:14:42 <zhaochao> it's already solved in the Trove repo
14:14:52 <gang> of course :)
14:15:00 <zhaochao> and the other repo have to be dealed is trove-dashboard
14:15:11 <zhaochao> we now have https://review.openstack.org/#/q/project:openstack/trove-dashboard+topic:mox-removal
14:15:41 <fanzhang_> ok, will do review later
14:15:54 <zhaochao> 5 patches for this topic in trove-dashboard
14:16:30 <zhaochao> one of them from Chuck Short, but no updates recently to address my comments, so I also updated it today
14:16:34 <zhaochao> fanzhang_: thanks, :)
14:17:14 <zhaochao> and https://review.openstack.org/#/c/562144/
14:17:35 <zhaochao> this one is related, without it, we cannot merge any patches... :(
14:17:52 <fanzhang_> better to add them to # link
14:18:16 <zhaochao> fanzhang_: good point, I'll do that
14:18:26 <zhaochao> #link https://review.openstack.org/#/q/project:openstack/trove-dashboard+topic:mox-removal
14:18:40 <zhaochao> #link https://review.openstack.org/#/c/562144/
14:19:02 <zhaochao> another patch need to mention from me
14:19:06 <zhaochao> https://review.openstack.org/#/c/562144/
14:19:10 <zhaochao> #link https://review.openstack.org/#/c/562144/
14:19:38 <zhaochao> I'm going to migrate the zuul jobs to Zuul v3 native
14:20:21 <zhaochao> the above is the first one, the jobs of trove repo will go after
14:21:53 <zhaochao> I have 10(or 11) patches recently, please help to review, thanks
14:22:08 <gang> zhaohcao: must say you really have done a lot of work!
14:22:14 <zhaochao> that's all from me
14:22:28 <zhaochao> gang: :)
14:23:23 <zhaochao> one more thing about the stable branches, you guys may have seen the mails in the mailinglist about this
14:23:37 <fanzhang_> Yes, thanks to Sean and Matt
14:23:49 <fanzhang_> we got the patches merged
14:24:30 <zhaochao> Yes, I think as we don't have much resouce, so currently we will rely on the core stable team to help us to got the patches merged
14:25:03 <zhaochao> If you want some fixes merged into the stable branch, please add the core stable team members to the reviewer list
14:25:57 <fanzhang_> IMHO, it's better this way right now, since we don't have much time focus on the upstream community as our full-time job :-(
14:27:18 <zhaochao> agreed, I may be kind of full-time from time to time, like these two weeks, :), but cannot permit that for a longer period
14:28:21 <zhaochao> OK, do you have more on the rocky update topic, gang have added another topic about cluster supporting, we could jump to that one
14:29:27 <zhaochao> then let's move on
14:29:32 <zhaochao> #topic cluster supporting
14:29:40 <gang> yes, I am not think clearly about trove cluster, need some advises from you guys
14:30:10 <zhaochao> gang: would you tell more about your thoughts about this?
14:31:09 <zhaochao> for me, "Remove all instance API and treate instance as a single node cluster." seems not the right way, but I don't know what's your detailed plan
14:31:09 <gang> I get some thought from the email and from my production experience.
14:31:18 <gang> And I had add to the agenda
14:32:15 <gang> for production env, cluster is more import than instance.
14:32:41 <zhaochao> gang: agree with the importance of cluster in product env
14:32:54 <fanzhang_> +1
14:33:07 <gang> So, my opinion is maybe we should re-architect clusters.
14:33:17 <gang> But it seems a big change.
14:33:18 <zhaochao> however from the api level, cluster is already the first citizen as instance
14:34:05 <zhaochao> and simple instance as single-node cluster, seems not correct and not easy to achieve
14:34:18 <zhaochao> we also support replication of instances
14:34:31 <fanzhang_> As I mentioned before, we have to figure it out what has been supported in trove, and what has not. And then we can add more useful and urgent functions that user desires most
14:35:04 <fanzhang_> as for re-architect, if you got the time, well, I think maybe you can try
14:35:22 <fanzhang_> detail spec should be needed definitely
14:35:54 <gang> well, if we can split it into some smaller task, maybe I can try.
14:36:25 <gang> It just what I thought trove should looks like...
14:37:15 <zhaochao> gang: fanzhang_ yes, bp is needed. the first design is important, any good ideas about this?
14:37:49 <gang> Like replication of instances, I mean maybe it should be "transparent" to end user.
14:38:16 <zhaochao> or what are problems do you think about the current design of clusters?
14:38:56 <zhaochao> gang: ok, I may got some points from that, replications could be a kind of cluster(or strategy, maybe)
14:39:31 <fanzhang_> the end users may want to know what they're using, replication or real cluster, that really depends on them, not us.
14:41:53 <zhaochao> fanzhang_: from gang's idea, we could design something like "cluster type" -> replication/sharded/...
14:43:29 <fanzhang_> yeah, exposing cluster type to end users may be a great feature
14:43:57 <gang> fanzhang_: yes, in some case user want to know the details, this is why we discuss.
14:44:10 <zhaochao> however we still have a lot changes for this
14:44:51 <gang> zhaochao: yes, if we do this, it will be a huge work.
14:45:37 <gang> so, do you think there need a spec?
14:45:56 <zhaochao> gang: would you add the related links in https://etherpad.openstack.org/p/trove-priorities-and-specs-tracking, under "Improve cluster supporting"
14:46:03 <zhaochao> gang: yes, we need a spec
14:46:23 <gang> OK
14:46:26 <zhaochao> gang: we may need more discussions about this
14:46:33 <fanzhang_> definitely
14:46:54 <gang> zhaochao: can't agree more
14:47:37 <zhaochao> gang: if you like to push this, you could create a new pad for it, or add your thoughts under "Improve cluster supporting" of the tracking page
14:47:57 <zhaochao> everyone could help to improve this
14:48:19 <zhaochao> I think this coud be a good direction
14:48:36 <gang> zhaochao: I will, if I have some step that I would ask you and fan.
14:49:33 <fanzhang_> would love to help with that
14:50:10 <gang> fanzhang: thanks in advance  :)
14:50:18 <zhaochao> gang: great, I will aslo do some investigation about this topic after I finish the global goals and Zuul v3 migration(may not take too long, one or two weeks maybe)
14:50:42 <gang> zhaochao: thanks!
14:51:24 <zhaochao> #action gang do the first draft design about improving cluster support, fanzhang and zhaochao will help on the that
14:51:28 <zhaochao> gang: no problem
14:52:34 <zhaochao> So any thing more about this topic? gang fanzhang_
14:53:02 <gang> no
14:53:13 <fanzhang_> no
14:53:40 <fanzhang_> really tired from work and gym 🤣
14:54:02 <zhaochao> fanzhang_: good for gym
14:54:18 <zhaochao> OK, I'll go the open discussiong topic
14:54:22 <zhaochao> #topic Open discussion
14:54:40 <kumarmn_> I wanted to discuss on the Trove project updated at the Summit in Vancouver
14:54:54 <kumarmn_> I am not able to go due to a personal trip/vacation.
14:55:30 <kumarmn_> Any of you planning to go?
14:56:17 <zhaochao> kumarmn_: sorry, I'm not going
14:56:22 <fanzhang_> sorry, can not make it
14:56:28 <zhaochao> kumarmn_: I just forgot another question about the rocky-1, do we have a deadline? tomorrow?
14:56:44 <kumarmn_> Sometime this week, preferably by tomorrow.
14:56:49 <gang> me too... sorry
14:57:10 <zhaochao> kumarmn_: got that, thanks
14:57:44 <zhaochao> kumarmn_: I don't know wether any other core member will go the Vancouver summit
14:58:00 <kumarmn_> I will check with Maciej
15:00:10 <zhaochao> OK, most of the other core members are in China, I didn't hear some of them will go to the summit. fanzhang_ , do you know some of us will go?
15:00:24 <fanzhang_> no sorry
15:00:41 <zhaochao> OK, time's up
15:00:49 <zhaochao> that's all today, thanks, everyone
15:00:54 <fanzhang_> will  ask songjian  tomorrow
15:01:01 <zhaochao> fanzhang_: thanks
15:01:06 <zhaochao> #endmeeting