15:00:26 <zhaochao> #startmeeting trove
15:00:27 <openstack> Meeting started Wed Mar  7 15:00:26 2018 UTC and is due to finish in 60 minutes.  The chair is zhaochao. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <openstack> The meeting name has been set to 'trove'
15:00:50 <zhaochao> #topic roll call
15:00:54 <songjian> o/
15:00:57 <fanzhang> o、
15:00:57 <wangyao_> here
15:00:58 <fanzhang> o/
15:01:55 <zhaochao> hi, this is the first time for me to hold the weekly meeting, thanks for attending
15:02:32 <zhaochao> we may need to wait the other core members to show up
15:03:01 <wangyao_> Congratulations
15:03:52 <zhaochao> wangyao_: thanks, :)
15:03:59 <fanzhang> Oh, right, I don't think Manoj and Maciej is here.
15:04:54 <fanzhang> kumarmn: hi
15:04:57 <wangyao_> gang is not here, can not connect to him
15:04:57 <kumarmn> I am one
15:05:01 <kumarmn> sorry for being late
15:05:33 <fanzhang> that's ok, we are about to start :)
15:05:36 <zhaochao> never mind, so let's start
15:06:06 <zhaochao> #topic announcements
15:06:44 <zhaochao> I copied some etherpads from the Cinder team to track how thing are going on
15:07:04 <zhaochao> #link https://etherpad.openstack.org/p/trove-rocky-meeting-agendas
15:07:44 <zhaochao> though the first meeting agenda is still not finished
15:07:47 <zhaochao> sorry for that
15:08:53 <kumarmn> looks good. this is a great idea
15:09:28 <fanzhang> looks great +1
15:09:42 <songjian> This looks very intuitive
15:09:44 <songjian> LGTM
15:10:39 <kumarmn> perhaps at the end of the meeting, we can add a link to the meeting log. that way if someone missed a meeting, they can easily catch up on what was discussed
15:10:50 <zhaochao> Ok, so for the following meetings, you could add your topics to the agenda
15:11:11 <zhaochao> kumarmn: yes, I also like this idea
15:12:26 <zhaochao> the next link
15:12:36 <zhaochao> #link https://etherpad.openstack.org/p/trove-priorities-and-specs-tracking
15:13:05 <zhaochao> this one is still empty, we need to put all tasks for Rocky in it
15:13:55 <zhaochao> I will make a first draft in a few days, maybe before the next week, sorry for the late
15:14:57 <zhaochao> you all can add any topics(the ones we discussed in the PTG) you're familiar about
15:16:06 <wangyao> got it, thank you for the hard work
15:16:55 <fanzhang> cool, it's never too late :-) Once we have a todo list, it's much more purposeful to do things. Big +1
15:17:12 <kumarmn> I do not know whether Maciej is on, but I added one item for us to discuss community wide and other cross project goals for Rocky
15:17:41 <kumarmn> Since he attended the PTG, he should be able to lead that discussion. If he is not on, we can table it for another week
15:18:20 <zhaochao> Maciej seems not online, so we may leave this for the next meeting
15:18:48 <zhaochao> And any suggestions about all these meeting and planning things?
15:18:53 <fanzhang> Sure.
15:20:29 <fanzhang> Right now, it looks good to me. The only thing I'm concerned about is what we want to accomplish in Rocky, and how to schedule the milestone
15:21:07 <zhaochao> kumarmn: I added the topic to the agenda of the next meeting
15:22:31 <fanzhang> There are lots of jobs needed to be done, and how can we manage our time and energy to do things better. It all depends on your priority list :-)
15:22:44 <zhaochao> fanzhang: I also didn't have a clear picture for that now, need to have the goals to be maintained first
15:23:24 <kumarmn> Once we write down the goals, perhaps we can vote on which ones are a higher priority.
15:23:26 <wangyao> We may try to make other committers to join this.
15:23:36 <kumarmn> I do not know how sophisticated the IRC voting system is
15:23:44 <fanzhang> I can help put some topics on that list. Recently, I am doing some work related to nova
15:24:05 <fanzhang> maybe I can help with file injection deprecation
15:24:22 <fanzhang> yes, voting is necessary.
15:25:03 <zhaochao> kumarmn: yes, we can try the voting system for the priorities next time
15:25:40 <zhaochao> wangyao: lacking participation is always pain for Trove, :(
15:26:16 <songjian> agree, this seems difficult to control
15:26:22 <zhaochao> fanzhang: thanks, please add the topic on the tracking page
15:26:47 <fanzhang> One of my colleagues shows big interests in trove, he may want to participate a little bit I guess. Something about matrix is on his todo list.  Really look forward to his spec.
15:27:51 <zhaochao> fanzhang: matrix? what's that about?
15:28:57 <fanzhang> Like in nova, there is table shows the hypervisors supporting some functions or not. Let me find the link.
15:29:00 <wangyao> fanzhang:That is great!
15:29:32 <zhaochao> Ok, seems planning discussion should be based on the list of goals, I'll finish the first draft asap. Let's move to next topics.
15:29:36 <fanzhang> Somethings like this https://docs.openstack.org/nova/latest/user/support-matrix.html
15:29:45 <zhaochao> fanzhang: O, I see
15:30:21 <kumarmn> There is a similar one for Trove, not very well maintained:
15:30:22 <kumarmn> https://wiki.openstack.org/wiki/Trove/DatastoreCompatibilityMatrix
15:30:35 <zhaochao> #action zhaochao finish the first draft of the list of Rocky goals ASAP.
15:31:19 <songjian> Seems like outdated for a long time
15:31:37 <zhaochao> #action Everyone could add any topics you're interested to the tracking page.
15:32:03 <fanzhang> Yep, it's similar. There is no guarantee for his work, LOL, but I have faith in him
15:32:07 <zhaochao> yes, I also saw this matrix of Trove before
15:32:29 <kumarmn> #action Update compatibility matrix at https://wiki.openstack.org/wiki/Trove/DatastoreCompatibilityMatrix
15:32:59 <zhaochao> #topic PTG summary and priorities for the Rocky release
15:33:58 <zhaochao> we may already talk some of this topic, any more discussions would you like to do?
15:35:23 <fanzhang> about the root history things, should we wait for the spec or just have a discussions here?
15:35:31 <kumarmn> We talked about a lot last week. I agree with fanzhang that we cannot accomplish everything.
15:35:58 <kumarmn> So we will have to prioritize. We did not talk much about python3
15:36:15 <kumarmn> I suspect there will be a bigger push from a cross project perspective.
15:36:38 <kumarmn> We should add python3 to the list of items for Rocky
15:37:31 <zhaochao> fanzhang: RootHistory design are not changed in my recent patches, those patches is for fixing the redis-single scenario tests
15:38:01 <fanzhang> Oh, right. There are lots of projects having done supporting py3 IMHO. Maybe in the next week, after maciej's sharing, we'll have much more info.
15:38:21 <fanzhang> zhaochao: OK, I see.
15:38:38 <zhaochao> though as I stated in one commit messages, I personally prefer the idea about RootHistory meaning different things for different datastore
15:39:02 <zhaochao> I'd like everyone to discuss about this under that patchset
15:39:15 <fanzhang> Sure, will do ;-)
15:39:45 <zhaochao> https://review.openstack.org/#/c/549255/
15:40:26 <zhaochao> kumarmn: for py3 support, it looks like the Trove project is almost fully supported
15:41:16 <zhaochao> However I didn't investigate this for the other projects, like troveclient/trove-dashboard, etc
15:41:37 <kumarmn> yes troveclient was not clean if I rememeber
15:42:14 <kumarmn> Perhaps Yao or Gang can look into it and report.
15:42:42 <zhaochao> wangyao: will you help on that? thanks
15:43:35 <wangyao> sure, will do  recently
15:44:36 <zhaochao> for trove, I remove the last py3 unittests blacklist in https://review.openstack.org/#/c/547724/, unittests work well, although we may have plenty parts not covered by unittest
15:44:41 <zhaochao> wangyao: thanks
15:46:12 <zhaochao> #action fanzhang will add some topics related to Nova to the goal page.
15:46:47 <zhaochao> #action Do some investigations about Python3 support across Trove projects.
15:47:13 <zhaochao> #action wangyao will look into the Python3 support of troveclient.
15:47:20 <wangyao> zhaochao:It`s my pleasure
15:47:27 <zhaochao> ok, the next topic
15:47:46 <zhaochao> #topic Keep the list of core members in gerrit and launchpad updated
15:48:59 <zhaochao> I found the member list of gerrit and launchpad groups are outdated, so I'm thinking about to make them keeping up-to-date
15:49:28 <zhaochao> kumarmn: would you help on this?
15:51:18 <zhaochao> for gerrit groups, none of us are in the trove-stable-maint group, this group seems related to the stable release branch
15:52:07 <zhaochao> we don't have much time for this meeting, so I'll go faster.
15:52:16 <kumarmn> I can help. trove-stable-maint needs more representation
15:53:01 <zhaochao> ok, thanks, I may talk about this with emails.
15:53:15 <zhaochao> #topic Weekly meetings time schedule
15:54:38 <zhaochao> kumarmn talked to me, as most of the core members now are in China, we could change the weekly meeting time schedule if it's not convenient
15:54:51 <zhaochao> I personally fine with the current schedule
15:54:59 <fanzhang> me too
15:55:01 <zhaochao> what do you think?
15:56:20 <zhaochao> songjian: wangyao what about you?
15:56:30 <wangyao> I fine. But an hour ahead may be better if possible :-)
15:57:36 <fanzhang> We can add our proper time schedule on etherpad, the vote for one
15:58:00 <songjian> agree with wangyao
15:58:27 <songjian> But I am worried that this will affect foreign colleagues
15:58:38 <fanzhang> time's running out.
15:58:46 <zhaochao> wangyao: songjian ok, I see.
15:58:47 <kumarmn> If it is one hour ahead, I can make it.
15:58:57 <fanzhang> What about Maciej?
15:59:04 <wangyao> yeah, agree song,that is what I want to say.
15:59:11 <kumarmn> Not much more. I suspect Maciej in Europe will have more common slots with China
15:59:26 <zhaochao> all, time is up
15:59:37 <kumarmn> ciao!
15:59:43 <fanzhang> All right. I am OK to both options :)
15:59:47 <fanzhang> Good night~
15:59:53 <zhaochao> #endmeeting