18:00:08 <amrith> #startmeeting trove
18:00:09 <openstack> Meeting started Wed Oct 12 18:00:08 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:12 <openstack> The meeting name has been set to 'trove'
18:00:18 <songjian> o/
18:00:30 <amrith> courtesy ping peterstac johnma dougshelley66 pmalik vgnbkr mvandijk trevormc aliadil spilla songjian trevormc apsarshaik
18:00:32 <amrith> hi songjian
18:00:36 <aliadil_> o/
18:00:40 <mvandijk> ./
18:00:40 <dloi> o/
18:00:44 <songjian> hi amrith
18:00:50 <peterstac> hi all
18:00:59 <vgnbkr> o/
18:01:15 <amrith> hello all
18:01:33 <pmalik> 😁/
18:01:38 <spilla> o/
18:02:03 <amrith> this may be a quick meeting
18:02:09 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting#Open_Discussion
18:02:27 <amrith> there was an action item from last week which I forgot to put on the agenda.
18:02:37 <amrith> I have to publish the list of ocata things.
18:02:45 <amrith> #action [amrith] publish list of ocata priorities
18:02:54 <amrith> But for today
18:03:00 <amrith> #topic Open Discussion
18:03:09 <amrith> pmalik had one topic, let's start with that one
18:03:15 <pmalik> Hi
18:03:15 <pmalik> The tests have been running for several weeks now and appear pretty solid. I propose we promote Postgresql (non-MySQL datastore with replication and user/database support) and PXC (MySQL-like clustering datastore).
18:03:15 <amrith> #topic  [pmalik] Promoting Postgresql and PXC to gating jobs.
18:03:47 <pmalik> The tests have been running for several weeks now and appear pretty solid. I propose we promote Postgresql (non-MySQL datastore with replication and user/database support) and PXC (MySQL-like clustering datastore).
18:05:46 <amrith> does anyone have thoughts on this ...
18:06:50 <johnma> that sounds good to me pmalik
18:06:56 <peterstac> It looks like both are fairly stable (just did a quick search)
18:07:16 <amrith> about how long do the tests take on average?
18:07:29 <amrith> the last few runs seem to be
18:07:38 <amrith> quite long
18:07:55 <amrith> and failing
18:07:56 <amrith> https://review.openstack.org/#/c/356698/
18:08:02 <pmalik> I'd say they are in the faster half... Somewhat like MySQL about 1:20-1:40.
18:08:20 <pmalik> This one failed in redstack.
18:08:52 <pmalik> * ok, this is a different one
18:08:59 <peterstac> I have seen that issue in Postgresql (wrt guest_log)
18:09:27 <amrith> i agree, seems to be 1h17m to 1h24m
18:09:38 <peterstac> it's a testware issue, not coding (sometimes the log can be written to right after a publish so the state can be either Published or Partial)
18:09:50 <peterstac> I can push up a fix for that
18:10:03 <peterstac> as for timing, I don't believe I've ever seen either time out
18:10:10 <amrith> how often does that fail peterstac; should we wait for a fix or push up the gate change?
18:10:41 <peterstac> It's not that often - I only noticed it recently so maybe it's hitting more often now
18:10:54 <peterstac> I can push up a fix today though, it's pretty easy
18:11:16 <amrith> does anyone feel that we should not make postgresql voting?
18:11:24 <amrith> does anyone feel that we should not make pxc voting?
18:11:57 <peterstac> I'm good with both switched to voting
18:12:03 <pmalik> +1
18:12:10 <songjian> +1
18:12:44 <amrith> johnma, vgnbkr, aliadil_, dloi, ...
18:12:49 <amrith> spilla ...
18:12:52 <johnma> +1
18:12:54 <dloi> +1
18:13:03 <amrith> #agreed to switch postgresql and pxc to voting
18:13:14 <amrith> #action [amrith] propose CI jobs to switch to voting
18:13:19 <amrith> thanks pmalik
18:13:28 <amrith> peterstac, it will take some time before the ci changes merge
18:13:36 <amrith> so we can do the ci change in parallel with your fix
18:13:39 <amrith> agreed?
18:13:45 <peterstac> sure, I can get the guest_log fix up in the mean time
18:13:50 <amrith> thx
18:13:51 <peterstac> yep
18:13:57 <amrith> if there's no other discussion ...
18:14:50 <amrith> #topic Please update barcelona session topics https://etherpad.openstack.org/p/trove-barcelona-design-summit-sessions
18:14:53 <amrith> #link https://etherpad.openstack.org/p/trove-barcelona-design-summit-sessions
18:17:25 <amrith> i had nothing other than the request that we all update the etherpad
18:17:47 <amrith> with things that you think should get discussed at Barcelona. If you won't be there, you can put links to other etherpads, reviews, ...
18:17:56 <amrith> (or not)
18:19:38 <amrith> I have nothing else for the meeting today
18:19:42 <amrith> #topic Open Discussion
18:21:25 <amrith> hearing nothing ... going once.
18:21:56 <amrith> .
18:22:13 <amrith> thanks everyone
18:22:13 <amrith> #endmeeting